[ROM][8.1][UNOFFICIAL] LineageOS 15.1 [TITAN]

Search This thread

sapo_joe

Senior Member
Oct 4, 2016
1,099
735
Does anyone else have an issue with the Gallery?
I get a popup on top of the gallery saying "No Storage" "No External storage available"
But in the background I can see the "Timeline" and it has photos in it, from the SD card

I've tried reformatting the SD card a few times and also tried setting the SD card as both internal and Portable storage, but it doesn't make any difference

I'm using open_gapps-arm-8.1.-nano

I've used this rom for 3 weeks and never faced this issue... :confused:
 

RogerClark

Senior Member
Feb 9, 2011
132
20
Melbourne
I've been using the ROM for a few weeks but I only just notice this. But I can't remember if I looked in the gallery before, as I normally upload my photos to my PC and then erase them

I tried doing a complete wipe and re-install but it didnt help :(

I'll try a different SD Card, but I've already tried doing a full reformat on the card at least once

Edit.
Tried a different card. Didnt make any difference

Tried denying and then enabling storage permissions, but it didn't help :(
 
Last edited:

RogerClark

Senior Member
Feb 9, 2011
132
20
Melbourne
I just tried official Lineage 14.1 and I get the same problem with the gallery app., but the camera app seems to have its own image viewer, so I never noticed it on that version.

Lineage 13 however is OK.

So I'll need to track this down with reference to 14.1 first, (looks like its a gapps issue)
 

sapo_joe

Senior Member
Oct 4, 2016
1,099
735
I've been using the ROM for a few weeks but I only just notice this. But I can't remember if I looked in the gallery before, as I normally upload my photos to my PC and then erase them

I tried doing a complete wipe and re-install but it didnt help :(

I'll try a different SD Card, but I've already tried doing a full reformat on the card at least once

Edit.
Tried a different card. Didnt make any difference

Tried denying and then enabling storage permissions, but it didn't help :(

Very strange indeed. I use the gallery a lot since I need it to cut and edit my photos... Never had this problem! Maybe you could try Moto gallery (now under Lenovo brand on apkmirror). Works fine on my Titan too.
 
Last edited:

RogerClark

Senior Member
Feb 9, 2011
132
20
Melbourne
Yes.. Very odd. Looks like the gallery app is looking somewhere that it can't access.

Edit.

Tried checking for updates in the Play Store for the Gallery app.

Installed Photos app onto Lineage 14 and that works OK.
I'll try re-installing

Edit.
Re-installed the ROM (did a full wipe of system, data, and caches etc), and gallery still didnt work,
Installed Photos app (Google) and that works.

Not sure if I can assign Photo's as the gallery to the camera app, as that would totally fix things for me
But at the moment the camera app still tries to open the Gallery, which then has the problem
 
Last edited:

Antoniozbx

Senior Member
Sep 17, 2017
52
25
Yes.. Very odd. Looks like the gallery app is looking somewhere that it can't access.

Edit.

Tried checking for updates in the Play Store for the Gallery app.

Installed Photos app onto Lineage 14 and that works OK.
I'll try re-installing

Edit.
Re-installed the ROM (did a full wipe of system, data, and caches etc), and gallery still didnt work,
Installed Photos app (Google) and that works.

Not sure if I can assign Photo's as the gallery to the camera app, as that would totally fix things for me
But at the moment the camera app still tries to open the Gallery, which then has the problem

Is very strange because i have the preinstalled gallery and don't have this issue, you try to repair file system?
 

RogerClark

Senior Member
Feb 9, 2011
132
20
Melbourne
Is very strange because i have the preinstalled gallery and don't have this issue, you try to repair file system?

I did a total re-install twice, and also tried several different SD cards
Its odd I get the same thing on Lineage 14, but not Lineage 13.
So the problem is not specific to this ROM
I have 2 Motorola G2014 (Titan), so I'll try installing it on the other one and see if it has the same problem.

Actually I'll try the official Lineage 14 on the other phone first, as thats the phone thats currently running Lineage 13
 

RogerClark

Senior Member
Feb 9, 2011
132
20
Melbourne
This is really odd.

I've just installed this ROM onto my other G 2014 and the gallery works fine.

I'd cleared the whole of the internal storage on both phones, using TWRP 3.2.x before installing the ROM, so it should not have any existing config information.

If I take out the SD card, the gallery also works OK. So the fault does not appear to be the SIM card.

I'll try reinstalling again, from scratch on the G 2014 that has the problem
 

RogerClark

Senior Member
Feb 9, 2011
132
20
Melbourne
I've done a complete wipe and reinstall on both phones and on one I have the problem with the gallery and the other one I don't have a problem.

Both are XT1068 and were bought at the same time, as I've owned them from new.

Both have TWRP 3.2.2.0 install
I did an Advanced wipe, of everything except the external SD card and the OTG
Both were installed using the files from the same SD card, in the same order, i.e
Lineage ROM
SU
Mind-the-gapps


TWRP app installation by TWRP was prevented

Both phones were had the same SIM card in them (as I did them one after the other)

I can't understand why they should behave differently.

Is there anything else I can do in TWRP or perhaps fastboot to completely erase the phone where the gallery doesn't work?

PS. I have a LogCat from the phone that doesnt work correctly, if anyone wants to take a look
 

RogerClark

Senior Member
Feb 9, 2011
132
20
Melbourne
I reinstalled for about the 4th time and the problem with the Gallery App not working no longer occurs.

The only thing I did was to use the Format option in the Wipe menu in TWRP, but I don't see how that should have made any difference, unless either the Wipe function does not fully wipe things, or one of the partitions had some problems

But its odd it manifested as the Gallery app, starting to display the images, (as I could see them behind the system popup), yet the system popup said that the storage could not be used.

Note. This issue also applied to the official Lineage 14.x for Titan, so is not a fault with this ROM.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 40
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 8.1 (Oreo), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's working :

    • Boots
    • RIL (Calls, SMS, Data)
    • Wifi
    • Bluetooth
    • Camera
    • Video recording
    • Video Playback
    • Audio ( Record and Playback )
    • Sensors
    • Flash
    • Led
    • Offline Charging

    What's not working :
    • SELinux is permissive

    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    Phone model (XT1063/XT1064/XT1068/XT1069):
    Lineage version:
    Lineage Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    LineageSettings/Performance settings (other than stock):
    Dual SIM:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    Credits :

    Donations :
    You don't have to but if you want so...

    XDA:DevDB Information
    LineageOS 15.1, ROM for the Moto G 2014

    Contributors
    RenanQueiroz
    Source Code: https://github.com/LineageOS/

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 3.4.x
    Based On: LineageOS

    Version Information
    Status: Beta

    Created 2018-05-06
    Last Updated 2018-06-10
    18
    (07/08/2018) Lineage 15.1 Update
    • Minor fixes and performance improvements
    • Added Adaptive LowMemoryKiller
    • ZRAM Disabled
    Download
    17
    (05/07/2018) LineageOS 15.1 Update
    • WhatsApp/Instagram videos not playing is now fixed
    15
    (06/10/2018) Lineage 15.1 Update

    Build Changelog
    • Offline Charging fixed
    12
    Changelog

    (05/07/2018) Initial release

    (06/10/2018) Second release
    • Offline Charging fixed (Custom Kernels may break this fix)
    (07/08/2018) Third release
    • Minor fixes and performance improvements
    • Added Adaptive LowMemoryKiller
    • ZRAM Disabled
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone