[ROM][9.0][FALCON] Pixel Experience [AOSP][APRIL UPDATE]

Search This thread

RohanHasabe8

Senior Member
Oct 17, 2018
58
185
Pune
WE ARE BACK BITCHES!

GtwTyCR.png

PixelExperience for Falcon

What is this?
Pixel Experience is an AOSP based ROM, with Google apps included and all Pixel goodies (launcher, wallpapers, icons, fonts, bootanimation)

Our mission is to offer the maximum possible stability and security, along with essential features for the proper functioning of the device

Based on Android 9.0


Whats working?
Wifi
RIL
Mobile data
GPS
Camera
Flashlight
Bluetooth
VideoRecording
FMRadio
Lights
Sound / vibration


Known issues
You Tell me

DON'T FLASH GAPPS, ALREADY INCLUDED
Download from Pixel Experience website

Donate
Liked my work? Give me a beer

Translation
Help with project translation

Telegram channel
Stay tuned

*******************************************************************************************************
Changelog:-
* Fixed LTE+/4G+ icon
* Merged new CAF tag: LA.UM.7.3.r1-07400-sdm845.0
* OTA app fixed
* Others fixes
*Whole lot of device changes

DONATE IF LIKE MY WORK:-
https://www.paypal.me/hasaber8
PAYTM:- 9172958878
 
Last edited:

DanGLES3

Senior Member
Nov 11, 2017
735
720
common problem in pie builds, not fixable right now
Sorry if that's slightly off topic but the titan (moto g2) doesn't have this problem on Lineage OS 16.0 but has on other pie ROMs,why does LOS 16.0 boots normally? Is the long boot times a ROM side issue?
 
Last edited:
  • Like
Reactions: profeet2

lucastracq

Senior Member
Jan 20, 2015
321
125
Sorry if that's slightly off topic but the titan (moto g2) doesn't have this problem on Lineage OS 16.0 but has on other pie ROMs,why does LOS 16.0 boots normally? Is the long boot times a ROM side issue?

well this is good to know. i'm on lineage 16.0 for falcon and it still has this issue, but the build is one month old. so if your lineage build is newer maybe the fix is recent and soon all other roms will follow. can't be sure, if i have a time i'll make a new build and check.
 

DanGLES3

Senior Member
Nov 11, 2017
735
720
well this is good to know. i'm on lineage 16.0 for falcon and it still has this issue, but the build is one month old. so if your lineage build is newer maybe the fix is recent and soon all other roms will follow. can't be sure, if i have a time i'll make a new build and check.
The Titan's Lineage 16.0 is old as well,it's from september
 

DanGLES3

Senior Member
Nov 11, 2017
735
720
that's bad. don't know what to say anymore :confused:
Its strange ,one of my friends also reported this doesn't happen on pixys OS,what's strange about every ROM with long boot times is that through the entire boot process and sometime after bootup the dex2oat process runs like crazy using almost all the CPU,so it seems to be a a problem with a big/important dex/odex/vdex file that needs to be recompiled at every reboot
 
Last edited:

lucastracq

Senior Member
Jan 20, 2015
321
125
Its strange ,one of my friends also reported this doesn't happen on pixys OS,what's strange about every ROM with long boot times is that through the entire boot process and sometime after bootup the dex2oat process runs like crazy using almost all the CPU,so it seems to be a a problem with big/important dex/odex/vdex file that needs to be recompiled at every reboot

that's exactly the problem. it's like every boot is the first boot.
so you can say for sure that you don't have that dex2oat activity in logs when booting los 16?
 

DanGLES3

Senior Member
Nov 11, 2017
735
720
that's exactly the problem. it's like every boot is the first boot.
so you can say for sure that you don't have that dex2oat activity in logs when booting los 16?
No,its very noticeable on ROMs with the issue, after bootup they all lag badly for 1-3minutes (AEX shows they keep all cores enabled during that time) but LOS 16.0 boots up normaly lwith no lag,I used the 'top' command on the terminal and dex2oat shows using ridiculous amounts of CPU for sometime
 
Last edited:

Allstargaurav

Senior Member
Sep 23, 2016
479
1,851
21
Delhi
well this is good to know. i'm on lineage 16.0 for falcon and it still has this issue, but the build is one month old. so if your lineage build is newer maybe the fix is recent and soon all other roms will follow. can't be sure, if i have a time i'll make a new build and check.
Can you make a new build and test, I might have missed something but I am 90% sure I did not also aex on Titan is having the same issue
 

DanGLES3

Senior Member
Nov 11, 2017
735
720
no problem, just curious since it's so strange.
Indeed,but I also noted that Lineage did use alot more system space than AEX so its possible LOS has some precompilled services to help it boot up faster,maybe that's why its still slow on the falcon as its system partition maybe can't fit both gapps and precompilled dex files
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 21
    WE ARE BACK BITCHES!

    GtwTyCR.png

    PixelExperience for Falcon

    What is this?
    Pixel Experience is an AOSP based ROM, with Google apps included and all Pixel goodies (launcher, wallpapers, icons, fonts, bootanimation)

    Our mission is to offer the maximum possible stability and security, along with essential features for the proper functioning of the device

    Based on Android 9.0


    Whats working?
    Wifi
    RIL
    Mobile data
    GPS
    Camera
    Flashlight
    Bluetooth
    VideoRecording
    FMRadio
    Lights
    Sound / vibration


    Known issues
    You Tell me

    DON'T FLASH GAPPS, ALREADY INCLUDED
    Download from Pixel Experience website

    Donate
    Liked my work? Give me a beer

    Translation
    Help with project translation

    Telegram channel
    Stay tuned

    *******************************************************************************************************
    Changelog:-
    * Fixed LTE+/4G+ icon
    * Merged new CAF tag: LA.UM.7.3.r1-07400-sdm845.0
    * OTA app fixed
    * Others fixes
    *Whole lot of device changes

    DONATE IF LIKE MY WORK:-
    https://www.paypal.me/hasaber8
    PAYTM:- 9172958878
    2
    just installed it, looks very good . for the next build i wish for a more decent boot animation, it is blinding!
    keep it up...

    We at PE try to keep this as close to stock. So the boot animation is also the same as Pixels. So I cant change that sadly,
    2
    Bro I tested it I know how much it lags , but I didn't get any crashes, the UI is heavy for the device and its time we accept it is the end on line for our beloved Moto G1 and about not give changelog here it is :-
    1. December patch
    2. Tried sepolicy stuff but I don't know **** about fixing denials
    3. Upstream to latest source and trees.
    And if you feel so much about positives and negatives you don't know how hard it was to boot this ROM on this device.
    1
    common problem in pie builds, not fixable right now
    Sorry if that's slightly off topic but the titan (moto g2) doesn't have this problem on Lineage OS 16.0 but has on other pie ROMs,why does LOS 16.0 boots normally? Is the long boot times a ROM side issue?
    1
    Here is the link to the last build: https://mega.nz/file/SMACHSTJ#nC0r-Pr3VW-PLwHBBb4Wm4kutCBEYEXIaSq0Ta_llno

    MD5 value from the original release: ee9cbaca29bfc527df114724c70ac6c7 (Source)
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone