[ROM][9.0][OFFICIAL] & [10][NIGHTLY] MoKee Open Source Android Project

Search This thread


Senior Member
Jan 14, 2012
Hereby a short update about what I've learned in the past days concerning flashing stock roms (downloaded from https://flashxiaomi.com/download-install-miui-rom-for-xiaomi-mi-2s-all-miui-firmwares/) and then Mokee 9, 10 or Havoc OS 3.2:
  • Stock MIUI, then Mokee 9: Bluetooth keeps crashing every few seconds, which makes the phone unusable
  • Stock MIUI, then Mokee 10: seems to work alright but not too stable. Also, the flash isn't working in the camera app. Worst for me, I experienced problems with charging, where the phone kept indicating it got disconnected.
  • Stock MIUI, then Havoc OS 3.2: seemed to be alright, but I experienced the same charging problems as with Mokee 10. My USB connection is a bit loose, but it also happened when the phone was perfectly still.
After this I decided to flash and older MIUI, to hopefully get rid of the charging problems:
  • Stock MIUI, then Mokee 9: this is what I'm currently running and seems to be fine
  • Stock MIUI, then Mokee 10: weird camera behaviour, also in Open Camera, as reported here
  • Stock MIUI, then Havoc OS 3.2: quite unstable, I've had a few crashes in a day which needed hard reboots
I hope this is helpful to someone!
What about battery drain?Is Mokee still draining like hell when screen is on?


Dec 5, 2018
Interesting this Rom. Anyone can share if the Mokee rom has the mBack home button ability the Meizu 16 devices offer?
Its the touch home button like on flyme


Dec 31, 2010
I have tried fresh install Mokee 9 with Magisk 19.4, 21.4, 22.0, all of them will bootloop, only Addon SU works.


Senior Member
Aug 9, 2015
guys, i can't manage to install gapps (pico) with Mokee 8/9/10.. insufficient system storage (1021mg total; 225 to 118 free depends on the Mokee version)
Is there anyway to resize system storage from data or something?


Senior Member
Aug 9, 2015
i'm trying Mokee 8.1 and Gapps MINDTHEGAPPS 8.1 and works fine. Any other gapps takes more space, so couldn't make it work.

cippa lippa

Senior Member
Apr 16, 2013
Hi guys!
I installed the havoc rom but...stil can't figure out how to install the gapps in right way...:( can't understand where and how is working the gapps config file

cippa lippa

Senior Member
Apr 16, 2013
i've tried to download the config gapps txt from here, put in the sd card root, data root whatever but always says error 70..

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Good evening everyone, I come to share with you this ROM which is still developed for our old but still functional Mi2/s.
    I find it indeed surprising that nobody talks about it ... Especially that a version on Android 9 is fully supported.
    I installed it for a while and everything works correctly even the GAPPS!

    I do not prefer to put links to respect the developers, but if they come forward, it is with pleasure that I would put them following this subject.

    So try Mokee!
    hi, i tried 10 but didn't try 9.0..
    10 has a camera problem; you get images 90 degree rotated.. didn't dig it too much and don't know if there is a solution..
    instead installed flyme 6.x based on android 7.
    it's flawless and much faster than miui..
    but i may try mokee 9 someday soon..
    thanks a lot.
    Yes Mokee 10 is out there is really not a long time and is therefore experimental version for the moment.
    But against the latest versions of Final Mokee 9 are really stable and fast.
    Keep me posted when you try it on the Flyme 6.x rom ;)
    I also just tested the Miui Pro v9.2.3.0 and Flyme ROMs.

    Miui Pro:
    The applications are launched generally quite quickly and the battery and indeed optimized.
    The shortcomings are the absence of languages (no French for my part) and the dated aspect of the UI.

    I like the interface of flyme that I know (I have a pro 5), on the other hand with this version, impossible to have the GAPPS of functional (Google install via Meizu AppStore).

    Finally, I'm back to Mokee 9 waiting to install Gapps on Mokee 10...
    Hi all,

    I have also just installed HavocOS 3.2 on our Aries device and it works like a charm (Android 10).

    Few days ago they also published on sourceforge the official 3.3 , but it crashes to me during first boot.

    I had to tweak a bit the gapps-config file to be able to install gapps due to the limited space.

    It's indeed awesome that we can still play with such old metal and bleeding edge software! ?

    Hi Gollum,
    Do you have a link for this HavocOS ROM?
    Camera, FM is supported?

    Camera works, not sure Radio FM as I haven't tried, but FM app is there. I will try and let you know.
    Yes, the link is the one shared in the post before this :)