• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][A11][OFFICIAL][MIATOLL] crDroid 7.4 Alpha release

Search This thread

xda-nick

Member
Apr 2, 2020
24
3
To install the apk within the OS obviously is always a necessary step, that's installing Magisk Manager. But it's not installing Magisk.

Anyway, it seems to be a known issue, see here. I was able to fix this in connection with this.
Here are the my exact steps:
  1. I installed the latest Magisk apk within the OS. I tried with the stable version first and after it worked I switched to Canary. That's only the manager, Magisk isn't installed yet.
  2. I rebooted to recovery and flashed Magisk v21.4.
  3. I started Magisk Manager and updated the now correctly installed Magisk v21.4 to the latest Canary.

SafetyNet passes and Magisk Hide seems to work like usually. Some "strenuous" banking apps like DKB Tan2go or Fiducia SecureGo still need Magisk to be frozen with AirFrozen.
 
Last edited:

vissegard

Member
Jun 1, 2021
8
0
yup, @xda-nick solution for magisk works.
For some reason, after the 7.6 update Play Services started to crash resulting in me having to reinstall GApps. After the reinstall the entire thing works. No idea what caused it.
 

xda-nick

Member
Apr 2, 2020
24
3
I also experienced the crashing of GApps after the update, but I think reflashing them is just the normal procedure in this case. See flashing instructions in the first post of this thread.
 

bonbonboy

Senior Member
Jan 14, 2007
76
14
Flashed the OTA, almost all seem to work smoothly.

Two issues i noticed:
  • After some times, my screen doesn't turn off automatically (i set up to turn off after 1min, but even in changing the value, it doesn't turn off). I need to reboot my phone to make it works as it should.
  • I have a banking app (ING PL) which force close 1s after i opened it. Clearing the cache, reinstall, magisk hide, nothing works. Didn't have any issue previously with that rom 7.4. Maybe a clue @xda-nick ?
One sub question, in which folder the OTA is downloaded? As the boot.img is mandatory to reflash magisk (a reminder HERE for those having issue with it), it's better to take it from the ota downloaded than to download again the rom on my computer.

Thx for your answers :)
 

vissegard

Member
Jun 1, 2021
8
0
@bonbonboy
Yeah, ING doesnt work for some reason - maybe it detects that SELinux is disabled? I've checked some other banks and MBank works though.
also xda-nick said that for some banking apps magisk needs to be frozen with AirFrozen, maybe this would help
 
Last edited:

educated__fool

Senior Member
Sep 18, 2014
98
36
Veles
stavrovski.net
Oh **** this after updating to 7.6 it reboots every 2 minutes! So tired of miatoll Custom-ROMs. Probably going to sell this crappy supported device.

well, I've just upgraded yesterday to 7.6 without a problem. needed to re-flash gapps and magisk (as expected) and I've experienced zero issues so far.


This ROM has been a smooth ride for me. The only thing I couldn't get it working is the google assistant responding on 'ok/hey google'. I'm unable to activate the 'voice match' toggle no matter what

Any feedback on the google assistant issue is very much appreciated.

Thanks
 

xda-nick

Member
Apr 2, 2020
24
3
I googled about the assistant issue and found the tip to install the Google app as a system app. I systemized it with Lucky Patcher. That was a bad choice. After reboot the Google app kept crashing. So I tried to de-systemize it. That was even a worse choice. It lead to a soft brick of my phone, i. e. crDroid booting up to the animated eye and then keeping in that state. Re-flash of the rom and Gapps didn't help. So I finally had to cleanflash the rom. Everything seems to work fine again, but there's one issue I didn't experience before: I cannot install the Revolut app vom Google Play store, the phone is recognized as incompatible. I tried to change the fingerprint with MagiskHide Props config but it didn't help. So I installed Revolut from the Aptoide app store. As I always have serious problems to log into Revolut after installing the app (it says passcode or phone number incorrect) since I switched to my Joyeuse, which leads to having me to contact their support so that they fix the issue on their side (I really would like to know what the actual problem is, but I never get an answer to this), I will not touch the current installation now and leave it as it is.
 

bawitdol

Senior Member
Aug 5, 2013
93
16
Gwangju Korea 광주 光州
I googled about the assistant issue and found the tip to install the Google app as a system app. I systemized it with Lucky Patcher. That was a bad choice. After reboot the Google app kept crashing. So I tried to de-systemize it. That was even a worse choice. It lead to a soft brick of my phone, i. e. crDroid booting up to the animated eye and then keeping in that state. Re-flash of the rom and Gapps didn't help. So I finally had to cleanflash the rom. Everything seems to work fine again, but there's one issue I didn't experience before: I cannot install the Revolut app vom Google Play store, the phone is recognized as incompatible. I tried to change the fingerprint with MagiskHide Props config but it didn't help. So I installed Revolut from the Aptoide app store. As I always have serious problems to log into Revolut after installing the app (it says passcode or phone number incorrect) since I switched to my Joyeuse, which leads to having me to contact their support so that they fix the issue on their side (I really would like to know what the actual problem is, but I never get an answer to this), I will not touch the current installation now and leave it as it is.
find and flash the file named NikGapps-Addon-11-Velvet-signed.zip. which is the real meaning of <install google app as a system app>
 

koshikas

Senior Member
Jun 16, 2015
704
304
Colombo
@henloboii you have erroneously put a link to a wrong XDA support thread in the official site (currently pointing to a unofficial crdroid 7.7. build thread) which should rightfully be this thread (i think :p )

EDIT: maybe i'm indeed mistaken OP please clarify when u can
 
Last edited:

Marcondes BR

Member
Aug 23, 2014
27
7
Rio de Janeiro
I'm having some problems with bluetooth. I can't pair my Huawei smart band at all and the sound in the earphone only comes out on one side. On other smartphones they work well. At MIUI too.
Does anyone have any idea what it could be? I'm using version 7.8.
 

Top Liked Posts