• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][A320FL/F/Y] LineageOS 16.0

Search This thread

slyfennec

Member
Nov 2, 2010
9
0
No sound

Hi McFy.

Owner of a A3 2017 (SM-A320F/DS) it's a long time I follow your work on this wonderful smartphone and want to test your roms.

I decided a few days ago to go. No issue to install (except with the OEM unlock, it tooks time before I understand why I couldn't flash TWRP...), all was fluid and I began to customize the stuff, BUT...

I realize that in fact I don't have sound... No rings, no music, nothing at all... When I test with earplugs, no issue, sounds play normally, but nothing with the internal HP. I didn't test with a phone call.
I try with other roms (LOS 14.1, LOS 15.1 and RR) and I got exactly the same issue. So I asked myself if it's not an issue particular to my model ? I'm not sure other owners of this model try your roms.

When I come back to a stock rom, no issue at all, sounds play perfectually.

If I can help to resolv, send some logs, etc... Tell me. I'm a french guy too, so we can private exchange in french, maybe it can be easier for technical requests.
Thx a lot for your work, I'm really disappointed to not have the possibility to use it...
 

zcacogp

Senior Member
Sep 18, 2007
54
2
A trivial Q: how do I make the BlueTooth icon display in the status bar? I believe that BT is working (I can see other BT devices from the 'phone) but can't see the icon at the top of the screen which is a bit of a pain.
Update on my own question: if you connect the 'phone to a BT device then the BT icon appears in the notification bar, when you disconnect it disappears. This isn't the same as previous versions of Android I have used whereby the BT icon is present when there is no connection but that's not a biggie.

Battery life is still very low with this ROM - it uses a lot of juice, which is a shame. I've also found that it can be unresponsive in some situations but can't pin this down - which is unhelpfully vague, I know. It needs a reboot on a regular basis to become smooth and crisp again. Other than that it's good, thanks for your work.
 

zogoibi

Senior Member
Aug 18, 2011
372
50
Battery life is still very low with this ROM - it uses a lot of juice

There's a huge drain by "Mobile network standby" in Oreo/Pie LOS ROMs all over, which apparently affects only some owners of the same device models.

I say "apparently" because I'm starting to wonder whether this bug really affects only some of us (which is sort of bewildering), or rather it affects everybody but only some of us are actually concerned enough to notice it (which would make more sense, in my opinion).

So, would you please mind to check your "full device usage" (three dots in upper right corner under Battery usage) and tell me if it reports a huge drain by Mobile Network Standby? I'm searching for clues to sort out this issue.
 
Last edited:

zcacogp

Senior Member
Sep 18, 2007
54
2
Zogoibi,

Thanks - that was an interesting post. I've checked that bit and the figure you are looking for is "Mobile network standby 2% (since last full charge)".

However the device currently sits at 47% charge, having been fully charged overnight last night and not used much since. I've talked on it for about 2 hours today but done nothing else with it as I've been sat at my desk (so no need for 'phone-based eMail, searches, watching videos etc). I expect it will be down to 25% or so by the end of the day, whereas it would be nearer 60% by the end of the day with the stock Samsung ROM before I changed things over.

So I'd say there is a current drain somewhere but it's probably not 'Mobile network standby'. BUT there will be many other people who will be able to give you more info than me.
 

Bernique

Senior Member
Apr 25, 2010
106
16
Paris
My feedback:
- My battery lasts 3 to 4 days, it's fine for me.
- I could not get wifi working until I checked and updated Magisk. Don't forget to check that.
- I still have a problem with the media scanner. My ringtone and alarm change randomly
Once again, great job McFy!
 

tablord

Senior Member
Mar 21, 2012
103
19
Encryption not working

As far as I'm concerned the ROM (current version "lineage-16.0-20181228-UNOFFICIAL-a3y17lte") works flawlessly so far. That is until you try to encrypt it...
which leads to an endless boot routine! If this process is manually stopped (after e.g. 30 minutes or 3 hours) and the A3 is rebooted it asks for the encryption password. But directly after entering the right password (sometimes even before one has even entered anything) the A3 reboots automatically into TWRP. TWRP accepts the password and decrypts /data but rebooting system (even after wipe cache&dalvik or even flashing the ROM again) only eventually leads to another automatic reboot into TWRP.

Is anyone else having these issues? Or do you have a hint how to make it work? @McFy Does encryption with pin or password work on your device?

Update 1:
Interestingly, if one does not use a pin or password but just the regular swipe it works! That is it reboots just fine. Using encryption without a key is pointless of course. :mad: But once one replaces the swipe with a pin or password the above issues reappear...
 
Last edited:

zogoibi

Senior Member
Aug 18, 2011
372
50
Zogoibi,

Thanks - that was an interesting post. I've checked that bit and the figure you are looking for is "Mobile network standby 2% (since last full charge)".

However the device currently sits at 47% charge, having been fully charged overnight last night and not used much since. I've talked on it for about 2 hours today but done nothing else with it as I've been sat at my desk (so no need for 'phone-based eMail, searches, watching videos etc). I expect it will be down to 25% or so by the end of the day, whereas it would be nearer 60% by the end of the day with the stock Samsung ROM before I changed things over.

So I'd say there is a current drain somewhere but it's probably not 'Mobile network standby'. BUT there will be many other people who will be able to give you more info than me.

My feedback:
- My battery lasts 3 to 4 days, it's fine for me.
- I could not get wifi working until I checked and updated Magisk. Don't forget to check that.
- I still have a problem with the media scanner. My ringtone and alarm change randomly
Once again, great job McFy!

Thanks for your feedback.

3-4 days was my battery life with stock; it would be more than fine for me, too. Unfortunately, LOS 16.0 scarcely gives me 24 h, like @zcacogp, except that my drain is reported to MNS.

I'm quite uncertain about the reliability of battery use statistics. I suspect they're wrong. For instance, it always reports my Spotify among the worst suckers, however I very rarely use that app.

I'll try to keep collecting information from other users.
 

zogoibi

Senior Member
Aug 18, 2011
372
50
New bugs observed after two weeks of use:
1.- Ring, alarm and notification tones changing by themselves randomly (already reported by @Bernique)
2.- When playing audio (I use ES Player), every time I plug or unplug the USB cable, the present sound track starts over from the beginning (i.e., either plugging or unplugging behaves exactly as if I had hit "sound track back").
3.- On Whatsapp, when playing back an audio note, putting the device to my ear (or hovering a hand, etc, over the proximity sensor) switches off the screen (no problem with that), but! releasing the proximity sensor pauses the playback.
4.- Very low maximum volume from the loudspeaker.
 

zogoibi

Senior Member
Aug 18, 2011
372
50
Mine did that on stock too.

Hmm... Interesting. You're right. I can't confirm this on stock now, but it's true at least for Resurrection Remix. That's weird. I'm 99% sure that it didn't happen to me before. May it be a Whatsap bug for the last version (2.18.380)?

How to reproduce: play a Whatsapp audio note. On proximity sensor activity, sound switches from loudspeaker to earpiece. On proximity sensor release, audio playback pauses.
 

SnowFuhrer

Senior Member
Apr 5, 2018
1,621
467
Spirit River
Hmm... Interesting. You're right. I can't confirm this on stock now, but it's true at least for Resurrection Remix. That's weird. I'm 99% sure that it didn't happen to me before. May it be a Whatsap bug for the last version (2.18.380)?

How to reproduce: play a Whatsapp audio note. On proximity sensor activity, sound switches from loudspeaker to earpiece. On proximity sensor release, audio playback pauses.
Tested it again and it still does it.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 74
    main-qimg-eae07393a6257f6f44f3a6f2a0be5cbb


    Lineage OS 16.0



    LineageOS is a free, community built, aftermarket firmware distribution of Android 9.0 (pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.


    Code:
    Your warranty is now void.
    I am not responsible for bricked devices, dead SD cards,
    thermonuclear war, or you getting fired because the alarm app failed. Please
    do some research if you have any concerns about features included in this ROM
    before flashing it! YOU are choosing to make these modifications, and if
    you point the finger at me for messing up your device, I will laugh at you.


    Working

    • All features must work


    Bugs/Issues :

    • You tell me


    Supported Models
    • A320F
    • A320Y
    • A320FL (the more reliable as I own it)
    • Dual Sim is supported


    DOWNLOAD : TWRP, ROM & GAPPS
    last build
    all builds
    GAPPS
    TWRP


    Instruction

    • Download the latest build
    • Download GAPPS for 32 bit, arm, pie device
    • Recommended : Do a Nandroid Backup
    • Wipe System, data, Cache and Dalvik
    • Flash ROM using latest TWRP Recovery
    • Flash GAPPS (if you want them)
    • Reboot
    • Enjoy!



    Enjoy and if you like my work, give a thumbs up :)

    Credit:

    • LineageOS team & Exynos7870 developpers working with me
    @McFy(me)
    • All peoples supporting me
    • Unbekannt1998 for lending me his VPS

    donators :

    - Peter S.
    - Rogier L.
    - Alex F.
    - Daniel M.
    - Markus R.
    - Jean-François R.
    - Paul F.
    - Ivann M.
    - Kim M. N.
    - Zalan N.
    - Thierry C.
    - Martin B.
    - Adrian A.
    - Alexander B.
    - Tribe of frog
    - Marc S.
    - Mathias E.
    - Valentin G.
    - Moritz D.
    - Emmanuel P.
    - Rafael E.
    - Manuel S.
    - Patrick G.
    - Georg W.

    Thanks you ! :)

    If you like my work you can put a thanks or give me to my paypal or my bitcoin:36zAbcB1patxNdt21cknwYg2k9jyCdj1GX
    as making rom is much time ! ;)

    If you want to get news or talk to me and other user you can join this group telegram : Lineage A3 2017




    XDA:DevDB Information
    LineageOS 16.0 , ROM for the Samsung Galaxy A Series 2017 A3, A5, A7

    Contributors
    McFy
    Source Code: [url]https://github.com/McFy49[/URL]

    ROM OS Version: 9.0 pie
    ROM Kernel: Linux 3.x

    Version Information
    Status: WIP

    Created 2018-12-27
    27
    Changelog
    Code:
    [B]27th December 2018[/B]
        - Initial build
    
    [B]28th December 2018[/B]
        - Enabled HWC
    
    [B]9th March 2019[/B]
       - February security patch
       - Selinux enforced
       - Fixed the wrong video lenght issue
       - latest LineageOS sources
       - Fixed the Wi-Fi in a better way
       - Removed magisk
    
    [B]30th March 2019[/B]
       - Labelized Selinux DRM denials
    
    [B]4th April 2019[/B]
       - April Security Patch
       - Updated LineageOS sources
       - Added custom update over the air (OTA)
       - Boosted mic gain
    13
    11
    Hey everyone, I am glad to share you a new build !

    The changelog is:

    - February security patch
    - Selinux enforced
    - Fixed the wrong video lenght issue
    - latest LineageOS sources
    - Fixed the Wi-Fi in a better way
    - Removed magisk

    Thanks for support I can see around the threads

    Stay Tuned !

    Download : here
    More info on first post
    9
    Today I found this ROM, I decided to test it, my expectation was low, but at the end I was amazed! :victory:

    The first boot is going to take like 8-12 Min. I never have functional WiFi in the first boot, so just reboot the phone 1 time in order to fix it and proceed with the initial configuration.

    Many thanks for your work McFy and the Teams that are working with you!
    If there is way to help you to improve the development of this ROM please let me know, I will donate soon!

    Sorry for my bad English.

    Device: A320Y
    Previous ROM: Android 8.0
    ROM: lineage-16.0-20181215-UNOFFICIAL-a3y17lte.zip
    TWRP: recovery_a3y17lte-050318.tar.md5
    GAPPS: Mini

    Pros:
    -Stability. 5/5
    -Battery life. 5/5
    -Sound, Video, Call, all the Apps I have tried works.
    AFwall
    WhatsApp
    YouTube
    PlayStore
    Opera Browser
    Nova Launcher
    Clover
    etc.

    Cons:
    -WiFi stop working after a reboot. When I reboot the phone I could lost the WiFi. (SOLUTION: Reboot the phone one more time solves the problem.)
    -I can't update to the new Magisk version, when I tried, the phone do a boot loop. (SOLUTION: Reinstall the Stock ROM (Oreo 8.0) with Odin and proceed to reinstall this ROM again)
    -SElinux Disabled :(

    Extra comment. When I want to charge it with the phone turned off there is no battery percentage % to know the level of charge, I was used to disconnect it around the 80% of battery charge, but now I can't do it. I think this is something about the Lineage ROMs, I have another phone with LOS 15 MotoE and its the same case, I cant see the battery % while charging it turned off. Maybe in the future this "Feature" will be added.

    Some Screenshots:
    Desktop


    System




    StatusBar & Desktop




    Many thanks McFy! Please keep improving this ROM and fix the SElinux issue

    Thanks for your support as well as the one from the others users.

    I am here to give you some update on what is going on :
    - first of all I want to give a big thanks to Peter who sent me an A3 2017 so I can work faster thanks to that unit that I don't need to be reliable!
    - a new build is comming soon ;)
    - I fixed the loops that some of you get with the encryption
    - I wrote the sepolicy rules so the next build will have selinux enforced
    - I fixed the wifi on a better way so now it's more stable
    - I am testing that everything work and looking about few last things so expect a build soon :)