[ROM][A520F/DS] LineageOS 14.1 Alpha

Search This thread


Senior Member
Apr 11, 2011
I just recompiled cm14.1 with a compatible kernel with an oreo bootloader.
Conserning the GPS I have a positioning error when I run. The rocking of the body disturbs the gps.
I have seen several reports on this problem. I do not know if samsung corrected this problem on the latest updates.
LineagesOS 16.0 should also use the latest libraries.

Top Liked Posts

  • There are no posts matching your filters.
  • 86

    LineageOS is a free, community built, aftermarket firmware distribution of Android 7.1 (Nougat), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Bugs/Issues :
    • GPS takes ~30secs to lock
    • Torch cannot be activated from quick settings
    • External SDCard not showing up in gallery, etc
    • Fingerprint
    • LTE is spotty - only 2G/3G seem to be stable
    • Screen recording is broken (csc errors)
    • Camera saves picture in wrong orientation (workaround: lower quality to 11,9MP 16:9 in camera settings)
    • ...more?

    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    ### RELEASES ###
    2017/08/11 - https://www.androidfilehost.com/?fid=817550096634791977
    2017/08/14 - https://www.androidfilehost.com/?fid=745425885120755593
    2017/08/22 - https://www.androidfilehost.com/?fid=961840155545590372
    2018/01/03 - https://www.androidfilehost.com/?fid=673791459329070889
    2018/01/03 - https://www.androidfilehost.com/?fid=746010030569953982

    The releases are based on Samsung Nougat kernel sources. If you are facing issues regarding the radio stack, you need to flash official N to get the new baseband. The M baseband might work, but it unsupported!

    XDA:DevDB Information
    LineageOS, ROM for the Samsung Galaxy A Series 2017 A3, A5, A7

    Source Code: https://github.com/raymanfx/android_kernel_samsung_a5y17lte

    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.10.x

    Version Information
    Status: Testing

    Created 2017-08-11
    Last Updated 2018-02-15
    I can not agree, unfortunately. Just take a look at here:

    They are already rolling it out and the finish will be the end of March.

    ... I still don't care?
    It hasn't been enabled here yet, and there are more important things I need to focus on.
    If you want VoLTE/VoWiFi, you'll have to do it yourself, review.lineageos.org is open for your contributions.

    For those who are feeling adventurous, here's a first build of Lineage 15.1 (Oreo 8.1):
    DO NOT USE OPENGAPPS, but instead use the Gapps that are inside that folder.
    Bluetooth is broken, NFC might require a restart to work - other than that it's okay-ish for a first preview build.

    If you want to support me and/or the project, I'm looking for a used Galaxy S8 to buy from donations, so, you know what to do if you want to help that cause :)
    Today might be the day you have waited for!

    This is the first build with open source (reversed) RIL I hacked and fixed today finally.
    Lots of effort went into this one, I hate playing the cat and mouse game, especially in the radio subsystem, which is the one I'm the least familiar with.

    Enjoy and report back please. Cycling between 2G, 3G, 4G should also work fine now.
    I guess I can give you some info about the progress on 15.1. :D

    Firstly read this post. What has happened since then?
    Well, a few things. Now I'm going on holiday so I am releasing all this. This is where we at now:
    It is still 95% work by raymanfx although I am releasing it. I maybe added some additional stuff to his work.

    * Bluetooth is now working -> RaymanFX was working on this and in the end he was finally able to fix it. edit: Well at least it turns on on boot now.
    * Always On Display -> Google added support for this on AOSP Oreo and I was able to enable it on lineage. Try it guys. Hopefully it works as intended and doesn't drain the battery too much.
    * A7 and A5 unification attempt -> Well firstly I need to say thanks to Skorupsi for testing out my stuff. I experimentally added A7 support. I own an A7 and I can verify that it boots and it appears to be working fine. But maybe some calibration stuff - screen, camera, battery is still set to A5. So it's still experimental and I don't guarantee anything. Flashing this is your responsibility. This only applies to A7 users, if you own an A5 you can ignore this statement. It is exactly the same as it was before for A5.
    * Fixed screen off while in calls. Yeah you probably saw this in 14.1 as well.
    * Perhaps I messed up media codecs. I see 1080p youtube videos somehow lagging.
    * Is NFC working? edit: I see some crashes in the logcat - probably not.
    * Upstream updates from lineage
    * You should use N bootloader and modem for your device

    Lastly thanks to xda moderators for acting. Yeah developers have their jobs/schools/families and can't focus on this all the time. Please don't get rude. No ETA/volte.

    Have fun :)
    So, as some of you might know, I was donated a SM-A520F (A5 2017) to work on it, these are the early results.

    What needs to be done still:
    * Reverse engineer the amplifier code for the OSS audio HAL
    * Fix fingerprint (looks like a mobicore issue?)