[ROM] Aidan's ROM [v7.5] [Netflix TV] [Prime Video TV] [S905X] [ATV 7.1.2] (Lag & Bloat Free, Pre Rooted, Samba & Miracast) 2021 Update!

Search This thread


New member
Nov 15, 2011
I believe the link for the Buzz TV XPL 3000 (Needs my Buzz TV 3000 Remote. patch) is down

any chance anyone can share the download for this file. Thanks!


May 21, 2015
witam mam mi tv stick na s805 mam ich ok 10 sztuk ale z uszkodzoną pamiecią emmc i jak z dobrego skopiowalem pamiec i zaprogramowalem nową to na innym sticku nie działa netflix primawideo co zrobić aby to zaczelo działać jak te stiki mozna zrotować mam z3x jtag meduse pro ufi i nic nie moge zrobić poza dampem jedyne co to po uart moge odblokować botloadera ale nie wiem jak go zrootować proszę o pomoć bo już nad tym siedze kilka tygodni i nadal nedflix nie działa

Mod Edit: English Translation Below

hello, i have a tv stick for s805 i have about 10 of them but with a damaged emmc memory and if i copied the memory from a good one and programmed a new one, netflix primavideo does not work on a different stick what to do to make it work how can these sticks be rotated i have z3x jtag meduse pro ufi and I can't do anything but damp the only thing after uart I can unlock the botloader but I don't know how to root it please help because I've been sitting on it for a few weeks and still nedflix doesn't work
Last edited by a moderator:
Feb 20, 2023
Boa noite, tenho uma versão do Android 7.1.2 instalada, mas não é a sua versão no meu nexbox a95x. Eu gostaria de ficar com sua interface. Existe uma maneira de disponibilizá-lo para download?

Mod Edit: English Translation Below

Good evening, I have a version of Android 7.1.2 installed, but it is not your version on my nexbox a95x. I would like to stick with your interface. Is there a way to make it available for download?
Last edited by a moderator:


May 21, 2015
Boa noite, tenho uma versão do Android 7.1.2 instalada, mas não é a sua versão no meu nexbox a95x. Eu gostaria de ficar com sua interface. Existe uma maneira de disponibilizá-lo para download?
this software under mi tv stick model mdz-24-aa android 9 amlogic s805y processor won't work and even if you edit files in hexeditor I can't fix apk netflix right away but I saw your box somewhere on the forum you have to look
Hey Guys,

anybody can help me?

I installed this Version of ROM and it runs flawless. But I have another project with this box now and I have to get into recovery mode. Sadly it doens't work anymore.

I tried:
- Various toothstick-methods -> No reaction, starts normally, no recovery!
- SD Card-method -> No boot from SD Cards
- Tried to install several APKs to boot to recovery -> many outdated, doesn't work or needs root
- Installed Termux but it needs Root/SU to be able to use the command

Anybody can tell me how to get into recovery again?



Senior Member
Jan 31, 2022
Motorola Defy
Samsung Galaxy S4 Mini
I installed this Version of ROM and it runs flawless. But I have another project with this box now and I have to get into recovery mode. Sadly it doens't work anymore...
Hey in this situation you would need to use "mask rom mode" thisbis achieved usally by shorting out 2 pins on the NAND / EMMC but can be located nearby, google your device and mask rom mode and check what NAND chip.is on your device to also help figure this out :)
Nice theory, but where is the NAND/EMMC Chip and which PINs? I have a MINIM8S_II Board.

BTW I dont see any PINs, the Chips have none visible.

My Amlogic is similiar to this one.

Finally I got my project to work. I used the Amlogic Burning Tool with a Stock Rom I found somewhere in the deep of the the internet. Boot to SD worked again. After that I used an Armbian SD Card to boot into Linux. BAM! :D

Now I have to search, how to install Linux on EMMC install Teamviewer and I have my Remote Computer.


  • MINI_M8S_II_Amlogic_S905X_Board.jpg
    2.5 MB · Views: 20
  • MINIM8S_II_Board_Large.jpg
    2.4 MB · Views: 20
Last edited:


Senior Member
Jan 31, 2022
Motorola Defy
Samsung Galaxy S4 Mini


Dec 16, 2019
Can anyone help me to identify chip to do a pin reset. I opened another tvbox I have, and I don't know how to identify it. I don't find the chip pins.

It is a Vontar X3 with S905X3 chip


  • IMG_20230501_180644.jpg
    1.6 MB · Views: 13
  • IMG_20230501_180737.jpg
    1.2 MB · Views: 13


Dec 16, 2019
Thanks, It is first time I found it. It is curious. I will try it and will comment here.


New member
May 22, 2023

Apologies if I posted in the wrong topic. I have a Mecool K1 Pro (with old tuner) box, I'm looking for a ROM that works with Netflix, Disney+, etc etc.

So which one would be suitable?
Is there a link?

I would be glad if you help.

Kind regards...

Top Liked Posts

  • There are no posts matching your filters.
  • 12

    Aidan's Custom Android TV 7.1.2 ROM
    UPDATED: 10/02/2021

    Netflix For Android TV!

    This is version 7.5 of my Rom, i use this as a daily driver and it is stable, it is CLEAN & NO BLOAT (any included apps are removable), this replaces my previous version (v6, v7 & v7.1 ect...)

    UPDATE: Aidan's Android TV 9 Pie Xiaomi Mi Box Firmware Port To S905X Now Also Available!
    XDA Post Clock Here

    NEW Website! Check it out & Downloads

    Improvements Made [V6]
    ●NOT pre-rooted (Flash Magisk via TWRP for root)
    ●User Interface renders at full 1080p
    ●Fixed bug where remote power button would turn box off/standby but not wake it up again
    ●Added Miracast (scren mirroring) [BROKEN] FIXED IN V7
    ●Removed Chromecast and other bloat (wont work in uncertified devices and would fill storage in 24 hours)
    ●New bootlogo and boot animation (No longer will boot animation appear frozen during 1st boot)
    ●Added New App Drawer (And modified APK) THIS WILL SHOW NON TV APPS
    ●Misc tweaks & adjustments

    Improvements [V7]
    ●Added More Wi-Fi Drivers
    ●WIFI & LAN SPEED fixed (Was maxing about 6Mbps, now sucsesfully got 40Mbps)
    ●DPI Changed to 320 (Android TV Stock DPI)
    ●More tweaks
    ●Now comes with Filelinked Pre-installed (You can uninstall if you dont need)

    Improvements [V7.1]
    ●TWRP replaced as was rendered at 720p in the top left on corner some devices
    ●More WiFi & Bluetooth improvements
    ●Updated boot animation android tv 11 (Thanks khurramrizvi for extracting)
    ●Added more keylayout files (USB)
    ●More visual tweaks
    ●More Performance tweaks

    Improvements [V7.2] (19/09/2020)
    ●Fixed Disney+ No sound issue fixed (Thanks to DiogoSilva48)
    ●More visual tweaks
    ●More Performance tweaks

    Improvements [V7.3] (06/10/2020)
    ●PRE ROOTED! (Root switch does not work, Always ON)
    ●Disney+ now has working sound (v7.2 but worth mentioning again)
    ●All preinstalled apps can be Un installed (exept system apps)
    ●Samba Windows File Server [NAS] (Usb HDD, SD, Internal)
    ●Google Documents UI added (fixes bugs in some apps opening files)
    ●Stock Downloads File Explorer Added (Related to documentsUI)
    ●Google Assistant Text Search Navigation Bug
    ●Phone Settings crash fixed
    ●Wi-Fi Tethering now works (Ethernet to Wi-Fi)
    ●Changed Mouse cursor
    ●Certificate installer fixed
    ●GlobalKeyInterceptor added
    ●OneTimeInitaliser added
    ●GooglePartnerSetup added
    ●Updated Backdrop (no longer claims chromecast built in)
    ●Alternative Screensaver Included (Can uninstall)
    ●Reboot to recovery option in all apps section
    ●More visual tweaks
    ●More Performance tweaks

    Improvements [V7.4] (06/10/2020)
    ●Added missing Files for WiFi Chip AW-NH665 (Thanks Erick)
    ●Special Build for devices that fail to flash Universal ONLY (MXQ Special Build) (Testing Need Feedback)

    Improvements [V7.5] (10/02/2021)
    ● Added Netflix Android TV Version

    Im very happy with how this turned out, please install and let me know if it works for you what device you installed on & if you have any suggestion

    Facebook Page

    Tested on
    ●MXQ Pro 4K (1GB RAM)
    ●Trongle X1 (2GB RAM)
    ●NPET A95X( 2Gb RAM)
    ●rasse-001 (unknown Ram/rom)
    ●Leelbox q2 (unknown RAM/ROM)
    ●X96 (1GB Ram 8GB Rom)
    ●Beelink MXIII-II (Unknown RAM/ROM)
    ●Sammix R95
    ●M9C PRO
    ●X96 Max
    ●Buzz TV XPL 3000 (Needs my Buzz TV 3000 Remote. patch)
    ●Trongle S3 (Report that needs super su to root)
    ●TX3 PRO
    ●KM5 OTT 1GB/8GB (No reset button 1 user reported using "Reboot Update" worked)
    ●Alfawise A12 Plus Projector (AW-NH665 WiFi fixed in v7.4, Also Needs my Remote patch)
    ●T6 S905X 1/8GB
    ●KM5 (This Version only Worked With Alternative Special Build AKA: MXQ Special Build) [No Reset Button, Connect the box to PC with USB & Connect AC Power WHILE also pressing the Power Button, the device should then connect to the software and Flash]
    ●Many More...

    Known Issues
    Wifi chip HS2734A
    ZTE B860H (2 reports didn't work)
    MXQ boxes have hundreds of clones, should work on 90% of boxes if no Roms work at all for you I have some last resot ROMs at bottom of this post

    V7 Download From Google Drive (Fast Download)
    Replaced with v7.1

    V7.1 Download From Google Drive (Fast Download)
    Replaced with v7.2

    V7.2Download From Google Drive (Fast Download)
    Replaced with v7.3

    V7.3 Download From Google Drive (Fast Download) (06/Oct/2020)
    Replaced with v7.4

    [V7.4] Universal Download (Fast Download) (24/Oct/2020)

    Special Builds (Fast Download) (06/Oct/2020)

    [v7.4] Nexbox A95X Remote WITH POWER ON BUX FIX (07/07/2020) (Updated 24/Oct/2020)
    This Version Has Nexbox_Remote.zip pre installed in case can't access recovery to flash the patch (Added 22/06/2020)
    ^ Thanks to klo33 (freaktab) for testing these changes

    [v7.4]Alternative Special Build [ONLY Use IF Universal Fails!] (07/07/2020) (Updated 24/Oct/2020)
    This Version has additional DTB files (Alternative P212 + p214 & p242)
    Drawback is the UI is rendered at 720p with 210 DPI, The UI wont look as Sharp as universal 1080p with 320 DPI

    MY Patches (Flash with TWRP)

    ●Mygica atv 495x REMOTE (Thanks to nicko450 for supplying the remote.conf file)
    ●Buzz TV XPL 3000 Remote patch (You need to use ADB or terminal to enter recovery on these Devices)
    ●Xview R7 Remote Patch
    ●Mini M8S II Remote Patch (Thanks to Kishore12 for finding and fixing a .conf file)
    ●Sunvell T95k Pro Remote Patch
    ●Alfawise A12 Plus Projector Remote Patch

    Patches (Flash with TWRP) [BY MINIXFREAK]
    Nextbox, sunvell, Mecool, Zoomtak Remote Patches
    a95X, l8, Magicsee, T95U, T95Z, Tanix, x92, Zoomtak, Youndoo Clock Patches
    QC9377 & 4.1 Bluetooth patches

    Install using amlogic burn tool

    Donate & Support Me & Buy me an IRN-BRU
    Paypal: http://paypal.me/aidanmacgregor92
    Bitcoin: 1GhSiPf2ZURa9HiVMVh5KXmmB8nXr6nCVZ

    FAQ (WIP)

    Q. Netflix wont work from play store
    A The TV Version of Netflix needs Widevine Level 1 DRM, This cannot be added to your device with a firmware, FIXED IN LATEST VERSION PATCHED NETFLIX PREINSTALLED

    Q. Amazon Prime Wont Work

    A. Like Netflix Install the mobile app, the TV version needs Widevine Level 1

    Q. Disney+ No Sound
    A. Fixed in v7.2

    Q. Root Switch Wont Work
    A. Unfortunately v7.3 is always rooted and the switch doesn't work (I may offer unrooted versions if there is demand)

    Screenshots On The Website

    If you have one of these devices that really struggle taking any custom ROM, sometimes these are MXQ devices (there are so many clones of these devices) and they may have a locked bootloader or it needs a DTB that isn't common or known, there are some ROMs that have saved some people before, these are only if no other custom ROMs will work for you and are a last resort :)

    See this post:
    Hi, Why should one pick this 7.5 version over the 8.0 one? Thank you
    This one did it because 8 does not support remote control and does not support the same set of keys in BT keyboard. Only 7.5 can be operable, but true, the both works and 8 has mutch better GUI.
    Ok here is TWRP backup of v7.1, Can you test this and let me know it works properly please? this can be installed over the top of v7 using TWRP. Simply place the "TWRP" folder onto a USB Drive (See Readme Instructions.txt)


    Installed and working fine. Thank you !
    Glad you used the Boot Animation, hoping more devs would include it in their builds ?