• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][All Quark][Android 11] LineageOS 18.1

Search This thread

fgl27

Recognized Developer
Feb 27, 2014
3,679
9,505
Brazil...South of the south
Active display is a Motorola name.

Use Ambient display, enable it on settings -> system -> actions

Hello MOTOrists !! Is there any alternative to display notifications on the locked screen like in stock 6.0 marshmallow?
Are you referring to wave related notifications?

If yes check the above comment... Or the bellow image.
Screenshot_20210902-093519_Advanced_settings.png
 

AVgen

Member
Aug 30, 2021
6
0
I mean, the notification icon appears periodically. But the AOD programs do not let the device fall asleep. You just need an indication of notifications, as in stock or as similar as possible.
 

fgl27

Recognized Developer
Feb 27, 2014
3,679
9,505
Brazil...South of the south
The device sleeps just fine, if aod is on or not also if notification are there or not.

How can you tell it's not sleeping?

I don't really know how moto implementation works I don't use that for years, for me is all the same, just the theme that is different as this is android 11 and not 6.

There also notification light... In apps & notifications... notifications advanced, will blink the device green LED if notifications are there.

Screenshot_20210902-113608_LineageOS_Settings.png
 

AVgen

Member
Aug 30, 2021
6
0
Here is an example of how a MOTO display works. At the same time, notifications "pulsate". That is, they appear and disappear periodically. I've tried 5 apps with similar functionality, but they keep the screen on all the time.
 

Attachments

  • IMG_20210902_220022.jpg
    IMG_20210902_220022.jpg
    94 KB · Views: 13

AVgen

Member
Aug 30, 2021
6
0
Anyway, thanks and great job! My turbo is alive again :) Is it possible to attach a setting for customizing vibration like on Havoc OS?
 

fgl27

Recognized Developer
Feb 27, 2014
3,679
9,505
Brazil...South of the south
Here is an example of how a MOTO display works. At the same time, notifications "pulsate". That is, they appear and disappear periodically. I've tried 5 apps with similar functionality, but they keep the screen on all the time.
We are making confusion here with aod and ad...

This device has support for "ambient display" not "always on display". No moto OS has ever had always on display support for this device.

In relation to the video. As I wrote before is just a theme change, on my device ambient display works just like that video minus the theme as this is android 11 and not 4 like that video.

If that isn't the case for you that isn't because ad.

Are you sure you are enabling ambient display in settings?

As you wrote "I've tried 5 apps", what apps?

Don't use any app for aod, enable the settings system option for ambient display, works just like moto after all moto didn't invented that Google did and moto just rebranded it.

BTW only share Imagen's on English that image makes no sense to me, mostly because doesn't prove is ad fault.

This is how my device behave with ad on all the time

Those 4h awake 2 was charging 2 was using no sleep issue.

Screenshot_20210902-142951_BHB27_Kernel_Adiutor.png
 
Last edited:

fgl27

Recognized Developer
Feb 27, 2014
3,679
9,505
Brazil...South of the south
Anyway, thanks and great job! My turbo is alive again :) Is it possible to attach a setting for customizing vibration like on Havoc OS?
I don't know what havoc os is or have, you can search in settings for vibration there is a lot of option's

Use the bhb27 kernel app, to change vibration strength, that app need root, the only root option is magisk

Screenshot_20210902-144001_BHB27_Kernel_Adiutor.png
 

AVgen

Member
Aug 30, 2021
6
0
I used: AcDisplay, Glimpse Notifications, Always On AMOLED, AOA: Always on Display, Glance Plus, Light Flow. All of them manage notifications, but not as in stock. Now Ambient Display displays a notification once, but I would like to until not view the notifications.
bhb27 kernel application changes vibration only in actions. In Havoс you can change the vibration pattern itself.
 

Attachments

  • Screenshot_20210521-025039_Настройки.png
    Screenshot_20210521-025039_Настройки.png
    91.1 KB · Views: 15

fgl27

Recognized Developer
Feb 27, 2014
3,679
9,505
Brazil...South of the south
I used: AcDisplay, Glimpse Notifications, Always On AMOLED, AOA: Always on Display, Glance Plus, Light Flow. All of them manage notifications, but not as in stock. Now Ambient Display displays a notification once, but I would like to until not view the notifications.
bhb27 kernel application changes vibration only in actions. In Havoс you can change the vibration pattern itself.

Ambient display from custom ROM works just like the stock ROM feature, if doesn't for you is because you don't know how to use it.

If you wanna something else buy a device that has what you wanna, quark never had and will never have always on display.
 
Wifi display is supposed to be working again on the latest september ROM version, I don't have a device that supports it so I can test if anyone test let me know.

Enjoy it.
Running fine for a week now on my backup/wifi Turbo. All wifi seems to work. Having an issue with running a dashcam app initializing the camera. 😕 Not complaining, only commenting. Likely something I'm missing. At this age, not surprising SOMEthing original-basic is not entirely compatible. Have you a preferred camera app for Android 11?

Update: Had some time, did a reinstall of sorts, camera works.
Update 2: Deactivated stock messaging app to avoid camera control conflict. BTW, dashcam app is DailyRoads Voyager.
 
Last edited:
  • Like
Reactions: fgl27

cachufleta

New member
Oct 3, 2021
2
2
hi, first of all: THANKS! I've been using the previous version and all was perfect
I updated to 18.1 and now I'm having an issue where I can't use my phone. I enter my pin when I turn it on and it takes it but screen stays black for about 3 seconds and then it takes me back to the unlock screen. I know the pin is right and also if I type a wrong one I get an error but can't seem to go past unlock.
 
  • Like
Reactions: fgl27

fgl27

Recognized Developer
Feb 27, 2014
3,679
9,505
Brazil...South of the south
hi, first of all: THANKS! I've been using the previous version and all was perfect
I updated to 18.1 and now I'm having an issue where I can't use my phone. I enter my pin when I turn it on and it takes it but screen stays black for about 3 seconds and then it takes me back to the unlock screen. I know the pin is right and also if I type a wrong one I get an error but can't seem to go past unlock.
If you use the auto update option....

Try to manually install the ROM in TWRP.

Flash the ROM followed by to the gap's you use.
 

cachufleta

New member
Oct 3, 2021
2
2
I tried the auto-update option but it was taking me to TWRP. I installed it manually and had to do a full wipe. it's working fine now, just had to reinstall all my apps, unfortunately.
 
  • Like
Reactions: fgl27

fgl27

Recognized Developer
Feb 27, 2014
3,679
9,505
Brazil...South of the south
I tried the auto-update option but it was taking me to TWRP. I installed it manually and had to do a full wipe. it's working fine now, just had to reinstall all my apps, unfortunately.
Auto update works with TWRP, I don't know what you did exactly, probably because the auto update process didn't properly worked caused the issue...

You need to check if you are using them proper TWRP the one described on first post must work ok to auto update.
 
Auto update works with TWRP, I don't know what you did exactly, probably because the auto update process didn't properly worked caused the issue...

You need to check if you are using them proper TWRP the one described on first post must work ok to auto update.
If you leave the LineageOS recovery in place, the AutoUpdate works flawlessly, seemlessly. TWRP will work, but done manually. At least, that's how it works on mine.
 
  • Like
Reactions: fgl27

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Just wanted to say, thank you @fgl27 for keeping this phone going! Amazing to see Android 11 on this, I use my XT1254 as a backup device.
    1
    Wifi display is supposed to be working again on the latest september ROM version, I don't have a device that supports it so I can test if anyone test let me know.

    Enjoy it.
    Running fine for a week now on my backup/wifi Turbo. All wifi seems to work. Having an issue with running a dashcam app initializing the camera. 😕 Not complaining, only commenting. Likely something I'm missing. At this age, not surprising SOMEthing original-basic is not entirely compatible. Have you a preferred camera app for Android 11?

    Update: Had some time, did a reinstall of sorts, camera works.
    Update 2: Deactivated stock messaging app to avoid camera control conflict. BTW, dashcam app is DailyRoads Voyager.
    1
    hi, first of all: THANKS! I've been using the previous version and all was perfect
    I updated to 18.1 and now I'm having an issue where I can't use my phone. I enter my pin when I turn it on and it takes it but screen stays black for about 3 seconds and then it takes me back to the unlock screen. I know the pin is right and also if I type a wrong one I get an error but can't seem to go past unlock.
    1
    I tried the auto-update option but it was taking me to TWRP. I installed it manually and had to do a full wipe. it's working fine now, just had to reinstall all my apps, unfortunately.
  • 3
    Below are some of the helps and or workarounds for the most occurring issues.

    ROOT Use Magiks

    GPS / Radio:
    Changing/Updating the ROM may cause GPS lock problem, there is two separated help

    option 1) Install "GPS Status & Toolbox" , open the app, slide the left option and open "Manage A-GPS state" click in Reset, after repete the process and now click in Download, close the app after receive the OK, wait a few seconds and try a gps lock using the same app, if that doesn't help try again after a reboot, if that doesn't help go to option 2 below

    option 2) If the above doesn't help you can try to erase all the radio status
    Erase the radio status also applies to the case you have No SIM Card or no Cell Signal level in status bar.
    To erase the radio status is very simple just flash this zip "Clean_modem_status.zip" via TWRP no wipe is need, is also recommended to try option 1 after this if you flashed because of a GPS problem.

    If after flashing the cleaner you find any problem related to lost of signal, re-try the flash of "Clean_modem_status.zip", if the problem persist, flash latest radio.img version via fastboot (aka "via bootloader")
    Code:
    mfastboot flash radio radio.img
    find the radio.img inside the stock ROM xml.zip, some xml.zip and fastboot for windows can be found here (click here)


    Random Power off or reboots?
    To identify if the device random reboot or simply power it self off there is two ways.

    1) If after the device goes black you can't power it up again without plunging the charger, then is because the battery is dead, even if yours battery had good % left before it shutdown yours battery is probably damage doesn't matter if the device/battery is new a battery can go bad simply by charging the device wrong, a wrong way to do it is let the device constantly go bellow 20% as low you let it get worse yours battery will be with time.

    2) Check the boot reason prop "ro.boot.bootreason" :

    Using the app BHB27 Kernel Audiutor > logs section > search in a log > mark getprop > search keyword "reason".

    If the result is power_key_press the device didn't reboot it power off.
    Code:
    [ro.boot.bootreason]: [power_key_press]

    On this case, is recommended to set the battery "Automatic power saver" from default 15% to a higher value then the one yours device is power it self off.

    -----------------------------

    If the result is reboot the device reboot it self
    Code:
    [ro.boot.bootreason]: [reboot]

    On this case, is recommended to just share a log, do as is recommended on next post.


    Bootloop to TWRP after a Factory Reset (Settings/System/Reset option/Factory reset):
    This is a Nougat and up problem, it only happens if you are using a TWRP from the official site (with is not update to properly support Nougat and Up Android versions) or a old version of TWRP, to fix it just flash latest MOD TWRP version from the TWRP xda.
    TWRP xda thread Click Here


    Pictures access, view, sharing or related:
    One thing that I notice regarding permission is if you have a app that access a folder that was created in older OS this app may be able to access this folder but not fully access the files like the below example.
    You take a picture or a screenshot and can't see or share it with some apps, the simple fix is just erased/delete the folder with that problem for example the DCIM (camera folder) and or Pictures (Screenshot) folder under Main storage (or any folder were you face a picture or file access related problem), of course you can backup the files to another folders first using a file explorer that can see the files (maybe necessary one with ROOT access), then let the OS service recreate the folder, it will automatic recreates after you take a new picture or screenshot (or manually make the new folder if is a custom folder mane by you), test to see if the problematic app can see after.


    USB OTG player:
    On latest android version Nougat and above, to play anything from a USB OTG device is needed proper permission, that is not simple to give as the app must request it to be given, so to play anything from a USB driver find a app like this one


    VVM XT1254 only
    VVM app (VVM may only be accessible via play with the link, click here and chose open with play), VVM may not work correctly google has it on version is free and seems to work 100% Google voice, the in the phone app of b this ROM also has a dedicated option for voice calls
    3
    Bug report are welcome, make with in the most accurate description possible, do not spare words, screens and logs, a bug that I can't understand or reproduced I can't fix.
    Always post a bug with @fgl27 and a log .zip generated by the app
    BHB27 Kernel Adiutor > Logs > One click all Logs to a ZIP (ROOT is needed for this)...

    Even after a random reboot share a log
    If is a Reboot/Power off related bug make the log as soon the device finishes boot up
    2
    ROM dedicated for All Quark (Moto MAXX/Turbo and Droid Turbo - XT1225, XT1250 and XT1254)

    This ROM is the LineageOS from https://lineageos.org/ with specific changes to improve the experience for Quark that is why the ROM has the MOD type, all modification are in the changelog


    Download:

    ROM:
    Main:
    Main google Drive link

    Secondary:
    sourceforge (This is the server used by the Updates app in Setting>System>Updater)

    Gapps:

    Open Gapps

    TWRP For Quark:
    TWRP Use laste Mod version from xda


    Installation:

    • Make sure you are running latest MOD TWRP from xda TWRP thread
    • Download the latest ROM and GApps**.
    • Reboot to recovery (recommended make a backup)
    • Coming from different ROM? Then Always wipe Data (without media aka without internal memory)
    • Wipe System*
    • Flash the latest build and GApps **
    • Reboot and enjoy!
    * Wipe of Dalvik Cache and Cache not demanding but may help with some random minor bug that show after a update
    ** Gapps not demanding the ROM works perfect without it but if you plan to use gapps you need to flash it on a clean install with the ROM, In a ROM updates a "dirty flash" if you already have gapps always flash gapps again with the ROM update

    Changelogs:
    LineageOS - 18.1 source and Quark Changelog (Click Here)

    What's working :

    • Everything minus VoLTE support for XT1254 (1225 doesn't have this featuring).

    Known Android 11 issues :

    • Not PRE-ROOTED, ROOT solution is available read this thread second post
    • Old issue maybe resolved on latest TWPR update but... TWRP may not be able to backup or decrypt data encrypted on Oreo or Up: no know workaround, one day TWRP will support it.
    • General bug help/fix in second post or some were in the thread, use XDA building "Search Thread" option to find general help for this thread project...

    Source:
    LineageOS Source

    Device Tree
    Kernel tree
    Vendor tree
    Mod Kernel Adiutor tree

    XDA:DevDB Information
    [ROM][All Quark][Android 11] LineageOS 18.1 for Quark

    Contributors
    Felipe Leon (fgl27) is the main contributor (as I'm the one making it).
    But the XDA community, quark user base plus the open source community from XDA, github and the LineageOS team is what make this project so good, thank you all :good:.

    ROM OS Version: 10.x
    ROM Kernel: Linux 3.10.x
    Based On: LineageOS 18.x

    Version Information
    Status:
    Stable

    Created 2021-30-05
    Last Updated Check Changelog click here
    2
    Everything was working great, until this weekend. I was in an old hotel that gets terrible signal, so i used WIFI the whole time. When i left to head in to work this morning, i noticed that my data never came back. I can make calls, send texts, get on WIFI, use bluetooth... but the 4g LTE icon is not on my top bar, and im getting "No internet connection" errors. --- I verified that Data is turned on, i have something along the lines of "LTE/CDMA/EvDo" selected, ive restarted the phone, and ive tried popping out my SIM card and reinstalling it. -- Any suggestions?
    I figured it out. I started playing with all the network settings, and i found one that allowed me to set the "access point". I found the access point somehow was set to "Xfinity", once i changed it to "Verizon" my data came back. I am not sure how it changed or why it changed, as it was working before I entered the no coverage zone.