• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][All Quark][Android 11] LineageOS 18.1

Search This thread

rajesh_khatwani

New member
Apr 27, 2017
4
1
My XT1225 stuck on LineageOS animation, clean installed latest firmware. Tried multiple times clean installation but still same, stuck on animation.

Edit: It was Gapps issue, I was able to boot after selecting pico package. Thanks!
 
Last edited:
  • Like
Reactions: fgl27

fgl27

Recognized Developer
Feb 27, 2014
3,696
9,508
Brazil...South of the south
This update I didn't look for any reported problem, I just update the source to build the latest version of Android 11.

Next update I see if I have time to check all report issues so I can at least have a proper answer for it.
 

KOAO

Senior Member
Oct 10, 2010
182
19
I'm getting error 70 when trying to install any version of gapps. Any fix for that? I haven't seen anyone report it yet.
 

giant killer

Member
Mar 19, 2017
5
0
You can also try to go back to stock ROM, get a GPS lock and then go back to custom, you can do that via twrp backups/restore.

Some GPS related files are persistent maybe they are corrupted only stock can fix.
Please can you explain this process step by step, i have backup off my stock rom and i am on my Linage OS 18.1 what to do now to get my gps back. If you can also explain the radio.img method also then it would be great. Thanks in advance.
 

fgl27

Recognized Developer
Feb 27, 2014
3,696
9,508
Brazil...South of the south
Please can you explain this process step by step, i have backup off my stock rom and i am on my Linage OS 18.1 what to do now to get my gps back. If you can also explain the radio.img method also then it would be great. Thanks in advance.
When I had this issue, the only thing I did was...

backup current ROM... restore a backup of Stock ROM... after it boot OK I check the GPS in GPS only mode, if all OK, I go back t TWRP and restore the custom ROM backup, after that GP is OK.

There is a dedicated help on second post of this thread, if you have a specific question that it doesn't help let us know.
 

AngelGc97

New member
Jan 5, 2022
3
0
Who could help me on how to remove the blocked bootloader in android 6.0.1 xt1254 verizon or at least downgrade and then delete it in lollipop
 
Who could help me on how to remove the blocked bootloader in android 6.0.1 xt1254 verizon or at least downgrade and then delete it in lollipop
If memory serves, 'Sunshine' did successfully get adapted to unlock the xt1254's bootloader, even with the last official software. Being so long out, I don't whether the site may be still active/Sunshine download available. I was quite active back in the day, so it shouldn't be hard to find with all the traffic, if it's still up. Cost was......$25, I think. WELL worth it!
 

AngelGc97

New member
Jan 5, 2022
3
0
Si la memoria no funciona, 'Sunshine' se adaptó con éxito para desbloquear el gestor de arranque del xt1254, incluso con el último software oficial. Habiendo pasado tanto tiempo, no sé si el sitio puede estar todavía activo / descarga de Sunshine disponible. Estaba bastante activo en el pasado, por lo que no debería ser difícil encontrarlo con todo el tráfico, si aún está activo. El costo fue ... $ 25, creo. ¡Bien vale la pena!
There is no free method?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Been sick at home with Covid, so what better opportunity to re-do one's electronics? Found some stuff on the 'Turbo I missed, but can anyone tell me where Smart Lock is? Running Lineage 18, Open Gapps mini, Magisk.
    Security... Device security.
  • 3
    Below are some of the helps and or workarounds for the most occurring issues.

    ROOT Use Magiks

    GPS / Radio:
    Changing/Updating the ROM may cause GPS lock problem, there is two separated help

    option 1) Install "GPS Status & Toolbox" , open the app, slide the left option and open "Manage A-GPS state" click in Reset, after repete the process and now click in Download, close the app after receive the OK, wait a few seconds and try a gps lock using the same app, if that doesn't help try again after a reboot, if that doesn't help go to option 2 below

    option 2) If the above doesn't help you can try to erase all the radio status
    Erase the radio status also applies to the case you have No SIM Card or no Cell Signal level in status bar.
    To erase the radio status is very simple just flash this zip "Clean_modem_status.zip" via TWRP no wipe is need, is also recommended to try option 1 after this if you flashed because of a GPS problem.

    If after flashing the cleaner you find any problem related to lost of signal, re-try the flash of "Clean_modem_status.zip", if the problem persist, flash latest radio.img version via fastboot (aka "via bootloader")
    Code:
    mfastboot flash radio radio.img
    find the radio.img inside the stock ROM xml.zip, some xml.zip and fastboot for windows can be found here (click here)


    Random Power off or reboots?
    To identify if the device random reboot or simply power it self off there is two ways.

    1) If after the device goes black you can't power it up again without plunging the charger, then is because the battery is dead, even if yours battery had good % left before it shutdown yours battery is probably damage doesn't matter if the device/battery is new a battery can go bad simply by charging the device wrong, a wrong way to do it is let the device constantly go bellow 20% as low you let it get worse yours battery will be with time.

    2) Check the boot reason prop "ro.boot.bootreason" :

    Using the app BHB27 Kernel Audiutor > logs section > search in a log > mark getprop > search keyword "reason".

    If the result is power_key_press the device didn't reboot it power off.
    Code:
    [ro.boot.bootreason]: [power_key_press]

    On this case, is recommended to set the battery "Automatic power saver" from default 15% to a higher value then the one yours device is power it self off.

    -----------------------------

    If the result is reboot the device reboot it self
    Code:
    [ro.boot.bootreason]: [reboot]

    On this case, is recommended to just share a log, do as is recommended on next post.


    Bootloop to TWRP after a Factory Reset (Settings/System/Reset option/Factory reset):
    This is a Nougat and up problem, it only happens if you are using a TWRP from the official site (with is not update to properly support Nougat and Up Android versions) or a old version of TWRP, to fix it just flash latest MOD TWRP version from the TWRP xda.
    TWRP xda thread Click Here


    Pictures access, view, sharing or related:
    One thing that I notice regarding permission is if you have a app that access a folder that was created in older OS this app may be able to access this folder but not fully access the files like the below example.
    You take a picture or a screenshot and can't see or share it with some apps, the simple fix is just erased/delete the folder with that problem for example the DCIM (camera folder) and or Pictures (Screenshot) folder under Main storage (or any folder were you face a picture or file access related problem), of course you can backup the files to another folders first using a file explorer that can see the files (maybe necessary one with ROOT access), then let the OS service recreate the folder, it will automatic recreates after you take a new picture or screenshot (or manually make the new folder if is a custom folder mane by you), test to see if the problematic app can see after.


    USB OTG player:
    On latest android version Nougat and above, to play anything from a USB OTG device is needed proper permission, that is not simple to give as the app must request it to be given, so to play anything from a USB driver find a app like this one


    VVM XT1254 only
    VVM app (VVM may only be accessible via play with the link, click here and chose open with play), VVM may not work correctly google has it on version is free and seems to work 100% Google voice, the in the phone app of b this ROM also has a dedicated option for voice calls
    3
    Bug report are welcome, make with in the most accurate description possible, do not spare words, screens and logs, a bug that I can't understand or reproduced I can't fix.
    Always post a bug with @fgl27 and a log .zip generated by the app
    BHB27 Kernel Adiutor > Logs > One click all Logs to a ZIP (ROOT is needed for this)...

    Even after a random reboot share a log
    If is a Reboot/Power off related bug make the log as soon the device finishes boot up
    2
    ROM dedicated for All Quark (Moto MAXX/Turbo and Droid Turbo - XT1225, XT1250 and XT1254)

    This ROM is the LineageOS from https://lineageos.org/ with specific changes to improve the experience for Quark that is why the ROM has the MOD type, all modification are in the changelog


    Download:

    ROM:
    Main:
    Main google Drive link

    Secondary:
    sourceforge (This is the server used by the Updates app in Setting>System>Updater)

    Gapps:

    Open Gapps

    TWRP For Quark:
    TWRP Use laste Mod version from xda


    Installation:

    • Make sure you are running latest MOD TWRP from xda TWRP thread
    • Download the latest ROM and GApps**.
    • Reboot to recovery (recommended make a backup)
    • Coming from different ROM? Then Always wipe Data (without media aka without internal memory)
    • Wipe System*
    • Flash the latest build and GApps **
    • Reboot and enjoy!
    * Wipe of Dalvik Cache and Cache not demanding but may help with some random minor bug that show after a update
    ** Gapps not demanding the ROM works perfect without it but if you plan to use gapps you need to flash it on a clean install with the ROM, In a ROM updates a "dirty flash" if you already have gapps always flash gapps again with the ROM update

    Changelogs:
    LineageOS - 18.1 source and Quark Changelog (Click Here)

    What's working :

    • Everything minus VoLTE support for XT1254 (1225 doesn't have this featuring).

    Known Android 11 issues :

    • Not PRE-ROOTED, ROOT solution is available read this thread second post
    • Old issue maybe resolved on latest TWPR update but... TWRP may not be able to backup or decrypt data encrypted on Oreo or Up: no know workaround, one day TWRP will support it.
    • General bug help/fix in second post or some were in the thread, use XDA building "Search Thread" option to find general help for this thread project...

    Source:
    LineageOS Source

    Device Tree
    Kernel tree
    Vendor tree
    Mod Kernel Adiutor tree

    XDA:DevDB Information
    [ROM][All Quark][Android 11] LineageOS 18.1 for Quark

    Contributors
    Felipe Leon (fgl27) is the main contributor (as I'm the one making it).
    But the XDA community, quark user base plus the open source community from XDA, github and the LineageOS team is what make this project so good, thank you all :good:.

    ROM OS Version: 10.x
    ROM Kernel: Linux 3.10.x
    Based On: LineageOS 18.x

    Version Information
    Status:
    Stable

    Created 2021-30-05
    Last Updated Check Changelog click here
    2
    Everything was working great, until this weekend. I was in an old hotel that gets terrible signal, so i used WIFI the whole time. When i left to head in to work this morning, i noticed that my data never came back. I can make calls, send texts, get on WIFI, use bluetooth... but the 4g LTE icon is not on my top bar, and im getting "No internet connection" errors. --- I verified that Data is turned on, i have something along the lines of "LTE/CDMA/EvDo" selected, ive restarted the phone, and ive tried popping out my SIM card and reinstalling it. -- Any suggestions?
    I figured it out. I started playing with all the network settings, and i found one that allowed me to set the "access point". I found the access point somehow was set to "Xfinity", once i changed it to "Verizon" my data came back. I am not sure how it changed or why it changed, as it was working before I entered the no coverage zone.