[ROM][Android 12.1][SURYA] crDroid v8.6 [OFFICIAL][30-06]

Search This thread


Senior Member
Apr 30, 2012


  • Screenshot_20220625_070348.jpg
    144.4 KB · Views: 36
Last edited:
  • Like
Reactions: EnisKPTeam


Senior Member


Senior Member

I wouldn't vouch for that -- meaning his AFH now only has 'twrp-3.6.2_12-0-surya-26.06.img', meant for devices running A12...

TWRP 3.6.2_12-0

- UI updated
- Additional wipe's (Package Cache and Metadata)
- Additional patches from 3.6.1 (dfe and other)
- Padding size fixed
- Settings now saved after reboot
- Maybe more fixes

- Decryption on A12.1 ROMs is fully working

Only for POCO X3/NFC

But he appears to have posted a 'twrp-3.6.2_11-0-surya-21.06.img' to Telegram, with the following changelog:

TWRP 3.6.2_11-0

• Support decryption of /data only MIUI A11
Don't use with A12.1 ROMs

Only for POCO X3/NFC



Senior Member
Jul 19, 2009
I have tried it (twrp-3.6.2_12-0-surya-26.06.img) on crDroidAndroid-12.1-20220617-surya-v8.6.zip as new install. It was flashed successfuuly with data decrypted. Just format data, flash rom, flash Gapp, that's it. But I have no success restoring data backed up with twrp-3.6.0_11-o previously using this twrp.


Senior Member
I'm using dark mode. If I select the first basic colour (pale blue) in the wallpaper menu (instead of a colour to match the wallpaper), not only is the accent colour applied in the quick settings, etc, but it's applied to the font in all of the settings menus. I want white text on a black background. Apparently, this doesn't occur on Pixel devices, so maybe it's just an AOSP thing. Can anyone comment on this?


Senior Member
-- After playing a little with UI fonts, system menus are now showing up mangled.


Replying to myself: apparently, the issue with the mangled System UI was caused by the 'NoStorageRestric' Magisk module (v2 by DanGLES3, part of the unnofficial Androidacy module repository). After uninstalling it, the problem disappeared... o_O

I'll try to open an issue about this at https://github.com/DanGLES3/NoStorageRestrict.

In the time being, any other solution for the problem this module tries to fix? :unsure:

EDIT: Shame, after I installed the Audio Modification Library module, the problem returned, so the issue isn't specific to this module. My apologies to the author. 😩
Last edited:


Recognized Developer
Jun 3, 2013
Moto G5 Plus
Xiaomi Poco F1
Update time:

- Updated blobs to 12.5.8
- Display/color settings are now back to old config (june 12th build and older)
- Add haptic feedback for QS tiles toggle
- Add haptic feedback for torch
- Added transparent QS customization
- Added ability to show daily data usage in QS footer
- Added animation options to quick settings tiles
- SystemUI make popup menus more rounded
- Various fixes for battery stats
- Disabled blur wakeup animation
- Fixed NPE for per-app volume
- Fixed an issue with screen never goinf off after sending and canceling a notification in a short amount of time
- Fixed possible developer options crash
- Fixed loading iconpack-based Wellbeing icon
- Fixed camera/mic toggle not working
- Fixed location indicator stuck in some specifc cases
- Fixed lock screen timeout
- Launcher: Adjust the icon size to the grid size
- Launcher: Set hotseat icons to 4 for 4_by_5 grid
- Improvements to android runtime
- Optimized Launcher3 and Settings for speed
- Cleanup some Pixel specific stuff
- Optimized freetype, harfbuzz_ng, and sqlite (this should increase performance)
- Some other various fixes
- Updated translations


New member
Jan 5, 2022
My phone was working fine with crdroid a12 and then stopped working because the battery charge had expired then after charging it did not open to the system or recovery again I tried a lot to turn it on but to no avail it depended on the poco logo and I installed more than one recovery and none of them worked the solution that What I did was flashing the firmware of the fastboot, what caused this problem and what is the solution to it because I want to use crdroid a12

Top Liked Posts