[ROM][Android 13][UNOFFICIAL][OTA] LineageOS 20.0 for Xiaomi Mi A2 Lite [daisy]

Search This thread


New member
Dec 27, 2022
I just installed the rom of 12/24 and the truth is that I am amazed with the fluidity of the system. it is much better than Android 12.

I only found the notification light bug, then the use of the SD card in Netflix, although I read the latter in the forums that it is the fault of Android 13.

Many thanks to the developer for this hard work and it seems to me that this version of Lineage OS could be official.
Agree! I jumped from the (pretty outdated) stock ROM to this one and the phone really feels brand new in terms of fluidity, previously it used to get laggy very fast. Kudos again to the developers for helping increase the lifespan of phones like these!

Out of curiosity, what are the requisites for a version of LineageOS to become official and show up in their page?
  • Like
Reactions: phonedriller


May 25, 2018
Help! Kindly :) I am quite a newbie, trying to install...what should I do when it says
"For these builds, I recommend downloading the latest Global Stable firmware to ensure compatibility with the used blobs:
Well, I download this file but it is just 50 mb...should I download also the complete 1.5 gb file (fastboot rom, .gz?) and flash the V11 fw?
Or do I flash just this V11 52 mb file directly on my Andoid 10 stock?

Also, it says "Flash LineageOS ONLY with LineageOS Recovery"....is it me or I can't find recovery for A2 lite on the itsvixano page?
Also, if there is no Lineage OS recovery, what recovery should I install? TWRP?

UPDATE: I was able to flash the firmware zip...but the next step that says "Sideload the LineageOS zip we downloaded before." it gives error " failed to find update binary meta-inf/com/google/android/update-binary ". ANy idea?

UPATE: I was able to install evething, good mod! Only one doubt: I have flashed MAGISK, how can I remove it and restore Lineage boot img?
Last edited:


Senior Member
Nov 6, 2015
AFamocc : I didn't found a way to remove Magisk after OS installation, i guess you have to begin from scratch again.

Last edited:


Apr 3, 2014
@Afamocc have you installed the Magisk-App, too? With this it should be possible to completely remove magisk. At least for me that worked. I installed Magisk for restoring data with two different tools and removed it afterwards.


Senior Member
Sep 28, 2013
I installed Lineage 20 (android13) on Redmi A2 lite yesterday. I installed it over the Arrow custom rom. I followed the procedure and installed it smoothly. Fortunately rom is working fine until today home screen is starts crashing. I cant find the reason but now working fine. But problem persist and showing in intervals.
As im typing this msg, phone is working fine. (but often starts crashing home screen)


Jun 1, 2013
Hi, thanks for all the hard work.

I switched from ArrowOS, so far so good. Except the camera is pretty bad (just like with other custom OSes). It looks like a webcam 10 years ago. Is there some sort of a fix? The original miui camera was pretty good.

  • Like
Reactions: phonedriller


New member
Dec 21, 2022
@demodl you can also try Google camera.
I use for ex BSG port, the quality is quite incredible.

I've only one limitation, I can't save the selfie pictures, even when disabling HDR+
For selfie I use OpenCamera


May 11, 2019
Hi, I have a pretty odd issue. I'm doing a fresh install of:


The firmware first, then the rom, then the MindTheGapps, and only after that the reboot. Everything goes well without any errors and returns the status 0. But after the reboot, I see no GApps. Only LineageOS apps are there. Not a single hint of GApps being present in the system.

Edit: Forgot to reboot the phone between each zip file. It works now.
Last edited:


New member
May 23, 2019
@Its_Vixano Thank you for your hard work.
What you've created is brilliant!
Except some negligible/minor things, everything is great.

However, I am using Signal messaging application and since letting the app running at background is the only way to get the notifications, it also seemed to me that it drains the battery.
I mean, it drains way faster than how it was while I was on the stock rom.

The application is on the optimized battery mode.

I am open to hear your suggestions.
Thanks in advance!
Last edited:


Senior Member
Feb 21, 2018
Xiaomi Mi A2 Lite


New member
Jan 29, 2022

I updated from Lineage 18.1 to 20.0, Feb release...great improvement in overall performance, thanks for the awesome work.
I have two findings, maybe someone can confirm if this happens to his/her device as well and maybe it could be fixed at some point:
  1. The very left edge of the screen does not take any touch inputs. So it is very hard to hit arrows (mostly back within an app) or keys of the keyboard on the very left side on the screen. This has definitely not been there before on my device.
  2. The volume during calls is quite low (even at max), so in noisy areas, it is hard to understand the other side. This has been there before (L-OS18.1), but maybe it could be fixed on this one.
Thanks already for answers

Top Liked Posts