[ROM][Android 4.4.4/5.1] CyanogenMod11/12 by ivanich [3.4Kernel][Up-To-Date][Stable]

lutyjj

Senior Member
Nov 25, 2013
241
510
0
Wrocław
CyanogenMod 11 and 12 by ivanich​
Features:
  • 3.4 kernel with latest patches
  • USB-OTG
  • Stable enough to be daily driver
  • Fully working camera
  • In kernel mp-decision
Bugs:
Major:
  • No one
Minor:
  • VoiP - BuiltIn VoIP client - no audio, also VoIP apps like Hangouts crashes when "Ok Google" enabled (CM-12)
  • All CyanogenMod upstream bugs
All thanks goes to ivanich, not me. I'm just started new thread.
Downloads:
CM11
CM12
GAPPS
Sources:
ivanich's GitHub

Changelog:
Kernel Changelog
ROM Changelog

TWRP Recovery:
Download

XDA:DevDB Information
CyanogenMod11 and 12 by ivanich, ROM for the HTC Sensation

Contributors
Daniiiik49, ivanich
Source Code: https://github.com/ivanich?tab=repositories

ROM OS Version: 5.1.x Lollipop
ROM Kernel: Linux 3.4.x
ROM Firmware Required: HBOOT 1.27/1.29
Based On: CyanogenMod

Version Information
Status: No Longer Updated
Stable Release Date: 2016-12-30

Created 2014-10-19
Last Updated 2016-12-03
 
Last edited:

klaust.net

New member
Oct 20, 2014
1
0
0
SD card problems?

First of all thanx a lot to ivanich and all others involved in the efforts of bringing up-to-date software to our manufacturer-abandoned hardware. Big thumbs up! :good:

I came to this rom some weeks ago from Albinoman887's CM10.1 which worked out quite well for more than a year now. Due to the space-consuming updates of the gapps i ran out of memory and searched for a more recent rom. Using this for two weeks now leaves me quite happy except one thing.

I expierience constant and sudden unmounts of the SD-Card, quite like papete mentioned them in the old thread for this rom.

Is this there anthing i can do on my side, to overcome this behaviour configuration-wise?
Could it be that i need a special firmware for this rom to work properly?

Getting rid of this problem would definetly let me use my Sensation for at least an other ten months or so. :D
 

Sajito

Senior Member
Sep 1, 2013
1,118
830
133
@Sajito , seems like I've found a workaround for LPA seek bug. Could you test it on your builds. Also If I remember correctly there was issue with lpa and bluetooth - can you check this too?
https://github.com/ivanich/android_...mmit/9093a8f1f4bef98fbf89b54bcdb1e735e0a821bc
I will merge that commit and make a build with that and lpa enabled.
I'll report back tomorrow.

Just remembered that in the last builds carbonrom seems to have a bug with playing music via bluetooth in general. It connects, but music plays always from phone, if lpa is enable or disabled doesn't matter. Gonna test it anyway.
 
Last edited:

kastlell

Senior Member
Jan 27, 2014
72
7
0
dirty flash

Hi, I've got two questions:

Can updates be flashed as dirty flash? I flashed the ROM's previus version three days ago with full wipe, it's ok to dirty flash the new one?
It's mandatory to flash gapps in a dirty flash?

Thanks.
 

Sajito

Senior Member
Sep 1, 2013
1,118
830
133
Hi, I've got two questions:

Can updates be flashed as dirty flash? I flashed the ROM's previus version three days ago with full wipe, it's ok to dirty flash the new one?
It's mandatory to flash gapps in a dirty flash?

Thanks.
You can dirty flash ROM updates always. If you experience problems, do a clean install.
Gapps usually don't need to be reflashed after an update.

This is for every rom the same.
 
  • Like
Reactions: kastlell

Sajito

Senior Member
Sep 1, 2013
1,118
830
133
@ivanich I've tried that commit on my own for normal playback and everything seems to be fine at least on paranoid android. Carbon seems to have issues with music at the moment.

Couldn't test bluetooth yet, someone else needs to test that.
 
  • Like
Reactions: devrruti

banesi

Senior Member
Dec 27, 2006
755
121
73
I remeber that Skype audio was not working when phone display is off, so I guess this could be a good test to try LPA, can't test myself unfortunately atm :(
 

Sajito

Senior Member
Sep 1, 2013
1,118
830
133
@ivanich I just tested your latest build and even with that one I'm not having any issues with seeking with lpa enabled.
After disabling touch sounds everything is perfectly fine.
But for some reason in my roms neither in carbonrom, nor in aospa audio over bluetooth is working. May I ask you for your local_manifest?
 
Last edited:

ivanich

Senior Member
Nov 6, 2011
1,167
2,612
143
Odessa, Kyiv
I don't get it. I use the same kernel and device trees, I didn't change anything to the audio or anything that could affect it and yet still audio over bluetooth is broken in my builds while it's working perfectly fine here...
So you built cm11 by yourself and got bt audio issues or it's broken only in carbon/aospa? Check repos in your build tree, maybe you changed something directly in code, in that case repo sync wont overwrite changes.
Seems I know why you are not experiencing issues with lpa seek. I've rebooted phone and start GooglePlay Music, seek issue almost not noticeable in this app, then I started Apollo and no seek issue again, but then I looked into logcat and realized that after I exited from GooglePlay Music it puts LPAPlayer into underrun state so lpa not worked after I've started Apollo.
EDIT: Returning to GooglePlay Music app shows in logcat that lpa is working again, probably there is something wrong with Apollo
 
Last edited: