Search This thread


Senior Member
May 9, 2011
Broken Arrow, Okla
Good advice, the only thing I'm not up to date on is the latest open gapps micro, but I usually just let it upgrade through playstore, other than that I'm up to date, Twrp, magisk, why I brought up internal storage, but it seems fine,

My computer is down or I'd just wipe everything, stock and start over, but I saw the earlier post, not just me, I like this phone, and waiting on 5g ready, but she's getting up there, it could be anything, wasn't complaining just hoping for a hint

andy hall

Senior Member
Mar 3, 2011
Google Pixel 3
I have just been caught with a predicament.
I have installed aicp_angler_p-14.0-WEEKLY-20200310 with a GAPPS package I have tuned down. No root
Booted no problem, done the google setup and pin and fingerprint.
Installed a bunch of apps set some up
setup a couple more apps
instaled a bunch more apps
Acctually what happens is this.
Phone boots up no errors or odd behaviour.
Notifiactions are displayed for step counter, avast and today wheather.
Swipe up to get pin entry
enter pin
screen goes blank for couple of seconds
then back to notifications and need to swipe up and start again

I have just cleared dalvik and cache with no change
Any tips

---------- Post added at 08:25 PM ---------- Previous post was at 08:05 PM ----------

Dirty flash of rom did not change anything.
next step clean system and reflash.
Last edited:
  • Like
Reactions: ivanperezcaro


Senior Member
Jan 26, 2015
Google Nexus 4
Huawei Nexus 6P
I'm also having the boot to black screen problem. Clean wipe (including storage), no magisk. All is good until I customize anything on the notification bar on the AICP settings (enable date on notification clock, set to right of clock and change format to Weekday Monthday Month, for instance) - at that point screen turns black. Long press does bring the boot menu (power off, reboot, lock). Screenshot also works via power + volume down (you can see the screenshot animation). Looks like something's screwing System UI.

I'm on latest (10 march).

Edit: This issue is not present on the previous build (Feb 25th).
Last edited:
  • Like
Reactions: ivanperezcaro


Senior Member
Oct 20, 2010
10th march working fine here, updated through aicp update centre from previous week, i do have magisk (20.3) installed. stating the probably obvious, have you tried going back a few updates, flashing say the 25/2/20 over the top.

a few months ago, i had system ui crashing, i just went back a few weeks build, and waited for a few more weeklies to come out and tried them until magical elves fixed whatever it was.
  • Like
Reactions: ivanperezcaro


Senior Member
Jan 23, 2017
Flashed stock ROM via all in one tool kit
Wiped data, system, cache etc
Installed ROM
phone booted!
Installed Magisk

The battery drain is soooo bad. Do I need to do something to stop that or the phone itself is crap?


Senior Member
Mar 23, 2015
Google Nexus 5
Huawei Nexus 6P

Top Liked Posts

  • There are no posts matching your filters.
  • 67


    Android Ice Cold Project

    AICP is known by everyone as the "Ice Cold Project" that started on a Desire HD years ago (2012) and since then evolved into a mature ROM with the BEST community you can find!!!

    Until Lollipop, the Rom has always been based on AOKP. Unfortunately, since AOKP stopped development (but made a comeback later), we changed our base to CM when it comes to hardware, drivers and some features.
    With the rebrand of CM to LineageOS (LAOS) we are now actually LAOS based with some tweaks from AOSP.

    If there are any bugs, either we will sort them out or the LAOS team will if it concerns their code base. This rom isn't LAOS supported, so no need to report errors or bugs to them!!

    #include <std_disclaimer.h>
     * Your warranty is now void.
     * We are not responsible for bricked devices, dead SD cards,
     * thermonuclear war or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at us for messing up your device, we will laugh at you. Hard & a lot.


    W. I. P.


    In the beginning we would like to thank:

    LineageOS & CM (R.I.P.) team
    @Maxwen and the rest of the OmniRom team
    @razorloves and @sam3000 for their awesome work with all Nexus devices & LineageOS
    DU team


    @LorD ClockaN
    plus the rest of the crazy bunch that we call "team"


    We are paying for servers that build nightlies/weeklies and everything that comes with it, so EVERY DONATION will really be appreciated and be used to cover those expenses.
    Thank you!!


    Latest Stable Release Version 13.1

    Download link: AICP Downloads


    By the download link


    It's a Nexus - You tell... :p

    Before using the ROM:
    Q. Can I have an ETA for the next build?
    A. Yes, just look in the OP to see, if your device is build on a nightly or weekly schedule.

    Q. Does this ROM support custom kernels?
    A. No. You can still use them (as long as they are LOS based), but discussion should go in the thread of the respective kernel. We don't offer support for bugs you might encounter using them!

    Q. Why doesn't this ROM support Xposed?
    A. Xposed is a hack that is geared towards AOSP, custom ROM's modify the framework a lot, so Xposed can cause a ton of issues on custom ROM's. Now it might work for you, however it is not to be discussed in this thread, and you should refrain from posting bug reports.

    Q. Alright, but I still want to flash Xposed, so which version do I need to install?
    A. Xposed is not yet available for nougat (officialy), however there are unofficial versions. You will need to use the version arm64/arm for SDK 25.

    Flashing the ROM:
    Q. What do I need to know before flashing?
    A. Check the install instructions in the first post...

    Q. Can the builds be dirty flashed over each other?
    A. Yes, however make a nandroid first as there is a chance of getting a bootloop or encountering bugs. Also bugs may only be reported on a clean flash.

    Q. How do I dirty flash builds?
    A. Wipe System, Cache and ART/Dalvik cache. Flash the ROM, your preferred root solution and reboot. Or you might just use the OTA app to preform that task for you.

    Q. How do I flash kernel builds?
    A1. Boot into TWRP and go to the install page in TWRP, in the bottom right corner select "install image", select the desired kernel, then select "boot", then swipe to flash, then go back to the install screen and install your root method again if you don't want to loose root, and then reboot.
    A2. LOS based kernels sometimes come as a flashable ZIP file too. You can flash them together with a ROM update or separately. Go to the install page in TWRP, choose the kernel zip (or add it to the flash queue right after the ROM zip). Then add your root method to the queue, if you don't want to loose root. Now swipe to flash, clear Cache & ART/Dalvik cache and then reboot.

    Using the ROM:
    Q. How do I enable software buttons?
    A. Settings -> Navigation -> Enable navigation bar. The bar can be configured separately in its settings.

    Q I installed a bad theme and now I'm getting a bootloop, how do I fix it?
    A In TWRP, flash the substratum rescue zip in the substratum folder on the internal storage.

    Q I keep losing root with Magisk, how do I fix it?
    A Check this out, if that doesn't work for you ask for help in this thread, read or ask in the Magisk thread on XDA or just flash Magisk again!

    Q I'm having issues with WhatsApp, how do I fix it?
    A Read this

    Q. Do I need to provide a logcat if I'm reporting a bug?
    A. If you want it to be fixed faster (or at all) then yes, you should definitely provide a logcat. (Note: Please just link the logcat from your GDrive, Dropbox, etc. and do not post the content here. Thanks.

    Q. How do I get a logcat, what type should I get and more questions that can conveniently be answered by my pre-determined answer?
    A1. Read this thoroughly. Also, here's a good app for getting logs: https://play.google.com/store/apps/details?id=com.tortel.syslog
    A2. If you are already rooted, you can use the built-in feature to make a logcat and provide that. Just look into the root section in the AICP Extras menu.


    The ROM should contain everything you need to enjoy Android Oreo. You don't need to install any Add-Ons, simply download the latest ROM, GApps, flash it and go!
    If you want the device to run the ROM "rooted", you can flash a root solution of your choice after the ROM Zipfile.

    It is STRONGLY recommended to fully wipe your device before flashing, and if possible avoid restoring system apps and system data with Titanium Backup as this can cause stability issues that are very hard to debug.
    If you believe you know what you're doing - then fine, go ahead, but please don't complain if you experience any strange behavior.

    How To Flash:

    (Again: Don't do it if you don't know it!)

    1. Download needed Factory Images from Google (bootloader, radio and vendor) OR from my 2nd post (Current: 8.1.0 (OPM7.181205.001, Dec 2018)) and flash them via FASTBOOT in Bootloader Mode.
    2. Download the ROM, GApps and Magisk 18.0 (or higher) (Optional) then transfer them to your device
    2a. Google Apps: I'm using micro package from OpenGAPPS. Also you can find the link for latest GAPPS in my 3rd post.
    3. Boot to recovery (TWRP recommended)
    4. Wipe system, Cache, data and ART/Dalvik cache
    5. Flash ROM Zipfile
    6. Flash/Install GApps (optional, needed for e.g. Google Playstore to work)
    7. Flash/Install the root solution of choice (optional) - Magisk 18.0 or higher versions works pretty nice!
    8. Reboot to system


    To be able to flash using the buildin OTA app that needs TWRP recovery installed to work.
    You can still use LAOS recovery and OTA app, but you will need to download the zip file and flash it manually from within your recovery.
    Zip gets saved in the "AICP_ota" folder on your internal storage.
    Please be sure that you are on the latest TWRP recovery.​

    The ROM has GApps persistance in between dirty flashes, so you only have to flash them once!
    No need to flash root solution on every OTA update (= ROM Update) If you are on Magisk 18.0 or higher!

    Supported Root Solutions:


    The kernel in this ROM follows LineageOS source with custom additions from AICP, AOSP and Android Community.

    If you want to contribute to the AICP or wanna see what is being worked on/merged, feel free to visit our Gerrit review system. (Link is at the bottom!!!)

    ROM & Additional links:
    Gerrit Code Review

    IceColdJelly AICP G+ community

    (mention all the devs who have contributed to your device tree, kernel, vendor, etc,
    only mention the main ones though, probably the top four or so, otherwise this list will be a mile long unless if you're a huge kanger xD)

    ROM OS Version: 9.0.x Oreo
    ROM Kernel: Linux 3.10.xxx

    Version Information
    Status: NIGHTLY
    Stable Release Date: Not released yet

    Creation date: 04-10-2017
    Last Updated: Nightly

    You want to see a normal night at the "DEV office", click here!!

    XDA:DevDB Information
    [ROM] [ ANGLER ] AICP 14.0 | Pie 9.0.rX | OFFICIAL WEEKLIES, ROM for the Huawei Nexus 6P

    semdoc, GreekDragon, LorD ClockaN, wartomato
    Source Code: https://github.com/AICP

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: 8.1.0 (OPM7.181205.001, Dec 2018)
    Based On: GZOSP

    Version Information
    Status: Nightly
    Stable Release Date: 2019-03-03

    Created 2017-10-04
    Last Updated 2019-03-13

    Notice: We are shipping vendor.img into ROM.zip. No need to flash any stock image on new ASB's with Pie Builds !!!

    Just make sure you are on Dec 2018 Stock images while you are starting....


    For Oreo Builds (AICP 13.1):

    Stock Images to be flashed via FASTBOOT

    ASB Dec 2018 Stock Images: 8.1.0 (OPM7.181205.001, Dec 2018)


    How to get my Fi Project SIM Discovered ? all credits goes to @flashblue. Please go and thank him :)

    I'd suggest these steps to get your Project Fi SIM discovered:

    1. Go to post #1 and install the ROM completely following the instructions.
    2. Setup your phone, but skip the window about inserting the SIM card.
    3. When your phone is setup (it will be without Fi service) go to settings and choose security.
    4. Make sure you select "none" as the security option. You don't want a pin for sure.
    5. Reboot into "Recovery" and follow the steps in post #1 to install the ROM and Vendor image.
    6. Your phone should boot normally and discover the Fi SIM card.

    As you can see from my post count I am new at helping anyone. Hopefully I did this right:)
    New build is on the way guys....

    Build link: HERE

    Changelog: HERE

    * Fixes here and there for angler trees...

    It's awesome to have ya back @razorloves :good:
    New build is uploading :highfive: (will be done in 15 minutes)

    Build link: here

    Changelog: here

    Enjoy :)
    Hey guys;

    New build is up to my BB folder: https://basketbuild.com/devs/semdoc/angler-pie

    The change proposed by @razorloves - http://gerrit.aicp-rom.com/79217 - is included and this change fixes hopefully the issue mentioned by @Toutatis_ some posts ago....

    Also changes from http://gerrit.aicp-rom.com/#/q/topic:QS-brightness-slider+(status:open+OR+status:merged) topic are included too...

    Build: Link HERE
    Changelog: http://haste.aicp-rom.com/heluzenipu.vhdl

    Just flash it dirty if you are on any of my previous angler Pie buidls....

    Btw; I'll keep posting these test buidls as far as you want to test and report back your thoughts....

    Cheerz :)