[ROM][AOSP 9.0.0_r37][XZ1 G8341/G8341] [Vanilla][90/120Hz]

Search This thread

celeron1

Senior Member
Oct 7, 2008
69
25
Xperia XZ1 G8341 Vanilla AOSP ROM

This is my first ROM and its fully Vanilla. I Just followed this Build guide without any modifications whatsoever.

The future goal is to build a stable Rom with mostly FOSS Software, stability and useful tools/settings.

Bugs/missing functions i discovered so far:
- Camera Not working always and -> Lens Distortion. Although RAW should be possible.
- Sony Bootlogo has some Artifacts
- No automatic APN setting
- No NFC 25.05 working
- No 90/120Hz mode (or does it?)
- No Display Colour Calibration
- Low Singlethread Geekbench Score (836) and (6060 Multicore) [Governors and schedulers not optimized]

Fingerprint Sensor is working and it takes some time to find Network (not sure if bug or normal).

I hope to find usable answers to those problems + ideas and hope, to receive enough feedback to improve as much as possible.


Just Flash all files (boot, recovery [or any working TWRP], system,vendor, userdata and the OEM Binaries [
SW_binaries_for_Xperia_Android_9.0_2.3.2_v9_yoshino.img] and you should be good to go.


XZ1 Single Sim(25.05.19)
XZ1 Dual Sim
SW_binaries_for_Xperia_Android_9.0_2.3.2_v9_yoshino.img
120Hz Mode

Obviously I am not responsible for bricked devices or anything that this could be related to.

XDA:DevDB Information
RumiRom, ROM for the Sony Xperia XZ1

Contributors
celeron1
ROM OS Version: 9.x Pie
ROM Kernel: Linux 4.x
Based On: Stock AOSP Userdebug

Version Information
Status: Testing

Created 2019-05-25
Last Updated 2019-05-30
 

Attachments

  • Screenshot_20190525-150039.png
    Screenshot_20190525-150039.png
    130.8 KB · Views: 5,045
  • Screenshot_20190525-150059.png
    Screenshot_20190525-150059.png
    104.5 KB · Views: 4,930
  • Screenshot_20190525-150126.png
    Screenshot_20190525-150126.png
    130.8 KB · Views: 4,948
  • Screenshot_20190526-083624.png
    Screenshot_20190526-083624.png
    96.4 KB · Views: 4,509
Last edited:

celeron1

Senior Member
Oct 7, 2008
69
25
I would marry if you turn 60fps to 90-120-144 omg plz plz
There is little to nothing about this I could find for the xz1 except one oreo based rom. I have to compile the kernel for it and find out if 60+ hz is really working and how to succesfully implement a toggle option for it. Since im new at this it might take some time without help but its something I want to impliment.

The Xz1s Display obviously is really underperforming in non Sony roms without the "Bravia engine" (colour apperence) imo compared to other open roms. I tried the Bravia magisk module but could not see any difference (also did not checked what it should do at system level).


So if someone has more knowledge feel free to share :)
 
  • Like
Reactions: ΒΕΓΑ

celeron1

Senior Member
Oct 7, 2008
69
25
I compiled a Kernel from here and modified:

arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar-base-sde.dtsi
arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar-sde.dtsi
arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar.dtsi

(changed 60hz to 90/120hz).

How can I check if the Panel really is working under those frequencies and if other steps are needed?

When compiling I got an Error with drivers/staging/wlan-qc/qcacld-3.0 -> so i removed them from drivers/staging/Kconfig (So apparently no Wifi).

These are the Kernels (boot):
90Hz
*Update 29.05. I Fixed Wifi for the 120Hz version. link in first post

Camera seems to work without problems (also Raw) so I guess there is something wrong with the precompiled Sony Kernel.

Also the Sony bootlogo is not present (no artifakts??)

And again. Flash at own risk.
 

Attachments

  • Screenshot_20190526-083304.png
    Screenshot_20190526-083304.png
    95.9 KB · Views: 1,311
  • Screenshot_20190526-083624.png
    Screenshot_20190526-083624.png
    96.4 KB · Views: 1,297
Last edited:

ΒΕΓΑ

Member
Oct 29, 2018
44
10
I compiled a Kernel from here and modified:

arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar-base-sde.dtsi
arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar-sde.dtsi
arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar.dtsi

(changed 60hz to 90/120hz).

How can I check if the Panel really is working under those frequencies and if other steps are needed?

When compiling I got an Error with drivers/staging/wlan-qc/qcacld-3.0 -> so i removed them from drivers/staging/Kconfig (So apparently no Wifi).

These are the Kernels (boot):
90Hz
120Hz

Camera seems to work without problems (also Raw) so I guess there is something wrong with the precompiled Sony Kernel.

Also the Sony bootlogo is not present (no artifakts??)

And again. Flash at own risk.

Can i use this kernel with stock sony rom? (Existenz patched btw...)
 
  • Like
Reactions: XperiakiasT

celeron1

Senior Member
Oct 7, 2008
69
25
Screen is not responsive (SOV36). Any suggestions?

update: not the rom. tried to flash different rom and same result.

Does it respond different while charging?
Is the screen properly clean?

Try flashing the last stock rom > same result?
If not try flashing any gsi > result?
Then full cfw flash + sw binary.

And do factory resets before flashing.

Hoping for the best. Not sure how and if the SOV36 model differs from the rest
 

sinkoo1979

Senior Member
Oct 29, 2016
657
101
Yigo
OnePlus Nord
Does it respond different while charging?
Is the screen properly clean?

Try flashing the last stock rom > same result?
If not try flashing any gsi > result?
Then full cfw flash + sw binary.

And do factory resets before flashing.

Hoping for the best. Not sure how and if the SOV36 model differs from the rest

no
yes
no
did not work
works with stock
 

celeron1

Senior Member
Oct 7, 2008
69
25
no
yes
no
did not work
works with stock

Dis you try one of these GSIs and did you flash the SW-Binaries after?

How "non responsive" is it? Laggy/Not at all/Ghost touches etc.?


Since this is off-Topic i will delete this message after you read it. You shuld open a new Thread where the Problem could be discussed.:good:
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    Xperia XZ1 G8341 Vanilla AOSP ROM

    This is my first ROM and its fully Vanilla. I Just followed this Build guide without any modifications whatsoever.

    The future goal is to build a stable Rom with mostly FOSS Software, stability and useful tools/settings.

    Bugs/missing functions i discovered so far:
    - Camera Not working always and -> Lens Distortion. Although RAW should be possible.
    - Sony Bootlogo has some Artifacts
    - No automatic APN setting
    - No NFC 25.05 working
    - No 90/120Hz mode (or does it?)
    - No Display Colour Calibration
    - Low Singlethread Geekbench Score (836) and (6060 Multicore) [Governors and schedulers not optimized]

    Fingerprint Sensor is working and it takes some time to find Network (not sure if bug or normal).

    I hope to find usable answers to those problems + ideas and hope, to receive enough feedback to improve as much as possible.


    Just Flash all files (boot, recovery [or any working TWRP], system,vendor, userdata and the OEM Binaries [
    SW_binaries_for_Xperia_Android_9.0_2.3.2_v9_yoshino.img] and you should be good to go.


    XZ1 Single Sim(25.05.19)
    XZ1 Dual Sim
    SW_binaries_for_Xperia_Android_9.0_2.3.2_v9_yoshino.img
    120Hz Mode

    Obviously I am not responsible for bricked devices or anything that this could be related to.

    XDA:DevDB Information
    RumiRom, ROM for the Sony Xperia XZ1

    Contributors
    celeron1
    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 4.x
    Based On: Stock AOSP Userdebug

    Version Information
    Status: Testing

    Created 2019-05-25
    Last Updated 2019-05-30
    3
    I compiled a Kernel from here and modified:

    arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar-base-sde.dtsi
    arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar-sde.dtsi
    arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar.dtsi

    (changed 60hz to 90/120hz).

    How can I check if the Panel really is working under those frequencies and if other steps are needed?

    When compiling I got an Error with drivers/staging/wlan-qc/qcacld-3.0 -> so i removed them from drivers/staging/Kconfig (So apparently no Wifi).

    These are the Kernels (boot):
    90Hz
    *Update 29.05. I Fixed Wifi for the 120Hz version. link in first post

    Camera seems to work without problems (also Raw) so I guess there is something wrong with the precompiled Sony Kernel.

    Also the Sony bootlogo is not present (no artifakts??)

    And again. Flash at own risk.
    2
    Having real trouble getting magisk to work. Everything i can find tells me to install Magisk then install the kernel. But the 120hz kernel seems to remove the Magisk install. So i install Magisk again, then the phone wont boot.

    ---------- Post added at 12:44 PM ---------- Previous post was at 12:36 PM ----------

    I give up, reflashing Magisk, gets it working, but then the phone acts wierd. Reboot from ROM, goes into TWRP. Shutdown does not actually shutdown the phone (she just goes off, but needs a Volume UP kill) I guess AOSP 9 just isnt ready yet?
    2
    I would marry if you turn 60fps to 90-120-144 omg plz plz
    2
    it would be great if you could build one for G8342 plz
    Im just uploading the Dual Sim AOSP now:good: