• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][AOSP 9.0.0_r37][XZ1 G8341/G8341] [Vanilla][90/120Hz]

Search This thread

celeron1

Senior Member
Oct 7, 2008
69
25
I flash through fastboot one by one ( boot -> recovery -> system -> vendor -> userdata -> oem ) and reboot. After reboot my screen dont't have reponsive, i think if i flash 120Hz boot.img, this error will be fixed but no ?
Sure you have a G8341 and not a japanese Version?
Also did you flash the latest skny stock firmware first?
 

Ledjon01

New member
Jun 7, 2016
1
0
Hello developer.the gcam work on my sony xz1 wtff..? You are the most amazing developer bro. Sony only not support camera2api but you create a rom to support this,WoW. But please fix the wifi. I try to fix with 90/120hz wifi fix and again not work,and the rom take restart automatically ,. Fix a rom please wifi and the auto restart. Fix wifi without change the Hertz of screen. Please please please ???. sorry for English. ? Or create another rom look like lineage rom and add camera2api support this is crazy ?? thank you very much ???
 

nhkhanh068

Member
Mar 19, 2014
39
17
Hanoi
Hello developer.the gcam work on my sony xz1 wtff..? You are the most amazing developer bro. Sony only not support camera2api but you create a rom to support this,WoW

Does the pictuce from google cams better than stock?

---------- Post added at 09:41 AM ---------- Previous post was at 09:39 AM ----------

I really want to use this rom for daily usage, but I think it í unstable for daily use. Hope you can make it better and better
 
  • Like
Reactions: Ledjon01

starvirus10

Member
Feb 7, 2019
30
4
Blitar
Xperia XZ1 G8341 Vanilla AOSP ROM

This is my first ROM and its fully Vanilla. I Just followed this Build guide without any modifications whatsoever.

The future goal is to build a stable Rom with mostly FOSS Software, stability and useful tools/settings.

Bugs/missing functions i discovered so far:
- Camera Not working always and -> Lens Distortion. Although RAW should be possible.
- Sony Bootlogo has some Artifacts
- No automatic APN setting
- No NFC 25.05 working
- No 90/120Hz mode (or does it?)
- No Display Colour Calibration
- Low Singlethread Geekbench Score (836) and (6060 Multicore) [Governors and schedulers not optimized]

Fingerprint Sensor is working and it takes some time to find Network (not sure if bug or normal).

I hope to find usable answers to those problems + ideas and hope, to receive enough feedback to improve as much as possible.


Just Flash all files (boot, recovery [or any working TWRP], system,vendor, userdata and the OEM Binaries [
SW_binaries_for_Xperia_Android_9.0_2.3.2_v9_yoshino.img] and you should be good to go.


XZ1 Single Sim(25.05.19)
XZ1 Dual Sim
SW_binaries_for_Xperia_Android_9.0_2.3.2_v9_yoshino.img
120Hz Mode

Obviously I am not responsible for bricked devices or anything that this could be related to.

XDA:DevDB Information
RumiRom, ROM for the Sony Xperia XZ1

Contributors
celeron1
ROM OS Version: 9.x Pie
ROM Kernel: Linux 4.x
Based On: Stock AOSP Userdebug

Version Information
Status: Testing

Created 2019-05-25
Last Updated 2019-05-30

Is this rom not continued?
 
  • Like
Reactions: BigBrother84

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    Xperia XZ1 G8341 Vanilla AOSP ROM

    This is my first ROM and its fully Vanilla. I Just followed this Build guide without any modifications whatsoever.

    The future goal is to build a stable Rom with mostly FOSS Software, stability and useful tools/settings.

    Bugs/missing functions i discovered so far:
    - Camera Not working always and -> Lens Distortion. Although RAW should be possible.
    - Sony Bootlogo has some Artifacts
    - No automatic APN setting
    - No NFC 25.05 working
    - No 90/120Hz mode (or does it?)
    - No Display Colour Calibration
    - Low Singlethread Geekbench Score (836) and (6060 Multicore) [Governors and schedulers not optimized]

    Fingerprint Sensor is working and it takes some time to find Network (not sure if bug or normal).

    I hope to find usable answers to those problems + ideas and hope, to receive enough feedback to improve as much as possible.


    Just Flash all files (boot, recovery [or any working TWRP], system,vendor, userdata and the OEM Binaries [
    SW_binaries_for_Xperia_Android_9.0_2.3.2_v9_yoshino.img] and you should be good to go.


    XZ1 Single Sim(25.05.19)
    XZ1 Dual Sim
    SW_binaries_for_Xperia_Android_9.0_2.3.2_v9_yoshino.img
    120Hz Mode

    Obviously I am not responsible for bricked devices or anything that this could be related to.

    XDA:DevDB Information
    RumiRom, ROM for the Sony Xperia XZ1

    Contributors
    celeron1
    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 4.x
    Based On: Stock AOSP Userdebug

    Version Information
    Status: Testing

    Created 2019-05-25
    Last Updated 2019-05-30
    3
    I compiled a Kernel from here and modified:

    arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar-base-sde.dtsi
    arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar-sde.dtsi
    arch/arm64/boot/dts/qcom/dsi-panel-somc-poplar.dtsi

    (changed 60hz to 90/120hz).

    How can I check if the Panel really is working under those frequencies and if other steps are needed?

    When compiling I got an Error with drivers/staging/wlan-qc/qcacld-3.0 -> so i removed them from drivers/staging/Kconfig (So apparently no Wifi).

    These are the Kernels (boot):
    90Hz
    *Update 29.05. I Fixed Wifi for the 120Hz version. link in first post

    Camera seems to work without problems (also Raw) so I guess there is something wrong with the precompiled Sony Kernel.

    Also the Sony bootlogo is not present (no artifakts??)

    And again. Flash at own risk.
    2
    Having real trouble getting magisk to work. Everything i can find tells me to install Magisk then install the kernel. But the 120hz kernel seems to remove the Magisk install. So i install Magisk again, then the phone wont boot.

    ---------- Post added at 12:44 PM ---------- Previous post was at 12:36 PM ----------

    I give up, reflashing Magisk, gets it working, but then the phone acts wierd. Reboot from ROM, goes into TWRP. Shutdown does not actually shutdown the phone (she just goes off, but needs a Volume UP kill) I guess AOSP 9 just isnt ready yet?
    2
    I would marry if you turn 60fps to 90-120-144 omg plz plz
    2
    it would be great if you could build one for G8342 plz
    Im just uploading the Dual Sim AOSP now:good: