[ROM][AOSP][dragon] -> [9.0.0_r31_PQ2A.190205.001] -> 02-2019 (DISCONTINUED)

Search This thread

followmsi

Senior Member
Oct 10, 2013
4,212
13,053
DISCONTINUED
Sorry .. due to limited time I have stopped all my AOSP projects.

Pls find the last AOSP downloads here ..
https://androidfilehost.com/?w=files&flid=289293

Thanks for understanding ..



It's AOSP time for Pixel C ...

Android Pie ..
AOSP_9.0.0_r31_PQ2A.190205.001_dragon-ota-eng.followmsi.zip

Known issues:
- Encryption seems not work - and has not been tested. -> Pls do not encrypt your data partition yet.

- Keymaster -> If you set Pattern, PIN or Password the Screen unlock may not work correctly.
Workaround for Pattern: On fresh boot you will need to wait a bit longer before you enter credentials.
The waiting time is required on fresh boot only, the following unlocks are working normally.


- The ROM does contain it's own vendor.img ! (If you go back to Oreo, pls reinstall stock vendor.img)

And big thanks to @NYCHitman1 (Dirty Unicorn) !
Without his work the Android Pie project would not have been possible !


Oreo ..
AOSP_8.1.0_r60_OPM8.190105.002_dragon-ota-eng.followmsi.zip

This ROM will require stock vendor.img - it's not part of the ROM installer !
You will find a copy inside the download folder.
Or just extract yourself .. https://developers.google.com/android/images#ryu
Pls install latest stock vendor.img via TWRP !


Installation:
1. Boot into TWRP (latest available version)
2. Wipe system, cache, dalvik and data partitions ! ( If you have encrypted /data partition - pls "format" /data via TWRP first ! )
3. Install latest ROM
4. Install Gapps (arm64) (optional)
5. install Magisk.zip (optional)
6. Reboot into system ..

- Please install Magisk.zip and/or SuperSu.zip yourself.
- If you face any strange issues, pls do a factory reset via TWRP first.


TWRP:
https://forum.xda-developers.com/pixel-c/development/twrp-3-0-2-0v16-t3400503


SOURCES:
https://github.com/followmsi/manifests/tree/dragon-aosp-pie
https://github.com/followmsi/manifests/tree/dragon-aosp-oreo
https://github.com/followmsi/manifests/tree/dragon-aosp-nougat
https://android.googlesource.com/


DOWNLOAD:
https://androidfilehost.com/?w=files&flid=289293
https://drive.google.com/drive/folders/0By6p5AdQfavBUTZmNWJoaU1iazg


Enjoy :p
 
Last edited:

TheNamesJohn

Member
Dec 16, 2010
28
13
Riga
Thank you for your work.
Its been a while since Pure Nexus was updated so will try this one when I'll get a free evening.
 

followmsi

Senior Member
Oct 10, 2013
4,212
13,053
Yes, the newer versions are for file based encryption (fbe) testing.
Pls install 3.1.0-1 .. Will work the same as the current one and maybe fbe is working too :)

No, pls wipe system the first time.
If you install update later on you can keep system.

Pls report if you like the ROM ..

Cheers
 

Istvan_86

Senior Member
Apr 9, 2011
698
93
Madrid
Yes, the newer versions are for file based encryption (fbe) testing.
Pls install 3.1.0-1 .. Will work the same as the current one and maybe fbe is working too :)

No, pls wipe system the first time.
If you install update later on you can keep system.

Pls report if you like the ROM ..

Cheers

After update TWRP to 3.1.0-1 and make a factory reset I try to install your first zip and I get error 7 message. I´m missing something?

Thanks in advance.
 

followmsi

Senior Member
Oct 10, 2013
4,212
13,053
After update TWRP to 3.1.0-1 and make a factory reset I try to install your first zip and I get error 7 message. I´m missing something?

Thanks in advance.
Wipe system is not included min factory reset :)

You need to do it manually .. Check system only and wipe.
Will be formated as ext4

Does it work for you ?

EDIT: .. We want to clean your system from all the stock google stuff .. And install AOSP only :)

Cheers
 
Last edited:
  • Like
Reactions: Istvan_86

jeffyca

Member
Jan 26, 2013
23
2
I am also getting an install error after manually wiping everything.

E3003: Can't install the package (Tue Mar 7 20:10:49 CET 2017) over newer build (Thur Mar 9 17:08:49 CET 2017)
Updater process ended with ERROR: 7
Error installing zip file /sdcard/AOSP_7.1.1_r24_N4F26T_dragon-ota-eng.followmsi.zip.
 
Last edited:

followmsi

Senior Member
Oct 10, 2013
4,212
13,053
I am also getting an install error

E3003: Can't install the package (Tue Mar 7 20:10:49 CET 2017) over newer build (Thur Mar 9 17:08:49 CET 2017)
Updater process ended with ERROR: 7
Error installing zip file /sdcard/AOSP_7.1.1_r24_N4F26T_dragon-ota-eng.followmsi.zip.
What system do you have installed now ?

This "****ty" update script is checking your current build date ..Automatic google script.

Did you wipe system partition ?

We can remove this check manually .. if needed.
 

jeffyca

Member
Jan 26, 2013
23
2
What system do you have installed now ?

This "****ty" update script is checking your current build date ..Automatic google script.

Did you wipe system partition ?

We can remove this check manually .. if needed.

I manually wiped everything. Did not have a system installed. TWRP even yelled at me when i wanted to reboot to try again saying no OS was installed. I was coming from February image and an older TWRP before updating to the newest TWRP and trying this AOSP package before going to March image.
 

followmsi

Senior Member
Oct 10, 2013
4,212
13,053
Strange indeed ...

Here is the relevant part ..

(!less_than_int(1488913849, getprop("ro.build.date.utc"))) || abort("E3003: Can't install this package (Tue Mar 7 20:10:49 CET 2017) over newer build (" + getprop("ro.build.date") + ").");
getprop("ro.product.device") == "dragon" || abort("E3004: This package is for "dragon" devices; this is a "" + getprop("ro.product.device") + "".");
ui_print("Target: Android/aosp_dragon/dragon:7.1.1/N4F26T/follow03072010:userdebug/test-keys");

Need to remove this and save the file and zip again ..

The script is the checking the date of the Recovery ;)))

Will remove this .. and make a new Upload ..
 

followmsi

Senior Member
Oct 10, 2013
4,212
13,053
What system do you have installed now ?

This "****ty" update script is checking your current build date ..Automatic google script.

Did you wipe system partition ?

We can remove this check manually .. if needed.

This is really funny .. :)

You are using already 3.1.0-1 from the download folder ... which is newer as the ROM ..
Look at the build date :
ro.bootimage.build.date=Thu Mar 9 17:08:49 CET 2017

Anyway ...

I already uploaded a new version .. same name !
Pls download again .. and install .. Thanks for your understanding !

The new update script looks like ..

Code:
getprop("ro.product.device") == "dragon" || abort("E3004: This package is for \"dragon\" devices; this is a \"" + getprop("ro.product.device") + "\".");
ui_print("Target: Android/aosp_dragon/dragon:7.1.1/N4F26T/follow03072010:userdebug/test-keys");
show_progress(0.750000, 0);
ui_print("Patching system image unconditionally...");
block_image_update("/dev/block/platform/700b0600.sdhci/by-name/APP", package_extract_file("system.transfer.list"), "system.new.dat", "system.patch.dat") ||
  abort("E1001: Failed to update system image.");
show_progress(0.050000, 5);
package_extract_file("boot.img", "/dev/block/platform/700b0600.sdhci/by-name/KERN-A");
show_progress(0.200000, 10);
set_progress(1.000000);

Sorry for this one :)

Will be fixed for the next month AOSP package ..

Cheers
 
  • Like
Reactions: cam30era

Istvan_86

Senior Member
Apr 9, 2011
698
93
Madrid
Wipe system is not included min factory reset :)

You need to do it manually .. Check system only and wipe.
Will be formated as ext4

Does it work for you ?

EDIT: .. We want to clean your system from all the stock google stuff .. And install AOSP only :)

Cheers

Sorry a hard day in the office and I go directly to bed.

I wipe everything and system is in ext4 but error 7 stiill stops the flashing process. Also my usb otg stop working in 3.1.0-1 and I must go back to 3.1.0-0 to restore my backup that iis stored iin a usb.
 

followmsi

Senior Member
Oct 10, 2013
4,212
13,053
Sorry a hard day in the office and I go directly to bed.

I wipe everything and system is in ext4 but error 7 stiill stops the flashing process. Also my usb otg stop working in 3.1.0-1 and I must go back to 3.1.0-0 to restore my backup that iis stored iin a usb.
Pls re-download new OTA version .. same name - from the one drive folder again.
Removed the error 7 check now .. The OTA is older as the recovery you are using :)

Pls stay with TWRP 3.1.0-0 for now.
 
  • Like
Reactions: Istvan_86

Istvan_86

Senior Member
Apr 9, 2011
698
93
Madrid
Pls re-download new OTA version .. same name - from the one drive folder again.
Removed the error 7 check now .. The OTA is older as the recovery you are using :)

Pls stay with TWRP 3.1.0-0 for now.

Ok I´m back on TWRP 3.1.0-0 and downloading the new AOSP ZIP. I reinstall Pure Nexus just for testing and it installs and boots without problems with TWRP 3.1.0-0. So now with a booting rom installed what must I wipe before install the new zip?

Thanks for all your help.
 

followmsi

Senior Member
Oct 10, 2013
4,212
13,053
Ok I´m back on TWRP 3.1.0-0 and downloading the new AOSP ZIP. I reinstall Pure Nexus just for testing and it installs and boots without problems with TWRP 3.1.0-0. So now with a booting rom installed what must I wipe before install the new zip?

Thanks for all your help.

Pls format system first .. to remove the pure nexus stuff ...

Have made dedicated version of the vendor.img too.
AOSP_Update.ZIP_PixelC_Ryu_vendor_N4F26T.zip
Oherwise you will get warning message at system start ..

All the small issues ... but now it's looking good.

I have moved as well ... I will stay on AOSP now .. no BETAs anymore !
Once they release the 7.1.2 code we will make a new AOSP :)

No problems on 3.1.0-1 in terms of USB.OTG ..
Just doing USB-OTG restore of my old data partition and will merge it "dirty" into AOSP now ..
All the google apps will cry :)
Takes 1-2 hours fixing stuff ... but not installing 150 apps and tons of other settings from scratch .. etc. :)

AOSP is coming :)

Cheers
 
  • Like
Reactions: Istvan_86

Istvan_86

Senior Member
Apr 9, 2011
698
93
Madrid
Pls format system first .. to remove the pure nexus stuff ...

Have made dedicated version of the vendor.img too.
AOSP_Update.ZIP_PixelC_Ryu_vendor_N4F26T.zip
Oherwise you will get warning message at system start ..

All the small issues ... but now it's looking good.

I have moved as well ... I will stay on AOSP now .. no BETAs anymore !
Once they release the 7.1.2 code we will make a new AOSP :)

No problems on 3.1.0-1 in terms of USB.OTG ..
Just doing USB-OTG restore of my old data partition and will merge it "dirty" into AOSP now ..
All the google apps will cry :)
Takes 1-2 hours fixing stuff ... but not installing 150 apps and tons of other settings from scratch .. etc. :)

AOSP is coming :)

Cheers

I repeat all the steps includiing downloading again all the files but when I end the process and try to reboot to boot in the rom TWRP says that OS isn´t installed.... We are missing something?
 

followmsi

Senior Member
Oct 10, 2013
4,212
13,053
I repeat all the steps includiing downloading again all the files but when I end the process and try to reboot to boot in the rom TWRP says that OS isn´t installed.... We are missing something?
Just reboot .. ignore the message.

Sometimes TWRP has an issues if system is mounted before you install the zips.

After you have formatted system, just manually unmount system in mount menu.

I am running AOSP myself .. works like a charm !
 
  • Like
Reactions: Istvan_86

followmsi

Senior Member
Oct 10, 2013
4,212
13,053
Using Tapatalk from the old backup .. all was working directly.
But not all apps .. maybe 15 of 140 apps have to be reinstalled .. if you want to keep the settings, just install apk version over the existing installation .. works fine too ;)

Fully burning AOSP ;)
 

Istvan_86

Senior Member
Apr 9, 2011
698
93
Madrid
Just reboot .. ignore the message.

Sometimes TWRP has an issues if system is mounted before you install the zips.

After you have formatted system, just manually unmount system in mount menu.

I am running AOSP myself .. works like a charm !

Ok, I install again pure nexus and boot it. After that I reboot in TWRP and wipe dallvik + cache + system and when this finish TWRP says "Unable to mount storage" Is this normal and I can now unmount system in order to flash the AOSP zip and the vendor zip + gapps and reboot?

Thanks.
 

Top Liked Posts