[ROM] AOSP Kitkat 4.4.2 - PRE-ALPHA 1- 01/03/2014-Unlock Bootloader Only

Search This thread

Tof37

Senior Member
Oct 6, 2009
620
2,468
Tours
Hello too all the "legacy and low activity devices" users :)



I'd like to share you something that will allow x10 to live a little bit longer ...


So here it is ... Kitkat is here !

The bug list is quite long but I wanted to share with you this preview ...

DOWNLOAD it here


What is working and not ?


Working : hmmmm it boots ;) that's the most important


Not working :
  • sd Mount : problem in kernel compilation against rom
  • recovery access : same reason as above
  • wifi : kernel / device tree to fix
  • camera
  • sound : kernel to fix
  • ...

The ftf file I share comes with 3.0.8 kernel BUT Ion memory manager is not working ...have boot problems with it ..


Hope you"ll enjoy it even if it's just a pre-alpha version but I promise to do much better.

Thanks to Evervolv team for their amazing work, CM Team, Scritch007 for his 4.3 device tree I used and avoid me days of work :) and of course Achotjan and Feravolt for their advices :)

Note : Flash this file only if you know what you're doing ...

The sources will be available asap, once I fixed some few stuff (repo sync etc ...)

SOURCES

To compile with PMEM memory management :
android_device_semc_es209ra-pmem-version

To compile with ION memory management (not booting yet)
android_device_semc_es209ra-ion
 
Last edited:

CryLegend

Senior Member
Feb 11, 2012
86
13
Paris
KitKat is known to run on lower-end devices, but X10 don't have the required 512MB* of RAM.
Anyway, good job.

"Envoyé depuis mon C6903 avec Tapatalk"
 
Last edited:
  • Like
Reactions: Tof37

doodownunda

Senior Member
Apr 10, 2013
231
136
Hi and thank you once again for your Rom. Congrats :highfive:

I can not download from the link at Mediafire, I get the following error message - This webpage is not available :confused:

EDIT - Tried using Internet Explorer instead of Google Chrome and is now downloading. :D

Thank's again :good:
 

aleespa

Senior Member
Jul 10, 2012
166
55
México City
Screenshots

:fingers-crossed::fingers-crossed::fingers-crossed::fingers-crossed:

So much unstable

EDIT: I'm usin Apex Launcher it looks better than Launcher3
 

Attachments

  • DSC07338.jpg
    DSC07338.jpg
    222.7 KB · Views: 823
  • DSC07339.jpg
    DSC07339.jpg
    223 KB · Views: 731
  • DSC07340.jpg
    DSC07340.jpg
    232.8 KB · Views: 725
  • DSC07342.jpg
    DSC07342.jpg
    239.7 KB · Views: 785
  • DSC07343.jpg
    DSC07343.jpg
    240.7 KB · Views: 675
  • DSC07344.jpg
    DSC07344.jpg
    235 KB · Views: 636
  • DSC07345.jpg
    DSC07345.jpg
    229.1 KB · Views: 586
  • DSC073421.jpg
    DSC073421.jpg
    246.2 KB · Views: 553
Last edited:

Dr Goodvibes

Senior Member
Dec 8, 2011
846
813
AnTuTu, Android 4.4.2 and X10i

I installed SetCPU, ES File Explorer, Root Explorer, Business Calendar, FSP2D and even started to install Google Play Store.

Didn't notice any apps outright failed. Google play probably needs correct infrastructure in place to work.
I was trying to be slack and install an old Google play and then have it detect it was old and re-install all the new correct stuff. Failed

Root Explorer and ES File Explorer are very usable with Alpha Android 4.4.2.
Didn't change or save any files so not absolutely sure on that part but root access is supported.

I can confirm 3G and HSDPA are functional at some level.

AnTuTu runs and returned 3045 clocked at 1190MHz.
Both 2D and 3D graphics are a long way from supporting high level applications.

FSP2D returns 32FPS stdev=4.77

But, all this may be taking the mickey out of the Alpha phase as there is still much work to be done on the core drivers before noob users should be even allowed to touch it.

Top marks to @Tof37 and those supporting him, as this is one small step for Tof37...but a giant leap for the XPERIA X10i
 

Bigkiler5

Senior Member
Oct 11, 2012
539
157
jalandhar
good job mate! its good to see that 4.4 booted perfectly on X10.
there are a little problems in rom. clock, settings, launcher works fine(launcher gives fc on walpaper change)
phone dials up fine, but there's no audio neither the mic works.
browser gives black screen but i am sure it is connected to internet and loads stuff.
-DSC02395.jpg
proof it loads stuff(i dont know how i got this but phone froze after this window)
-DSC02402.jpg
sd card, camera doesnt work as stated in OP
ram status with many apps cached
-DSC02389.jpg
and btw after tapping for sometime on build nnumber, it said i am a developer... what does that mean?
-DSC02388.jpg

i'll be looking forward to further releases...
Thanks for a KitKat break :D
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 55
    Hello too all the "legacy and low activity devices" users :)



    I'd like to share you something that will allow x10 to live a little bit longer ...


    So here it is ... Kitkat is here !

    The bug list is quite long but I wanted to share with you this preview ...

    DOWNLOAD it here


    What is working and not ?


    Working : hmmmm it boots ;) that's the most important


    Not working :
    • sd Mount : problem in kernel compilation against rom
    • recovery access : same reason as above
    • wifi : kernel / device tree to fix
    • camera
    • sound : kernel to fix
    • ...

    The ftf file I share comes with 3.0.8 kernel BUT Ion memory manager is not working ...have boot problems with it ..


    Hope you"ll enjoy it even if it's just a pre-alpha version but I promise to do much better.

    Thanks to Evervolv team for their amazing work, CM Team, Scritch007 for his 4.3 device tree I used and avoid me days of work :) and of course Achotjan and Feravolt for their advices :)

    Note : Flash this file only if you know what you're doing ...

    The sources will be available asap, once I fixed some few stuff (repo sync etc ...)

    SOURCES

    To compile with PMEM memory management :
    android_device_semc_es209ra-pmem-version

    To compile with ION memory management (not booting yet)
    android_device_semc_es209ra-ion
    19
    Pas si simple mon ami :)

    2.6.32 doesn't build, 2.6.29 does, boots but got nearly the same problem than 3.0.8 .. stuck at scanning network and don't have bluetooth




    in BoardConfig.mk change this line :
    PHP:
    TARGET_KERNEL_CUSTOM_TOOLCHAIN := arm-eabi-4.4.3

    This should do the trick :)

    Mate contact me on Gtalk we will tray to fix Bluthooth and wifi for 3.0.8 and 2.6.32

    cheers

    Achotjan
    14
    ah sh*t, you're first :D.. Nice job.. thank you :)

    Don't worry there's many things to do with it :)

    For the sources file I have to make some clean up before... and I won't have time before tomorow or monday.
    Thanks :)
    13
    Same problem for me I get a WLOD, and i try the same as you. :(
    I think is for some xperia, my processor never has working to more than 1036....and other xperia work fine with 1190 or 1228 :eek:

    Ah is this ROM overclocked by default then? Would explain the crashes if so.

    Mind you my GB Fera ROMs have usually always worked at 1.14Ghz. Anything above that and I always got WLOD.

    You're right ... I didn't notice I kept 1228 in kernel defconfig ... have to update it to keep 988 by default but have higher frequencies available
    11
    ah sh*t, you're first :D.. Nice job.. thank you :)
    Do you have source files? I wanted to try on LegacyXperia builds..