Development [ROM]ArrowOS 13.0 | 12.1/12L for Xiaomi Pad 5 (nabu) | [OFFICIAL]

Search This thread

mikefnz

Senior Member
Jan 30, 2008
811
239
Christchurch
OnePlus 7T
Xiaomi Mi Pad 5
can u tell the step by step on how to install magisk ? this is my first time, i read all the thread, all i found is people saying patched boot.img and vendor_boot.img, do i patch vendor with the same way i patch boot.img on magisk? ive tried the root guide but magisk is not installed. im clueless here. I hope u or anyone here can help me.

EDIT: Nvm, I reinstalled everything with the correct boot.img for arrow13 after my pad bootloop and try it again now it works.
Sounds good. Guides available: https://www.xda-developers.com/how-to-install-magisk/
 

reymasters

Senior Member
Oct 22, 2013
70
6
Quezon City
Hi, can I just simple extrqct the boot.img from arrow os.zip file and patch it with magisk or need to pull the boot.img on my device via adb and patch it?
 

timuh

New member
Jul 23, 2009
4
0
i tried to root the rom with patched boot.img but it didnt boot anymore. i flashed the old boot.img an wipe userdata and flashed last arrow rom again.

now its booting but cant find any wifis and dont stop searching. anyone has an idea how to fix this?
 

mikefnz

Senior Member
Jan 30, 2008
811
239
Christchurch
OnePlus 7T
Xiaomi Mi Pad 5
i tried to root the rom with patched boot.img but it didnt boot anymore. i flashed the old boot.img an wipe userdata and flashed last arrow rom again.

now its booting but cant find any wifis and dont stop searching. anyone has an idea how to fix this?
I would suspect a mismatched boot image. You might have to start again and make sure you use the matched boot image... That's just my guess...
 

bonks60

Member
Dec 19, 2017
8
1
46
Nexus 9
Remix OS
Hi, just sharing my flash experience:
I was in EEA 13.1.3 and tried flashing to Arrow 13 ... with no sucess, device was only able to boot in recovery or fastboot (fortunately), after some research it seems that trying installing from 13.0.4 avoid issues.
I could downgrade to 13.0.4 and then, reflash from the beginning .... and everything went as expected , it's so cool !!
Watch out, it can happen that 13.1.3 is not the best starting point.
Thanks @kubersharma001 ! Awesome job
 

riverstyxxx

Senior Member
May 9, 2015
168
24
How do I get rid of the icons at the bottom and replace it all with the normal three buttons? I tried gestures/3-button navigation but that doesn't fix it.
 

albireox

Senior Member
Nov 25, 2009
1,625
404
Timisoara
Doesn't work. That was suggested before and the other poster reported the same. Just a grey bar that takes up 3/4ths of an inch and four apps I'll never open. I'm using the android 12 build.
You're right, it seems to be the same on A13, when using navigation buttons you can't seem to get rid of the taskbar, it dissapears only when using gesture navigation.
 

Ethan Bastian XDA

New member
Nov 18, 2022
2
2
hi, nice rom indeed but i will give some of my comments about this rom

firstly i seem cannot connect my mi keyboard case, but i can install a magisk module :
and if you dont know how to install magisk this is my tips
1. you need a pc
2. download magisk apk
3. copy boot.img that you have downloaded in the arrow os recovery to your tab ( i suggest in root folder)
4. open magisk and press on the magisk option and select your boot.img that you've selected before
5. it will create a patched boot img that you have to re patch using fastboot flash boot ( it was like the first time, but just use the "fastboot flash boot" command)
5.1. the patched boot.img usually sits on your downloads folder. copy it to your computer and just reflash the img (no need to rename it to boot.img)
6. after that you can just type "fastboot reboot" to enter arrow os and you are done.

mi pen works fine but if you want to take full advantage of the button you can just install button mapper and remap your button

but i still have a problem about taskbar that was disturbing me in lockscreen like this
Screenshot_20221118-220301_WhatsApp.png

i hope there will be a fix for this

about face unlock. somehow i manage to successfully installed it using the universalauth
this is the github https://github.com/null-dev/UniversalAuth

for this face unlock universalauth to work ofc you need magisk and you have to insta some sort of xposed? (actually i dont know what is xposed), i installed the altervative that was riru LSPosed.
firstly you need to install riru in magisk, and after that you can install LSPosed.

and to install the face unlock module you need to download both apk and install it. after that you have to reboot and register your face in the face unlock app. after you register your face you can test auth your face and if it was recognizing your face go ahead and open LSPosed (for me its was a widget on my home screen) and enable universalauth. font forget you have to tick the android12. after that you have to reboot and face unlock should be available (for me i have to insert password for the first time after boot to use face unlock for the next unlock)

i think that's all from me , thank you @kubersharma001 for porting this rom because miui13 based on android 12 was unpolished at all.
 
Last edited:

riverstyxxx

Senior Member
May 9, 2015
168
24
Here's how I installed magisk.: Enable developer mode/adb. Then "adb reboot sideload", then sideload magisk*.apk (Not the zip), then press down, then power (This is to accept a warning). It'll take a few minutes then return an xfer message, then adb reboot. You'll still have to go through the prompts in magisk and reboot once more, then you're good.

So only two issues with this rom: The grey bar at the bottom, and we can't see anything in sideload or recovery.
 
Last edited:

Weedy0104

Senior Member
Jul 18, 2012
78
29
Samsung Galaxy S20
Xiaomi Mi Pad 5
i tried to root the rom with patched boot.img but it didnt boot anymore. i flashed the old boot.img an wipe userdata and flashed last arrow rom again.

now its booting but cant find any wifis and dont stop searching. anyone has an idea how to fix this?
Had the Same Problem a few weeks ago. Dont wipe or anything else. Just flash the other Boot img from Arrowos Page. I think it is named with verifaction disabled or sth Like that. If flashing this my WiFi instantly was back
 

lanstang

New member
Nov 22, 2022
1
0
When I try to root my device with magisk, got this error when flash magiskboot img, and I can search it but don't have OEM unlock option in my developer options, is that normal?
 

Attachments

  • IMG_20221122_064406.jpg
    IMG_20221122_064406.jpg
    399.3 KB · Views: 70
  • Screenshot_20221122-070309.png
    Screenshot_20221122-070309.png
    356.1 KB · Views: 70
  • Screenshot_20221122-070303.png
    Screenshot_20221122-070303.png
    99.4 KB · Views: 70

Ethan Bastian XDA

New member
Nov 18, 2022
2
2
how to install magisk. im still lost when i flash the patched image it just bootloops. Edit:- it worked just needed to do it twice thanks for the help anyway
Can you teach me what is the meaning of doing it twice ??, Flash the patched img twice or what ?

FIXED :
  1. go to your rom zip and extract the payload.bin
  2. download a payload bin extractor and copy the boot.img that the extractor had extracted. NOT THE ONE THAT YOU FLASHED
  3. go to magisk and patch that boot.img
  4. after that just flash the patched boot.img and you are done
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    yeah, faced the bootloop issue myself, debugging and probably will be fixed with next update as maybe I think I know why that glitch

    anyways, new update soon (maybe today or later tonight)

    Also, I have decided not to renew my website next time around maybe, so I moved everything to medium
    https://k001droid.medium.com/ - follow me here if you want

    nabu instructions post:-

    extracting boot.img:

    something I wrote for encryption on custom roms:-

    (not sure how medium works, but here are always free unlimited reading links)

    enjoy
    2
    In case I am the first trying this:
    I was on MIUI 14 CN Stable Dev Android 13 (unrooted) exactly as described below under firmware, and then flashed ArrowOS 13 accordint to the guide. Everything works out of the box without any issues: Pen, Keyboard (After activation under Bluetooth Settings), WIFI6, Audio (Dolby?)

    Therefore I can verify this works flawlessly:
    • Firmware: nabu_images_V14.0.22.12.21.DEV_20221221.0000.00_13.0_cn_140cca658d.tgz
    • ROM: ArrowOS 13 GAPPS 3. January

    Maintainers and the ArrowOS team: You guys are genious! Much love to you guys
    2
    I had success when I flashed Magisk via sideload
    adb reboot sideload
    adb sideload Magisk***.zip
    press lower volume [short] - press on/off [short] - that it worked for me
    2
    Hi everyone! I updated from December 8th build to 17 Junary build from the updater and didn't get any bootloop. Hope everyone gets the same result as I can't assure you'll get the same behaviour
    1
    Hello guys,

    Do you know If It is posible to update the build without losing any data? Since there isnt any twrp for mi pad 5, the only way to update It is through flashing it with fastboot?

    Also, is the last build, the one of Jan 3 stable?

    Thank you
    I don't have an answer to the first one because of all the issues on the installation phase but in general, it does update without any data loss. There is a recovery but the interface isn't visible. Jan 3 is stable so far for me.
  • 58
    logo.png

    ArrowOS for Xiaomi Pad 5 (nabu)(sm8150)

    Code:
    /*
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, We will laugh at you.
    * It is your fault because you chose to do all the modifications on your device.
    * Remember projects like these and the work done on them is a hobby to the
    * contributors and the team members, no one is working for you nor is getting paid for it
    * have some respect for the work done by them since it is done purely on interest or a hobby
    */

    ABOUT
    ArrowOS
    is an Android Open Source Project based Android mobile operating system started with the aim of keeping things simple, clean and neat.

    Website: https://arrowos.net
    Telegram: Channel | TG Portal/Links
    Github: https://github.com/ArrowOS
    Code Review: review.arrowos.net
    E-mail: arrowos.contact
    PayPal: Donate to us
    Blog: blog.arrowos.net

    Checkout more documentation at (maintainership/contributing): Check this out

    WHAT WORKS?
    • Almost everything (including Xiaomi Stylus/Mi Pen and Xiaomi Keyboard) except proprietary features like Mi Pen (they will likely not work in AOSP, but we aim to make it work in the near future if we get the time and pen)

    WHAT DOESN'T WORK?
    • You tell me
    Be sure to include a log : check how to

    DOWNLOAD
    supported versions:
    - arrow-13.0 based on android13
    - arrow-12.1 based on android12L

    Click here to Download
    Select "nabu" from Xiaomi tab
    Tip: Select OEM -> Device, choose Arrow version, and choose the build type: "GAPPS" or "VANILLA" to download.

    HOW TO FLASH | RECOVERY DOWNLOAD

    Firmware: MIUI android12 firmware but any fw from MIUI a11 to latest will work!

    GPL compliance:
    ROM Source
    - https://github.com/ArrowOS
    Kernel Source- https://github.com/ArrowOS-Devices/android_kernel_xiaomi_nabu

    Contributors: kubersharma001, ganeshi4u, LynnrinChan

    Read our blog article/post about:
    * HOW-TO report a bug
    * GAPPS and VANILLA variants
    * Checking build integrity

    Donate: https://www.paypal.me/kubersharma001
    UPI: [email protected]

    ENJOY
    18
    I guess you all might wanna check out:

    Mi Pen now works w/ palm rejection just like MIUI in official ArrowOS!
    hoorah! :D

    ----x----

    1. ArrowOS 13.0 (android13) is here for Xiaomi Pad 5 (nabu) | OFFICIAL
    2. New Update of ArrowOS 12.1 / 12L is here for Xiaomi Pad 5 (nabu) | OFFICIAL

    Changelogs:
    DEVICE:

    - Supports Xiaomi Stylus/Mi Pen
    - Latest MIUI Android 12 odm,vendor base (you can use latest a12 fw but a11 fw will work fine too thanks to vendor_freeze)
    - Ships with custom-kernel/source-compiled ArrowOS kernel
    - Lots of other misc changes
    ROM: https://arrowos.net/changelog.php

    How to flash?:
    https://kubersharma001.com/arrowos-for-xiaomi-pad-5-nabu

    Donate: [email protected] | PayPal
    9
    Latest ArrowOS 13.0 update is here for Mi Pad 5 (nabu) By kubersharma001, LynnrinChan and ganeshvarma

    Mi Pen and Mi Keyboard both work
    High pitched audio issues on voice should be fixed
    Other improvements and changes

    Have any issues flashing? Read the goddamn instructions post https://kubersharma001.com/arrowos-for-xiaomi-pad-5-nabu

    What firmware to use? Any that works for you if you can't decide to use whatever your region 's fw is. I see a lot of people blindly flashing CN fw.

    Support: kubersharma001chat and Lynnrin_group (on telegram)

    PS: When downloading select arrow-13 and OFFICIAL tabs not experimental🤦‍♂
    Do not flash stupid mods that break system and come back to me complaining. If you wanna mod, learn to deal with it.

    Donate:
    Kuber:
    [email protected] | http://paypal.me/kubersharma001
    Lynnrin:

    Enjoy
    8
    Hello, guys. I have been super busy so I may not be posting anything on XDA and hardly anything over my TG channels. OTAs will keep releasing/builds will be up on the website.
    ALSO:
    I do not own the Xiaomi Keyboard, it seems the latest changes broke it for some users which should be fixed in the latest release.

    A lot of people are asking me if this is a good tablet for art or not. I am a simple man and have very basic tablet needs. I do not own a pen (too expensive) nor can I draw something good. Please, can someone with a pen or knowledge of apps which works best for artists give their short insights so I can refer people here?
    7
    Planning to buy a Mi pen to support it
    if anyone is donating, please mention "nabu" or "mipad5" in the payment description
    Gonna save for it, those donations will help

    UPI: [email protected] | PayPal

    edit: Mi pen is now supported from 14/oct builds :D