Development [ROM]ArrowOS 13.0 | 12.1/12L for Xiaomi Pad 5 (nabu) | [OFFICIAL]

Search This thread


Aug 10, 2017
OnePlus 6
Xiaomi Mi Pad 4
Maybe because of this?
ArrowOS Infra is "Everything related to maintaining/manage our project Infrastructure" (GitHub).


New member
Dec 5, 2022
I appreciate that there's finally a rom for this great tablet.

For me, wifi 5ghz sadly also didn't work (I am forced to use it at work). Also wifi settings showed the wifi version wifi 4 instead of wifi 5 or 6, in case that helps somehow for debugging

Yes I flashed the correct firmware (global)

Other than that, I was surprised how smooth this rom is, given how recent it was published
Last edited:


New member
Dec 6, 2022
Anyone got the last ArrowOs 13? Y need to reflash due to bootloop and lost all necesary archives to flash, and download page isnt online yet :s


Dec 4, 2022
Xiaomi Mi Pad 5

I followed the manual from kubersharma001 and on step:
fastboot -w
i got

platform-tools_r33.0.3-windows\platform-tools>fastboot.exe -w
Erasing 'userdata'                                 OKAY [  0.023s]
F2FS-tools: mkfs.f2fs Ver: 1.15.0 (2022-05-20)

Info: Disable heap-based policy Info: Debug level = 1
Info: Trim is disabled Info: Set conf for android
Info: Enable Project quota       
Error: Sparse mode is only supported for android

platform-tools_r33.0.3-windows\platform-tools/make_f2fs failed: 4294967295 fastboot: error: Cannot generate image for userdata

I went through next step and all of them were ok. At the end got arrow android fully installed.

But i'm wondering if this bug can affect the operation of the tablet? could something be wrong? At the moment it seems that everything is ok, the only problem I have with the prime video application, which from time to time hang, android exit it, but maybe it's the fault that it's not compatible with android 13?
I've solved that by switching to older platform-tools from 33.0.3 to 31.0.3. I'm not sure why, but without magisk I got Widevine L1, can install netflix...
  • Like
Reactions: realsatnav


Senior Member
Apr 6, 2012
What exact do you mean if I have tried magisk?

My steps are:

*Sideloading 14/11/2022 build
*Install magisk
*Extracting boot.img with ADB / fastboot tools
*Patching boot.img with magisk
*Flashing patched boot.img with ADB / fastboot tools

Then you will have the root access

that is the current way to get rooted on 13 arrowos?

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    yeah, faced the bootloop issue myself, debugging and probably will be fixed with next update as maybe I think I know why that glitch

    anyways, new update soon (maybe today or later tonight)

    Also, I have decided not to renew my website next time around maybe, so I moved everything to medium - follow me here if you want

    nabu instructions post:-

    extracting boot.img:

    something I wrote for encryption on custom roms:-

    (not sure how medium works, but here are always free unlimited reading links)

    Happy new year

    Download over the arrowos website doesn't work (android 13). Any update on when it will be available again?
    And there is a one more problem. I use 22.10.22 build (i cant download new build) and then i try to split userdata, rom stops booting. It is just bootlooped. How do i split userdata to 64/64 and keep rom alive?
    It seems like it was removed from the us mirror. Couldn't find it within the archive either.... Maybe @kubersharma001 would be so kind and rebuild the ROM?
    Does anyone have an alternative link? The one from ArrowOS site is down. :/
    Hi. I can't download rom
    download url didn’t work
    3rd of Jan release: Same for me.

    I recovered by:
    1) reboot to fastboot
    (power - -> hold - and release power)
    2) identify boot slot
    (fastboot getvar all -> search current slot)
    3) switch to old slot
    (e.g. fastboot --set-active=b)
    4) restart by key-combi

    I'm back in my old 14th Nov ROM without full wipe.

    Additional notes:
    - For me fastboot is buggy, i.e. after 1-2 min no commands are accepted anymore. Enter the commands quickly after a reboot into fastboot.
    - Another way to recover - as last resort before wipe/fullflash - one may try:
    enter normal fastboot,
    command: fastboot recovery,
    command: adb reboot sideload,
    command: adb sideload,
    then try if one of the both slots boots (fastboot --set-active=XY)

    Let's keep in touch, if one can confirm new OTAs working again!?!
    In case I am the first trying this:
    I was on MIUI 14 CN Stable Dev Android 13 (unrooted) exactly as described below under firmware, and then flashed ArrowOS 13 accordint to the guide. Everything works out of the box without any issues: Pen, Keyboard (After activation under Bluetooth Settings), WIFI6, Audio (Dolby?)

    Therefore I can verify this works flawlessly:
    • Firmware: nabu_images_V14.
    • ROM: ArrowOS 13 GAPPS 3. January

    Maintainers and the ArrowOS team: You guys are genious! Much love to you guys
    Hi everyone! I had the bootloop issue after the 20230103 OTA. The device got into recovery. Plugged-in into the pc, run adb shell and after that recovery --wipe-data. The device rebooted, pressed the power button and started right up, no data loss. Hope everyone gets the same result after following those steps
  • 57

    ArrowOS for Xiaomi Pad 5 (nabu)(sm8150)

    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, We will laugh at you.
    * It is your fault because you chose to do all the modifications on your device.
    * Remember projects like these and the work done on them is a hobby to the
    * contributors and the team members, no one is working for you nor is getting paid for it
    * have some respect for the work done by them since it is done purely on interest or a hobby

    is an Android Open Source Project based Android mobile operating system started with the aim of keeping things simple, clean and neat.

    Telegram: Channel | TG Portal/Links
    Code Review:
    PayPal: Donate to us

    Checkout more documentation at (maintainership/contributing): Check this out

    • Almost everything (including Xiaomi Stylus/Mi Pen and Xiaomi Keyboard) except proprietary features like Mi Pen (they will likely not work in AOSP, but we aim to make it work in the near future if we get the time and pen)

    • You tell me
    Be sure to include a log : check how to

    supported versions:
    - arrow-13.0 based on android13
    - arrow-12.1 based on android12L

    Click here to Download
    Select "nabu" from Xiaomi tab
    Tip: Select OEM -> Device, choose Arrow version, and choose the build type: "GAPPS" or "VANILLA" to download.

    Click here to download recovery and see instructions
    Firmware: MIUI android12 firmware but any fw from MIUI a11 to latest will work!

    GPL compliance:
    ROM Source
    Kernel Source-

    Contributors: kubersharma001, ganeshi4u, LynnrinChan

    Read our blog article/post about:
    * HOW-TO report a bug
    * GAPPS and VANILLA variants
    * Checking build integrity

    UPI: [email protected]

    I guess you all might wanna check out:

    Mi Pen now works w/ palm rejection just like MIUI in official ArrowOS!
    hoorah! :D


    1. ArrowOS 13.0 (android13) is here for Xiaomi Pad 5 (nabu) | OFFICIAL
    2. New Update of ArrowOS 12.1 / 12L is here for Xiaomi Pad 5 (nabu) | OFFICIAL


    - Supports Xiaomi Stylus/Mi Pen
    - Latest MIUI Android 12 odm,vendor base (you can use latest a12 fw but a11 fw will work fine too thanks to vendor_freeze)
    - Ships with custom-kernel/source-compiled ArrowOS kernel
    - Lots of other misc changes

    How to flash?:

    Donate: [email protected] | PayPal
    Latest ArrowOS 13.0 update is here for Mi Pad 5 (nabu) By kubersharma001, LynnrinChan and ganeshvarma

    Mi Pen and Mi Keyboard both work
    High pitched audio issues on voice should be fixed
    Other improvements and changes

    Have any issues flashing? Read the goddamn instructions post

    What firmware to use? Any that works for you if you can't decide to use whatever your region 's fw is. I see a lot of people blindly flashing CN fw.

    Support: kubersharma001chat and Lynnrin_group (on telegram)

    PS: When downloading select arrow-13 and OFFICIAL tabs not experimental🤦‍♂
    Do not flash stupid mods that break system and come back to me complaining. If you wanna mod, learn to deal with it.

    [email protected] |

    Hello, guys. I have been super busy so I may not be posting anything on XDA and hardly anything over my TG channels. OTAs will keep releasing/builds will be up on the website.
    I do not own the Xiaomi Keyboard, it seems the latest changes broke it for some users which should be fixed in the latest release.

    A lot of people are asking me if this is a good tablet for art or not. I am a simple man and have very basic tablet needs. I do not own a pen (too expensive) nor can I draw something good. Please, can someone with a pen or knowledge of apps which works best for artists give their short insights so I can refer people here?
    Planning to buy a Mi pen to support it
    if anyone is donating, please mention "nabu" or "mipad5" in the payment description
    Gonna save for it, those donations will help

    UPI: [email protected] | PayPal

    edit: Mi pen is now supported from 14/oct builds :D