[ROM][BETA][10.x] LineageOS 17.1 [clover / MiPad4/ MiPad4 Plus]

Search This thread


Senior Member
Jun 14, 2015
Install Magisk. It will have cts profile mismatch in safetynet check. you have to fix it by magisk hide props config. there is aconfig for mipad for, look for the procedure in interne. Clear google play store and
services app data. Restart your device will pass cts profile in safety net. Now you can download netflix from playstore. Works in my three devices.

Can anyone help me to get Netflix working on this?

I'm a super novice when it comes to flashing ROMS and stuff.

I bought the tablet 1 year ago and at the time I unlocked the bootloader and updated to version 10.1 EU of MIUI. This was fine and I had Netflix working.

Now today I decided to update to 10.3 and install LineageOS to try something new. It's updated and installed, but I can't get Netflix to show up in the playstore?
I fixed problem with netflix after changing fingerprint to xiaomi device which does not exist in China version. If fingerprint defines China version of device, play store will not find an app and an app will not work after installation.
(Interesting find : playing 45minutes material over LTE eat 24% of battery, the same over WIFI and only 7% battery consumption)
  • Like
Reactions: pnin


Oct 1, 2010
Hi all, I'm posting to express thanks to all the devs whose work made this great ROM possible, and especially to @rcstar6696 and @S-trace and @michael_ch and @sabar_op.

After much trial & error, I have just successfully compiled a new build of this 17.1 LineageOS ROM, with an updated Android security patch (August 5, 2021) and an updated kernel version to 4.4.245-Xiaomi_SDM660-LA.UM.8.2.r2-02500+ #2 Mon Aug 16 19:23:55 PDT 2021.

I have been running it on my MiPad 4 for a day now, and it seems to run as well as the @sabar_op version from October 2, 2020, that I was running before.

I'll try to find a place to host the zip file.

(Edit - I used Sourceforge, here's the link: )

I am a total newb at ROM building, but if I could pull it off, then I'm sure lots more of you could do it too. Obviously there are huge advantages to being able to do it for yourself.

There are plenty of how-to guides here at XDA, and I loosely followed this one: https://forum.xda-developers.com/t/guide-build-lineageos-how-to-use-github.3551484/

I started with Ubuntu 20.04 running in a VM on a Windows 10 PC, but even with 16 GB of ram configured for it on the VM, the build process kept crashing until finally I installed and enabled ZRAM. That last step took the build process from an ordeal of 3+ hours to get to 85% done at the failure point, into a 59 minute and 32 second speed demon success! After so many failures, I could hardly believe it finally worked.

Once everything was set up, the working commands in the terminal were as follows:

repo init -u https://github.com/LineageOS/android.git -b lineage-17.1

repo sync --force-sync

source build/envsetup.sh

brunch lineage_clover-userdebug

The specific conversation between @michael_ch and @rcstar6696 at post #909 and #910 in this thread was crucial to make it work. From that, I was able to create a working XML file in the local_manifests folder of the source code.

From reading that, my final local_manifest XML file looked like this:

(edit - Now I see a typo in sabarop's github address, which explains why those files didn't sync. Oh well, next time...)

<?xml version="1.0" encoding="UTF-8"?>
    <remote name="lineageos"
            fetch="https://github.com/LineageOS/" />

    <remote name="sdm660"
            fetch="https://github.com/xiaomi-sdm660/" />

    <remote name="rcstar6696"
            fetch="https://github.com/rcstar6696/" />

    <remote name="crdroidandroid"
            fetch="https://github.com/crdroidandroid/" />
    <remote name="sabraop"
            fetch="https://github.com/sabraop/" />

    <project name="android_build_scripts" path="build/scripts" remote="sdm660" revision="lineage-17.0">
        <linkfile src="buildxiaomi.sh" dest="buildxiaomi.sh" />
        <linkfile src="buildxiaomi_kernel.sh" dest="buildxiaomi_kernel.sh" />
        <linkfile src="sync.sh" dest="sync.sh" />
        <linkfile src="buildmodule.sh" dest="buildmodule.sh" />

  <!-- Xiaomi Mi Pad 4 (clover) -->
    <project name="android_device_xiaomi_clover" path="device/xiaomi/clover" remote="sdm660" revision="lineage-17.1" />
    <project name="android_device_xiaomi_sdm660-common" path="device/xiaomi/sdm660-common" remote="sdm660" revision="cr-8.0-hmp" />
    <project name="android_kernel_xiaomi_clover" path="kernel/xiaomi/clover" remote="sdm660" revision="kernel.lnx.4.4.r38-rel-wifi" />
    <project name="android_kernel_xiaomi_sdm660" path="kernel/xiaomi/sdm660" remote="sdm660" revision="master" />
    <project name="android_vendor_xiaomi_clover" path="vendor/xiaomi/clover" remote="sdm660" revision="master" />
    <project name="android_vendor_xiaomi_sdm660-common" path="vendor/xiaomi/sdm660-common" remote="sdm660" revision="cr-8.0-hmp" />
    <project name="android_vendor_xiaomi_MiuiCamera" path="vendor/xiaomi/MiuiCamera" remote="sdm660" revision="master" />

  <!--    Fixes "make[1]: clang: Command not found" kernel build failure  -->
    <project path="prebuilts/clang/host/linux-x86/clang-r377782c" name="android_prebuilts_clang_host_linux-x86_clang-6305083" groups="pdk" clone-depth="1" remote="crdroidandroid" revision="10.0"/>
Many thanks for this info. Bumped build till December security patches. If someone need new build please let me know, i'll upload then.
  • Like
Reactions: pnin


Oct 1, 2010


  • Screenshot_20211228-222936_Settings.png
    124.8 KB · Views: 186
Last edited:
  • Like
Reactions: jason605


New member
Jan 1, 2022
Hello, how can I get the cts profile working?

TWRP installed
Magsik is installed
Lineage 17.1 installed
Bootloader open
MI Pad 4 Plus China Version

All works fine but I can't find Netflix in the Play Store and the Magisk internal check fails.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 73

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    This Rom works on MI PAD 4 or MI PAD 4 PLUS​


    1. Download ROM, Gapps, TWRP recovery.
    2. Flash TWRP Recovery via fastboot (fastboot flash recovery pathTo/recovery.img)
    3. Boot into Recovery
    4. Format System, Data and wipe Dalvik, Cache from recovery (Wipe Option).
    5. Flash Lineage zip.
    6. Flash Gapps zip.
    7. Reboot.

    6.2 Root: Download Magisk & flash Magisk zip via Recovery

    Downloads :
    Recommand TWRP
    TWRP with ability to decrypt /data/ partition (origin)

    Clover Builds (by S-trace)
    lineage-17.1-20200512-UNOFFICIAL-clover.zip - Current release.

    Gapps (use open_gapps-arm64-10.0 versions only)

    Known Issues:
    * nothing

    • OTA:
      OTA support has been added in lineage-17.1-20200406-UNOFFICIAL-clover build.
      Any test reports are greatly appreciated.
    • OTA+Magisk+encryption:
      If your device is encrypted and you are using Magisk - please use TWRP with encryption support (above) and install downloaded by OTA updater ZIP manually after reboot into TWRP, or reflash Magisk ZIP after update (reboot to TWRP, decrypt /data/ and then flash Magisk).
    • SafetyNet:
      To pass SafetyNet ctsProfile enable Magisk Hide in Magisk Manager and wipe Play Store data.
    • Legal questions about the state of this project:
      rcstar6696, the original developer of this ROM have abandoned it for a while after the build 20200106 , and I (S-trace) built a new build of this ROM, and then I fixed an issue with WLAN Tethering offload on encrypted devices (rcstar6696 don't support the device encryption, but don't forbid the encryption completely), and then I got the invite from rcstar6696 to the xiaomi-sdm660 team to maintain the LineageOS for the clover (rcstar6696 supports several Xiaomi SDM660 devices, not only clover). Then I got the piracy attack from LR-user but rcstar6696 responded to this attack and confirmed me as the new LineageOS maintainer for clover because he simply not have the time to maintain 3 ROMs and transferred this project to me.
      I'm too don't have much time to develop the LineageOS for clover, so I just merge the cr-8.0 branch to lineage-17.1 branch and build the ROM, install it to my clover tablet (LTE-4GB-8" model) and quickly test it, and (if no problems were detected) upload it and post it here and release the ROM as an OTA update. So, please also thank rcstar6696 for this ROM, because I don't develop it very much but just maintain it using rcstar6696 original development for cr-8.0 ROM.

    Changes (full changelog):
    • May Security Patch
    • Switched to cr-8.0-eas common vendor tree
    • Android updated to 10.0.0_r35
    • Kernel updated to 4.4.223
    • Blobs updated to LA.UM.8.2.r1-06500-sdm660.0
    • Misc LineageOS fixes and updates

    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    XDA:DevDB Information
    [ROM][BETA][10.x] LineageOS 17.1 [clover / MiPad4/ MiPad4 Plus], ROM for the Xiaomi Mi Pad 4

    rcstar6696, S-trace
    Source Code: https://github.com/xiaomi-sdm660

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x
    Based On: Lineage

    Version Information
    Status: Beta
    Current Beta Version: 17.1-20200512
    Beta Release Date: 2020-05-12

    Created 2019-10-23
    Last Updated 2020-07-20
    ##### Android 10 Beta Lineage Build #####

    Xiaomi Mi Pad 4 (clover) Update 06-01-2020

    Maintainer: @rcstar6696

    Device Changelog:
    • Updated Kernel to 4.4.208
    • December Security Patch
    • Bring inline with Xiaomi sdm660 Source (Same Base as CarbonRom)
    • Minor Improvements and Cleanup

    Download Link: https://mega.nz/#!rB5kSabC!7ScCYVTyRcJvW6icCu3MJ6zZcsvoQ5Xg0v-ptTpalhQ

    Recommand TWRP: https://mega.nz/#!CQQRwSAL!VX34bYDiiZCfYAIE03ZhIfkhxyx7-fb1wm1rI6abVek

    The Build contains no Gapps. Gapps have be installed again.

    Clean Flash needed from Lineage 17.0 no update possible
    ##### Android 10 Beta Lineage Build #####

    Xiaomi Mi Pad 4 (clover) Update 29-11-2019

    Maintainer: @rcstar6696

    Device Changelog:
    • Updated Kernel to 4.4.205
    • November Security Patch
    • Bring inline with Xiaomi sdm660 Source (Same Base as CarbonRom)
    • Minor Improvements and Cleanup

    Download Link: https://mega.nz/#!nNJznQIL!8tnPSb8zadjCg6xGQcucOWkOMFNM0IAccpchmtgwBfg

    Recommand TWRP: https://mega.nz/#!CQQRwSAL!VX34bYDiiZCfYAIE03ZhIfkhxyx7-fb1wm1rI6abVek

    Only Magisk higher than 19.5 supported

    Note: Don't except that everything is working smooth and perfect. All is Work in Progess. Keep that in mind and not officialy released by Lineage

    The Build contains no Gapps. Gapps have be installed again.
    ##### Android 10 Beta Lineage Build #####

    Xiaomi Mi PAD 4 (clover) Update 01-11-2019

    Maintainer: @rcstar6696

    Device Changelog:
    • Updated Kernel to last CAF Release
    • Updated Wifi Driver to last CAF Release
    • Updated Qcom Configs from LA.UM.8.2.r1-04800
    • Unified some Vendor Blobs
    • Updated Kernel to 4.4.198
    • Fixed Ui Lag after some days
    • Added Snapcamera
    • Updated Round Corner Configuration
    • Set default Wifi country code (5Ghz for all)
    • Fixed Encyrption
    • Minor Improvements and Cleanup

    Download Link: https://mega.nz/#!eRInXaYR!CxbXcS9cmydh7I7t3JCLd7CDStBFQWPuLlwoOZKx03U

    Recommand TWRP: https://mega.nz/#!CQQRwSAL!VX34bYDiiZCfYAIE03ZhIfkhxyx7-fb1wm1rI6abVek

    Only Magisk higher than 19.5 supported

    Note: Don't except that everything is working smooth and perfect. All is Work in Progess. Keep that in mind and not officialy released by Lineage

    The Build contains no Gapps. Gapps have be installed again.
    Kernel WiFi Speed fix for all 10 Roms

    It restores pie Wifi driver and upstreams kernel to newest Release