[ROM][BETA][UNOFFICIAL] LineageOS 17.1 for Galaxy A70

Search This thread


Senior Member
Jan 12, 2011
One love for the energy put into the echoing problem.

How can you readers and users of lineage and a70 be using this combination in real life??

I hang up and call my callers back every time the phone rings.

This problem should be mentioned in OP. I tried taking the configuration files from the stock rom and had no success.

Yes, that was the major bummer for me too, so I switched back to stock 10 and debloated it.

haky 86

Recognized Contributor
Oct 5, 2012
Hama (Syria)
LineageOS 17.1 for Galaxy A70

* Download link via telegram channel https://t.me/Haky86Dev/
* Enhance FOD compatibility to be used on OneUI 2 vendor too.
* Security Patches: November 2020.
* Credits: Grarak for his trees.

I can do some roms tho if the community want it(until I fix enforcing).


Senior Member
Nov 13, 2012
FOD works?
If I'm on BTJ4 can I install it?
Installation instructions?
Must wipe vendor?
What with GAPPS?


Mar 10, 2020

Broken mouse?

Skip to content
Android ROMs Maker


OneUI Android Custom ROMs Home Page
Welcome to OneUI 1.1/2.0 Custom ROMs developments. In this page you can download the latest mod for your device, so let’s see the requirements.

Contents hide
1 OneUI Home Page
1.1 Requirement
1.2 Installation Guide
2 Android 10.0
2.1 LineageOS 17.1
OneUI Home Page
Unlocked device.
At the moment, you have to be on 1.1 version based on Android 9.0 Pie vendor.
Grarak’s TWRP.
Installation Guide
Reboot into TWRP.
Make sure to backup your data (I’m not responsible for any brick)
Tab on Wipe.
Select Cache, System, Vendor and Data.
Swipe to wipe.
Tab on Install.
Select ROM’s path.
Swipe to Flash.
Same steps for GAPPS too.
Android 10.0
LineageOS 17.1
SPL: October 2020.
Bugs: same as older builds.
SPL: November 2020.
Fix hal_audio_default denial.
Fix hal_bluetooth_default denial.
Update fingerprint build to A705FNXXU5BTH4 based on Q’s 2.0.
Update /vendor/firmware from A705FNXXU5BTH4 to use FOD on Q vendor too.
Haky86 Developments Channel

-HI6250 Downloads


-Telegram Channel.


Copyright © 2020 Haky86. Powered by WordPress. Theme: Spacious by ThemeGrill.
  • Haha
Reactions: DroidGTV


Senior Member
Nov 13, 2012
I think you have no idea what I asked and that is why you used copy / paste.
In recent versions of LOS FOD did not work and you must stay with the stock Vendor because the one from LOS was causing problems.
In addition, after installing the rom, you need flash dm-verify in TWRP.
I suggest you study first and then answer the questions :)


Senior Member
Apr 27, 2017
Cebu City
LineageOS 17.1 for Galaxy A70

* Download link via telegram channel https://t.me/Haky86Dev/
* Enhance FOD compatibility to be used on OneUI 2 vendor too.
* Security Patches: November 2020.
* Credits: Grarak for his trees.

I can do some roms tho if the community want it(until I fix enforcing).

Booted & FOD works?
Anyway, thanks so much tho.

Besides FOD, is camera working too?

haky 86

Recognized Contributor
Oct 5, 2012
Hama (Syria)


  • Screenshot_20201110-130611_Settings.png
    105.5 KB · Views: 135
  • Like
Reactions: witampanstwa_


New member
Nov 26, 2014
same as previous builds.
about fod yes it's working, at least on my variant (A705FN)

Hi Haky

I flashed it on mine (A705MN) and it boots, but WiFi and Mobile Data Is not working
Bluetooth and Camera is fine!
FOD works too

This are my logs
Thanks for making this build!

drive. google. com /file/d/1DMIzjkvn2md7xZcScCzLofO74h5tilYj/view?usp=sharing
I cant post outside Links bear with me please uwu
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 33

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.


    Everything, but
    Known issues
    • Selinux permissive
    • VoLTE/VoWifi not working
    • Camera only shows up to 8MP
    • NFC is enabled on all models, even on the ones without it (please report device model)
    • Dualsim is enabled on all models, even on the ones without it (please report device model)
    • Screen flickering when using fingerprint (That's normal and how optical fingerprint sensors work. Flickering doesn't happen on stock I know, but that's due to poor UI implement from lineage site)
    • TWRP can't decrypt your data

    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Firmware version:
    Model number:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:


    Additional patches


    XDA:DevDB Information
    LineageOS 17.1, ROM for the Samsung Galaxy A70

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x

    Version Information
    Status: Beta

    Created 2019-10-23
    Last Updated 2020-02-13
    here is the proper way to install twrp ,los 17, gapps and magisk. ill provide links at end of post to make it easier. Many thanks to the dev @Grarak. Without his work, we would be without.. Note: you still can not backup\restore data but internal storage is decrypted. Also, Its the second formatting of data after setup that's getting decryption going *If you want faster access to enable wifi, pull your sim before this procedure. **You don't have to use wifi although I recommend it. You do need some kind of access to the internet. If you don't, knox will not let you flash and you could soft brick your device.

    1. get the latest Android 9 Baseband/bootloader for your model using samfirm and flash using odin. setup device using wifi and enable dev options. make sure oem unlocking is on and grayed out saying the bootloader is already unlocked. shut down the device.
    2. Hold both vol+ and vol- and plug into pc. hit vol+ on the next screen to enter download mode. flash twrp 3.3.1-6. when pass, hold vol- and power till device screen goes blank then immediately hold vol+ and vol- to boot back into download mode.
    3. when your back in download mode, flash vbmeta. when pass, hold vol- and power till screen blank then immediately hold vol+ to boot to twrp.
    4. click on settings and uncheck prompt to install twrp. go back. click on mount and make sure mount system partition read-only is unchecked
    5. copy Los 17 20200213, open-gapps nano 20200127 (optional), and magisk 20.3 to external sd card.
    6. Back in twrp, click wipe, advanced wipe and check ALL except micro sd card and usb otg. Slide right to confirm. DO NOT REBOOT. click back and click install.
    7. click select storage and select micro sd card. click on los 17 then click add more zips. then click gapps nano (optional). swipe right to confirm.
    8. once complete, go back and click wipe then click format data. type yes and enter. now reboot to system and wait.
    9. setup wifi and skip the rest. enable dev options and select advanced restart. hold power and select restart then restart to recovery.
    10. in twrp click wipe and format data, type yes and enter. then reboot back to recovery. internal storage should now be decrypted.
    11. reboot to system and setup your device normaly. reboot back to recovery and flash magisk 20.3 and reboot to system. you should now have magisk in your app drawer, update it.


    • Can I use this ROM to boot other GSIs?
      You can but I won't provide any support. If you are stuck in a bootloop or something does not work, you have to look for a fix yourself. Here is a list of things that will probably be broken when using a GSI:
      • Fingerprint
    • Fingerprint doesn't work anymore after flashing a new build/installing magisk/etc.!
      Redo your fingerprints.
    • I can't enroll any fingerprints!
      Turn off night mode/lower night mode intensity.
    New release


    I understand that. some are saying to install 20191025 build first then dirty flash over and will work but I cant get the 20191025 to download fully. Its okay as im not in a hurry. I played around with it so much I ended up wiping out the download mode. I wiped everything and rebooted, twrp wouldn't boot so i installed just vendor from stock and that did not work. took me to a screen that said there was an error updating your device and must use smart switch emergency repair. smart switch couldn't do anything with it so i thought i was screwed but i said lets see what happens if i just flash stock even though i was not on a bootloader screen and it worked. apparently it was a bootloader screen, just not one that looked like one. back on 16 from backup. 16 has a few bugs but nothing major and is very stable.

    I am wondering however if the dev is still working on 16 and 17 or just 17 now? @Grarak

    I have limited time, so I will only update lineage 17 for now