[ROM] CM9 for s7 model-105 by hal version-53

Search This thread

hal_2000

Senior Member
Oct 16, 2012
74
31
Hi all, after a great effort and lot of work finally i got cm9 compile from source working in my s7 model 105.
this is a more stable version it still has some bugs that i'm trying to solve, help is welcome.
I used kernel from jotamj from another forum and i use asturel device files to get it started, asturel files is for the slim so i had to made some changes in the files, thanks to them.
For a long time i hope for a update from huawei but notthing came, people at huawei suck, they dont give any suport to there clients, so i and other had to do it in order to have cm9 or cm10 in huawei s7.

this work on:
my s7 model=105, it may work on 104 and in 106, probably will not work on s7 slim

what works:
-wifi
-bluetooth
-audio
-gps
-google play (solve, install gaps file)
-streaming (must install flash player 11)

do not work:
-camera
-usb mount on pc

how to install:
first do a backup, IMPORTANT , backup first ( in case same thing go wrong)
copy file zip to sdcard
boot on cwm and install zip file
reboot and wait 4 to 5 minutes, if anything goes wrong restore from backup.

version 53 (more stable)
link: https://docs.google.com/file/d/0B9OIKoN0knUtSGNfVWpOSjBqNEE/edit?usp=sharing

to solve google play install gaps
link: https://docs.google.com/file/d/0B9OIKoN0knUtUTdSQUpERHhfYTg/edit?usp=sharing

help is welcome,
install on your device, test what work and what does not, google for solutions on the bugs you find, post solution here, i will aplly it to the next version, that way we can have a cm9 working 100% in very little time
in the case you can post, write a message to me.

edit


edit


edit


to do next:
-correct google play (solved)
-camera

test it
hal_2000
 

Attachments

  • Screenshot_2013-02-11-18-38-19.jpg
    Screenshot_2013-02-11-18-38-19.jpg
    17.8 KB · Views: 1,704
  • Screenshot_2013-02-11-18-38-36.jpg
    Screenshot_2013-02-11-18-38-36.jpg
    23.2 KB · Views: 1,689
  • Screenshot_2013-02-11-18-38-56.jpg
    Screenshot_2013-02-11-18-38-56.jpg
    24.4 KB · Views: 1,940
Last edited:

xaueious

Senior Member
Dec 17, 2009
980
176
Toronto
Huawei isn't to blame I think. I don't think there are many QSD8250 devices that made it past Gingerbread. Acer (Liquid, Liquid E) and HTC (Desire) left their devices on Froyo. Dell (Streak 5) moved up to Gingerbread.

I have given my S7 away to a family member and won't be changing the firmware, but thanks for putting this together.


That's a weird looking ro.build.fingerprint you have there. Fix in cm.mk for build. Play Store also freaks out if you have a date too far from the present.
 
Last edited:
  • Like
Reactions: Zayar Htut

hal_2000

Senior Member
Oct 16, 2012
74
31
Huawei isn't to blame I think. I don't think there are many QSD8250 devices that made it past Gingerbread. Acer (Liquid, Liquid E) and HTC (Desire) left their devices on Froyo. Dell (Streak 5) moved up to Gingerbread.

I have given my S7 away to a family member and won't be changing the firmware, but thanks for putting this together.


That's a weird looking ro.build.fingerprint you have there. Fix in cm.mk for build. Play Store also freaks out if you have a date too far from the present.

Hi xaueious, when i bought my s7 it came with android 2.1, some time after huawei lunch android 2.2 for asia, i had to wait for a suedish user to hack it and lunch it for europe, they could lunch android 2.3 but they where not interest, that why i said huawei suck, other manufactures realeases updates for they clients, but not huawei.

the fingerprint of the build has to do with the system i came up with to test things, i started with asturel base devices files but that is for the slim, so i had to test what option worked or not, it took dozens of test and tries, to get it to work.
i got the google play problem solve, see post 1, and streaming to :D

I'm close to get a 100% working rom.
test it if you can, and help me solve the bugs if you find any, enjoy.

hal_2000
 
  • Like
Reactions: dodiandria

grka

Member
Apr 8, 2011
34
6
I installed your rom on my s7-105 but now it's not starting proper anymore. I see the word ANDROID and I can hear a small click every second but nothing more... what's wrong?

---------- Post added at 04:07 PM ---------- Previous post was at 03:53 PM ----------

After a re-boot I get the message "Update failed! Please retry!" No matter which key combination I try (vol+ & power, menue&green&power, oder vol+&vol-&power) this is all that I get!!!!!!! HELP PLEASE!!! What can I do now?????? How can I get back into CWM to reinstall a rom??????

after some try & error I found out that with the key combination back&red key & power I can make the device to boot, I see the words Ideos and later android again but that's all. It's not going on. I have no idea how I can install an older rom now....
 
Last edited:
  • Like
Reactions: dodiandria

xaueious

Senior Member
Dec 17, 2009
980
176
Toronto
I installed your rom on my s7-105 but now it's not starting proper anymore. I see the word ANDROID and I can hear a small click every second but nothing more... what's wrong?

---------- Post added at 04:07 PM ---------- Previous post was at 03:53 PM ----------

After a re-boot I get the message "Update failed! Please retry!" No matter which key combination I try (vol+ & power, menue&green&power, oder vol+&vol-&power) this is all that I get!!!!!!! HELP PLEASE!!! What can I do now?????? How can I get back into CWM to reinstall a rom??????

after some try & error I found out that with the key combination back&red key & power I can make the device to boot, I see the words Ideos and later android again but that's all. It's not going on. I have no idea how I can install an older rom now....



Sounds like a boot loop. What ROM did you come from? You should be coming from Android 2.2, not 2.1.

Here's a list of stock firmware to use: http://johnnyparanoia.blogspot.co.uk/2012/04/huawei-s7-tablet-firmware-list.html

Install procedure for stock: http://www.androidtablets.net/forum...d-2-2-2-dual-camera-s7-s7v100r001c98b021.html
 
  • Like
Reactions: dodiandria

grka

Member
Apr 8, 2011
34
6
Sounds like a boot loop. What ROM did you come from? You should be coming from Android 2.2, not 2.1.

Here's a list of stock firmware to use: http://johnnyparanoia.blogspot.co.uk/2012/04/huawei-s7-tablet-firmware-list.html

Install procedure for stock: http://www.androidtablets.net/forum...d-2-2-2-dual-camera-s7-s7v100r001c98b021.html
To be honest, I can't say it for sure which one I had. In the status menue it said "2.1 update 1" Whatever this means. I had problems to install the clockworkmod I finally found this ROM: rom tri_zet. With that I could install clockworkmod and reboot the tablet into recovery mode. Then I installed this rom here and run into the problem.

Last night I finally managed to install the official swedish ROM 2.2.2. With that my tablet is running again.

Do you think with that one I could make another try to install this rom now? How can I install the clockworkmode now? Maybe the tri_zet rom was the cause of the problem...
 
  • Like
Reactions: dodiandria

hal_2000

Senior Member
Oct 16, 2012
74
31
To be honest, I can't say it for sure which one I had. In the status menue it said "2.1 update 1" Whatever this means. I had problems to install the clockworkmod I finally found this ROM: rom tri_zet. With that I could install clockworkmod and reboot the tablet into recovery mode. Then I installed this rom here and run into the problem.

Last night I finally managed to install the official swedish ROM 2.2.2. With that my tablet is running again.

Do you think with that one I could make another try to install this rom now? How can I install the clockworkmode now? Maybe the tri_zet rom was the cause of the problem...

Hi grka, i tryed tri_zet but i didnt liked so i used the swedish ROM 2.2.2 until recently.
My advice install cwm 6.0.1, backup and then when install, clear cache and data, then intall my rom it should work :)
If you get problems again restore from bacup.
1º install the rom, let it boot, after sucessul boot install gaps to make goople play work.

If you need more help ask.
hal_2000
 
  • Like
Reactions: dodiandria

grka

Member
Apr 8, 2011
34
6
Hi grka, i tryed tri_zet but i didnt liked so i used the swedish ROM 2.2.2 until recently.
My advice install cwm 6.0.1, backup and then when install, clear cache and data, then intall my rom it should work :)
If you get problems again restore from bacup.
1º install the rom, let it boot, after sucessul boot install gaps to make goople play work.

If you need more help ask.
hal_2000

Can you please tell me where to download cwm 6.0.1 and how to install it? I spend some hours with downloading different files and trying to install them without success.
 
  • Like
Reactions: dodiandria

hal_2000

Senior Member
Oct 16, 2012
74
31
Can you please tell me where to download cwm 6.0.1 and how to install it? I spend some hours with downloading different files and trying to install them without success.

Hi, follow this steps:
1-boot in fastboot, with device power down, click vol up+home+power , fastboot apears in screen
2-connect s7 to pc
3-extract the zip file
4-in a dos text console inside the dir where are the files execute: "fastboot flash recovery s7-recovery-v601.img"
5-to reboot "fastboot reboot"

to go to cwm, with device power down, menu+call (green key) + power on
this commands work in a windows xp, never tryied in win 7 or 8.

More help ask,
hal_2000
 

Attachments

  • s7-recovery-v601.zip
    4.9 MB · Views: 1,048
Last edited:
  • Like
Reactions: dodiandria

threader

Senior Member
May 31, 2010
213
136
I think there is a flag to make the userdata ext4 , but do not make it ext2! It is prone to dataloss if not unmounted properly, it is better to compile in ext3 and 4 support in to the kernel. But i believe if im not mistaken i have seen options to make ext images in the codeaurora sources
 

xaueious

Senior Member
Dec 17, 2009
980
176
Toronto
Under BoardConfig.mk, TARGET_USERIMAGES_USE_EXT4

Relevant: https://groups.google.com/forum/?fromgroups=#!topic/android-building/wdV3GIe_XC4


The update.zip should be sufficient for most users. Shouldn't need to provide fastboot images.

build/core/Makefile contains the rules to generate the boot, userdata,
and system images. The choice of file system for the two latter is
determined by the setting of the TARGET_USERIMAGES_USE_EXT[234]
variables, so to get ext4 for your system and userdata images you can
say

TARGET_USERIMAGES_USE_EXT4 := true

in e.g. BoardConfig.mk.

For the usb mount, I don't really know how to fix this at all, but the is the Acer Liquid similar? https://github.com/thepasto/liquidCM_devicetree/blob/master/acer/liquid/BoardConfig.mk

BOARD_USE_USB_MASS_STORAGE_SWITCH := true
TARGET_USE_CUSTOM_LUN_FILE_PATH := "/sys/devices/platform/msm_hsusb/gadget/lun"


(lun path needs to be fixed to match S7. I remember changing this when I kanged recovery)
 
Last edited:

xaueious

Senior Member
Dec 17, 2009
980
176
Toronto
Under BoardConfig.mk, TARGET_USERIMAGES_USE_EXT4

Hi xaueious, thanks for those tips, always learning :D in this forum.

One question, is there a manual where i can learn about all the options of config files in cm9 or cm7 ?

hal_2000

I'm not an expert at CM. I just worked on building one very specific platform and know where some files are... But from what I know...

For Android platform: http://elinux.org/Android_Build_System and https://android.googlesource.com/platform/build/+/master/core/build-system.html

If you modify specific packages, mm and mmm are nice tools to use. For building, make otapackage does a lot more crap than just making the target images (make bootimage, make systemimage). Enabling CCACHE is supposed to help with build speed too. Also consider stripping the unnecessary languages during development, and stuff builds a lot faster (PRODUCT_LOCALE flag), because a ton of time is spent building together strings.

Originally build options are mostly in /build/. CM has some new options in there, but I am not sure if they add new ones elsewhere. Other things to pay attention to are the .prop options that CM has added. Those things are littered all over and don't have documentation, but at least git commits are easy to follow.
 
Last edited:

hal_2000

Senior Member
Oct 16, 2012
74
31
Hi, thank you,
Just in case someone else as same question, TARGET_USERIMAGES_USE_EXT4 in cm9 only acepts ext4 no ext2 or ext3, i tryied all tree options.
Great tips, as always thank for taking the time to anser my questions.

hal_2000
 

hal_2000

Senior Member
Oct 16, 2012
74
31
Just installed on my S7 107 Australian version. Excellent work hal_2000. I think after install your rom , i hear some times a crackling sound.
Waiting for a fix for camera :)

Hi, kosmasgr, the audio same times gives a click, is a little bug, the device source i used is from asturel and his files are for the slim version, i'm trying to fix the camera its more critical then the audio bug.

enjoy cm9.
hal_2000
 

goodoane

Senior Member
Jul 22, 2007
369
183
The click is a problem from kernel that Huawei provided for 2.2.2. Kernel source is generic for both version fat and slim.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Hi all, after a great effort and lot of work finally i got cm9 compile from source working in my s7 model 105.
    this is a more stable version it still has some bugs that i'm trying to solve, help is welcome.
    I used kernel from jotamj from another forum and i use asturel device files to get it started, asturel files is for the slim so i had to made some changes in the files, thanks to them.
    For a long time i hope for a update from huawei but notthing came, people at huawei suck, they dont give any suport to there clients, so i and other had to do it in order to have cm9 or cm10 in huawei s7.

    this work on:
    my s7 model=105, it may work on 104 and in 106, probably will not work on s7 slim

    what works:
    -wifi
    -bluetooth
    -audio
    -gps
    -google play (solve, install gaps file)
    -streaming (must install flash player 11)

    do not work:
    -camera
    -usb mount on pc

    how to install:
    first do a backup, IMPORTANT , backup first ( in case same thing go wrong)
    copy file zip to sdcard
    boot on cwm and install zip file
    reboot and wait 4 to 5 minutes, if anything goes wrong restore from backup.

    version 53 (more stable)
    link: https://docs.google.com/file/d/0B9OIKoN0knUtSGNfVWpOSjBqNEE/edit?usp=sharing

    to solve google play install gaps
    link: https://docs.google.com/file/d/0B9OIKoN0knUtUTdSQUpERHhfYTg/edit?usp=sharing

    help is welcome,
    install on your device, test what work and what does not, google for solutions on the bugs you find, post solution here, i will aplly it to the next version, that way we can have a cm9 working 100% in very little time
    in the case you can post, write a message to me.

    edit


    edit


    edit


    to do next:
    -correct google play (solved)
    -camera

    test it
    hal_2000
    1
    Huawei isn't to blame I think. I don't think there are many QSD8250 devices that made it past Gingerbread. Acer (Liquid, Liquid E) and HTC (Desire) left their devices on Froyo. Dell (Streak 5) moved up to Gingerbread.

    I have given my S7 away to a family member and won't be changing the firmware, but thanks for putting this together.


    That's a weird looking ro.build.fingerprint you have there. Fix in cm.mk for build. Play Store also freaks out if you have a date too far from the present.
    1
    Huawei isn't to blame I think. I don't think there are many QSD8250 devices that made it past Gingerbread. Acer (Liquid, Liquid E) and HTC (Desire) left their devices on Froyo. Dell (Streak 5) moved up to Gingerbread.

    I have given my S7 away to a family member and won't be changing the firmware, but thanks for putting this together.


    That's a weird looking ro.build.fingerprint you have there. Fix in cm.mk for build. Play Store also freaks out if you have a date too far from the present.

    Hi xaueious, when i bought my s7 it came with android 2.1, some time after huawei lunch android 2.2 for asia, i had to wait for a suedish user to hack it and lunch it for europe, they could lunch android 2.3 but they where not interest, that why i said huawei suck, other manufactures realeases updates for they clients, but not huawei.

    the fingerprint of the build has to do with the system i came up with to test things, i started with asturel base devices files but that is for the slim, so i had to test what option worked or not, it took dozens of test and tries, to get it to work.
    i got the google play problem solve, see post 1, and streaming to :D

    I'm close to get a 100% working rom.
    test it if you can, and help me solve the bugs if you find any, enjoy.

    hal_2000
    1
    I installed your rom on my s7-105 but now it's not starting proper anymore. I see the word ANDROID and I can hear a small click every second but nothing more... what's wrong?

    ---------- Post added at 04:07 PM ---------- Previous post was at 03:53 PM ----------

    After a re-boot I get the message "Update failed! Please retry!" No matter which key combination I try (vol+ & power, menue&green&power, oder vol+&vol-&power) this is all that I get!!!!!!! HELP PLEASE!!! What can I do now?????? How can I get back into CWM to reinstall a rom??????

    after some try & error I found out that with the key combination back&red key & power I can make the device to boot, I see the words Ideos and later android again but that's all. It's not going on. I have no idea how I can install an older rom now....
    1
    I installed your rom on my s7-105 but now it's not starting proper anymore. I see the word ANDROID and I can hear a small click every second but nothing more... what's wrong?

    ---------- Post added at 04:07 PM ---------- Previous post was at 03:53 PM ----------

    After a re-boot I get the message "Update failed! Please retry!" No matter which key combination I try (vol+ & power, menue&green&power, oder vol+&vol-&power) this is all that I get!!!!!!! HELP PLEASE!!! What can I do now?????? How can I get back into CWM to reinstall a rom??????

    after some try & error I found out that with the key combination back&red key & power I can make the device to boot, I see the words Ideos and later android again but that's all. It's not going on. I have no idea how I can install an older rom now....



    Sounds like a boot loop. What ROM did you come from? You should be coming from Android 2.2, not 2.1.

    Here's a list of stock firmware to use: http://johnnyparanoia.blogspot.co.uk/2012/04/huawei-s7-tablet-firmware-list.html

    Install procedure for stock: http://www.androidtablets.net/forum...d-2-2-2-dual-camera-s7-s7v100r001c98b021.html