• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM] CyanogenMod - Scary experimental builds! [UPDATED 6/30 - v3.5.3]

Status
Not open for further replies.
Search This thread

tissle

Senior Member
Dec 9, 2007
170
3
Maybe Bug:


When I try to hook up my phone to my Car Stereo via USB or Computer vis USB..
it just don't mount the first time. It takes couple of unplugging and replugging.
 

xdothenderson

Member
Jun 13, 2009
47
0
seemed to speed it up a bit faster boot & the auto-rotate flips in less than a second now.

the swap is still at 0 0 0 i also still have 56 mb, everything is running smooth if the swap is activated will my mb change?
 

Chedderknight

Senior Member
Nov 20, 2008
151
9
Los Angeles
updated from 3.4.6 last night, very pleased at the speed increase, I didnt realize how much faster it could get from 3.4.6., v3.5.3 even fixed my usb issue, comp recognizes the phone and is mountable now

Edit: I forgot to mention that streetview doesn't work, I dunno if it is the App itself or the build, doesn't bother me, just something worth noting.
 
Last edited:

JanetPanic

Senior Member
Oct 17, 2005
595
50
Rockville, MD
If you copy /system/lib/liba2dp.so from a previous release, does it work?

Known bug, will be fixed in the next version. Grab /system/lib/libsgl.so from a previous version, push it to your device, reboot, and it will work.

replacing libsgl.so with the previous version fixed copilot and PDF Viewer.

replacing liba2dp.so fixed AVRCP.

So it appears that everything is working now. Thanks again for all your hard work.
 

yomamaster

Member
Jun 9, 2009
26
0
3.5.3 issues

I did a no-wipe upgrade from 3.5.2 to 3.5.3. I noticed a few interesting quirks:

1. My orientation setting is now honored. I had it turned off and rotating my phone physically no longer also rotated the screen. I turned the setting back on and it worked normally. Prior to to 3.5.3, it didn't work.

2. It is a bit laggy compared to 3.5.2 although it hasn't caused it to be unusable.

3. Applying the Hero theme made it super laggy and broke Swapper. Swapper would Force Close and when I tried to load it back up, it would just hang.

4. The battery meter (without the Hero theme applied) always shows 100%.

I think I'm going to downgrade to 3.5.2. It was working pretty well for me!

I am also wondering...there any good scripts that will rebuild the screens, properly install apps, etc. after a wipe? It seems a wipe is necessary for some of the upgrades, but it also means setting up Gmail all over again, setting up screens, all over again, etc.
 

xdothenderson

Member
Jun 13, 2009
47
0
Did you create the linuxswap fs after the ext2/3/4?

when i type upgrade_fs:

/dev/block/mmcblk0p2 was not cleanly unmounted, check forced.

checks Pass 1-5

/dev/block/mmcblk0p2: 137/180848 files (29.2% non-contiguous), 63684/722925 blocks

i believe the phone is picking up an EXT3 but its not activating swap space yet.

EDIT: do i need the swapper apk?
 
Last edited:

prash

Senior Member
Feb 7, 2009
565
16
Philadelphia
I did a no-wipe upgrade from 3.5.2 to 3.5.3. I noticed a few interesting quirks:

1. My orientation setting is now honored. I had it turned off and rotating my phone physically no longer also rotated the screen. I turned the setting back on and it worked normally. Prior to to 3.5.3, it didn't work.

2. It is a bit laggy compared to 3.5.2 although it hasn't caused it to be unusable.

3. Applying the Hero theme made it super laggy and broke Swapper. Swapper would Force Close and when I tried to load it back up, it would just hang.

4. The battery meter (without the Hero theme applied) always shows 100%.

I think I'm going to downgrade to 3.5.2. It was working pretty well for me!

I am also wondering...there any good scripts that will rebuild the screens, properly install apps, etc. after a wipe? It seems a wipe is necessary for some of the upgrades, but it also means setting up Gmail all over again, setting up screens, all over again, etc.
You may want to look into "Backup for Root Users" in the market (free app) for backing up a LOT of the settings available to you if you do a lot of flashing of roms.

Also MyBackup app (not sure if the free version has it) has a choice to backup desktop shortcuts alone or with a lot of the other options on it. Check that out. Should be in your market.
 

nxt

Senior Member
Jun 5, 2006
2,052
396
Southern California
Samsung Galaxy S20
Edit: I forgot to mention that streetview doesn't work, I dunno if it is the App itself or the build, doesn't bother me, just something worth noting.

Street view works just fine.
It's the new google maps version 2.x
Street view is not in the menu Maps view anymore
You have to tap and hold somewhere on the map, wait for the "loading address" to pop up, tap that, then select Street View.
 

ScottGood

Senior Member
Feb 9, 2009
190
0
That's very interesting, my lockscreen battery was fine all day, it just now started saying 100% when all other data shows 60%

Edit : a simple reboot makes the lock screen show the proper battery level.
 
Last edited:

ubernicholi

Senior Member
May 6, 2009
346
8
arvada,co
madzorg.blogspot.com
when i type upgrade_fs:

/dev/block/mmcblk0p2 was not cleanly unmounted, check forced.

checks Pass 1-5

/dev/block/mmcblk0p2: 137/180848 files (29.2% non-contiguous), 63684/722925 blocks

i believe the phone is picking up an EXT3 but its not activating swap space yet.

EDIT: do i need the swapper apk?


mmcnlk0p2 is yout ext2/3/4 partition, for apps2sd. you need to add a lunixswap fs after that.

download gparted and shrink your ext partition by 24 mb, then use that space to create a linuxswap fs, and then format the linuxswap fs.

then use "mmcblk0p3"
that will be your swap partition. look on page 8 for more details,
 

Diceman4

Senior Member
Jun 9, 2009
445
4
St. Louis
No major problems.

For some reason though when I get an SMS, HandCent and SMS Popup both popup sms notifications.

I plan on uninstalling SMSPopup, but can I also uninstall the system Messaging apk? Or will that make me lose all SMS capability?

Thanks!

Edit: I uninstalled SMS Popup and the issue resolved. I think it had something to do with restoring my app settings with Backup for Root Users after my last wipe. (On a side note, Backup for Root Users REALLY takes the sting out of wiping)
 
Last edited:

YPhoto

Senior Member
May 28, 2009
63
8
Near Philly
Desktop Empty

I saw a post mentioning this, and the only solution was to reboot, reboot, reboot until it works. I know occasionally on rebooting my desktop comes back empty. This happened on 3.4.6 as well as my current install, 3.5.3. I really am not sure what to do to help troubleshoot the issue. I know others have seen the issue, but I do not think it was resolved. Just figured I would mention it. :)
 

Diceman4

Senior Member
Jun 9, 2009
445
4
St. Louis
I saw a post mentioning this, and the only solution was to reboot, reboot, reboot until it works. I know occasionally on rebooting my desktop comes back empty. This happened on 3.4.6 as well as my current install, 3.5.3. I really am not sure what to do to help troubleshoot the issue. I know others have seen the issue, but I do not think it was resolved. Just figured I would mention it. :)

I don't know if this is relevant information, but mine got fixed after I uninstalled Open Home.
 
Status
Not open for further replies.