{ROM-DEV} FrOyO-EVO

Search This thread

toastcfh

Retired Senior Recognized Developer
Feb 11, 2009
1,309
1,881
0
Lakeland, FL
This is mainly a proof of concept rom i cooked up for good measure of root. thanx goes to maejrep for his help and testing.

this rom was just a dirty kang of the Nexus One update from google. for the most part its usable. meaning most things work. the down fall are the thing that dont.

What works:
- basic android
- JIT of course
- A2SD google style
- data
- phone
- hw3d

What doesnt work: :rolleyes:
- cameras < i believe that it may be possible to fix at least the main cam. will work on this first
- mms < send can be fixed i know for sure. will come in next build
- 4G DATA < maejrep was working on this a bit. still not sure how 4G works just yet. i will look into it
- tethering < at the moment, its no dice

Info and the link:

FrOyO-EVO-test2
 
Last edited:

infamousjax

Senior Member
Mar 29, 2010
896
47
0
Atlanta
Really curious about how this performs... anyone done a linpack benchmark yet? Or Quadrant? Also, do the tethering features work?

Hell, if this runs just as good as it does with the N1 -- and all I'm sacrificing is the camera, and 4G (which is flaky here anyway) -- I might be running this on day one!
 
Last edited:

maejrep

Senior Member
Jun 25, 2007
248
69
0
Really curious about how this performs... anyone done a linpack benchmark yet? Or Quadrant? Also, do the tethering features work?

Hell, if this runs just as good as it does with the N1 -- and all I'm sacrificing is the camera, and 4G (which is flaky here anyway) -- I might be running this on day one!

Linpack got a 41, and sorry I don't remember what the Quadrant score was.

Oh right, tethering was the other thing that wasn't working... Toast should update his post :p
IIRC, the error was something to do with "softap", but I didn't spend a lot of time looking at it. I'll try to dive in to it this weekend to see if I can track it down
 
Last edited:

Tenny

Senior Member
Jul 10, 2007
688
27
58
37
Houston, TX
www.tenfpv.com
So, I did all the rooting / evo recovery stuff... and it seemed to be fine...

Did a wipe, then flashed this rom...

now it's got a picture of a phone and a Triangle with ! in the middle... I can get into the HTC recovery, but not sure how to get into the other recovery.
Any suggestions?

C:\AndroidSDK\tools>adb logcat
- waiting for device -
- exec '/system/bin/sh' failed: Permission denied (13) -


Got out of that "loop" by running the evo-recovery bat file, trying it again...

Same thing...
 
Last edited:

gators0223

Member
Jun 13, 2008
29
4
0
having problems... trying to see if it's me or not...

I'm having problems too. Seems the install likes to abort at line 36 for me. Still trying to figure it out.

Code:
Copying files...
E:Can't symlink /system/bin/reboot
E:Failure at line 36:
symlink toolbox SYSTEM:bin/reboot

Installation aborted.

Tried many different ways, including wiping everything and wiping nothing.

C:\AndroidSDK\tools>adb logcat
- waiting for device -
- exec '/system/bin/sh' failed: Permission denied (13) -

Getting that too. It only happens after an unsuccessful flash for me. A quick reboot back into recovery returns it back to normal though (through 'adb reboot recovery' then executing the script again)
 

maejrep

Senior Member
Jun 25, 2007
248
69
0
Heh, yeah I had that problem at first too.. I had to delete reboot from the update zip, and I told toast about it.

EDIT: toast has fixed the "reboot" error in update.zip.
 
Last edited:

toastcfh

Retired Senior Recognized Developer
Feb 11, 2009
1,309
1,881
0
Lakeland, FL
i fixed the sdcard. but yeah i forgot reboot, damn it i need a EVO :-/

flipz is fixing it on his server now. should be good in a few
 
Last edited:

gators0223

Member
Jun 13, 2008
29
4
0
If you're ambitious, you can just unzip, delete system/bin/reboot, and re-zip, then push it to sd card and flash it again.
x

Did that, removed all references to system/bin/reboot in the update-script as well (failed if I just removed the file) and flashed...

running froyo now!

Damn this thing is fast. You guys are amazing.
 

maejrep

Senior Member
Jun 25, 2007
248
69
0
Did that, removed all references to system/bin/reboot in the update-script as well (failed if I just removed the file) and flashed...

Whoa.. Did you do both? Cause that would mean you don't have a reboot option :) The problem with the update script is it has both a reboot file, AND a line in the update script to symlink the reboot file. You should only need to fix one or the other for it to work. If you removed both the file and the line, you would have no 'reboot'.
 

gators0223

Member
Jun 13, 2008
29
4
0
Whoa.. Did you do both? Cause that would mean you don't have a reboot option :) The problem with the update script is it has both a reboot file, AND a line in the update script to symlink the reboot file. You should only need to fix one or the other for it to work. If you removed both the file and the line, you would have no 'reboot'.

Haha...good call.

I was just kinda anxious to try it out. Didn't quite think that one through. :p
 

maejrep

Senior Member
Jun 25, 2007
248
69
0
nbd, you can fix it in recovery pretty easily, if you need to. Just symlink reboot to toolbox.. go back to the custom recovery, then:

Code:
$ adb shell

# mount /system
# cd /system/bin/
# ln -s toolbox reboot
done.