[ROM] [DEV STOPPED] JB AOSP 4.3 alpha 1

Search This thread

Ben36

Senior Member
Jun 8, 2012
8,258
2,868
253
flashed this rom last night, and all ben´s add ons... installed my apps.
all looking great!
but, just found out that 3g-mobile data didn´t work :eek:.
flashed the 96 baseband, didn´t help.

so went back to 4.1.2 pureslim.

did you wipe data etc?

all works fine here. maybe you need to set APN up?


Sent from my AOSP 4.3 Xperia S via Tapatalk
 

zaidx

Senior Member
Feb 23, 2013
600
94
0
ERBIL
definitely try again. this is the fastest smoothest rom for the xs no doubt!

Sent from my AOSP 4.3 Xperia S via Tapatalk

Yeah the fastest rom and subway surfers is not working so what's the point I want to play games you know

Sent from my LT26i using xda app-developers app
 

precardo

Senior Member
Jun 25, 2012
630
136
0
Yeah the fastest rom and subway surfers is not working so what's the point I want to play games you know

Sent from my LT26i using xda app-developers app

:DLMFAO:D kwaaaaaks.... Funny guy... U cracked me up man :) why dont you just try a different version of your game "subway suffers" ... I don't think it's the rom's fault though. Some game just ain't keeping up with Android 4.3
 

Ben36

Senior Member
Jun 8, 2012
8,258
2,868
253
i don't care about playing games I'd rather use an xbox or a tablet than a little phone screen

Sent from my AOSP 4.3 Xperia S via Tapatalk
 

red-Tequila

Senior Member
Nov 21, 2012
78
12
0
This rom is the fastest rom when using apps and searching for it,but when swipe to homescreen lag as hell

Sent from my LT26i using XDA Premium 4 mobile app
 

dreezz

Senior Member
Feb 24, 2011
660
122
0
flashed this rom last night, and all ben´s add ons... installed my apps.
all looking great!
but, just found out that 3g-mobile data didn´t work :eek:.
flashed the 96 baseband, didn´t help.

so went back to 4.1.2 pureslim.

Hmmm, just flashed this rom again, to see if something went wrong last time...

it seems that mobile data is working fine, but there is no sign showing it's active (H, or 3g) as i'm used to.
is it possible to make that visible?

edit: app that uses wifi to locate my phone is way off (500m) and Lenovo camera fc's (specially the gallery), also after claring data/data/lenovo

other than that, fast rom, looks great.
 
Last edited:

Ben36

Senior Member
Jun 8, 2012
8,258
2,868
253
i have the data symbol fine -

uploadfromtaptalk1380270594075.jpg

Sent from my AOSP 4.3 Xperia S via Tapatalk
 

dreezz

Senior Member
Feb 24, 2011
660
122
0
Weird things happening on my side then, Ben.
I only have the roaming 'r', nothing else.

Sent from my Xperia S using xda app-developers app
 

Ben36

Senior Member
Jun 8, 2012
8,258
2,868
253
unless everybody has flashed my toggle mods zip and that's sorted the problem without anyone knowing? lol

Sent from my AOSP 4.3 Xperia S via Tapatalk
 

dreezz

Senior Member
Feb 24, 2011
660
122
0
difference i notice now...
i had the roaming 'r' and nothing else.
now i'm back on Slim rom, i only have '3g' or 'H', no roaming sign (like on your screenshot).

(roaming was on on both roms, same apn settings)
 
Last edited:

mehdi-18

Member
Jun 4, 2013
49
30
0
KHOZESTAN
:/ why should you need any screenshot?? it looks like normal stock android...check galaxy nexus review 4.3 to see how it looks like :/

Please give me links to screenshots
did you installed this rom?
it is ok?
it is constant?
How about speed?

I'm sorry that the English language is not good:(

---------- Post added at 02:38 PM ---------- Previous post was at 02:21 PM ----------

just install it, it's awesome

Sent from my AOSP 4.3 Xperia S via Tapatalk

really?
it is constant?
How about speed?
How about camera quality?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 98
    JB AOSP 4.3 alpha 1 by LeTama

    8d9c.png

    *** DISCLAIMER ***
    I'm not responsible if it breaks your device! Don't install it if you want something stable.
    *** /DISCLAIMER ***

    Be careful, this is a very preliminary build. Backup your stuff and expect problems.
    DON'T TRY TO FORMAT any unformated external USB drive/key with OTG cable, it could format internal storage instead !!!

    Introduction

    Here is my port of JB AOSP 4.3 for our Xperia S. This is a work in progress, it's currently missing few of the patches I used in 4.2.X and few things are completely untested.

    Installation and downloads

    1. You need unlocked bootloader and a working recovery.
    2. Download installation zip from here, mirror thanks to @androidlover007 (I know, uploaded.net is not the fastest of the earth, multipload mirrors coming soon. I'm not against posting any other mirror).
    3. Copy it to internal storage
    4. Wipe Data/Cache
    5. Install gapps for 4.3. Currently, we don't have "official" gapps from CM team, I used PA ones with good success.
    6. Reboot and let the rom settle down a bit
    7. Important: Current release has a recovery with broken offline charging, you should flash a fixed one after installing the rom to avoid any trouble. Check this post.


    Kernel source code is here (branch jb-4.2-experimental).

    Note: this rom flashes its own kernel that comes with TWRP recovery and last version of Boot Manager. Just use volume up/down to navigate boot manager menu and power to select if you want to go to TWRP. Don't play with Boot Manager options if you don't know what you're doing.
    46
    Status

    Working:
    • Display / 3D (with some stuttering, under investigation)
    • Audio (without LPA, won't add it)
    • Calls / SMS / MMS / Data
    • Camera (Pictures / Videos)
    • Bluetooth
    • Wifi
    • Wifi Tethering
    • Sensors
    • GPS
    • Hardware video encoding/decoding
    • Offline charging
    • NFC
    • SELinux
    • WIFI EAP. (untested, can anyone confirm ?)

    Not working:
    • FM radio: I won't implement it in aosp with current proprietaries as they will conflict with 4.2+ bluetooth.
    • HDMI.
    • Auto brightness (disabled now)
    • And probably more, let me know

    Missing
    • TRIM Support

    Known issues
    • 1080p video stuttering (waiting for new Sony firmware)
    • voip audio disabled, voip is going through normal channels (waiting for new Sony firmware)
    • Wifi direct disabled (waiting for new Sony firmware)
    • subway surfers game is not working
    • SuperSU not working. You can flash a working one here.
    30
    Changelog

    • 2013/08/07 - Alpha 1

      - SELinux added
      - Media server crash on audio notification fixed
      - Move to SD fixed
      - Ril crash on some mvno fixed.
      - SuperSU updated to 1.51
      - 12 and 9M camera size
      - Panorama fix
      - Google backup selected as default
      - EAP finished

    • 2013/08/03 - Alpha 0
    24
    Well it worked pretty good on the open semc(4.2.2) rc1....
    On what bug do you focus now?(not asking eta's but just to have an idea)

    Well, I'm still working on video driver. I thought I obtained what I wanted, using 4.3 adreno proprietaries, with the bonus of having Subway Surfers issue and probably more like Sygic fixed, but I lost camera preview in the process. Still trying to understand why and fix it.

    I integrated the new proprietaries from 1.96. they indeed fix the 1080p problem, I'm still waiting for Sony source code to add the other fixes they added in kernel.

    If I can fix this preview release and add these kernel fixes, I'll do another alpha and see what will be next.
    19
    Alpha 1 released, see changes in 3rd post.

    I'm still working on the 3D/display stuttering, it seems that at least vsync is broken.
    @htcp3300fun, your issue should be fixed in this one, can you confirm ? Thanks!
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone