[ROM][Developer] MIUI 10 Global links

Search This thread
G

GuestK00375

Guest
Do you think it'll add treble support? That'd be awesome....


Also... My updater app now classifies the latest build as "top-secret" ???
 

Attachments

  • Screenshot_2018-08-24-20-06-22-077_com.android.updater.png
    Screenshot_2018-08-24-20-06-22-077_com.android.updater.png
    251.7 KB · Views: 189

_Legend0

Senior Member
Aug 26, 2012
207
113
Do you think it'll add treble support? That'd be awesome....


Also... My updater app now classifies the latest build as "top-secret" ???

Right now treble is useless, doesn't help with anything. Maybe on Android One devices, with stock Android, but not on MIUI, where you have to redo entire code...

About "top-secret". This update had some bugs with camera crashing so it has been put down.
 
G

GuestK00375

Guest
Right now treble is useless, doesn't help with anything. Maybe on Android One devices, with stock Android, but not on MIUI, where you have to redo entire code...

About "top-secret". This update had some bugs with camera crashing so it has been put down.
I mean we already have unofficial treble.... If we got official support we could flash one of the vendors from one of the treble roms.

As for the update... Will I still get the next weekly update or what do I do?
 

goldbeard

Senior Member
Sep 4, 2008
296
78
It didn't work for me. Said android version different from what is in the update package.
I'm downloading fastboot version now. What a waste.

You need to download the latest public beta release. The latest version is 8.8.23 as on today. If anything lower than this, you would get the android version different error....
 

_Legend0

Senior Member
Aug 26, 2012
207
113
I mean we already have unofficial treble.... If we got official support we could flash one of the vendors from one of the treble roms.

As for the update... Will I still get the next weekly update or what do I do?

Yeah. You will get next update without any problems. It's just a killswitch for people who haven't downloaded 8.8.23 update.
 
  • Like
Reactions: StewieTech

macmilla

Member
Dec 18, 2009
11
1
You need to download the latest public beta release. The latest version is 8.8.23 as on today. If anything lower than this, you would get the android version different error....

It was 8.8.23 I downloaded. I downloaded the zip file for use with updater app. But I got that message.
I then downloaded the fastboot file and it worked. I forgot to remove "flash and lock" on miflash app. So I got a locked device that won't boot (essentially a brick). But when I realised my mistake, I unlocked it again and it booted right up.

It's a very stable os. Everything works perfectly. But I noticed the bootlogo shows MIUI 8. That is strange. Not even 9.
I also saw "top secret" on the updater app.
I hope I will continue getting OTA updates from here? Will I?

Thanks so much.
 
Last edited:
G

GuestK00375

Guest
It was 8.8.23 I downloaded. I downloaded the zip file for use with updater app. But I got that message.
I then downloaded the fastboot file and it worked. I forgot to remove "flash and lock" on miflash app. So I got a locked device that won't boot (essentially a brick). But when I realised my mistake, I unlocked it again and it booted right up.

It's a very stable os. Everything works perfectly. But I noticed the bootlogo shows MIUI 8. That is strange. Not even 9.
I also saw "top secret" on the updater app.
I hope I will continue getting OTA updates from here? Will I?

Thanks so much.
Read the reply on top of this one. I just asked the same question
 

mlfcnt

Member
Aug 17, 2018
16
4
Hey guys. Im on 9.6.4.0 stable (vince) and when i try to install 8.8.2 global i get the "looks like the current android version is different from that in the recovery package,..." error.

I also tried with the 8.4.2 but im getting this error "You allow to flash the newest develop version from stable version only".

What should i do? thank you
 

rokudoz

Senior Member
Sep 30, 2017
59
19
Hey guys. Im on 9.6.4.0 stable (vince) and when i try to install 8.8.2 global i get the "looks like the current android version is different from that in the recovery package,..." error.

I also tried with the 8.4.2 but im getting this error "You allow to flash the newest develop version from stable version only".

What should i do? thank you
From my experience, you need to update to the latest stable, and then you can flash Dev ROM
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone