[ROM][DISCONTINUED][10.x]LineageOS 17.1 for Samsung Galaxy A70

Search This thread

MarvinMod

Senior Member
May 20, 2015
682
275
Samsung Galaxy A70
Hello, I flashed twrp on my A705fn but cant flash any rom because of weird file names.
Tried flashing rom from an sd card but the phone goes to download mode after flashing the rom successfully. Anyone can help?
You need to flash disable force encryption and format data in twrp advanced wipe.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    My Channels :

    Builds :
    • 03-11-2020:
    • 11-11-2020:
      • SPL: November 2020.
      • Fix hal_audio_default denial.
      • Fix hal_bluetooth_default denial.
      • Update fingerprint build to A705FNXXU5BTH4 based on Q’s 2.0.
      • Update /vendor/firmware from A705FNXXU5BTH4 to use FOD on Q vendor too.
      • androidfilehost.
    • 07-12-2020:
      • SPL: November 2020.
      • AudioFX: should be working now for all, in case not just disable it.
      • Headphones: fixed.
      • Update fingerprint build to A705FNXXU5CTK4.
      • Wifi: it should work on all variants now.
      • sourceforge.
    • 26-12-2020:
      • SPL: Dec 2020.
      • Fix Bt Sco Headset Mic.
      • Address macloader denials.
      • sourceforge.
    • 05-01-2021:
      • Initial release for OneUI V2.5.
      • androidfilehost.
      • sourceforge.
      • Note: You have to be on stock unmodified OneUI 2.5 firmware, also do no wipe /vendor partition or it will never boot.
    • 19-01-2021:
      • Headphones: that is to say has been fixed such as plug/unplug without issues.
      • Import Google Pixel A4 /product props.
      • androidfilehost.
      • sourceforge.
    • 21-01-2021:
      • Fix boot again, I don't won't more excuses.
      • Fix Double tab to wake.
      • This is a final release, I'm not gonna focus on Q anymore, it's time for prebuilt vendor 18.1.
      • androidfilehost.
      • sourceforge.
    • 26-01-2021:
    • 20-02-2021:
    • 26-05-2021:
    Important Note :
    • My actual roms is intended to be flashed on OneUI 2.0 due to some updated blobs like FOD, so OneUI 1.1 support will be discontinued.

    What's not working :
    • FOD Dimming (enrollment is fine tho)
    • Permissive.
    • Camera: still show 8mb pixel, so you have to use a gcam or OneUI's camera "port" from other devices.
    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Resources

    XDA:DevDB Information
    LineageOS for A70Q, ROM for the Samsung Galaxy A70

    Contributors
    haky 86, Grarak
    Source Code: https://github.com/Haky86

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x
    ROM Firmware Required: OneUI 2.0 and up (I'm not gonna support modded firmware)
    Based On: LineageOS/AOSP

    Version Information
    Status:
    Beta
    Stable Release Date: 2020-11-21
    Beta Release Date: 2020-11-21

    Created 2020-11-21
    Last Updated 2020-11-21
    5
    Hi!


    LineageOS 18.1 for Samsung Galaxy A70:
    • SPL: July 2021.
    • Fixed FOD on some MN and FN by using a dark theme.
    • Drop generic aosp_arm64_ab stuff, legacy SaR is no longer needed.
    • Introduce Ramdisk Loader, thanks to Linux4.
    • Keep in mind to be on stock vendor.
    • sourceforge.

    4
    will this work on Android 11?
    Edit: NVM I see its 17.1
    I'll release a newer version of my 18.1 for OneUI 3.1 for prebuilt vendor as initial release and then with a proper vendor.img based on R blobs
    3
    Porting the samsung camera app won't work either, breaks lineage ever time. Lineage is using generic/old drivers in the repo. Been this way for a few years now.
    Ik, I'm planning to do 18.0 but it will take some time because the trees are very old.
    3
    LineageOS 17.1 07/12/2020
    • 07-12-2020:
      • SPL: November 2020.
      • AudioFX: should be working now for all, in case not just disable it.
      • Headphones: fixed.
      • Update fingerprint build to A705FNXXU5CTK4.
      • Wifi: it should work on all variants now.
      • sourceforge.

    • Telegram channel