[ROM][DISCONTINUED][cedric][11] StellarOS 1.1 "Bellatrix" #RideIntoCosmos

Search This thread


Apr 18, 2018
Hello, I have a little problem with the OS. Unfortunately, since StellarOS, I can only charge slowly instead of quickly. With LineageOS Mint, I was able to charge quickly.


Apr 18, 2018
I have make the update via twrp. Now it did not Boot. It's show the Stella OS Screen and after that, he goes back to the Recovery Mode.


Sep 23, 2021
i installed today. Really fluid ROM, i liked! Can anyone tell me how i can lock my phone on the biometric sensor? I managed to do this with Lineage OS 17, but on this Stellar ROM it didn't :(

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Warning: bugs and outdated SP ahead...

    #include <std_disclaimer.h>
    * Your warranty is... still valid?
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.

    Stellar OS is an optimized LineageOS-based Android aftermarket firmware with extra features, developed by people all over the world.
    Quoting the LineageOS description:
    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.
    We offer vanilla and gapps variants. If you install a vanilla variant, the only supported Gapps package is MindTheGapps (gapps builds are not available for a few devices due to space issues).

    Download & instructions:
    Build 23th September 2021
    • 1.1 source update (September SP + new features)
    • Fixed fast charging display

    Vanilla | Gapps

    Old releases:
    Build 12th August 2021
    • Initial release
    • If you are coming from an older build (beta testers), clean flash is required
    Vanilla | Gapps

    IMPORTANT: If you are coming from another ROM, you need to format data (there where you type yes in twrp).
    IMPORTANT: OTA updates require enabling recovery update in Setup Wizard (or, if you already set your device up developer options) - they do not support TWRP.


    • All Mint 2.1 features
    • September security patch
    • SafetyNet passing WITHOUT Magisk Hide
    • Many optimizations
    • New wallpapers & bootanimation
    • QS customization (tint, rows customizer, data usage)
    • Status bar customization (4G/LTE toggle, new NFC & VoLTE icons)
    • Kill app from notification
    • Notification pulse
    • KitKat-style notification ticker
    • Screenshot sound toggle
    • Per-app volume
    • WiFi & Bluetooth timeout
    • Stellar Tweaks customization section
    • Navbar Tuner
    • Improved Trebuchet+
    • OmniJaws weather service
    • Many lockscreen clocks
    • Statusbar ticker
    • Signed official builds
    • Smart Charging & Cutoff
    • Sensor, Wakelock and Alarm blocker
    • Battery info on lockscreen
    • Improved microG support (signature spoofing, location support)
    • ...and more (we accept suggestions)
    The focus for the inital release was an neccessary set of tweaks and optimizing android.

    What's working:
    • WiFi
    • Camera and Camcorder
    • Bluetooth
    • Fingerprint - Oreo firmware required
    • GPS
    • OTG
    • Video Playback
    • Audio
    • RIL
    • VoLTE
    • USB tethering/audio
    • SELinux: Enforcing
    • You tell me
    Sources are available at https://github.com/Stellar-OS and https://github.com/Stellar-Devices
    Screenshots from ocean are attached

    ROM OS Version: 1.0
    ROM Kernel: Linux 3.18.140
    ROM Firmware Required: Must be on latest Oreo Stock firmware
    Based On: LineageOS 18.1

    Version Information
    Current Stable Version: 1.0
    SELinux Status: Enforced
    Release Date: 15th August 2021

    Thank you for your work !
    My questions may be slightly off-topic... and from a newbie but I am wondering why SafetyNet is OK on this ROM (checked with an application, without Magisk installed) BUT some applications still refuse to work or complain :
    - WhatsApp just warns my device is not supported
    - HID Approve (an MFA auth. app) refuses to run
    - My banking app refuses to enable basic features at launch

    What kind of checks have been implemented within these applications (are they well-known ?) and is there a way to workaround these issues ?

    Otherwise, I could relock my bootloader and reinstall Oreo Stock but I tried many times a few months ago and never managed to do it without losing my IMEIs (I have not done EFS backups before installing MintOS...). Any suggestion to make this work without buying another phone ?

    Thank you !
    Is your device rooted at all?

    If so the apps can detect you are rooted and they can detect that magisk is installed

    So in magisk settings enable magisk hide
    Also in magisk settings hide magisk with a random package name and call it something totally random (this will now be the name of the app)
    Open the app back up and go to magisk hide and tick any app that detects root eg banking app

    Force close any apps that were open and restart them

    If that doesn't work you can try RevengeOS as I don't implement safetynet patches on that rom and then read the faqs about passing safetynet then do the above

    If you are not rooted it maybe because the app can detect secure boot is not enforced. Flash magisk to patch boot.img and then do above to hide root
    hey, I installed Stellar OS on my Moto G5 today, and everything seems perfect !

    as @AndyFx12, I'm looking forward kernel update if it can reduce booting time.

    now I encountered a real issue when I ran out of battery : when I plug in my USB cable, there's 2 scenarios :
    • when the phone is turned off, it takes 2 minutes before actually charging
    • when it's on, there's the "plugged in" animation, but the phone is not charging (the battery manager settings say "not charging"), still the eco battery settings are turned off because it's plugged ...
    plus the battery is like super hot when it's charging ...

    any suggests ?

    EDIT : okay nevermind, I just activated "Smart charging" and "Smart cutoff" without understanding what it does ...
    Is there a way to configure Lineage Recovery see the phone on Windows to transfer files like with TWRP?

    And also, is there a way to use the fingerprint sensor to turn off the screen and lock it?
    nope, except about the fingerprint, you maybe have luck with this old app I made.