• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][DISCONTINUED] LineageOS 17.1 for Xiaomi Mi 5

Search This thread

fence

Senior Member
Aug 1, 2008
106
75
I've been having real trouble getting GPS lock in the UK recently.

I seem to be getting much faster/more reliable locking by changing the NTP server from time.izatcloud.net to 1.android.pool.ntp.org in gps.conf.

Just sharing in case it helps anyone else out.


Nevermind, after brief success GPS is back to not locking.
 
Last edited:

radau

Member
Mar 14, 2011
14
8
OnePlus 8 Pro
then i would do a fresh install like this (make a backup of your files you want to keep beforehand):

boot to twrp recovery
go to wipe
then go to advanced wipe
select everything and wipe
then go to format and type yes and format
then install/flash in this order
firmware
lineage os
gapps
then wipe dalvik and cache and restart

if this does not work your gps is most likely broken on a hardware level
I tried fastbooting the latest global, and still no luck.
BUT
your instructions work flawlessly with fw_gemini_miui_MI5Global_8.11.22_c5d7ee6745_8.0.zip firmware (not the latest).
Now GPS works fine and other little bugs like app crashing disappeared.
Thanks a lot, mate!
 

eriol1

Senior Member
Feb 16, 2015
177
119
For some reason fingerprints stopped working suddenly.
I don't mean the sensor, just the 3 fingerprints I had set up.
The device just didn't seem to try and authenticate against the saved fingerprints. Wouldn't even lock me out after failing multiple times to unlock with a wrong finger. Just gave the tiny vibration feedback every time I tried a finger.

Since the sensor is in fact working, I ended up setting up new fingerprints, then deleted the nonfunctional ones.

No idea if this is a los17 thing or specific to my setup, either way hope this helps someone.

Logs if anyone is interested (I've also got full log saved but rather not post publicly):
Code:
07-19 09:00:08.981 I/fpc_fingerprint_hal(946): fpc_worker_set_state_locked worker_state_t = 0
07-19 09:00:08.992 I/fpc_fingerprint_hal(946): do_navigation end -
07-19 09:00:08.992 I/fpc_fingerprint_hal(946): workerFunction STATE_IDLE
07-19 09:00:08.993 I/fpc_fingerprint_hal(946): fpc_worker_set_state_locked worker_state_t = 2
07-19 09:00:08.993 I/fpc_fingerprint_hal(946): workerFunction STATE_AUTHENTICATE, status:0, nav:1
07-19 09:00:09.010 I/fpc_fingerprint_hal(946): fpc_wait_finger_up FPC_LIB_FINGER_LOST
07-19 09:00:09.010 I/fpc_fingerprint_hal(946): do_identify start -
07-19 09:00:09.012 E/fpc_fingerprint_hal(946): do_identify failed -4
07-19 09:00:09.012 I/fpc_fingerprint_hal(946): do_identify end -
07-19 09:00:09.023 I/fpc_fingerprint_hal(946): fpc_wait_finger_up FPC_LIB_FINGER_LOST
07-19 09:00:09.023 I/fpc_fingerprint_hal(946): workerFunction STATE_NONE (Navigation), status:0
07-19 09:00:09.023 I/fpc_fingerprint_hal(946): do_navigation start -
07-19 09:00:09.606 I/fpc_fingerprint_hal(946): wait_wake_up (get_irq)
07-19 09:00:15.571 I/fpc_fingerprint_hal(946): fpc_cancel
07-19 09:00:15.571 I/fpc_fingerprint_hal(946): fpc_worker_set_state_locked worker_state_t = -1
07-19 09:00:15.582 I/fpc_fingerprint_hal(946): do_navigation end -
07-19 09:00:15.582 I/fpc_fingerprint_hal(946): workerFunction STATE_IDLE
07-19 09:00:15.600 I/fpc_fingerprint_hal(946): fpc_wait_finger_up FPC_LIB_FINGER_LOST
07-19 09:00:15.600 I/fpc_fingerprint_hal(946): workerFunction STATE_NONE (Navigation), status:0
07-19 09:00:15.600 I/fpc_fingerprint_hal(946): do_navigation start -
 

mruibal

Member
Apr 19, 2011
35
5
In today rom gps worked finally but it took more than half hour to get location for gmaps. Something is sitll not ok with gps.
Thanks for your work.

Enviado desde mi MI 5 mediante Tapatalk
 

mruibal

Member
Apr 19, 2011
35
5
One question? Is this firmware (fw_gemini_miui_MI5Global_8.11.22_c5d7ee6745_8.0.zip) directly flashable by TRWP?
Regards.

I tried fastbooting the latest global, and still no luck.
BUT
your instructions work flawlessly with fw_gemini_miui_MI5Global_8.11.22_c5d7ee6745_8.0.zip firmware (not the latest).
Now GPS works fine and other little bugs like app crashing disappeared.
Thanks a lot, mate!
 

pl4yeR

Senior Member
Dec 20, 2008
131
25
GPS is not working. Locking is very slow and precision is so low...

Maybe missing blobs?

Enviado desde mi MI 5 mediante Tapatalk
 

fence

Senior Member
Aug 1, 2008
106
75
GPS worked perfect for me before the builds went official. Since official builds started GPS has great difficulty obtaining lock, taking minutes if it works at all, often google maps navigation will fail due to this.

I have found that flashing 'Enchanted LineageOS 17.1 with 4.4 kernel' resolves all these issues and performance returns to normal.

Something must have changed when the builds went from unofficial to official.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 65
    2okPze5.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10 (Q), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    GPL compliance:
    yG18r6g.png

    Broken / not yet supported:
    • VoLTE (?)

    Working:
    • Camera (and flashlight)
    • WiFi
    • NFC
    • Bluetooth
    • Telephony (Calls and Data)
    • Audio (Record and Playback)
    • Video Playback
    • Sensors
    • GPS
    • HW crypto (FDE)

    Compatibility:
    Compatible with all Xiaomi Mi 5 variants (32GB / 64GB / 128GB). Xiaomi Mi 5S and 5S Plus are not supported.​
    Builds are based off the Xiaomi's Android 8.0 firmware with proprietary blobs from MIUI V10.2.2.0.OAAMIXM global stable package.​

    Downloads:

    Notice:
    • No custom kernels are supported in this thread. Only stock kernel and official builds will be supported. No bug reports if that's not the case.

    Installation:
    • Reboot to recovery (TWRP recovery for Mi 5 - Direct link)
    • Format /system, /data and /cache
    • Install LineageOS zip package
    • Install [optional] a Google Apps package of your choice (Open GApps is advisable, but stock and super variants are not recommended!!!)
    Important notes:
    • Current minimal * required * firmware version is MIUI V10.2.2.0.OAAMIXM global stable, otherwise installation will fail. Download the latest dev fastboot package directly from Xiaomi and flash it prior to installing LineageOS or, alternatively, download and install one of the latest custom packages containing firmware only (at your own risk).
    • GApps can only be flashed on clean installs.
    • Formatting data (all user data is wiped, including internal storage) is a must if MIUI was previously installed and device was encrypted.

    Credits & collaborations:
    This work is due to efforts from Mi5Devs founding members (@h2o64 and me) that did the full device bring-up. Huge thanks to @deovferreira for all the help during the kernel bring-up after source code dropped. Last but not least, pleasure having @luca020400 and @LuK1337 onboard since the bring-up of the whole Xiaomi 8996 family.​
    Finally, all LineageOS team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!​


    Device wiki:
    40
    Will Mi5 migrate from los 17 -> los17.1 with fixes? We have been waiting for the update with impatience for a month now, I hope you have not "abandoned" us, thanks for continuing to support our device.

    Yes, the next build will be 17.1 and I will be releasing it this week. I didn't abandon you guys, don't worry.
    39
    Good news, folks. I decided to move Mi 5 to official 17.1 builds. :victory:
    33
    The new build is up as promised. Enjoy! :highfive:
    31
    Guess what... a new build is up. Let's see if if I can enable official nightlies soon. :fingers-crossed: