• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][DISCONTINUED] LineageOS 17.1 for Xiaomi Poco F1

Search This thread

fightforlife

Member
Oct 25, 2012
32
12
Last edited:
  • Like
Reactions: duttyend

PcJonts

Member
Oct 21, 2017
11
2
Tallinn
Seems like some behaviours have changed since last major android version. Maybe somebody has a solution for me?

I'm using pattern lock, and also have some fingerprints registered. Because of the latter one, the phone listens on fingerprint reader even when screen is off and unlocks the phone when correct finger is given.

Is there any way to turn off the fingerprint reader for unlocking? I have few apps i would like to keep using with fingerprint, but i don't want fingerprints to be used at all for phone unlocking.

I remember older android version had specific fingerprint settings that allowed to do that. But now, all of this seems to be missing.

Any solutions to make it happen on latest lineage os?
 
  • Like
Reactions: duttyend

dantrolene

Member
May 16, 2009
18
2
Hi,
I am having issues with android auto. It remains stuck at the loading screen with icon.
Device is unrooted. Clean installed and had open gapps pico .
Any help.
 

ManyPhones

Member
Jun 27, 2014
25
0
Hamburg Area
I am desperate.
Two days ago i iried to restore an older TWRP backup of system and data to get some deleted contacts back. The LOS started to boot and asked for a pin. That PIN I did not know, so I tried to restore the current backup again. That ended up in messing up the phone completely for some reason, even fastboot was not responding properly any longer at some point; with different results on Win / Linux. I fixed installing a "recovery" version of the original MIUI to reset everything to "normal", which finally worked out.
Then I re-installed TWRP (3.4), installed the current version of LOS 17.1 (13.03.2021) and OpenGApps just to see, whether this would work. And it did.

Now the problem: whenever i restore the TWRP backup (system (also based on LOS 17.1 (13.03.2021)) AND data; OR data only), the device will boot into the "pocophone" logo, then restart automatically into recovery mode. Then it will prompt me "Enter Password for User[0]". Before taking the backup i had deactivated "Sicherer Start" (save start) in the LOS system lockscreen settings, but a pin code was active just after entering the SIM pins. Now, in TWRP it won't help to enter the lockscreen PIN of the system.
I can do "cancel" in that TWRP dialogue, got to Advanced, Decrypt Users, then it shows me "Select user" along with the old Username, followed by (0).
I am 100% sure, that the pin i enter is correct, as my wife and I both now it; it is the birthdy of our dog (-; (which nobody knows except for us two).

What can I do? I need the backup as it contains Signal and Threema databases.

Help appreciated. I spent like 10 hours on this now, and I am about to become crazy.
 

in_out

Senior Member
Aug 30, 2018
102
27
What can I do? I need the backup as it contains Signal and Threema databases.

Help appreciated. I spent like 10 hours on this now, and I am about to become crazy.
that is the know issue with TWRP from 8.1 for many phones, they are not able to decrypt the lockscreen password after restoring twrp backup if they wipe all the 5 partition

if you able to enter in TWRp menu then restore the backup then delete the some files using twrp file manager
/data/system and delete
  • password.key
  • pattern.key
  • locksettings.db-wal
  • locksettings.db-shm
  • locksettings.db
/data/system/user/0 and delete settings_fingerprint.xml

working in mido & many other devices
don't know whether working on miui roms or not


better watch video on youtube how to do this after that try to do anything, i am not an expert
 
Last edited:
  • Love
Reactions: duttyend

Optimissimus99

Senior Member
Feb 21, 2014
359
116
I have a question:
today I flashed build 20210313 (before I had an older build installed, probably late frebruary). For years, this was the first build that failed booting for me (Bootloop).
I didnt think of anything special and dirty flashed (downgraded) to the version before (0306).


After rebooting, lineage, but also TWRP do now ask to decrypt data. Even with my correct pin, it fails to do so.
(I think because the security patch level is now upgraded)
I think I had a very similar issue years before, back then updating to a newer rom fixed it up again.
However this was when Lineage was still decrypting on boot normally. It doesnt do that now anymore (not when it is working normally at least)

Is this correct? will version 20210320 (which hopefully will be built tomorrow) fix this issue?
Or can it be fixed otherwise? I dont necesarilly need the /data partition or a booting system, however I do need the /sdcard partition, as there are a lot of important files on it and my backups are kind of outdated.
 

Optimissimus99

Senior Member
Feb 21, 2014
359
116
20210320 is out, but it didn't fix the error. So I suppose the internal storage encryption has nuked the files.
(default_password and the 4 digit login pin don't work)

Just so others don't make my mistake anymore:
- With Android 10, NEVER EVER do a downgrade to a previous security patch level or especially vendor.
it will destroy all data. They will not be accessible anymore, not even with a more modern "vendor" image.
with data, I mean EVERYTHING on the internal storage, also /data/media ("/sdcard on older phones").

I thought everything that could go wrong would be that it doesn't boot. That was a mistake.

I think this should be written everywhere, on the OP and in the lineage wiki/download page. Even after modding phones for almost 10 years I made this mistake, thinking I am safe by making a nandroid backup to the internal storage.
There are a few reddit / xda posts about this, but I only found them after hours of googling. So please, include this to places where it can be seen.
 

Largamelion

Senior Member
Sep 10, 2010
515
224
For me the solution that has always worked when bootlooping is to flash the magisk uninstaller zip. I don't reboot very often (only when I run into issues) but when I do, 80% of the time the phone bootloops and the only way to get out of it is by uninstalling Magisk, booting the system and then reinstalling Magisk and my module (I only use ANX Camera).
 
  • Like
Reactions: duttyend

Optimissimus99

Senior Member
Feb 21, 2014
359
116
that would have indeed most likely fixed the bootloop issue.
Well, for me, that was not the issue. The real issue was that downgrading the phone seems to permanently damage /data, including the internal storage, with no way to fix the issue.

With android 9, going back to the newest release fixed this. With Android 10, it doesn't. Your data are permanently lost!

This should be a big fat warning in the OP, as I didn't know that, and many other people probably don't know about it. It makes backups to the internal storage completely worthless
 

Tremolo4

Member
Dec 2, 2017
11
11
The issue of erasing all data when downgrading security patch level comes up regularly in this thread. I fell victim to it as well around 1.5 years ago. (I lost only a week of data luckily, because I make out-of-phone backups before upgrading). A few pages back I posted a warning about it again.

As can be seen from your example, this is not sufficient. It is unreasonable to expect anyone to work through this whole thread to become aware of potential pitfalls. And this particular pitfall has quite severe consequences.

And it's so stupidly preventable as well. It's not like a bug that comes up unexpected. It is (as far as I know at least) expected behavior that one just needs to be aware of.

So, I very much agree with you, there need to be more prominent warnings about this, for example in the OP.


PS: When I encountered the issue I was on Android 9 and I did try upgrading patch level again so I cannot confirm that it's "fixable" there.
 
  • Like
Reactions: duttyend

ManyPhones

Member
Jun 27, 2014
25
0
Hamburg Area
that is the know issue with TWRP from 8.1 for many phones, they are not able to decrypt the lockscreen password after restoring twrp backup if they wipe all the 5 partition

if you able to enter in TWRp menu then restore the backup then delete the some files using twrp file manager
Thanks for the description! I think, I had read about that method before, but I was not able to locate the files or I couldn't acccess them (I don't rememeber the details, in any case there was a mounting error for one partition - probably the encrypted one?).
In the meanwhile I re-installed everything from scratch, which took ages. I re-enabled Backup via Acronis mobile and Seedvault Backup to my Nextcloud, so I try to save as much data as possible (even though Seedvault does not successfully backup ALL apps).

For the next time: where exactly are those - above mentioned- files located?
 

SilverHawk.83

Member
May 8, 2020
8
2
Hi there,
is there a way to decrease the headphones volume? Not the speaker, only the headphones when on call.
I read that volume settings are related to mixer_paths_tavil.xml, but I don't know which tags I should change.
Any hint?
Thanks
 

mdude22

Senior Member
Sep 25, 2014
76
8
How do we download magisk? Where can i find magisk

I downloaded the magisk app and i went to install it and it's asking for a img or tar file but i have no idea where to find the magisk file
 

Top Liked Posts

  • There are no posts matching your filters.
  • 135
    2okPze5.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10 (Q), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    GPL compliance:
    yG18r6g.png

    Working:
    • Camera (and flashlight)
    • WiFi
    • Bluetooth
    • Telephony (Calls and Data)
    • IMS (VoLTE and WiFi Calling)
    • Audio (Record and Playback)
    • Video Playback
    • Sensors
    • GPS
    • Encryption (FBE / FDE)

    Broken:
    • Nothing (?)

    Compatibility:
    Compatible with all Xiaomi Poco F1 variants.​
    Builds are based off the Xiaomi's Android 10 firmware with proprietary blobs from MIUI v11.0.3.0 global stable package.​

    Downloads:

    Notice:
    • No custom kernels are supported in this thread. Only stock kernel and official builds will be supported. No bug reports if that's not the case.

    Installation:
    • Reboot to recovery
    • Format /system, /data and /cache
    • Install LineageOS zip package
    • Install [optional] a Google Apps package of your choice (Open GApps is advisable, but stock and super variants are not recommended!!!)
    Important notes:
    • * Required * firmware version must be based on MIUI Q-based builds.
    • GApps can only be flashed on clean installs.
    • Formatting data (all user data is wiped, including internal storage) is a must if MIUI was previously installed and device was encrypted.

    Credits & collaborations:
    All LineageOS team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!​

    Device wiki:
    51
    Enjoy everyone. :)
    42
    Will you gonna maintain this rom?

    Obviously. Did you ever look at the wiki and the list of maintainers? ;)
    35
    The silence is certainly the best reply for the ignorant people.

    Sent from my Mi MIX 2S using Tapatalk
    22
    Lost magisk again when updating OTA with latest recovery. Now I have to plug my phone into my PC and flash back to TWRP because LOS recovery still doesn't have working decryption.

    Why not delist this recovery until it works? Lol ? Very broken.
    Dude, LineageOS recovery is not broken just because you lost Magisk. Also, not having decryption support doesn't mean it's broken. No one forces you to use LineageOS recovery, so you are free to use TWRP recovery. Finally, you are not even forced to use LineageOS at all, but at least show some respect for the people that brings you stuff for free.