• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][EXYNOS] LineageOS 18.1 for S10e|S10|S10+ - v2.2 (UPDATE: 2021-07-23)

Search This thread

sappounet

Member
Jan 30, 2011
36
6
I've been rooting my S10e by flashing Magisk onto the boot partition (using the file magisk_boot_beyond0_dtja_v1.3.img), like explained in the OP.

But I've just realized that I need to temporary remove root in order to install some very pain-in-the-ass security oriented banking and ID-card related apps.

Is there a way to remove Magisk from the boot partition without having to wipe/format any data ?

And if so, what is the right way to do it ?

EDIT : Nevermind, the problem is most likely due to the fact that the SatefyNet check is failing because I'm using microG :cry:
 
Last edited:

doeternietoe

Senior Member
Dec 31, 2010
71
27
I don't really understand all the problems.

Yes, TWRP cannot access the encrypted data on the phone. It does not even ask for unencryption.

But:

Yes, I can nevertheless still dirty flash the ROM updates fron this thread. Doing it all the time. (I don't really mind if you call them OTAs or whatever.)

The only "problem" is that you have to access the downloaded ZIP from TWRP in order to flash ist. Which means you cannot use your internal data storage for the file. That's why I use an SD card formatted as portable storage for all that stuff I don't need encrypted but easily accessible. Problem solved.
Yes, your half right. I've just flashed the new ROM and it works fine.

All the same, I spent a lot more time making a proper backup with other tools before doing so. Also, I wanted to update some Magisk modules and had to do so with the knowledge that if my phone went into a bootloop I could not stop that by disabling the Magisk module from TWRP.

On another note: really great to have glove mode, I've recently replaced my screen protector with one that is slightly too thick, so this improves the experience by a leap.
 

sappounet

Member
Jan 30, 2011
36
6
It seems like multiple Samsung models are experiencing issues with the SIM Toolkit app, which is sometimes used by some mobile phone providers to provide Identity-based authentication (like for login on banking apps).

There has been an issue opened on LineageOS's gitlab page, but since this issue is only impacting Samsung phones, nobody has picked it and it got closed.


I'm having this problem too, where I'm unable to validate my PIN input exactly like explained in the ticket.
 

flunkyball

Senior Member
May 20, 2019
100
68
Please find in the attached zip file a binary patch (.bsdiff) and a objdump patch (.diff) to show the differences in the ARM32 disassembly, in case the binary patch ever fails and a new one must be derived. Changes:

1. In _ZN7android29ExynosCameraMetadataConverter49m_createScalerAvailableStreamConfigu[email protected]@Base, we do NOT take two branches based on the presumably zero contents of offsets #24 and #28.

2. In _ZN7android29ExynosCameraMetadataConverter40m_createScalerAvailableMinF[email protected]@Base, we similarly do NOT take the branch based on the presumably zero contents of offset #24.

To test, in TWRP I took the original libexynoscamera3.so from my phone from /vendor/lib. I applied the binary patch. I copied back the patched file. I rebooted.

You should immediately notice the difference! In OpenCamera, now the front camera is overexposed. Colours are good, but a bit too bright. I also tried zgcam, now the front camera works, also overexposed. I also tried idan's gcam 5.1 for RAW front cameras, that also works, but only on first execute. The next time you run it it crashes, and keeps crashing. So I cannot recommend that gcam 5.1 over the one I already did.

If you do decide to apply this patch by default, I'd recommend backing off the default exposure for the front camera a bit. I'd also get someone more into photography to give it more testing, and perhaps to suggest a default exposure for RAW front camera so it matches non-RAW front camera.

I haven't ported the patch to the arm64 libexynoscamera3.so. I'm out of time today, but I'll look into that tomorrow. No idea how many 64 bit camera apps there are mind you, but completeness is a virtue.

Does the patch file still apply for the current LOS version ? I just recently updated and my ZGCAM stopped working due to no newly available libexynoscamera3.so.
Furthermore your patch enables only the front camera, right ? It does not bring the wide angle camera online....
 

ms2204

Member
Aug 26, 2018
24
0
I recently installed LOS on my Samsung 10 with microG like so:

  • Followed the standard install guide on this page, and installed the Magisk boot image.
  • Right after install, I boot into TWRP, Mount System partition, open terminal go to /system/app/ and did rm-r UnifiedNLP, NominatimNlpBackend, and IchnaeaNlpBackend
  • After reboot, I install MicroG, FakeGapps Xposed Module, Fakestore release, Mozilla Backend, Nominatim Address Backend from
One of the problematic things was signature spoofing. Since I wasn’t too keen on patching, I installed

Riru- Core and Riru – EdXposed

using this guide: https://android.gadgethacks.com/how-to/install-systemless-xposed-almost-any-android-phone-0199790/

Everything is working and MicroG passes all checks, but my question now is:

How do I update LOS?

If I just download the updated image, and install it, what do I do about step 2? Can I just repeat it and delete the 3 folders?
 

flunkyball

Senior Member
May 20, 2019
100
68
I noticed some people fail to prepare their firmware dumps from Frija, etc. Also I wanted to speed up my own workflow to upgrade my S10e, so I wrote a small bash script to repack the firmware for use with heimdall.

Please read the script first and use at your own risk. Although it worked the last two times when I upgraded the firmware on my S10e.

The script assumes you used Frija to download the firmware. Further you need to have some small tools installed on your Linux machine: "md5sum", "unzip", "tar" and "lz4". Also the script will not flash the firmware via heimdall, but only unpack the needed files to one folder, so the heimdall-command can be run like this:
[...]

main $1[/CODE]

Great script ! Thank you. I suggest to include it in the FAQ as it is really helpful for updating to the necessary firmware without using Odin.
 
  • Like
Reactions: Keule-Tm

Radem

Senior Member
Jan 29, 2010
55
4
Góra
Hello, for the first time, I am very happy with this ROM, everything is nicely propellers, even the camera has some modes and additional settings. You do not have to bother with overdubbing not polished applications, and most importantly, music works on wireless headphones in various modes, not like viper4android that sometimes it does not work. great thank you finally refined ROM that you want to use it.
 

pyosnka

New member
Sep 5, 2010
2
0
I would like to upgrade to this ROM, but I'm a little confused about the process. Hoping someone could point me in the right direction here.

I'm currently using Ivan's LinegeOS for S10e, with Magisk installed and TWRP. I'd like to install this ROM with Magisk and TWRP.

The link for repacked firmware files only goes to DTH7, but it says DTK9 is required.

How do I update to DTK9 packages?

After I've updated to DTK9, is this the correct way to install the ROM+Magisk and TWRP:

DTK9 upgrade--->install TWRP-->install LineageOS--->install Magisk

Thanks for the help.
 

Nosepull

Senior Member
Jan 9, 2015
215
43
How do I update to DTK9 packages?

Get the original firmware from Sammobile or something like that, unpack it (several times, that are archives within archives) and flash the *.bin files as needed for the Heimdall command line. That's how I do it. The OP should be updated, as the prepackaged stuff is not updated any more.

As for the update procedure, I got it from the OP that you first flash the Lineage-ZIP from TWRP and then reboot to download and then the above mentioned firmware. Probably it does not matter, as long as you don't fully reboot in between!?!?
 

pyosnka

New member
Sep 5, 2010
2
0
Just wanted to say thanks, got this ROM installed today w/ Magisk and TWRP. Working great.

And thanks to modpunk for the ROM! Love the focus on security.
 

realityexists

Member
Jul 7, 2017
17
0
I updated my S10e to v1.4 and firmware XXS9DTK9 and now my front camera is no longer working.

The rear camera works. When I switch to the front camera the preview image is simply all black, as if the camera was taped over. When I press the same icon to switch back to the rear camera the app freezes for a few seconds, then exits, but when I restart the Camera app it has switched back to the rear camera (which works). I can't be 100% sure that this started when I updated to v1.4, but I haven't tried the front camera since then and can't think of what else could have caused this. I was previously using v1.0 and the front camera worked.

I tried rebooting and power off, of course. Tried clearing the Camera app cache and storage, wiping the cache partition - no change. Has anyone else run into this? Any ideas how to fix it?
 
Last edited:

Thorst1

Senior Member
Mar 11, 2018
129
36
Shatin
Samsung Galaxy S10e
Sorry for this ****ty post, but I'm kinda panicking. I had originally installed version 1.2 of this ROM using the general TWRP. I wanted to upgrade my ROM to the latest version, and thought I'd install Modpunk's TWRP too. During this first step, some stuff didn't work properly: after I installed TWRP through Odin I didn't get a black screen. I think there was an unreadably small message at the top of my screen.

I rebooted from the download mode (power+down) and got stuck in TWRP. Installed the latest version of LineageOS but still no dice. Looking further along the instructions I saw I needed to install the firmware after installing LineageOS. Saw two possible options for the firmware, chose the latest one, installed that, wham:
'An error has occured while updating the device software. Use the Emergency recovery function in the Smart Switch PC Software.'

Smart Switch doesn't see the phone. Can't get it into download mode to flash the other firmware (power, bix, vol down). Cannot even turn the bugger off. Bricked?

Is there any thread / post on what to do when you've put yourself in the ****s like I have? Thanks in advance, guys&gals.
 
Jun 9, 2012
43
17
It's not bricked and can be recovered.

1) Reboot it by pressing/holding the "Vol down" and the "power" key. And as soon and it restarts:

2) Press the "Vol down" and "Bixby" key and plug in the USB cable. (Connected to your PC)

You will then be in the download mode
 
  • Like
Reactions: Thorst1

Thorst1

Senior Member
Mar 11, 2018
129
36
Shatin
Samsung Galaxy S10e
It's not bricked and can be recovered.
1) Reboot it by pressing/holding the "Vol down" and the "power" key. And as soon and it restarts:
2) Press the "Vol down" and "Bixby" key and plug in the USB cable. (Connected to your PC)
You will then be in the download mode
Phew, thanks. Managed to download an Samsung ROM package which I could flash with Odin, even though the screen of my phone was still locked to the 'An error has..." message. Now I just have a German T-mobile version of the official Samsung ROM :) I'll retry flashing Modpunk's TWRP and LineageOS ROM.
 
  • Like
Reactions: Sheffield Steve

jfk_77

Member
Nov 12, 2019
18
1
Quick question:

You update Magisk according to new firmware releases right? I'd like to install 21.2 on CFT3, so I must update the firmware first if I use your boot image..?
 

ctrej

Senior Member
Jun 19, 2017
76
102
PSA: If you run magisk, do not update from within the magisk manager! If you do, your phone will be stuck in a bootloop! Just ignore the notification.

If you're a dumbass like me and installed it anyway, you can fix it by re-flashing the boot.img:
  • Connect the phone to a PC and launch your flashing tool (eg. Odin)
  • The phone will be in the bootloop and won't respond to any input and will reboot periodically
  • Hold the buttons to enter recovery (up + bixby + power) utill the phone reboots itself. In TWRP choose reboot to dowloader (direct button combination might work, but haven't tried this)
  • In odin, select bootloader (BL button) and choose the magisk-enabled bootloader that was previously on your phone (I hope you have a backup). As a reminder: the file has to be named "boot.img" and must be packed in a "boot.tar" archive to work with odin
  • Click "start" to re-flash the bootloder and the phone should reboot just fine
 

jfk_77

Member
Nov 12, 2019
18
1
PSA: If you run magisk, do not update from within the magisk manager! If you do, your phone will be stuck in a bootloop! Just ignore the notification.

If you're a dumbass like me and installed it anyway, you can fix it by re-flashing the boot.img:
  • Connect the phone to a PC and launch your flashing tool (eg. Odin)
  • The phone will be in the bootloop and won't respond to any input and will reboot periodically
  • Hold the buttons to enter recovery (up + bixby + power) utill the phone reboots itself. In TWRP choose reboot to dowloader (direct button combination might work, but haven't tried this)
  • In odin, select bootloader (BL button) and choose the magisk-enabled bootloader that was previously on your phone (I hope you have a backup). As a reminder: the file has to be named "boot.img" and must be packed in a "boot.tar" archive to work with odin
  • Click "start" to re-flash the bootloder and the phone should reboot just fine

Hi thanks for your reply!

Yes I did this procedure when I first installed the ROM. Precisely to avoid the dumbass-prone auto-update, I was rather wondering how the dev followed the updates of Magisk since (as I understand it) a magisk build is linked to a S10 firmware. I guessed that once a new build gets out, they don't update the previous magisk-enabled bootloader to keep up with Magisk updates. So if I want to upgrade Magisk, I necessarily need to change the whole system/firmware.

Am I clear? :)
 

jfk_77

Member
Nov 12, 2019
18
1
To upgrade magisk you have to wait for the developers to build a new boot.img file. I don't think you need to update anything else.


I'd like a confirmation of your intuition. Mine tend to differ since the boot images are entitled (for instance) as such:

magisk_boot_beyond0_ctf3_rc2.img.xz

My interpretation being: it is the newest build of Magisk at the time CTF3 was realeased (and not the current build of Magisk for CTF3 firmware).

Similarly magisk_boot_beyond0_dtk9_v1.4.img.xz should be used for DTK9 firmware even if we don't really know what version of Magisk is included.

So this is a bit unclear. Obviously we still can build the image ourselves but I wanted to know beforehand if there wasn't a quicker way.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 59
    - - - - - -
    This project provides LineageOS with SELinux for the Samsung Galaxy S10e (SM-G970F, beyond0lte), S10 (SM-G973F, beyond1lte) and S10+ (SM-G975F, beyond2lte).
    - - - - - -


    lineage_17.1_banner.jpg

    FEATURES

    We provide a secure and up to date ROM, check the Lineage Trust status of your phone!

    Secure ROM

    • Fine-grained SELinux policy
    • Latest 4.14 Linux Kernel release
    • Improved performance
    • Wireguard support
    • USB restrictions
    • AES-256-XTS File Based Encryption (FBE)
    • Signed with developer keys

    Nice features

    • FDroid and AuroraStore preinstalled
    • Bluetooth phone calls

    lineage_version.png
    lineage_trust.png


    KNOWN ISSUES

    Don't be scared by the "BETA" label. Our ROMs are always rock solid.

    • Some audio effects are missing
    • Miracast not working
    • Wideband SCO
    • IMS not working (No AOSP solution yet)

    Some minor issues are described in the FAQ below.

    DOWNLOAD

    You can download the latest version under the following links:

    S10e
    S10
    S10+


    INSTALLATION

    Put the zip file of the ROM on your external SD card boot into recovery. If you use our TWRP recovery, you should use that one to flash the ROM.

    Make sure you select: Zip signature verification.

    This will verify that the signature of the ROM will match the one in TWRP recovery. A more detailed step by step description is in the FAQ below.

    SECURITY ADVICE

    Don't flash Magisk modules or anything else which sets SELinux to permissive or you open your device for malware!
    Do not flash Multi Disabler on this ROM!


    What a Wurst!

    This ROM is developed by derf elot, linux4 and modpunk

    Contributors
    modpunk, derf elot, linux4
    Source Code: https://github.com/whatawurst

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.14.236
    ROM Firmware Required: XXSBFUF3
    Based On: LineageOS
    26
    REQUIRED FIRMWARE: XXSBFUF3


    CHANGELOG


    2021-07-23 | 2.2
    • Update to Linux 4.14.239

    2021-06-23 | 2.1
    • Update to Linux 4.14.236
    • Fixed GPS
    • Improved autobrightness (Thanks to linux4)

    2021-06-07 | 2.0
    • Added support to disable fast charging
    • Kernel fix to disable the touchscreen during handheld phone calls
    • Improved auto-brightness
    2020-12-17 | 1.4
    • Add support for glove mode

    2020-10-26 | 1.3
    • Update to Linux 4.14.206

    2020-10-26 | 1.2
    • Update to Linux 4.14.202
    • Added Seedvault (Video)
    • Fixed bluetooth regression
    • Fixed NFC service registration (SELinux denials)
    • Fixed camera issues
    • Fixed LineageOS recovery

    2020-09-11 | 1.1
    • Update to Linux 4.14.196
    • Added Kernel changes from CTG4 (fixes usb audio issues)
    • Improved DT2W support (thanks linux4)
    • Fixed camera access to some sensors

    2020-08-08 | 1.0
    • Update to Linux 4.14.192
    • Performance improvements
    • New thermal HAL for better overheating protection
    • Fixed light sensor auto-brightness
    • Fixed extended-length NFC (required for ePerso App)

    2020-07-13 | RC2
    • Update to Linux 4.14.188
    • Fixed reboot issue with new Power HAL
    • Fixed crash issue with power HAL
    • Update to latest Security release
    • Removed su for adb root

    2020-07-06 | RC1
    • Update to Linux 4.14.187
    • Performance improvements (new power HAL)

    2020-06-17 | BETA3
    • Update to Linux 4.14.184
    • Update to Wireguard 1.0.20200520
    • Fixed HDR support
    • Upstreamed vibrator service implementations

    2020-05-20 | BETA2
    • Update to Linux 4.14.177
    • Added Wireguard support
    • Added support for L1 widevine security level (Netflix etc.)
    • Added in-screen fingerprint support for S10(+)
    • Added "Wireless Powershare" support
    • Get the full list of sensors working, including tilt, rotation_vector, game_rotation_vector and pick_up_gesture
    • Fixed USB tethering
    • Fixed wifi hotspot
    • Fixed proximity sensor
    • Fixed phone calls over bluetooth
    • Fixed phone off charger with nice animation now

    2020-04-14 | BETA1
    • Update to Linux 4.14.175
    • Added magisk building support
    • Added USB Trust HAL
    • Added "Always On Display" quick setting tile (merged upstream)
    • Fixed performance issues
    • Fixed video calls (e.g. in Signal)
    • Fixed proximity sensor
    • Fixed significant motion sensor

    2020-04-05 | BETA0.1
    • Fixed Play Store
    • Fixed permission list
    • Added missing vendor properties
    • Fixed product definitions

    2020-04-03 | BETA0
    • Initial release


    OUR UPSTREAM EFFORTS

    21
    Features + Known Bugs Summary:
    This ROM does already support most features of the hardware. If you need specific features, please check the list below. Each feature was manually tested, so it is possible that it does not match your experience with the ROM. In this case please tell us, see the "Getting Help" section at the end of this post.


    Ratings Description
    • ++ perfect (in depth tested, performs like stock or better)
    • + good (lighly tested only or has minor flaws but is good enough for normal use)
    • o ok (can be used with some limitations)
    • - broken (doesn't work at all)
    • x not supported (unlikely to be implemented, relies on samsungs closed source code)
    • ? can't test, please give feedback

    Performance
    • ++ geekbench 5 score: 2267 (gsmarena stock: 2141)
    • ++ antutu v8.4.1 score: 403909 (gsmarena stock: 389694)

    Speed (values in MB/s, sr =seq. read, sw = seq. write, rr = random read, rw = random write)
    • ++ internal SD 128GB
      • AndroBench5: sr 815.0, sw 193.1, rr 138.7, rw 24.7 (= notebookcheck stock)
      • CPDT 1GB: sr 735.3, sw 139.2, rr 19.2, rw 4.52
    • ++ external SD, 128GB Samsung Evo Plus
      • Androbench5: sr 68.2, sw 34.5, rr 5.75, rw 2.56
      • CPDT 1GB: sr: 75.2, sw: 29.5, rr: 4.08, rw: 1.71
    • ++ USB 3.0 MTP, sw 105MB/s (PC CrystalDiskMark -> mtpdrive -> internal SD)
    • ++ USB 3.0 OTG, sw 105MB/s (Sandisk Extreme 64GB -> internal SD, 10.8GB file, 102s)
    • + bluetooth file transfer, 0.1MB/s (29MB; from other phone 4m42s, from PC 5m24s) (theoretical max. is 0.3 for BLE4.0, 0.8 for BLE4.2 and 1.4 for BLE5.0)

    Connectivity
    • ++ phone calls, 3G, LTE; also with dual sim
    • ++ wifi (delivers 50Mb/s, the maximum my provider supports)
    • ++ bluetooth (file transfer to phone & pc; headphons incl. mic; speakers; keyboard incl. special keys)
    • ++ NFC (only card read tested)
    • x VoLTE

    Screen
    • + 10 finger multitouch, "high touch sensitivity" mode not available
    • ++ full brighness range available
    • ++ double tap to wake
    • + AOD works, but might be dimmer than stock and brightness cant be changed. While active the proximity sensor is used an its LED blinks dimly next to the camera

    Sound
    • ++ dual laudspeaker for media, quality as expected, high volume selectable
    • + earpiece (no in depth test)
    • + headphones (3.5mm jack) have clean audio, high volume selectable, limited to 16bit/48kHz (instead of 24bit/192kHz) possibly by ROM
    • + build-in mic, limited to 16bit/48kHz (instead of 24bit/192kHz), volume should be normal (test)
    • + headphone mic, limited to 16bit/48kHz (instead of 24bit/192kHz)
    • + some external DACs supported, limited to 24bit/48kHz; (reported by @El Dun)

    Camera (with opencamera + camera API v2)
    • ++ wide, ultrawide, front, front-crop
    • ++ PDAF autofocus, face tracking optional (main + front camera, ultrawide is always fixed focus)
    • ++ manual setting for exposure/ ISO/ shutter/ focus
    • ++ raw files option (main camera)
    • ++ optional HDR
    • + dual apperature (main camera), only manual switch (default f1.5)
    • + video up to 2160p/30fps, 1080p/30fps (all cameras should support 60fps, but OpenCamera only produces 30fps files)
    • + 1080p/240fps (main)/ 1080p/120fps (front) high speed/ slow-mo works in stock cam + GCam
    • x no 720p/960fps super slo-mo
    • x no supersteady
    • - S10, S10+: no telephoto camera (details + help wanted)
    • x S10+: no front depth camera

    Sensors
    • ++ gps, quick fix with A-GPS data
    • + fingerprint (all variants), can glitch during setup (see bug list)
    • ++ accelerometer, gyroscope, magnetometer, pressure, light (front) (all values are within tolerance)
    • + light sensor, but only the front/ under-screen sensor, not the rear sensor
    • ++ IR/RGB sensor outputs values for IR/Red/Green/Blue/Clear (test) (COM.SAMSUNG.SENSOR.LIGHT_IR)
    • ++ grip sensor
    • + front proximity (makes only one measurement per second, if you put it quickly to your ear it may touch the screen before it's turned off; reported by @Lav64)
    • ++ software sensors: step counter, rotation vector, gravity, linear acceleration, compass
    • ++ S10/S10+ heart rate/ SpO2 (confirmed by @Ned)
    • o several software sensors don't produce data, but don't do it on stock either. Affected are the IDs: PICK_UP_GESTURE, COM.SAMSUNG.SENSOR.PROXIMITY_POCKET, COM.SAMSUNG.SENSOR.HALLIC, COM.SAMSUNG.SENSOR.BIO_IR (proof thanks @Brembo109, more info from modpunk)

    Charging & Battery
    • ++ 15W quick charge
    • ++ 4.75W reverse charge (with USB OTG adapter)
    • + 7.5W+ qi-wireless charge (limited by my charger)
    • + 2.5W+ reverse qi-wireless charge (limited by the receiver IC BQ51013)
    • + low 40mW idle power consumption (details)
    • + ACCA (advance charging controller app) works with limited settings

    Misc
    • ++ all buttons, bixby can be reprogrammed (workaround for other functions)
    • ++ wired headphone buttons (pause/play, vol+, vol-)
    • + flashlight has only one brighness option (instead of 5 on stock)
    • - S10e: no fingerprint swipe up/down geture, not even with 3rd party app "Quick Fingerprint Geture"

    Known bugs:
    • when phone is shut down, it reboots instead (fixed in RC2)
    • reboot to recovery boots directly into system (fixed in RC2)
    • reboot takes long, about 30s (fixed in RC2, now it only takes a few seconds)
    • double tap to wake not always working (should be fixed in RC2)
    • holding fingerprint too long during setup can cause problems details
    • in full screen apps there may be a black bar to hide the camera cutout which can not be disabled (details, workaround)
    • high sensitivity touch screen / "glove mode" not available (details)
    • bixby-button hold-shortcut does not work (details)
    • google backup does not work with 4x4 or 5x5 pattern. This is an LineageOS issue, but important enough to deserve a note here. (details (thanks @Ivo_Todorov)


    Installation:

    How do I install this ROM on my phone for the first time?
    Below you find a brief checklist of the required installation steps. Installation is more complicated than other ROMs because we take device security very seriously. If you are unfamiliar with installing custom roms , please click the links and read the additional details there.

    • Confirm the firmware version
      • Check the top of the ChangeLog which firmware version is required for the ROM release to work well
      • Go to settings/software-update and update only if the new version matches the requirement!
      • Alternative: flash with odin/heimdall (details see below)
    • Unlock your device
      • Backup all data, unlocking will factory reset your phone
      • Enable developer mode to and enable the OEM-unlock switch there
      • Turn off device and boot to bootloader (hold VolumeDown + Bixby, then connect USB cable)
      • Follow instructions on-screen
      • Finish the initial setup after unlock. You must connect to WiFi, but can skip everything else. Do not specify a pin/pattern during setup afterwards, otherwise TWRP may cause the "try again after 86400 seconds" issue (see below)
      • Confirm in the settings that the bootloader is actually unlocked. (greyed out, telling you its unlocked)
    • Install our TWRP (official thread) | more details (thanks @AndrOdin)
      • Download our TWRP recovery and the vbmeta-disabled.img file
      • Unpack the .xz file with 7zip
      • Check integrity of TWRP (optional, but important for security)
      • Rename files to recovery.img and vbmeta.img; then pack both files together in a .tar archive with 7zip
      • Install Samsung USB drivers and odin, (direct link)
      • Start odin as admin, disable "Auto Reboot" and click "AP "to select the .tar archive
      • Turn off device, boot to bootloader and, once odin detects it, click "Start"
      • When the screen turns off, immediately hold (and keep holding) VolumeUp + Bixby + Power to enter recovery mode
      • When the secondary warning appears, release everything but VolumeUp
      • Swipe slider to allow for modification
    • Install LinageOS
      • copy the ROM ZIP file an external SD card
      • Boot into the recovery
      • Wipe cache + dalvik (wipe->advanced and select cache + dalvik)
      • Format data (wipe->format data, use the dedicated button, wipe->advanced does not work)
      • Flash the ROM (install -> select storage -> micro SD card and select the .zip file)
      • Optional: Flash GAPPS (e.g. OpenGAPPS)
      • Reboot to system

    How do I update LineageOS?
    Updating LinageOS is a lot less work and you can keep all user data. The process is similar to the last part of the installation:

    • Backup all important files optional, but very helpful if something goes wrong)
    • Remove any pin/password/pattern to prevent "retry after 86400 seconds"
    • Copy the ROM ZIP file an external SD card or internal storage; download the new firmware files to PC (if needed)
    • Boot into the recovery, do not reboot until you've installed the new ROM and firmware
    • Flash the ROM (install -> select storage -> micro SD card and select the .zip file)
    • (Optional: Update GAPPS to the latest version)
    • Wipe dalvik and cache
    • Reboot to download
    • Flash new firmware with instructions below
    • (Optional: if you use Magisk, flash the new BOOT file. You can also do this in previous step instead of using Stef4n82's "BL.tar" file.)
    • Reboot to system


    How do I update the firmware?
    On the stock ROM you can update from the settings menu. You can't do this on lineageOS (yet), so ypu need to use use Odin or Heimdall instead.

    How do I update the firmware manually?
    Thanks to @Stef4n82's new instructions and repacked firmware files installation is easier than ever. Below you find a copy of his post:

    If you use Heimdall:

    1. Download the latest firmwarepackge for your device: "G97?F_Firmwareupdate_Heimdall_????.tar.gz"
    2. Extract the package
    3. Flash the firmware files with this command:
    Code:
    heimdall flash \
        --BOOTLOADER sboot.bin \
        --PARAM param.bin \
        --UP_PARAM up_param.bin \
        --CM cm.bin \
        --KEYSTORAGE keystorage.bin \
        --UH uh.bin \
        --DTB dt.img \
        --RADIO modem.bin \
        --CP_DEBUG modem_debug.bin

    If you use Odin:
    1. Download the latest firmwarepackge for your device: "G97?F_Firmwareupdate_Odin_????.zip"
    2. Extract the package and you will get an AP.tar, a BL.tar and a CP...tar.md5
    3. Flash the 3 files with Odin (tested with latest Odin 3.14.x)

    You can download the repacked firmware from the links below.
    1. S10
    2. S10e
    3. S10+

    If you don't want this repacked firmware packages and want to download the whole firmware by your own. Make sure if you flash it via Odin that you use this files:

    1. From AP_G97?FXX*.tar.md5 take the dt.img and create a new AP.tar
    2. CP_G97?FXX*.tar.md5
    3. Extract BL_G97?FXX*.tar.md5 and create a new BL.tar without the vbmeta.img.lz4


    Try again after 86400 seconds?
    With newer version of the Samsung blobs, if you unlock the storage (/data) with TWRP (ie. you enter your pin/password/pattern in TWRP), the trustzone thinks it is a failed attempt and will lock the storage unlocking for 1 day (86400 seconds). To prevent this do not enter your pin (press cancel) and you can still flash an update. If you tripped the trustzone you can either wayt for 1 day to unlock your device (do not power it off) or try rebooting the phone a few times (thanks @Stef4n82), or this slightly more detailed guide (thanks @Exilion90)

    You can prevent this completely by removing any pin/password/pattern before entering recovery. This does remove all stored fingerprints, so you'll have to set the up again after the update.



    3rd Party Software:

    How do I install Google apps?
    You can download and install the Google Apps from Open Gapps Project. You need ARM64 and 10.x. We suggest to always use the pico package. If you need additional apps you find them in the Play Store.

    Put the Open Gapps ZIP file on your SD card and flash it directly after you flashed LineageOS and before the first boot!


    Can I use GPay? What about other banking apps
    GPay as well as some other banking apps check if the device passes safetynet and will not start if it doesn't. Safetynet fails when the bootloader is unlocked and therefore this ROM will not run GPay and other applications that need it. This official LineageOS statement explains why safetynett will never by bypassed (by default).

    Safetynet used to be easy to bypass with Magisk, but since an Update eralier this year Google uses the TPM module and that can't be circumvented easily. However there might be a workaround with "MagiskHide Props Config", please check out this post and this one. (thanks @Stef4n82) Please note that this has not yet been tested and we can not provide any support. If you got it working on your device, please share how you've done it so we can add it here!

    How do I get MicroG with this ROM?
    MicroG is an open source alternative to GAPPS. , but unfortunately not recently updated and therefore not recommended.

    If you want to install it anyway, read this guide by @JoeRifle and this post (appendum) by @ned14 . Update: It has been reported that the new MicroG version works without issues. (thanks @ichmyselfandi)


    Does this ROM have root?
    Not by default. If you need root (eg. for AFWall) you can get it through Magisk.

    How do I install Magisk?
    Important security Advice: Don't flash Magisk modules or anything else which sets SELinux to permissive or you open your device for malware!

    Option 1 (recommended):

    • Download the boot image for Magisk: S10e -- S10 -- S10+
    • Verify the integrity of the file -> See INTEGRITY
    • Unzip the boot image using xz or p7zip
    • (Needed for Odin) Rename the file to boot.img and use 7zip to pack it into a .tar file
    • Flash the boot image to the BOOT partition using Odin, Heimdall or TWRP
    • Install https://******************/

    Option 2:


    Which camera app do you suggest?
    OpenCamera:
    Great open source app that supports a lot of the camera's features with the camera API v2 (select this option in the settings):
    • All cameras supported (except telephoto, this is a issue with the ROM)
    • Manual change of exposure, aperture, shutter speed, ISO
    • The (main) developer uses an S10e himself so you can expect good HW support :p
    You can get it from F-Droid or Play Store

    GCam Variants:
    There is no "official" GCam for this ROM, but there are some that work. Please read this excelent post by @ned14 for more details. The current recommendation is "GCam_5.1.018.177470874.41362666_IDan_N6_3.5_fix.apk" from (IDan). You need GAPPS, microG (post) or the Google Service Framework(post).

    In comparison to OpenCamera it sacrifices manual controls + extra lenses for:
    • simpler user interface
    • better single-shot HDR
    • better panoramas + photospheres
    • SlowMo video (1080p @120/240fps)
    I've also written a more detailed comparison. You can have both camera apps installed at the same time, so you can always choose the better one depending on the scenario.


    Getting Help:

    General:
    Before you post, please check this FAQ, use the search function and skim the few last pages of this thread. We want LinageOS to work on your device, that's the whole point of this thread, but this way you can get the fastest help. If you did not find an answer, feel free to ask here :) We do this in out free time and it may take us some time to answer, so please be patient.

    How to report a bug?
    To fix any bug we first have to be able to reproduce it. Please include all relevant information:
    • device (S10e/S10/S10+)
    • ROM version
    • is gapps/ microg/ magisk installed?
    • steps to reproduce the issue

    When in doubt it's better to include to 0much information than too little. A good example is @Sheffield Steve's bug report. Check out Simon's "How to Report Bugs Effectively" to write even better reports (and thus get better help).

    How to create a logfile?
    To get an even better insight into your issue, a logfile can help us a lot. On Android this is called "logcat". Short logcats are best. They contain less fluff which makes finding the issue easier. Here are the steps how to create a log with adb:

    • install adb drivers
    • open cmd and navigate to the adb file eg. cd C:\Users\<user>\Desktop\platform-tools
    • Connect your phone via USB
    • Select "Allow USB Debugging" on the popup on the phone (see below how to activate it)
    • Clear the log using: adb logcat -c
    • Start loggingwith: adb logcat | tee beyond.log
    • Reproduce the issue
    • Stop logging by pressing CTRL+c
    • Send us the log (in a PM)

    How do I enable USB Debugging?
    To enable USB Debugging you need to do the following steps:

    • Go to Settings -> About Phone
    • Look for Build number
    • Tap on Build Number several times till you get the message that Developer Options have been enabled
    • Go to Settings -> System -> Advanced -> Developer Options
    • Enable USB Debugging


    About this FAQ:
    This FAQ is originally written by modpunk and partly maintained by me (ctrej) to reduce modpunk's workload. We try to keep the FAQ as up-to-date as possible, but it may lag a few days behind. Please read the last posts in this thread for latest information.

    Changelog:
    20200813 (v1.0)
    • update: this changelog, now with ROM version at time of posting and a hide section for older changelogs
    • update: firmware update section (thanks @Stef4n82!)
    • update: ROM update section
    • update: getting help section, rewritten for clarity
    • update: proximity sensor, slow sample rate (thanks @Lav64)
    • update: audio section with my test and @El Dun's report
    • add: gpay/safetynet explanation
    • change: link formating to stay under the 30k character limit

    20200809 (RC2)
    • update: audio output with limited frequency range, limited DAC support (thanks @El Dun)
    • update: double tap to wake works well, used it for a few weeks now without issues
    • update: "86400 seconds" section (thanks @Exilion90)
    • add: links to each version of this FAQ, just click one of the datecodes
    • add: ACCA to feature list
    • add: ADO works kinda
    • add: dual sim to feature list (thanks @Exilion90)
    20200802 (RC2)
    • update: microG section (thanks @ichmyselfandi)
    • update: unlock instructions, setup with wifi required (thanks @Lunat1c)
    • update: "86400 seconds" section (thanks @Lunat1c & @Stef4n82)
    • add: gapps/ microg/ google framework requirement for the GCAM (thanks @KanyT & @ned14)
    • add: bug google backup pattern with 4x4 or 5x5 pattern (thanks @Ivo_Todorov)
    • fix: twrp "more details" link (thanks @Lunat1c)
    20200719 (RC2)
    • update: rgb light sensor, all channels working
    • update: software sensors don't output values on stock either (thanks @Brembo109)
    • add: gcam information (thanks @ned14)
    • add: grip sensor
    • add: microg appendum (thanks @ned14)
    • add: workaround for black status bar in fullscreen
    • add: bug no glove mode (thanks @raggatip)
    • add: bug bixby button hold shortcut (thanks @Lav64)
    20200713
    • update: feature/ bug list (previously called working/ not working) with fixed from RC2
    • update: instructions for microG (thanks @ned14)
    • update: magisk install instructions
    • update: wireless power share works fine, the phone just didn't like the synthetic load I used for testing
    • add: black bar on camera cutout in fullscreen apps (thanks @Sradgads)
    20200707 (RC1)
    • update: section "get help" with copy & paste template
    • update: font for cmd to Courier New
    • confirm: removing pin/password/pattern solves the 86400 second wait delay (thanks @fishnetfancy)
    • add: working/not working section
    • add: this changelog
    • add: telephoto lens not working (thanks @Ned)
    • add: several RC1 issues (thanks @angela5246)
    • add: vbmeta_disabled note to firmware instructions (thanks @okloloi)
    • add: reminder to update Magisk alongside lineage (thanks @fishnetfancy)
    20200705 (Beta3)
    • first FAQ update by me (ctrej)
    • change: order to the "natural" installation flow
    • change: install section into a more detailed checklist (thanks @AndrOdin)
    • add: sub-sections (install/ 3rd party/ support)
    20
    JFYI: I'm working on LineageOS 18.1 however I didn't have had time to work on it the last two weeks. Next week will be better.
    17
    What is difference between this and Ivan's lineage os?

    The most obvious one is that we provide SELinux enforcing and care about security and privacy. For the rest I can't give you an answer as Ivan doesn't want to release the source of his device tree. It would be great if Ivan would join our effort and contribute.