• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][FINAL][7.1.2][UNOFFICIAL] LineageOS 14.1

Search This thread

k2-18b

Member
Nov 19, 2020
10
0
Is Installation on f2fs-System-Partition possible?

Does the ROM support Installation on f2fs-System-Partition? Instead of Ext4. I´d like to try out.
 
Last edited:

k2-18b

Member
Nov 19, 2020
10
0
SWAP and ZRAM onboard?

1.
Since Android 4.4. ZRAM is supported as a Kernel Feature, ZRAM is told (i´m not an expert) to be a compressed Swap File inside RAM.
Does the Build include ZRAM?
2.
Is it possible formatting an external SDCard with f2fs, and using it or a Part of it as Swapfile? I think yes. How much faster would LineageOS than run? I´d like to test. :mad:


Sounds like slightly more is used in /system than I'd expect, but entirely possible (I haven't used this particular ROM). You could try removing some apps from /system that you don't need.

It is possible to adjust the size of /system, have a look at the updater.sh in the zip file. Problem is that if you increase the /system partition by 500MB then you're decreasing the size of your /data partition by 500MB as well :) Note that this will also wipe /data.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 24
    Code:
    /*
    * Your probably long dead warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */

    LineageOS is a free, community built, aftermarket firmware distribution of Android 7 (Nougat), which is designed to increase performance and reliability over stock Android for your device.


    This thread is organized into different posts so that people dont quote the whole OP.
    Please read all the posts and updates, before flashing.


    Changelog Summary:
    For full changelog follow the link.

    #FINAL: 28 Jan 2018
    Repo synced with latest LineageOS 14.1 sources.
    Updated system webview to 64.
    Added postinstallzip due to kernel not being flashed.
    Added Magsik 15.3 support in ramdisk.

    #4: 14 Nov 2017
    New feature: UA:CMA
    Added back Device Settings.

    #3: 14 Nov 2017
    Switched to a more stable kernel with improvments
    Fixed Camera
    Fixed Bootanimation

    #2: 12 Nov 2017
    Enabled OpenGLES 2.0
    Fixed Audio/Video Playback.
    Fixed Webview.

    #1: 11 Nov 2017
    Initial build.

    Latest Download:
    You need to flash lineage-14-postinstall.zip after installing the ROM, or else it wont boot.
    For some reason ramdisks arent being flashed.. and I cant be bothered to figure out why..


    lineage-14.1-20180127-UNOFFICIAL-galaxysmtd.zip
    lineage-14-postinstall.zip


    Older builds



    XDA:DevDB Information
    GalaxyS1 Resurrected Nougat Project, ROM for the Samsung Galaxy S I9000

    Contributors
    (°_o), ColdwindOfnowhere, xc-racer99
    ROM OS Version: 7.x Nougat
    Based On: LineageOS

    Version Information
    Status: Beta

    Created 2017-11-11
    Last Updated 2017-11-14

    XDA:DevDB Information
    GalaxyS1 Resurrected Nougat Project, ROM for the Samsung Galaxy S I9000

    Contributors
    (°_o), ColdwindOfnowhere, xc-racer99
    ROM OS Version: 7.x Nougat
    Based On: LineageOS

    Version Information
    Status: No Longer Updated

    Created 2017-11-11
    Last Updated 2018-01-28
    5
    Full changelog: build #2

    Fixed Audio/Video playback

    I had to remove ffmpeg codecs as they were causing hardware decoding to not work.
    Hardware decoding is working fine and 720p playback is smooth too..
    I've tested without bigmem mode.. I havent implemented bigmem libs for 720p playback.
    So please try without bigmem before reporting issues with it.


    Fixed Webview

    AOSP Webview was somehow not working on our device.. as pointed out by @MYEUHD
    The solution he linked was to revert to older webview.
    But that is outdated and unsafe so I tried with latest Android System Webview.
    It seemed to work so I set it to default.
    I havent tried but we can also use Chrome as our Webview..

    Switched to OpenGL 2.0
    We were stilling using OpenGL 1.4 for rendering.. this shouldnt affect much.. but animations should be smoother
    Since we no longer get Shader errors with OpenGL 2.0
    Let me know if you find any difference performance wise compared to build #1.

    Downloads are in OP.
    5
    Full changelog: build #3

    Switched kernel from @Coldwindofnowhere to @xc-racer99
    I think xc-racer99 kernel has better memory management. since the lowmemory killer doesnt kill many processes..
    However I did make some changes to it.
    • Disabled CMA
    • Enabled and set zRAM to 1/4 of total memory
    • Some kernel build optimizations.
    Note that.. this kernel doesnt have BigMem Support so wer'e stuck with 383MiB ram for now.

    Fixed Bootanimation
    Yeah.. that was a my mistake.. err..
    At least you know its booting now.. but since we use pre-odexed ROM first boot shall be done in 5 minutes now..

    Fixed Camera
    Taking pictures should work now. Video recording is broken.. It needs to updated for Nougat..

    Added Magisk in ramdisk
    Latest version 14.0. Just install magisk manager AND DONT TRY TO PATCH BOOT.IMG..
    We use very differnet system for boot.img and ramdisks..
    I will try to update Magisk to latest version.

    Fixed a big mistake in updater
    https://github.com/galaxys1-nougat/...mmit/a6f51178503a01f6b1e7b0c8222e875392af8a8e
    Flashing boot.img would actually result in wiping it in some cases..
    If you had troubles installing this ROM or any ROMs in the past.. this might be the case..
    5
    Full changelog #build 4

    New feature: UA:CMA
    Allows user or any userspace program to allocate and deallocate CMA memory.
    So what does that mean for user.. you can control when memory for 720p decoding
    or Camera is allocated and when it's freed to be used by other apps.
    It's kind like bigmem but without the reboot.

    A big thanks to @xc-racer99 for implementing error handling and entry in Device Settings.
    A detail guide about UA:CMA will come soon.

    Added back Device Settings.
    Previously it was missing due to build errors. I have fixed them and now you can change tunables you had before in Device Settings.
    4
    Status Update:

    Project discontinued.
    Status Update:
    You can skip this paragraph if are not intrested in my long story cut short.

    So I have been trying to fix stuffs which means.. rebuilding and flashing the ROM.
    Wiping data .. getting logs.. testing if something works.. Repeat

    I hadnt really used my Galaxy S1 phone.. It was just lying around a corner of my table getting dust.
    Until one day I thought, let's build Oreo for this old time phone.. turns out the battery was RIP due
    to not charging it for so long.. so I got a replacment battery then booted to see cm-14.1 build by
    Coldwindofnowhere and missing IMEI which I sucessfully restored after creating a thread here.
    Again thanks for that to @xc-racer99 and @MYEUHD

    So I started out device trees and repos based on Coldwindofnowhere and xc-racer99
    and made it compatabile with Oreo. And thanks to rInanD0 I was able to pick stuffs necessary on
    kernel side.

    Then me and @xc-racer99 discussed some stuff and I picked changes from Unlegacy-Android gerrit to properly do some stuff.. I fixed lots of stuffs.. but I couldnt get the display to initialize... so I decided
    to wait for Unlegacy-Android for their take on Galaxy Nexus which shares same GPU as us to bring up Oreo first.

    In the mean time, I thought again.. why not build Nougat for now.. so I again setup device tree and repos for
    nougat. and we are here..


    Okay so I havent really used my Galaxy S1 let alone this ROM.
    This ROM does seem fast while moving around just after a first boot.
    And really I hadnt installed or used any apps besides the one that came with LineageOS.

    But today while trying to fix Camera, I had to actually take photos. Oh, and the reason camera was not working
    was due to I had disabled building of Camera HAL in Oreo which stuck around... big derp

    So camera preview was working now.. Snap camera wasnt savinf photos at first..
    so I thought to install Open Camera.. I installed F-Droid.. then Open Camera..
    Then I clicked some photos which seemed to be saved.
    There were a lot of photos created so I decided to delete them.

    But Files app wasnt deleting them.. must be a permission issue?
    So i installed a file manager from F-Droid and deleted the photos.
    Good enough.. then I thought I need to download these apps again after a data wipe..
    Lets backup them.. so I installed an apk backup again from F-Droid.


    While it was downloading.. BAM Screen went all BLACK.

    I tried clicking home button but nothing.. then I clicked power button nothing.
    Then I hold power button.. i got the options...
    Now I was reminded of this bug which has been around since Lollipop? or Marshmallow days..

    Screen going all black.. back then Coldwindofnowhere predicted it might due to out of memory issues..
    And he is right.. I had adb running so I checked free memory and swap.. The swap file was and memory was nearly full.

    I checked dmesg for logs... then I saw lowmemorykiller killing all kinds of stuff.. but there was only one time it killed this..
    Code:
    lowmemorykiller: Killing 'system:ui' (5642), adj 902,

    And thats the reason for the black screen.. Now we all know this device doesnt have much memory.
    So the option would be to not install many or any apps.. on this option..
    Ofcourse I could try to get CMA working properly.. which adds just around 70-80mb I guess..
    And we could just white list system ui to not get killed.. but then it would kill other important processes..

    So I've decided to stop working on Nougat. I dont wanna give people false hope of *stable* nougat.
    I will still upload a build with Camera fixed.. Well video recording still doesnt work.. Looking at logs.. i need to resurrect
    the old way of video buffer. which got removed in Nougat.

    And while Project Nougat is offically discontinued, Project Oreo is still alive just paused.
    I will at least get Oreo bootanimation on this device.

    Thanks for trying out this short lived nougat ROM.