[ROM] [Final] LineageOS 19.1 UNOFFICIAL - 1.6 [2022-09-18]

Search This thread

Guntram

Senior Member
Oct 30, 2010
117
13
Anybody else having problems with GoogleMaps? I'm not able to see my planned (?) route, because the last suggested last destinations won't close up :-(. Deleting them isn't possible either (under options), as the corresponding button is not visible...

Tried vers. 1.3 and 1.6, using MindTheGApps as recommended. Did also full wipe (including internal storage) and reinstall...

Any ideas?
Solved the issue. Seems to be related to bad gps fix at the beginning. Sorry for bothering you...
 

android666

Senior Member
Jun 19, 2010
89
18
Thank you petefoth for getting me back up and running. Just to follow up on the original problem: For me, I experienced the network disconnect/reconnect loop issue on 1.4, 1.5, and 1.6. 1.3 works fine though, so I'm sticking with that. Now I begin the arduous work of resetting all of my 2FA logins to all of my online accounts :/
thanks for finding workaround with 1.3, my network also flapping with 1.6
Unfortunatelly 1.3 does not support ext4 on externalSD (my is 512GB - for better space management ext4)
 
Last edited:

android666

Senior Member
Jun 19, 2010
89
18
I'm confused a bit. Any idea how to decrypt android ? I'm on 19.1 and I have no idea why it's encrypted. TWRP decrypt it without problem, but I do not want have phone encrypted (maybe I clicked somewhere, overlooked something). Maybe I save some battery/cpu without crypto,

Update: I decrypted phone by using (it does not mean it's the best way, I believe there is far simpler and better way...):
- installed TWRP
- full TWRP backup (+ also backup internal data to SD - done when phone is on)
- wipe all (including internal); Format data ("fastboot format userdata"; or TWRP change to ext2; then back to ext4 in Wipe Advanced)
- install desired ROM;
- restore DATA from previous TWRP backup; restore internal SD (could be after phone start);
- install MagiSK'
- install https://forum.xda-developers.com/t/...ncrypt-disk-quota-disabler-11-2-2020.3817389/
- reboot

I'm not happy I had to use Verity module (disabling Android verified boot) , but without it I have bootloop - no idea why, but would like to live without it. Maybe one day ... :)
 
Last edited:

gladykov

Senior Member
Jul 12, 2010
75
14
This is so strange. I'm on Lineage 20, and just encountered issue, with not being able to connect to GSM network which was also distrupting WiFi. Had to restart few times, and last restart I just waited little bit longer. What is funny, I'm on Claro network in Brasil.

Also I noticed strange hangs from time to time, when screen does not want to turn on.

Is it slowly dying, and previous version can handle it better?

Out of curiosity - is it possible to downgrade painlessly from 20 to 19.1 (1.3) if this will occur again?
 

gladykov

Senior Member
Jul 12, 2010
75
14
After installing MindTheGapps, most of my applications are running fine. But few of them show an error when I try to open it. "won't run without Google Play services, which are not supported by your device
Saw the same in one app I could really use, but on Lineage 20 with even more fresh version of MindTheGapps. I miss Open Gapps which were not refreshed since February
 

Top Liked Posts

  • There are no posts matching your filters.
  • 32
    LineageOS 19.1 for Sony Xperia XZ1 Compact


    logo.png



    RELEASE

    This is an alternative ROM for the Sony Xperia XZ1 Compact, offering several privacy features.

    Please report any issues you observe apart from the ones listed below. Logs are needed for me to fix anything (preferably dmesg and logcat). I can't test NFC very thoroughly, to please report your findings.

    FEATURES
    • Signed with dev keys
    • Up-to-date kernel
    • WireGuard kernel support
    DOWNLOAD

    You can download the latest ROM releases here: https://androidfilehost.com/?w=files&flid=333224
    Latest TWRP: https://dl.twrp.me/lilac/

    Check the ChangeLog below for firmware requirements!


    INSTALLATION

    Before first install: flash and boot into TWRP, format data, reboot to recovery and wipe all internal partitions.

    After above step / any subsequent dirty flashes: Boot into recovery, put the ROM, GApps and root (if needed) on sdcard and flash.

    Note: There is not going to be a LOS su addon anymore. If you need root, flash a root manager of your choice. No guaranteed support from LOS for this.

    When updating from previous builds, simply dirty flash the ROM, together with any GApps and/or other modifications - addon.d will not work due to currently unavailable TWRP decryption.

    Recommended GApps: MindTheGapps-12.1.0

    KNOWN ISSUES
    • Stock camera is not working anymore due to incompatibility of stock library (libimageprocessorjni.so) with new libgui
    • You tell me...
    Contributors
    derf elot, modpunk, Rooted_Ansh

    Thanks to the yoshino testers (let me know if I forgot to add you)
    coin3x, feduss, GiaSen, Gizanagi, hsheemi, kaancaliskan, sohrab1985


    Source Code
    https://github.com/whatawurst/android_device_sony_lilac
    https://github.com/whatawurst/android_kernel_sony_msm8998

    Rom Information
    ROM OS Version:
    Android 12
    ROM Kernel: Linux 4.4

    Version Information
    Status:
    Stable
    Current Stable Version: 1.6
    Stable Release Date: 2022-09-18
    7
    I have constant freezes with chromium based browsers on 1.5. Anyone else have this problem?

    Great to see this rom continuing to be updated, however is there any information on what has changed between 1.3 and 1.4, and then to 1.5? Is @No1Alien able to update the posts on the first page with relevant info? How are people finding out about the new releases, other than manually checking the AFH page each day?

    same here chromium browsers freeze and sync bookmarks is not working in chrome, and i saw the same report in xz1 thread, i wonder should i go back to 1.3 that worked fine or 1.4 that i never tested?

    Chrome, opera, brave are all freeze force quit. System WebView Downgrade & upgraded still no luck. The stock browser is fine thoo.
    The battery life is crazy best for S0-02K.

    Well, seems there are now only 2 main SUPL providers: Google & Vodafone. We know it, bad gov guys know it. So what is the difference between them? Also at least Google was built for world wide coverage in mind. So unless someone is willing to create supl server and serve this data https://cddis.nasa.gov/Data_and_Derived_Products/GNSS/broadcast_ephemeris_data.html with this protocols https://en.wikipedia.org/wiki/Assisted_GNSS#SUPL or at least spawn some deanonymizing proxy like this https://github.com/tajuma/supl any change will be just virtual change. But why not change gps.conf directly in the repo then, if gps.conf modification can block sending geo data?

    Hi all, derf just built 1.6, please have a try. Issues like chromium/WebView should be fixed. GPS config is updated as well.
    5
    Nice to have a separate LineageOS 19.1 for XZ1C thread, but it might be nice to credit this ROM to @derf elot more explicitely in the OP, since it seems to be mostly his work.
    No worries, I asked @No1Alien if he could open the thread since I don't have much time to maintain it ;)
    5
    I've made an unofficial build of LineageOS for microg based on this ROM. It's had basic sanity testing: calls, sms, wifi, camera, mobile data all seem to work.

    Build is available on AndroidFileHost:
    https://www.androidfilehost.com/?fid=15664248565197203978

    Feedback welcome, either here (if @No1Alien doesn't mind), by PM, or at https://github.com/petefoth/unofficial-l4m-builds/discussions (where issues can be raised if needed).
    4
    Its working for me mate, this lineage build + microg. Microg is installed through the microg4magisk revived module, while the signature spoofing is granted through lsposed and the FakeGapps 2.0 xposed module. Then you install the backends and its working perfectly.
    Working for me too :)
    If someone is interested, I used:
    Thanks a lot to the devs to get another Android release on the great XZ1C!