ROM / Firmware/ Brick Recovery for 7" Android Head Unit AC8227l YT9217 YT9218 1/16GB

Search This thread


Nov 25, 2022
Kyocera Zio M6000
MOD Translation: What is the name of the model on the green label on a white connector.? I can't see it in the picture ما هو اسم النموذج على الملصق الأخضر على كونكتور أبيض.؟ لا أستطيع رؤيته في الصورة


  • ٢٠٢٢١٢٠٧_١٩٢٤٣١.jpg
    1.2 MB · Views: 17
Last edited by a moderator:


Senior Member
Jun 6, 2012
I see you haven't read the any previous posts. The login is xyauto pass 123456.
what to choose and how to install you have described in the previous posts in this thread


Senior Member
Jun 6, 2012
Do you have screenshot of your original system info? If you had android 8.1 you should use only 8.1 firmware, if you had 9.1/10 you should use 9.1/10 firmware. To downgrade or upgrade you need suitable preloader for it. Wich you have different motherboard than mine so i dont know wich one is appropriate for you (flashing with wrong preloader you'll need to use testpoints to revive your motherboard)


Nov 25, 2022
Kyocera Zio M6000
مرحبا، لديHello I have been logged into the site I will try today to try thank you🌹🌹


  • Screenshot_٢٠٢٢١٢١١-١٤١٩٣٦_Chrome.jpg
    242.8 KB · Views: 32


New member
Dec 11, 2022
Good afternoon!

I bought a volvo xc90 stereo DAWEW-8719T 7.1 T3 2G+32G, the firmware is damaged.

Does not work properly.

Processor type QuadCore-T3

Android Version: 7.1.1

MCU 5.3 19-23-833-E43101-171107

System V8.3.2-20181215.170525_PH23-1280-Idrive-N6502

I can't choose an auto type, there is no can bus steering wheel. No FM radio.

Can they provide new update or volvo xc90 frimeware?

Thank you from Hungary


Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Same, I used supermod8 package to get twrp recovery and magisk root, just by flashing package thru Twrp recovery.

    But after rooting the system took much longer to load, not sure why and i had couple other issues after.

    Anyway, twrp recovery has built-in 'File manager' so you can explore and modify whole system files without root.
    So im not using magisk root anymore, just deleted apps that i didnt need thru twrp 'file manager'.

    Lastest addon from xyauto, adds 21 themes to choose from.
    upload via usb by 'android upgrade' thru car settings.
    I used twrp from the zip/rar extremeMod android 8 package. It's on the first page. I think there's also instructions for rooting via magisk manager. The files and the app L_Speed.apk are on the 4PDA website. There's a lot of useful stuff there. The site is in Russian, use a translator. You must be registered to download the app, firmware, etc.
    I were not able to use supermod8, as i already posted in that thread i get a bootloop right after installing the rom on first boot
    i think is just a waste of time trying to get supermod8 working.

    I didn't mention it earlier, but I believe that it's worth to flash your own backuped metazone.bin when flashing different firmware, because I think that metazone contains a lot of settings dedicated to a given motherboard like buttons, touch, screen etc.

    If You are looking foor 'speed' i remember that ExtremeMod said that stock android 6.0 runs fastest.
    But it requires downgrading preloader.
    Of course old Os comes with outdated can data base, oldest apps etc.

    Heres package of fake8.1 wich is android 6.0, with preloader included 8.1Go_1024X600

    Personally, I prefer to use the latest releases.
    I don't know about that speed. Android8 is better for me. The first start after rooting was longer, subsequent starts are fast, I keep noticing that I don't have google services. I don't have any problems with android8, only one when it sometimes restarts while running,it did the same randomly on android6 . I don't know why it sometimes restarts, it does it randomly, but in any case, removing all google services from the system and installing L_Speed.apk are the cure for my small 1gb ram. I can see it when I start Sygic, for example. It's faster than on android 6, but I also had google services there, so maybe it's that.
    Thank you for your reply, i will check the root procedure.

    Which TWRP you used? And im also interested in the two zips for optimizing system performance, you got any links for me?

    EDIT: Rooting does not work, i did it like you described (Preserve AVB 2.0/dm-verity and Patch vbmeta in boot image were not picked in the options), after flashing the new boot.img magisk itselfs says installed 25.2 and an app like link2sd or mixplorer accesses root but when i try to delete an app or rename a system file it says no file deleted, no file renamed.

    When open Magisk it says "Abnormal State A "su" binary not form Magisk has been detected. Please remove any competing root solution and/or reinstall Magisk"
    If you flashed twrp, try using twrp and delete what you don't need. As Emilson wrote..

    I had the same error on magisk. I downloaded an older version called Magisk Manager, made root, and then updated magisk. If you have a root file browser, after opening magisk for the first time, it asks if you have granted root rights for the root browser, or download another app to manage root rights and remove magisk. e.g. SuperSU
  • 39
    ROM / Firmware/ Brick Recovery for 7" Android Head Unit AC8227l YT9217 YT9218 1/16GB

    Thanks everyone who contributed in my effort to fix my bricked device. Here is all that I have found useful in successfully reviving my device.
    The files shared here are the ones that worked on my unit (see specs and pictures below) If your device is different, it may or may not work.
    If the device has dedicated radio chip inside, the Firmware number will show as YT9218, if no radio chip, then it will show as YT9217
    Note: if your device is not bricked, Make a full backup before trying another firmware.

    I hope it helps.
    (donations are always welcome ) :D

    Memory dump:
    firmware 20181222 HiFi: (Link) (thanks mazepa2000) (May 2019 update below)
    Rooted TWRP firmware 20190523 HiFi: (Link)

    Preloader (Boot_1) from other Similar Firmwares: (Link) <- Click again if it doesn't lead to the relevant post.
    Download the one similar to your device's version.

    Firmware via flash tool: Rooted TWRP 20190523 (Link) Thanks Maxkir
    (You may need to remap side touch buttons in Factory settings (code 8888) -> Touch settings -> Click start -> Name of the button -> The button itself ->Repeat for all the buttons -> close -> ok).

    Firmware for YT9213 Device: (Link) (Thanks pajurpl)

    Update / Upgrade Files USB flash drive:
    Firmware 20190522 HiFi:
    (Link) (Thanks foxgiggle , iSevenAuto)
    Firmware 20190906: (Link)

    MCU 3.1 (Link)(Thanks foxgiggle )
    MCU 2.8 (Link) (Thanks lemmon and foxgiggle)

    I hope it helps. (donations are always welcome ) :D

    Memory Dump Procedure via flashtool:
    (Memory dump is only needed if you need full recovery from a backup. Otherwise you may only need to do the next part.)
    Download and install MTK drivers. (Link)
    Load scatter file and preloader (Link) in spflashtool. Press Ctrl Alt V , then go to Window and select "write memory". In file path select "user", in begin address put 0x0, In Region select the partition named "EMMC_USER". Hit Write memory. After that plug in the usb cable (connected to usb1 port). If the device is not detected, you need to power it on. If still not detected then you might need to short the two test points (see picture) (without power this time) and then plug in the usb cable. Remove the short when write process starts. Check if the issue is fixed. If its not fixed, then do the same to write boot2 and boot1 partitions as well. You may need to download Boot_1 specific to your original firmware from the link above.

    Uploading Firmware (full or parts) via flashtool:
    If you are uploading the firmware available in parts, you only need to upload "BOOTIMG" and "ANDROID" (SYSTEM).
    You may also need to flash "RECOVERY". Remember to uncheck the preloader. Here is a nice instructions file. (Link) (thanks Maxkir)
    There is more info and firmwares to chose from at 4pda forum.

    Update / Upgrade Procedure via USB flash drive:
    Copy the zip file (do not extract) to usb drive or microSD card, (formatted by SD Card Formatter). Connect to usb port 1 or 2. Go to Car Settings, System info. Click Android Upgrade.
    Extract the zip into a folder named XYAUTOUPG into the flash drive or microSD card, connect to usb port 1 or 2 and then reboot. Upgrade should start automatically. You might need to try with different USB drives or sd cards. For some reason this only works with certain usb and cards.

    I hope it helps. (donations are always welcome ) :D

    MCU Upgrade Procedure via USB flash drive:
    Extract the mcu file into flash drive or microSD card. Connect to usb port 1 or 2. Go into system info and update mcu.

    Make a Full Backup/Memory Dump:
    Open SPFlashtool, Select Memory Test Tab, Select only RAM Test (uncheck the rest), push start, and connect the unit. Save the information appeared, in a text file for later. (Read above "Memory dump procedure" for the usb connection setup).
    Now go to ReadBack Tab, Double click on empty space next to tick mark, Select a folder where you want to store the dump file, and Type a name for the dump file you are going to creat, (ie. Boot_1, Boot_2, USER). Click Save. In next window "Readback block start address", select the region you want to make backup of (ie. EMMC_BOOT_1, EMMC_BOOT_2, EMMC_USER).
    Start address is 0x0000000000000000
    Length copy and paste from the text file you created earlier.
    typically for Boot_1 and 2 the length is 0x0000000000400000
    and for USER (16GB models) the length is 0x00000003a8000000
    Click OK.
    Now click on Readback and then connect the unit via usb cable. and Read process will start.
    Do the same to make backup of all three partions. USER will take long time because its the largest partition.

    RDS FM Radio:
    Radio app with fixed RDS, channel names on buttons and HiFi: (Link) (thanks sjguk)
    Copy to FMRadio directory /system/priv-app/FMRadio, rename to FMRadio.apk and change permission 764. (or 755 ?).

    Channel name Editor: (Link) (thanks mclaught)
    install as normal. You may need to install GalaPublicResources. Click top right dots.

    I hope it helps. (donations are always welcome ) :D

    Multi Window Mode:
    Go to root folder, look for build.prop. Open in text editor. Change the line to
    If no such line is there, then simply add the line at the end. Save and exit. Go to Android settings, Developer options, look for multi window mode and enable it. Swipe down from the top of the window, Click on recent apps tile. You'll see the new multi window option there.

    Subwoofer output Pin:
    The default AUX_out pins are for mid range audio and is controlled by Mid slider in the mixer. The subwoofer output is on another pin (See Picture).
    it is easy to remove one of the AUX_out pin and install it at the Sub output. this pin is controlled by Subw slider in the audio mixer.

    Launchers UI1, UI2, UI4, UI5 (Link) (Thanks Maxkir)

    Boot animation: (Resolution is 1024x600)
    eg. (Link)
    The animation preview didn't work for me, but I installed it anyway and it worked fine.

    OBD Dongle Bluetooth Setting:
    Open Bluetooth app, Click on settings, tap on the pin code "0000" and type in "1234" instead. Save settings.
    Now search and connect the OBD dongle normally.

    I hope it helps. (donations are always welcome ) :D

    Unit Specs:
    motherboard marking YT9217 VER1.5 XY AUTO also 9218 VER2.4 XY AUTO near the antenna
    Model no 8227L_demo android 8.1
    Android YT9217C_00005_V003_20191402_HIFI
    Kernel 3.18.22
    CPU A7 1.3GHzx4
    Amplifier AC7315 mos bile duct 45Wx4
    AutoChip ARM AC8227L
    Mediatek MT6323LGA
    Kingston EMMC 16G
    the link takes me to the main page. and then its like finding needle in a haystack.

    All relevant info about ROMs and flashing you can find in top header of this russian forum.
    Look at the spoilers in the gray header layer and use Google translate to understand what is written there.

    There are 3 ROM versions for the 8227L based head units. I downloaded and installed the oldest of the 3 (rooted and TWRP IMG included). Copy all files from the RAR to a flashdrive in root folder.
    Turn off the head unit.
    Connect the flashdrive to USB 1 slot of the head unit.
    Turn on the the head unit.
    The install process starts immediately after turning on.
    It takes about 10 minutes.
    When install process is ready, turn off the head unit.
    Detach the flashdrive.
    Turn on the head unit and it will boot with factory settings like a new device....

    Note that there are also ROMs for flashing wit MTC flash tool downloadable.
    But the versions for installing from USB sticks ( po russki - dla flashky) are more comfortable to install and I don't own a Windows pc. So this variant was my favorite method...

    Regards and good luck...

    Edit: if your unRAR program asks for a password for unpacking the RAR file, then use Eazy unRAR app from Playstore on your Android device - it ignores password lock in RAR file ;) ...

    Edit2: the 5th gray spoiler in the top header of the Russian forum hosts the links to the ROM RAR files...
    Lots of info on those headunits (russian, use google translate):

    new firmware and MCU

    comming soon:
    Very nice indeed.
    Im using Agama launcher at the moment, far better than others in my opinion.
    a bit off topic...

    Updated to MCU 2.8 - automatic acc off time delay works > 24hours...
    I modded the UI2 Launcher a little bit for my personal needs.
    See attached screenshot.
    (my car, VW golf plus 2013, is now shown in Homescreen...)