• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][G920/5-F-I-S-K-L-T-W8][10.0] UNOFFICIAL LineageOS 17.1

Search This thread

cookieflips

New member
Apr 26, 2021
4
0
Philippines
Hi everyone, I installed this on a GM-920W8 and I got as far as setup.

As was already listed, setup hangs when setting up fingerprint during the first time

PC File Transfer also does not work. I cannot transfer files to my device when plugging it in via USB
 

cookieflips

New member
Apr 26, 2021
4
0
Philippines
Hi again! I'm here with more reports:

I flashed the latest Stock Rom (July 2018 FIDO) for SM-G920W8 via Odin
  • I then flashed TWRP
  • Wiped the first 3 on the list
  • Installed this Lineage OS Rom
  • Flashed GAPPS Pico, ARM64, 10.0
After Initial setup, I'm running into the following problems:
  • Phone detected but not appearing in Windows 10 File Transfer
  • WIFI download speed occasionally dropping to very slow speeds
  • Google Camera crashing when switching to front camera
Can anyone help me with sorting this out? Thanks so much and the rom is beautiful btw!
I installed Accubattery and I went from
  • Stock Battery Usage: 800 mah Screen on | 300 mah Screen off
  • Lineage Rom: 300 mah Screen on | 150 mah Screen off
EDIT:

I reread the original post, I will try to gather logs for when connecting the USB to my PC. I understand slow wifi is a part of the current ROM's problem sorry for not reading properly!
 
Last edited:

black_sheep1

New member
Nov 24, 2016
4
0
bugs: echo

920f clean install with recommended TWRP and gapps also modem updated.
going back to note FE port :/

Anyway thanks enes for your work Ive been following you for years!
 

squier1985

New member
Feb 17, 2013
1
0
Hello from Berlin (Germany)

First of all I wanna thank enesuzun2002 for the awesome work in offering LineageOS ROMs even for old devices like the Samsung Galaxy S6.

I want to give it a try and update my S6 (SM-G920F) to LineageOS 17.1 by using the following files and versions:
  • Odin 3.14.4
  • twrp-3.3.1-0-zeroflte.img
  • lineage-17.1-20200606-UNOFFICIAL-zerofltexx.zip
  • open_gapps-FIXED-arm64-10.0-nano-20200131.zip
I successfully could install TWRP on the S6 via ODIN and can boot into recovery mode with TWRP.

With TWRP I was following the installation these steps:
  1. Go to "Wipe / Advanced Wipe"
  2. Select Dalvik / ART Cache, System, Data and Cache
  3. Swipe to Wipe => everything OK
  4. Go to "Install" and select "lineage-17.1-20200606-UNOFFICIAL-zerofltexx.zip"
  5. Swipe to confirm Flash => everything OK
  6. go to "Install" and select "open_gapps-FIXED-arm64-10.0-nano-20200131.zip"
  7. Swipe to confirm Flash => everything OK
  8. Select "Wipe Cache/Dalvik" and Swipe to Wipe
  9. Select "Reboot System"
Then my S6 starts to boot LineageOS by showing the blue animation. However after a few minutes the animation starts to vanish and my S6 reboots into recovery mode and showing TWRP. When selecting "Reboot System" the problem/loop does not disappear. Even a clean install did not work so far.

In various blogs people had a similar problem and the solution was to delete the TWRP app. In my case I never installed this app within TWRP.

I hope someone can give me a hint how to solve this problem. If you need any further information please let me know.

Greetings, Alex
 

Bocaj67

Member
Jun 10, 2021
30
4
Hello from Berlin (Germany)

First of all I wanna thank enesuzun2002 for the awesome work in offering LineageOS ROMs even for old devices like the Samsung Galaxy S6.

I want to give it a try and update my S6 (SM-G920F) to LineageOS 17.1 by using the following files and versions:
  • Odin 3.14.4
  • twrp-3.3.1-0-zeroflte.img
  • lineage-17.1-20200606-UNOFFICIAL-zerofltexx.zip
  • open_gapps-FIXED-arm64-10.0-nano-20200131.zip
I successfully could install TWRP on the S6 via ODIN and can boot into recovery mode with TWRP.

With TWRP I was following the installation these steps:
  1. Go to "Wipe / Advanced Wipe"
  2. Select Dalvik / ART Cache, System, Data and Cache
  3. Swipe to Wipe => everything OK
  4. Go to "Install" and select "lineage-17.1-20200606-UNOFFICIAL-zerofltexx.zip"
  5. Swipe to confirm Flash => everything OK
  6. go to "Install" and select "open_gapps-FIXED-arm64-10.0-nano-20200131.zip"
  7. Swipe to confirm Flash => everything OK
  8. Select "Wipe Cache/Dalvik" and Swipe to Wipe
  9. Select "Reboot System"
Then my S6 starts to boot LineageOS by showing the blue animation. However after a few minutes the animation starts to vanish and my S6 reboots into recovery mode and showing TWRP. When selecting "Reboot System" the problem/loop does not disappear. Even a clean install did not work so far.

In various blogs people had a similar problem and the solution was to delete the TWRP app. In my case I never installed this app within TWRP.

I hope someone can give me a hint how to solve this problem. If you need any further information please let me know.

Greetings, Alex
Hi,

Had the same problems.
I see u are using the wrong downloads.
Please use the correct downloads (From page 1) and it will work!

Jacob
 

Top Liked Posts

  • There are no posts matching your filters.
  • 36
    2okPze5.png
    Note: This is not a ROM based on the ROM shipped with your device.

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10 (Q), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github Repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's working:
    • Telephony (Calls, SMS, Mobile Data)
    • WiFi
    • Bluetooth
    • NFC
    • GPS (Plain Device Mode Works)
    • Fingerprint
    • Camera
    • HWC

    What's not working:
    • Fingerprint at first setup bugs the setup wizard, so skip it.
    • Obviously Samsung's own features such as Samsung Pay, KNOX, Theme Center, Game Launcher, etc. won't be ported to LineageOS. We may have our own implementation to similar functions, though.
    • IMS services (VoLTE, VoWiFi, etc). Samsung has their own proprietary implementation. It is not really possible to easily port that to LineageOS.

    Possible Problems:
    • Please keep this in mind that Android 10 is still a quite new release so it may contain major/non-major bugs.
    • Problem: Problems with modem like dropping/slow/slowly connecting data connections, missed calls/SMS
      Solution: Try to update your device's baseband/modem to the latest available version. If there are still problems, report this bug to the developers.

    Instructions:
    • Make sure TWRP has been installed and functional.
    • Download the latest build (and optionally gapps).
    • Reboot to recovery
    • Wipe data and cache (required if you switch from other ROMs)
    • Flash the latest build (and gapps)
    • Reboot

    Downloads:

    Reporting Bugs:

    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)

    Telegram Group:

    Samsung Galaxy S6 LineageOS Development: https://t.me/joinchat/GhF7_U8IaarGQ2Y08NWilg

    Donate:

    I do this in my free time and currently i work on this alone. If you want to support the project feel free to donate

    XDA:DevDB Information
    LineageOS, ROM for the Samsung Galaxy S6

    Contributors
    enesuzun2002, lukasb06, u99dev, TeamNexus
    Source Code: https://github.com/Exynos7420

    ROM OS Version: Android 10
    ROM Kernel: Linux 3.10.x

    Version Information
    Status:
    Testing

    Created 2020-02-20
    Last Updated 2020-04-14
    8
    F.A.Q.

    It is a good idea to read here before asking same question


    1- Q: How can i report a bug?
    A: Download Syslog app from Google Play Store and send me all log types and explain the bug clearly please.

    2- Q: I have a tmobile device and can't connect LTE what should i do?
    A: Try this workaround (till i find a real fix for that) by @bohica888: https://forum.xda-developers.com/showpost.php?p=81732753&postcount=602
    5
    New build is up most of the issues are fixed now.
    3
    Installed

    Did a clean wipe and installed, everything seem to be working, battery was 95% after set up, and after 4 hours iam 65%(Heavy installing of apps and data). No lag any sort of, will give a full review in a week. Seems to be good, Thank you so much developer...