[ROM][gginggerbread-6] - Wimax for cm7 is officially merged with the cm7 codebase!

Status
Not open for further replies.
Search This thread

Neotelos_com

Senior Member
Jul 29, 2008
322
62
Seattle
What is it lacking? It's the same build as CM 6.1.2, but has WiMAX working in alpha build form...

What is it missing?

I wasn't sure what build of CM it was, that's all...it would be great if that would be stated in the first post rather than having to find it on the 7th page.

this is an alpha 4G rom to work on cm, why can't people just use their head and know this will be based off of cm's latest stable release. this is a dev website, people shouldn't need their hands held thru everything.

Oh so since it's a dev website there aren't other working on CM7?
I mean since the ROM is listed as alpha, it could be any release of CM.

Now, enough with the smartassed comments...maybe you need your hand held when you're in social situations.
 

jrseaman

Member
Oct 4, 2010
5
2
IPv6

Looks like IPv6 isn't apart of the wimax kernel. Just found this out when I updated Google Goggles. Aparently the new version won't run without IPv6. Just thought I would that along.
 

LifeInTheGrey

Senior Member
Dec 2, 2009
1,304
231
Boston
Oh so since it's a dev website there aren't other working on CM7?
I mean since the ROM is listed as alpha, it could be any release of CM.

Now, enough with the smartassed comments...maybe you need your hand held when you're in social situations.

Kanged from the OP:


[/Lawyered]

Was added AFTER I originally said something.

[/Lawyered]

Guys, relax ... there's no need for this anymore. You strain any harder to get distance and your piss will turn red.

Its in the OP, the confusion is put to rest, lets just move on.
 

spiicytuna

Senior Member
Feb 5, 2009
1,591
228
SF/Bay Area
spiicytuna.com

TheMatrixx

Member
Dec 28, 2010
41
3
After flashing this and successfully using it, wimax no longer works on my backed up Sense rom. It says "Turning on..." then "Scanning..." appears for a fraction of a second, and then it's disconnected. I vaguely remember seeing others with this problem, but I can't find any posts about it. Does anyone have any idea what might be wrong? I'd post a logcat, but like I said, I think this problem has been mentioned before.
 
Last edited:

knives of ice

Senior Member
Jul 12, 2007
1,486
250
man, not sure what is going on. i just loaded this in anticipation of heading into a 4g city tonight to try it out. now i can't connect to wifi and it won't even see my home network says its out of range. any ideas?
 

tomh1979

Senior Member
Jun 22, 2010
1,190
100
York, PA
After flashing this and successfully using it, wimax no longer works on my backed up Sense rom. It says "Turning on..." then "Scanning..." appears for a fraction of a second, and then it's disconnected. I vaguely remember seeing others with this problem, but I can't find any posts about it. Does anyone have any idea what might be wrong? I'd post a logcat, but like I said, I think this problem has been mentioned before.

do you use amon recovery or clockwork?
 

ninjaquick

Member
Mar 20, 2009
28
2
After flashing this and successfully using it, wimax no longer works on my backed up Sense rom. It says "Turning on..." then "Scanning..." appears for a fraction of a second, and then it's disconnected. I vaguely remember seeing others with this problem, but I can't find any posts about it. Does anyone have any idea what might be wrong? I'd post a logcat, but like I said, I think this problem has been mentioned before.

Backup with Clockwork? if yes then RSA lost phone will never connect to 4G.

I had lost RSA but fortunately i had 002 HW that had all kinds of issues so just got it replaced with 003 HW, RSA intact now. If you feel like being shady unroot and go back to non repair sprint store and say 4 gees no worky, act like noob and ask for replacement.
 
Last edited:

TheMatrixx

Member
Dec 28, 2010
41
3
After flashing this and successfully using it, wimax no longer works on my backed up Sense rom. It says "Turning on..." then "Scanning..." appears for a fraction of a second, and then it's disconnected. I vaguely remember seeing others with this problem, but I can't find any posts about it. Does anyone have any idea what might be wrong? I'd post a logcat, but like I said, I think this problem has been mentioned before.

It seems I had to wipe data on my backup. Weird. :/
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 194
    SOURCE CODE:

    Over the past several months, toastcfh and I have worked endlessly day and night, over vacations and holidays to bring this achievement to the great community of XDA. :p
    BHLws.png


    Code:
    DISCLAIMER: No one is responsible for your phone but you. No member of team win is responsible for any loss of RSA keys or any other bad result of flashing this ROM.

    Ok that said, we have had lots of people test this this successfully with no issues. I am currently running it as my daily driver with no issues. There are few caveats that you need to be aware of:

    Aside: Show your support for team win! :) (Thanks SHlFT!!!)

    Basic ROM Info:
    -This beta is based off of CM7 nightly 40
    -gginggerbread-6 is stable and should be fine to use as a daily driver.

    1) There are bugs. I will detail the ones I know about
    2) If you have a problem, please feel free to ask a question in this thread and I will do my best to let you know what may be happening.
    3) If you have a problem, POST A LOGCAT - use pastebin please.

    (If you'd like the Wimax icons used in this ROM, first send a thank you to shift_ :) then download them here.)

    Basic Instructions:
    If you are coming from an existing cm 7, you don't *have* to wipe beforehand, but if you are paranoid, feel free.

    I guarantee that this beta in no way interferes with your ability to connect to 4G on Sense! If you at all believe that this has happened to you, calm down, take a step back, and realize it's probably something coincidental.

    MAKE SURE YOU BACKUP USING AMON-RA 1.8 OR LATER. SAVE YOUR RSA KEYS MAN!

    1) Flash the ROM
    2) Flash the Gingerbread Gapps (EVEN IF YOU HAVE FLASHED GAPPS IN THE PAST - REFLASH THEM!!)
    3) Once you are booted, open the Wireless & Networks menu
    4) Press the "Turn on WiMAX" checkbox
    5) If you STILL have the gps bug, do this: http://forum.xda-developers.com/showthread.php?p=11183817#post11183817

    So go post screenshots of your speed tests! Let's see how we compare to Sense :D

    Changelog:

    • froyo-alpha-1: OMG KILL IT WITH FIRE! Has to connect by turning the screen off and back on. There's no wimax status anywhere. SuperKang rules supreme. 3G icon still displays when connected to wimax. Gmail sync doesn't work over 4G. Yikes the kernel is so bad. No kernel with Wimax baked into the ROM. Wifi doesn't work.
    • froyo-alpha-2: Wifi works again! Heyyy, this one is better! Can connect without toggling the screen and the 3G icon disappears now! Wimax Settings options added to the Wireless Networks menu. Still no 4G icon. Can't get back to 3G after wifi or wimax without toggling data off and on.
    • froyo-alpha-3: You can get back on 3G without toggling your data anymore! \o/
    • gginggerbread-1: Never publicly released. Initial port of wimax commits from android 2.2 to 2.3. Cheers all around @ first wimax on gingerbread in the world!
    • gginggerbread-2: Updated base code to cm7 nightly-24. There was much whining for the theme engine for this one. Added 4G iconz! .34 kernel still gay. Broke MMS and the data toggle!
    • gginggerbread-3: Updated base code to cm7 RC1. Fixed Gmail syncing!
    • gginggerbread-4: SLEEP BUG FIXED! AWAY WITH THE GAY .34 KERNEL! Fixed MMS and the data toggle (yeah they were related :p)! SlingPlayer and Dish Network apps broken... ?
    • gginggerbread-5: SlingPlayer and Dish Network apps work! Should now be speed improvements to JNI.
    • gginggerbread-6: Turning wimax off is MUCH FASTER!

    Outstanding Bugs:
    • The Wimax Settings Advanced menu isn't fully implemented and doesn't really work.
    • It seems that wifi tethering is slow for some people over 4g... workaround: install filterproxy from the market and use it when you wireless tether

    Fixed Bugs:
    • When you turn wimax off, it waits for 60 seconds before allowing you to turn wimax back on. Sorry, this is a semi-workaround to make restarting wimax work right now. It probably won't stay like this. :eek:
      [*]THE .34 KERNEL IS CRAPPY but you guys are impatient, so here
      [*]If you are using the .34 kernel, the notification bar pull down won't display anything to transfer files to and from your computer. ADB transferring works just fine.
      [*]If you are using the .37 kernel (that comes with the ROM) and your phone is unplugged, wimax will reboot itself randomly if the screen shuts off for some period of time. If the phone is plugged in, it works just fine.
      [*]If you lose your wimax signal, occasionally it will bounce from "Connecting" to "Scanning" and back forever. I know what is causing this bug, but I ran out of time to fix it. Workaround: reboot the phone.
      [*]MMS fails to send currently
      [*]The data toggle appears to be off and can't be re-enabled - data still works, but this is what is causing the MMS issue.
      [*]There is no 4G icon yet (but the 3G icon disappears when you're on wimax...)
      [*]There's some strangeness if you connect to wifi and then connect to wimax or vice versa. If you have issues connecting to networks, toggle your wifi or wireless data off and on a couple times and it should fix itself.
      [*]If you have Wimax on, DO NOT USE WIFI
      [*]There is a Wimax section of Wireless Settings. THIS DOES NOT WORK YET.
      [*]If you disable Wimax it will automatically re-enable itself if you reboot.
      [*]You can't really turn Wimax back on without rebooting the phone.
      [*]When you turn off Wimax it does not automatically re-enable 3G.
      [*]You cannot tether over 4G yet. This is likely to change eventually.
      [*]There is no button to connect to 4G. This will change.

    Downloads:

    Kernel Source:
    https://github.com/CyanogenMod/cm-kernel/tree/android-msm-2.6.37-supersonic

    Frequently Asked Questions:
    Q: Browsing the web is slow on 4g, wtf?!
    A: You probably have AdFree installed. Uninstall it and your browser speed problems should disappear.

    Q: Do I have my RSA keya? Can I still connect to wimax?!
    A: To check your RSA keys, go to the market and download "Wimax Keys Checker" by joeykrim

    Q: My wimax keeps turning itself off! What gives?!
    A: Are you using a switch widget/application like Switcher Pro? UNINSTALL IT.

    Q: How do I use logcat?
    A: See below:
    spiicytuna said:
    Option #1
    1. Download aLogcat from the market
    2. Launch the aLogcat
    3. Go launch the program thats crashing, allow it to crash
    4. Go back to aLogcat
    5. Menu -> Send
    6. Email it to yourself, then post it on here for shinzul/toast + thread

    Option #2
    1. Hook your phone to your computer with the usb cable
    2. With your fav CLI type: "adb shell logcat > crashlog.txt" (w/o the " ")
    3. On the EVO launch the program that's causing problems, allow it to crash
    4. In the CLI hit "crtl+c" (to stop the logging process)
    5. In the same folder as adb will be a text file called "crashlog.txt"
    6. Post it on here so that shinzul/toast + thread can take a look at it

    Option #3
    1. open terminal on your phone
    2. if the character showing is a '$' type "su"
    3. type "locat > /sdcard/logcat.txt"
    4. post the logcat.txt file on your SD card on here so that shinzul/toast + thread can take a look at it

    CREDIT:
    -First of all, credit to team douche for the amazing ROM!
    -JesusFreke, without your work this wouldn't be possible!!!! MANY THANKS
    -MadCoder and Cyanogen for the initial Wimax commits
    -toastcfh, you're the man - TEAMWIN 4 LIFE

    And our army of AMAZING and patient testbots (in no particular order):
    -onicrom
    -SHlFT
    -eyeballer
    -vividboarder
    -spiicytuna
    -AssassinsLament
    -xak944
    -myndwire
    -OtisFeelGood (mostly :p)
    -kpoz
    -Dees_Troy
    -dkelle4
    -joeykrim
    (if I missed a tester, I apologize!)
    38
    The Day Has Come!!!!!

    This thread has served it purpose, and no longer needs to be open.

    Before it's closed I want to thank everyone who supported us on behalf of TeamWin. Without all of you this would not have been possible. In the beginning it seemed impossible, together we proved it wasn't, and showed everyone what teamwork and determination could do. Again thank you to all who have stood behind, worked with, and supported us. You guys are the best


    TeamWin FTW


    ;)
    24
    What gps fix? Can you please direct me to the fix. This about the only thing stopping me from using this as my daily driver. Thanks in advance!

    I want to post this for whoever may be having trouble with the GPS working properly. There is a fix for this problem but is kind of a pain in the ass. Here is a detailed fix to the problem:

    1 - Go to the Market and download the app: MSL Reader
    2 - Use this app to get your MSL # (mine was six digits)
    2 - Flash to any Sense ROM
    3 - Launch phone dialer and dial ##GPSCLRX# (##4772579#)
    4 - Enter the MSL Number from above
    5 - Your phone will automatically reboot in 10 seconds
    6 - After you're rebooted back into the Sense rom you can go and reFlash CM7
    7 - Hopefully this fixed your GPS!
    15
    "Sorry, you are limited to five thanks per day"

    ...damnit.