[ROM][GT-P52XX][UNOFFICIAL][7.1.2] LineageOS 14.1

Search This thread


Senior Member
I have a Samsung Galaxy Tab 3 SM-T116. I downloaded the latest Odin and installed the latest TWERP. The device now just reboots. Can any body Help

Try to get into download mode, then reflash stock rom with Odin. Did you flash the right twrp and using the AP field of Odin?

Isn't SM-T116 the GALAXY TAB 3 7.0 LITE? THis forum is for a different tablet. The custom roms and twrps are model specific.
Last edited:
  • Like
Reactions: J.Michael


Senior Member
Does someone know where to download LineageOS 17.1 or 18.1 for santos10wifi ?

Based on that link, it should exist:

thx :)

No, I haven't seen anything on XDA higher than 14.1. But my understanding is that there were only 13 such installs. But I guess it wouldn't be something workable. If you find anything, please do tell, I am curious too.


Senior Member
So, I get a weird bug with the latest build.

After some time, after I install what seems to be some app that needs root, I am not able to install any software on the tab or to change android settings. This happened most recently with Greenify (a battery app), after unistalling it. Unless I reflash the custom rom, I am not able to install/update any apps.

I used the swap file settings and I am using Magisk. Has anyone seen something similar? Is this a bug with Magisk?
Hi guys,
I ve the 3g Version of tab 3 10.
Twrp is already inszalled and i installing Rom "lineage-14.1-20210426-UNOFFICIAL-santos103g.zip". Unforgently (after calvik clean) the Logo is coming, but Not more (6h running in this Status ist). Restart didnt helps too..

Any ideas about my mistake?
Thx a lot cosmic


Forum Moderator
Staff member
Hi guys,
I ve the 3g Version of tab 3 10.
Twrp is already inszalled and i installing Rom "lineage-14.1-20210426-UNOFFICIAL-santos103g.zip". Unforgently (after calvik clean) the Logo is coming, but Not more (6h running in this Status ist). Restart didnt helps too..

Any ideas about my mistake?
Thx a lot cosmic
Remove your SD card and reboot. This issue seems quite common and this seems to fix it Everytime. Once the tablet boots just put the SD card back in
  • Like
Reactions: J.Michael


New member
Oct 18, 2015
Hello. Just installed this rom on p5200 with gapps nano. Sadly apps detect that device is rooted (i did not install the root package). Any way to 'hide' the non existent root access?


Senior Member
Feb 22, 2011
Tablet working beautifully, especially after the swap mod. Thx out to nels83, ax562, Thumaroil, & Kingcraft on getting me there. I just have one issue and was wondering if anyone else is experiencing it. For some reason in the last month I lost pinch and zoom on some apps (like my PDF viewer and Google books). It is still available on my browser and gallery app but those might be native. I already tried looking at all settings to see if i missed something. I tried the magnification gesture accessibility option but only the taps work and not the pinch and zoom. Went under Dev options and enabled "show taps" and yes all my finger touches register. I already wiped and re-flashed this tablet so I'm at a loss here people. Any help would be appreciated.
Last edited:
  • Like
Reactions: warpti


Senior Member
Feb 22, 2011
Sounds like a hardware problem. Idk.
Never had zoom problems, I just tried it out.
Maybe some devs like Ivan can help you out?
Tried to join a telegram channel to ask some skilled devs? Just an idea....
Never actually though about being a hardware problem...but then again some apps do still have pinch & zoom and like I stated my touches are registering on the screen so i don't know for sure. Thank you for your advice...I will check up on that.


Senior Member
Aug 11, 2011

I successfully launch TWRP 3.0.2 for my GT-P5210 tablet (samsung galaxy tab 3 wifi)

but when I want to install the .zip downloaded from your link (lineage-14.1-20210426-UNOFFICIAL-santos10wifi.zip),

I have very quickly an error message :

can't install this package on top of incompatible data. please try another package or run a factory reset
updater process ended with ERROR: 7
Error installing zip file '/external_sd/lineage-14.1-20210426-UNOFFICIAL-santos10wifi.zip

do I need to do the factory reset ? or something else ? I install a lot of other os like cyanogen mod and I think it worked like this. maybe sometime I have to provide a pit file but It seems no be not necessary here.

ps : same error with 2019 version one of lineage OS...

ok.... resolved. forgot the : Wipe -> Advanced Wipe -> Dalvik Cache + System + Cache + Data


Senior Member
Aug 11, 2011
now I have an error message when I want to install gapp. it said that I don't have enough space in system partition... I have download gapps as explained in the first post : x86 and Android 7.1.


how can I do ?


Senior Member
Aug 11, 2011
Thanks a lot, the mini version works also.

I have chosen pixel launcher tool instead of trebuchet and it seems to be very slow. Is trebuchet lighter than pixel is execution time and ram consumption ?

Is it possible to switch the launcher after ?
Last edited:


Senior Member
Aug 11, 2011
Also is there a pinch zoom weakness with this room ? On photo the pinch zoom works but on baobab app (epub comics reader) it doesn't (whereas it works on my phone)

Top Liked Posts

  • There are no posts matching your filters.
  • 173
    Unofficial LineageOS 14.1 for Samsung Galaxy Tab 3 10.1

    LineageOS is a free, community built, aftermarket firmware distribution of Android 7.1 (Nougat), which is designed to increase performance and reliability over stock Android for your device.

    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards, ...
    * You flash this at your own risks

    About LineageOS

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Important information

    You need a recent TWRP version to flash this ROM.


    First time installing, coming from another ROM
    • Copy ROM to SDCard
    • Copy GApps to SDCard
    • Boot into recovery
    • Backup EFS partition
    • Wipe -> Advanced Wipe -> Dalvik Cache + System + Cache + Data
    • Install ROM
    • Install GApps
    • Reboot
    • First start takes a long time

    Upgrading from earlier version of LineageOS 14.1
    • Copy ROM to SDCard
    • Boot into recovery
    • Install ROM
    • Reboot

    [OPTIONAL] Converting filesystem to F2FS (thanks @michiil)

    The ROM has F2FS support. You may want to use it instead of the default (EXT4).

    This will delete ALL files/data from your tab.

    What you will need: A working PC and a working USB cable.

    1. Install the most recent Recovery
      Download the most recent Recovery from the second post. Flash the zip file in recovery. Back in the main menu press Reboot > Recovery
    2. Format Data and Cache to F2FS
      Wipe > choose Cache > repair or change file system > change file system > F2FS > Swipe to Confirm
      Go back and repeat the same steps with Data. I got some error messages when formatting Data but they don't seem to be a problem.
      Back in the main menu press Reboot > Recovery
    3. Install Rom + Gapps
      Connect your tab to your PC and copy the zip files on the tab.
      Flash the files, reboot and enjoy :good:

    How to get back to EXT4

    You will again loose all files/data on the tab.
    Just repeat Step 2 but use EXT4 instead of F2FS.

    What's working

    • RIL (audio calls, data, sms, mms)
    • 2D/3D acceleration
    • HW video encoding/decoding
    • Screen cast (Miracast/Wifi Display)
    • MHL/HDMI
    • Sound
    • InfraRed
    • Camera
    • Wifi
    • Bluetooth
    • GPS
    • Sensors
    • SDCard, USB OTG
    • Tethering (USB, Bluetooth, Wifi)
    • Software DRM (Level 3, see below)

      Known to be working
      • Google Movies
      • Amazon Prime Video
      • Molotov TV
      • myCANAL
      • Canalplay Kids
      • 6play


    • Automatic brightness
    • Change Color profile
    • Change mDNIe scenario
    • Enable/disable mDNIe negative mode
    • Multiuser
    • Enable/disable capacitive keys
    • Change capacitive keys width
    • Buttons backlight on screen touch or key touch only
    • Smart cover lock/unlock
    • F2FS and exFAT support
    • Houdini (allows to install arm only apps on this x86 device) - Old version so some apps may crash
    • Updated ZRAM support with LZ4 compression for maximum memory and speed
    • Updated Xbox Controller driver
    • Updated interactive CPU governor
    • Available CPU governors: powersave, interactive, performance, ondemand
    • Available I/O schedulers: noop, deadline, cfq, bfq (v7r8), fiops
    • Available battery modes (power profiles): power save, balanced, performance

    What's not working

    • Some SDCards cause bootloop, in this case: remove SDCard and insert it again when device is booted
    • Audio and camera need work
    • Chromecast screencasting (other functions work)
    • Hardware DRM (Level 1)
    • SELinux (permissive)
    • You tell me

    How to root

    • Download addonsu-14.1-x86-signed.zip
    • Copy addonsu-14.1-x86-signed.zip to SDCard
    • Boot into recovery
    • Install addonsu-14.1-x86-signed.zip
    • Reboot
    • Go to 'Settings/About tablet'
    • Tap 7 times on 'Build number'
    • Go back
    • Go to 'Developer options'
    • Tap on 'Root access'
    • Select 'Apps only' ('Apps and ADB' if you plan to use it in adb shell)

    How to help

    When something is not working correctly, in addition to common informations, I may ask you to provide logs. There are different kind of logs and it's not always easy to get all of them. For this, you can use SysLog (available on F-Droid or Google Play).
    Make sure to root device before using this app.

    To get the logs:
    • Start SysLog
    • Click on 'TAKE LOG'
    • Once log is taken, SysLog will try to share the resulting file, just cancel
    • Send me the file /sdcard/SysLog/[YYYY-MM-DD_HH.mm]/[YYYY-MM-DD_HH.mm].zip

    If you left 'Scrub potentially personal information from the logs' checked, you should be safe.



    • Angel_666 , moonbutt74 and Restl3ss for starting the work on this device
    • Android-Andi for his device tree
    • crpalmer for his work on Intel support
    • Deltadroid for his GApps package
    • All testers of the "signup" thread
    • CyanogenMod, LineageOS and Google for Android
    • XDA
    • AndroidFileHost

    XDA:DevDB Information
    LineageOS 14.1 for GT-P52XX, ROM for the Samsung Galaxy Tab 3 10.1

    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.4.x
    Based On: LineageOS

    Version Information

    Created 2017-04-11
    Last Updated 2018-10-07


    ROM - Beta 7 (20210426)
    Galaxy Tab 3 10.1 3G : santos103g (MD5)
    Galaxy Tab 3 10.1 Wifi : santos10wifi (MD5)
    Galaxy Tab 3 10.1 LTE : santos10lte (MD5)

    You can find old versions on AndroidFileHost. Version code is in file description.

    See Open Gapps, select Platform x86 and Android 7.1.


    Flash player (
    Flash player for x86 - Nougat
    Note: not much used nowadays but useful if you want to play flash games.


    Beta 7 (20210426)
    - LOS update (security patch level April 05, 2021)
    - Magisk should be fixed (thanks @ddudek77)

    Beta 6 (20210405)
    - LOS update (security patch level March 05, 2021)
    - Microphone should be fixed
    - Wifi should be fixed
    - Adjusted LMK parameters and swappiness
    - Increased ZRAM to 600MB
    - Some kernel updates for LMK and ZRAM

    Beta 5 (20190408)
    - LOS update (security patch level April 05, 2019)
    - Updated kernel random handling (fixes many FC's like Google Play Services)
    - Updated audio configuration
    - Disabled swap file

    Beta 4 (20181007)
    - LOS update (security patch level September 05, 2018)
    - Lots of CVE fixes (thanks @cschsz)
    - Applied @willy-goergen's swap parameters update
    - Added 512MB swap file (thanks to @tester272001 for the idea and everybody for the feedback)

    Beta 3 (20180422)
    - LOS update (security patch level April 05, 2018)
    - Applied @willy-goergen's swap parameters

    Beta 2 (20171118)
    - LOS update (security patch level November 05, 2017)
    - Removed Substratum patches
    - Some RIL fixes (network and audio calls quality)

    Beta 1 (20170824)
    - LOS update
    - Fixed RIL
    - Fixed HDMI audio
    - Switched to common samsung audio hal

    Alpha 8 (20170810)
    - LOS update (security patch level August 05, 2017)
    - Removed included SU
    - Fixed Gallery FCs (LOS)
    - Fixed resolution in some apps
    - Added substratum support
    - Added a lot of SELinux rules

    Alpha 7 (20170708)
    - LOS update (security patch level July 05, 2017)
    - Fixed Widevine/Netflix support

    Alpha 6 (20170611)
    - LOS update (security patch level June 05, 2017)
    - Fixed green bars on some videos (we do need one patch after all)
    - Fixed resize of videos
    - Fixed software avc encoder
    - Updated media codecs performance config file

    Alpha 5 (20170528)
    - LOS update
    - Fixed Google SetupWizard (LOS)
    - Updated mixvbp blobs to Asus Z00D (no more patches needed for media codecs)
    - Updated Widevine DRM library
    - Fixed safetynet
    - More selinux rules

    Alpha 4 (20170512)
    - LOS update
    - Integrated houdini
    - Fixed avc and hevc software codecs
    - Updated media codecs configs (cts)
    - Secured signature spoofing

    Alpha 3 (20170425)
    - LOS update
    - Fixed boot animation
    - Fixed high cpu usage (and thus battery drain)
    - Restored power configuration (lost when switching to common power hal)
    - Tweaked wifi driver
    - Cleaned up device tree (this one is for devs ;))

    Alpha 2 (20170414)
    - LOS update (Android 7.1.2)
    - Fixed DRM L3
    - Fixed charger animation
    - Switched to common samsung power hal
    - Updated kernel net drivers
    - Removed april fool stuff (boot animation and Br0Zip)

    Alpha 1 (20170406)
    - First release
    - Disabled houdini support
    - Disabled dexpreoprt
    - Assigned menu key to app switch
    - Switched to common samsung IR driver
    - Switched to common samsung lights driver
    - Switched to sdcardfs
    - Updated cpusets
    @nels83 Since there hasn't been any update to the 14.1 version for several months, do you happen to be working on a 15.0 version? If so, please let us know what we can do to help development!


    I'm still working on 14.1 (big RIL cleanup). I'm also trying to fix these annoying FCs caused by OpenGL but it's really time consuming (for me at least...) since it happens in proprietary files.
    Development slowed down for personal reasons (new house and a daughter in 1st grade :victory:).

    Anyway, I'll upload an updated version with November security fixes even if OpenGL FCs are not gone.

    As many of you know now, development on this device slows down from time to time since I work alone on this but I always come back ;)
    Beta 2 uploaded

    Hi there,

    Beta 2 has been uploaded (LOS released November security patches yesterday).
    Major change is the removal of substratum patches. I'm sorry for those of you who use it but I suspect some problems may come from these and it will be easier for me to focus on "pure" LOS stability.
    There is also some RIL work: network should be more stable and audio calls should be crystal clear (added wide-band support). Again, since I don't own a 3G or LTE device I can't test it so let me know ;)
    Last thing is a possible SDCard fix for those who experience bootloops.

    I'm now working on OpenGL FC's and audio fixes (mic and volume).

    Happy flashing