• XDA Forums have been migrated to XenForo. We are aware of several issues including missing threads, logins not working, and more. To discuss, use this thread.
  • If you are experiencing issues logging in, we moved to a new and more secure software and older account passwords were not able to be migrated. We recommend trying to reset your password, then contacting us if there are issues.

[ROM][H910|H918|LS997|US996|VS995|H990*] UNOFFICIAL LineageOS-15.1 for LG V20

Should we re-partition /system for /vendor to be able to go treble and GSI?

  • Yes.

    Votes: 202 93.5%
  • No.

    Votes: 14 6.5%

  • Total voters
    216

Phoenix591

New member
Oct 15, 2017
677
751
0
how to do for the "PSA by CM" links in the OP text then?
I can't remember what they said, but they wern't something to do, just informative... one thing you may want to know that one of them said is that Lineageos has their own root package available that may optionally be used instead of magisk/supersu. If thats something you want to use go for the arm64 version.
 
H

heavytull

Guest
the to-x86cpu.zip is needed if the rom file available for our variant has X86CPU in its name?
I'm mostly tempted to go for the "second screen" section rom, but could someone tell me why that rom dates back to last year august while the "v20" section rom dates from 3 days ago? are there more issues with the "second screen" one?

---------- Post added at 04:16 PM ---------- Previous post was at 04:02 PM ----------

i just noticed that for the non "second screen" version only LOS 16.0 is available for the h990 variant.
 

Redline

Retired Forum Moderator
Aug 12, 2014
1,591
1,739
0
Victoria, Australia
twitch.tv
the to-x86cpu.zip is needed if the rom file available for our variant has X86CPU in its name?
I'm mostly tempted to go for the "second screen" section rom, but could someone tell me why that rom dates back to last year august while the "v20" section rom dates from 3 days ago? are there more issues with the "second screen" one?

---------- Post added at 04:16 PM ---------- Previous post was at 04:02 PM ----------

i just noticed that for the non "second screen" version only LOS 16.0 is available for the h990 variant.
You only need the x86cpu zip if you're on a now ancient version of an x86 ROM.
If you're running a recent build, or clean flashing, you don't need it.
If you want a more up to date second screen capable version of 15.1, use ResurrectionRemix and search the thread for the second screen download. The LOS version is old because it was only built once or twice, they're not maintained (or needed, imo, now that 16.0 has native support for the second screen).
Otherwise, I'd recommend flashing 15.1, going through setup, then flashing 16.0 over the top and then any extras like Gapps or Magisk.
This will allow you to have most if not all things working, people babe had good success with the recent Gamma Kernel Pie versions.
If you want to stick with 15.1 and don't want the second screen, just flash the regular version of the ROM. But 16.0 is quite stable and well updated.
 
  • Like
Reactions: x86cpu
H

heavytull

Guest
You only need the x86cpu zip if you're on a now ancient version of an x86 ROM.If you're running a recent build, or clean flashing, you don't need it.
I'm currently on stock
[ ... ]
Otherwise, I'd recommend flashing 15.1, going through setup, then flashing 16.0 over the top and then any extras like Gapps or Magisk.
[ ... ]
But i don't find any 15.1 non-SS rom for the h990, which my variant. Did you mean 15.1 SS rom and then the 16.0 rom? "over the top" isn't it the normal way of upgrading as described in the OP text?
 

Redline

Retired Forum Moderator
Aug 12, 2014
1,591
1,739
0
Victoria, Australia
twitch.tv
But i don't find any 15.1 non-SS rom for the h990, which my variant. Did you mean 15.1 SS rom and then the 16.0 rom? "over the top" isn't it the normal way of upgrading as described in the OP text?
That's because the non-SS 15.1 version is the regular version. There IS no actual specified, separate version that doesn't give you the second screen.
The regular 15.1 version doesn't give you the second screen, the SS version does.
Flash the regular 15.1 build, which does NOT give you the second screen, go through setup and whatnot, and then flash the 16.0 one, over the top, without clean flashing, which DOES give you the second screen enabled natively.
 
H

heavytull

Guest
That's because the non-SS 15.1 version is the regular version. There IS no actual specified, separate version that doesn't give you the second screen.
The regular 15.1 version doesn't give you the second screen, the SS version does.
Flash the regular 15.1 build, which does NOT give you the second screen, go through setup and whatnot, and then flash the 16.0 one, over the top, without clean flashing, which DOES give you the second screen enabled natively.
But where is that regular 15.1 LOS rom for the h990?
 

Redline

Retired Forum Moderator
Aug 12, 2014
1,591
1,739
0
Victoria, Australia
twitch.tv
But where is that regular 15.1 LOS rom for the h990?
Ahhhhhh, I see what you're saying now. There's no H990 15.1 version available for download under the Google drive folder. Gotcha.
I assume @x86cpu has a reason for this (or maybe it was simply left out).
In any case, try just clean flashing the 16.0 version for your h990, with Gapps 9.0 and see how that goes. If something's not working, people have had success with the Gamma kernel Pie version getting things working.
 

joachim123

New member
Jul 3, 2008
128
18
0
Roselle, NJ
Hi guys, I have the h918.
I just followed this process to clean flash los 16 with working fingerprint fw(stock nougat>alpha omega kernel>format system>flash los 16>flash magisk> flash gapps)

The only issue I am finding is that I can't get a camera working at all. It will not show any visual from the camera when trying to open one, some cam apps don't even load.

Do other people have the camera working?

I'm OK with no video recording if that's something that's an issue with los16
 

Mnementh666

Member
Feb 9, 2009
351
86
28
Portland OR
Hi guys, I have the h918.
I just followed this process to clean flash los 16 with working fingerprint fw(stock nougat>alpha omega kernel>format system>flash los 16>flash magisk> flash gapps)

The only issue I am finding is that I can't get a camera working at all. It will not show any visual from the camera when trying to open one, some cam apps don't even load.

Do other people have the camera working?

I'm OK with no video recording if that's something that's an issue with los16
You may have to start with a flash of LOS15, boot and setup, then flash 16. That seems to be the trick for missing cameras.
 
  • Like
Reactions: joachim123

asl9622

New member
Jan 2, 2011
406
61
0
Hoping someone can help. I was on lineage is 16.0 and had the following problem so I switched to 15.1 with the same issue. When I make or receive a call, the screen is stuck on black until the call ends. It is like the proximity sensor thinks the phone is close to my ear. I have h910. I tried multiple other dialers with the same issue. the screen. when connected to Bluetooth, I have full control to switch between speaker Bluetooth and phone with no black screen.

Is there any fix?
 
  • Like
Reactions: sderaps

Mnementh666

Member
Feb 9, 2009
351
86
28
Portland OR
Hoping someone can help. I was on lineage is 16.0 and had the following problem so I switched to 15.1 with the same issue. When I make or receive a call, the screen is stuck on black until the call ends. It is like the proximity sensor thinks the phone is close to my ear. I have h910. I tried multiple other dialers with the same issue. the screen. when connected to Bluetooth, I have full control to switch between speaker Bluetooth and phone with no black screen.

Is there any fix?
Sounds like your prox sensor is not responding. Try finding a sensor test app on the play store and see if the sensor changes state as you wanted your hand in front.
Did you by chance have your screen replaced recently, or something of that nature?

Edit: try this app, no ads and it check my prox fine.
https://play.google.com/store/apps/details?id=ru.andr7e.sensortest
 
Last edited:

asl9622

New member
Jan 2, 2011
406
61
0
Sounds like your prox sensor is not responding. Try finding a sensor test app on the play store and see if the sensor changes state as you wanted your hand in front.
Did you by chance have your screen replaced recently, or something of that nature?

Edit: try this app, no ads and it check my prox fine.
https://play.google.com/store/apps/details?id=ru.andr7e.sensortest
The screen I was using prior to flash had no issues with the sensor on stock oreo. This only occurred after flashing. I have tried proximity sensor apps and they are not responding. I just finished changing my screen to a new one (I was planning on doing it anyways do to a crack) and no luck with the new screen). I have tried flashing 15.1 and 16 again with no luck. Thanks for the response and trying to help. I will try stock oreo again to test the sensor

Edit: well it really was the sensor. I guess I never realized it because on calls in stock oreo i could hit the power button to turn the screen back on.
 
Last edited:

Mnementh666

Member
Feb 9, 2009
351
86
28
Portland OR
The screen I was using prior to flash had no issues with the sensor on stock oreo. This only occurred after flashing. I have tried proximity sensor apps and they are not responding. I just finished changing my screen to a new one (I was planning on doing it anyways do to a crack) and no luck with the new screen). I have tried flashing 15.1 and 16 again with no luck. Thanks for the response and trying to help. I will try stock oreo again to test the sensor

Edit: well it really was the sensor. I guess I never realized it because on calls in stock oreo i could hit the power button to turn the screen back on.
There's a tiny black gasket that goes on glass side of the proximity sensor. It's critical somehow to the sensor working. Don't ask how I know. :)
 
  • Like
Reactions: t-what and asl9622

asl9622

New member
Jan 2, 2011
406
61
0
There's a tiny black gasket that goes on glass side of the proximity sensor. It's critical somehow to the sensor working. Don't ask how I know. :)
Haha. I found out about the gasket on the Reddit thread last night and ordered one from eBay. This is my third screen and I am guessing the last place I took it to my have left out the gasket. I changed it myself yesterday and there was definitely no gasket.
 
Our Apps
Get our official app! (coming soon)
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone