[ROM][H910|H918|LS997|US996|VS995|H990*] UNOFFICIAL LineageOS-16.0 for LG V20

Search This thread

x86cpu

Senior Member
Aug 25, 2010
1,759
4,095
Rochester
Google Pixel 6 Pro
yUIn6TF.png

WARNING: BETA BUILD. There are numerous issues still.

Disclaimer

Your warranty is now void.
I am not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed. Please do some research if you have any concerns about features included in this ROM before flashing it! YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you.

Nougat firmware needed for fingerprints to work correctly : https://forum.xda-developers.com/showpost.php?p=79342931&postcount=939

Introduction

LineageOS is a free, community built, aftermarket firmware distribution of android, which is designed to increase performance and reliability over stock android for your device. More info.


These are my UNOFFICIAL builds of LineageOS-16.0 for LG V20 variants. I did NOT create this ROM. I am helping to contribute to this ROM. Thanks to all other coders who contributed to LineageOS.

IMPORTANT

  • BACKUP! These are UNTESTED builds. Please be ready to recover your previous ROM. If it kernel panic, boots into bootloader, etc... grab as much info as you can.
  • Builds are done periodically (see download below)
  • Do NOT be rude.
  • Respect all users.
  • Any and all users, please help each other. I have a us996 variant, so other variants might have some issues.



For broken issues see 2nd post

Issues:

  • us996 static on boot: Unlock bootload from LG, using dirty Santa causes static on boot, will not fix. (Flash the us996-DS version)
  • WiFi or Bluetooth MAC is "00:00:00:00:00:00" - You wiped the misc partition, you'll need to fix: https://forum.xda-developers.com/showpost.php?p=70474540&postcount=12 (Should be fixed by static hax thanks for @Blaises)
  • 5Ghz tether not working due to "error"
  • H918 - ARB1 .. flash the 10p version, ARB0..flash the PRE10p. (10p is where the ARB got tripped to 1)

Install
  • You can upgrade from 15.1 (UNOFFICIAL) to 16.0. If you are not on my UNOFFICIAL yet, flash the to-x86cpu.zip first (and reboot recover before upgrade, not reboot into system).
  • I would suggest the TWRP from Phoenix591 (See Thanks section below)
  • Flash to-x86cpu.zip if needed. (See Downloads below)
  • Flash UNOFFICIAL ROM
  • Wipe cache, and dalvik cache
  • Magisk if you choose
  • Flash GAPPS (I use nano)
  • Reboot and wait....

(Copied from OFFICIAL thread)
To enable Developer Options go to Settings, About Phone and repeatedly press Build Number.


Bugs
If you encounter issues/bugs that are not known, please report. This is not the OFFICIAL ROM, but I can help to get any issues fixed. I use the us996 variant. If I can replicate your issue then I can track it down. If I cannot, please provide as much detail as possible. Logcats are great.
Please indicate what v20 variant you have (h910, h918/p, ls997 us996, vs995, h990/ds) athe dated version. Any mods (no judgment) as well.
I am aware people run mods or change things. I am not against it (as I do myself). However, if needed I may ask you to data wipe (you can say no), or remove a mod that might be interfering. I will do the best I can.


Thanks


Downloads
ROM: UNOFFICIAL downloads (Note date)
Gapps: arm64 nano 9.0


Sourcesrs/0B51rjK5Hd_P5NmpwY1o4VmlyaUk


UNOFFICIAL downloads
 
Last edited:

x86cpu

Senior Member
Aug 25, 2010
1,759
4,095
Rochester
Google Pixel 6 Pro
Issues

WARNING: This build is running in permissive mode.

What is working:

What is NOT working:
  • VoLTE and WiFi calling do not (and most likely never will).
  • 5.0 Ghz Hotspot (still)
  • Bluetooth will fail if you wipe (clean flash).
  • NFC
  • IR
  • Encrpytion is untested, so it may fail.
  • Fingerprints will only work until a reboot. You can then enroll again. If you get an error in enrolling, the fpdata is "full", and you will need to do the following as root and reboot. You can then enroll again:
    Code:
    rm /data/system/users/0/fpdata/user.db
    rm /data/system/users/0/settings_fingerprint.xml
  • Most likely safteynet will fail. This build is in permissive mode, unsure if anything can help to fake it (nor will I try).
  • Gamma Kernel will not work without updates to it. Camera will definitely break.


Anything else NOT listed above might or might not work. I will adjust as necessary and reports. If anyone has any knowledge and can troubleshoot and fix the NOT working items, let me know.
 
Last edited:

x86cpu

Senior Member
Aug 25, 2010
1,759
4,095
Rochester
Google Pixel 6 Pro
logcat capture

Here is how I capture logs. You need to ensure you can do this right at boot and will need to setup ahead of time.

You need to have root, either su, or "adb root". Verify you can get root quickly.

Here are the steps I do to accomplish this. This is a Linux system, so windows will vary slightly.

  1. Reboot the phone while plugged into the computer.
  2. At a shell, keep attempting to get root/shell:
  3. Code:
    adb root ; adb shell
  4. Once connected, immediately paste the following (to capture logs).
  5. Code:
    cd /cache
    dmesg -w > dm &
    logcat -b all > lc &


If you have root installed via Magisk as "su":

  1. Reboot the phone while plugged into the computer.
  2. At a shell, keep attempting to get root/shell:
  3. Code:
     adb shell
  4. Once connected, immediately paste the following (to capture logs).
  5. Code:
    su
    cd /cache
    dmesg -w > dm &
    logcat -b all > lc &

Once Phone reboots, or boots up. The needed files are in /cache "lc" and "dm", and are available in TWRP even.
 
Last edited:

damadikaz

Senior Member
Jun 26, 2014
135
54
Whoa! whaaaaat!
Definitely will try this ASAP.
Out of curiosity tough, so the 2nd scree will be treated as a notch right?
What will happen to the screen on landscape mode? The statusbar will remain on the 2nd screen or moved to the top of screen as usual?
 

Redline

Retired Forum Moderator
Aug 12, 2014
1,591
1,743
Victoria, Australia
twitch.tv
Quick & Dirty Testing

Okay, so.
I did a full TWRP backup, flashed the 16.0 build for my H990DS, the openGAPPS AROMA zip for 9.0 (importing all the same options I did when first installing 15.1) and the latest Magisk beta 17.3, following the installation instructions to the letter.
This was a "DIRTY" flash over 15.1 (it's not really dirty when doing it how Lineage does its patching but I digress).
No custom kernel, no Xposed (after flashing the xposed uninstaller). Just the ROM, GAPPS, Magisk and everything my phone already had on it.
I previously had Gamma kernel, Xposed & Magisk.
The device boots (takes about 10 mins the first time) and gets to the lock screen, and after a few seconds it shows "shutting down" when I'm in the middle of entering my PIN, turns off and boots back into recovery.
I flashed the Magisk uninstaller, rebooted and tried again with the same result. I can see on the second screen for a few seconds that WiFi/Cell and Bluetooth are all working, and my watch pops up that it's connected to my V20 before it shuts off.
I'm not willing to completely wipe and test in case something gets wiped that a TWRP backup has missed. Going to try to pull any logs I can and upload them.
Edit: After a few more attemps including a battery pull, it booted and is currently in the system updating apps.
Edit 2: Just did it again while I was taking screenshots. Was in the system for maybe 3-4 minutes. Going to try to install Magisk and get root for logs.
Edit 2.5: Formatted /system and flashed the ROM clean, same issue
Edit 3: @x86cpu I managed to get a couple straight "adb shell dmesg" in between the device booting to the lock-screen and the shut-down occuring. I also got a kmsg from TWRP in case it's of any use. There's a lot of failures for stuff to opening and in the dmesg logs you can see where the shutdown occurs so maybe you'll be able to tell what's causing it.
Logs are here and I'm going to revert to my 15.1 setup backup for now.
I hope this helps! Do let me know if you need me to do the process again and manually pull any specific log files using TWRP.
 
Last edited:

x86cpu

Senior Member
Aug 25, 2010
1,759
4,095
Rochester
Google Pixel 6 Pro
Okay, so.
I did a full TWRP backup, flashed the 16.0 build for my H990DS, the openGAPPS AROMA zip for 9.0 (importing all the same options I did when first installing 15.1) and the latest Magisk beta 17.3, following the installation instructions to the letter.
This was a "DIRTY" flash over 15.1 (it's not really dirty when doing it how Lineage does its patching but I digress).
No custom kernel, no Xposed (after flashing the xposed uninstaller). Just the ROM, GAPPS, Magisk and everything my phone already had on it.
I previously had Gamma kernel, Xposed & Magisk.
The device boots (takes about 10 mins the first time) and gets to the lock screen, and after a few seconds it shows "shutting down" when I'm in the middle of entering my PIN, turns off and boots back into recovery.
I flashed the Magisk uninstaller, rebooted and tried again with the same result. I can see on the second screen for a few seconds that WiFi/Cell and Bluetooth are all working, and my watch pops up that it's connected to my V20 before it shuts off.
I'm not willing to completely wipe and test in case something gets wiped that a TWRP backup has missed. Going to try to pull any logs I can and upload them.
Edit: After a few more attemps including a battery pull, it booted and is currently in the system updating apps.
Edit 2: Just did it again while I was taking screenshots. Was in the system for maybe 3-4 minutes. Going to try to install Magisk and get root for logs.
Edit 2.5: Formatted /system and flashed the ROM clean, same issue
Edit 3: @x86cpu I managed to get a couple straight "adb shell dmesg" in between the device booting to the lock-screen and the shut-down occuring. I also got a kmsg from TWRP in case it's of any use. There's a lot of failures for stuff to opening and in the dmesg logs you can see where the shutdown occurs so maybe you'll be able to tell what's causing it.
Logs are here and I'm going to revert to my 15.1 setup backup for now.
I hope this helps! Do let me know if you need me to do the process again and manually pull any specific log files using TWRP.

I checked logs, nothing out of the ordinary (for this beta build), most failures are ok. Obviously, something caused the shutdown. I had the same issue initially on my us996, but did get past it. I'm guessing something with the H990 is causing it, which might be the dual sim.

If you want to enable the loggy.sh, you need to remount system rw, then edit /vendor/bin/loggy.sh an uncomment the two logcat and dmesg lines. It'll then catch a dmesg and full logcat from boot. Those might help more so.

In twrp even...
mount /system
vi /system/vendor/bin/loggy.sh (You'll need to understand vi at this point).

It should look like this: (right now the logcat and dmesg are commented out).

Code:
#!/system/bin/sh
# loggy.sh.

#_date=`date +%F_%H-%M-%S`
logcat -b all -f  /cache/logcat_${_date}.txt &
dmesg -w > /cache/kmsg_${_date}.txt &

Save..
umount /system

Then after boot check for the files in /cache in TWRP.
 

aminjomaa13

Senior Member
Aug 6, 2018
138
22
Are IR blaster/fm radio tested? and are there areas where lineage os 16 adds to 15.1 in terms of non-stock features?
 

Capt_rusty

Member
Jul 15, 2018
22
9
Up and running on h918p clean flash from RR
How to enable swipe gestures?

It's under System -> Gestures.

So I flashed onto my H918-10p, was encrypted under 15.1 previously. Wasn't able to get past the password initially, just kept rebooting into recovery like Redline, and once I did it seems it also corrupted my data, I got a warning about my password being correct but the data being corrupt, and was prompted to reset my phone. I tried just about everything, but had to format my data and clear the encryption, as even TWRP was no longer able to mount system (unknown error 150). Reflashed after formatting, and now up and running, currently charging my phone to try and encrypt again. Can't thank you enough for getting this ROM out so quick, this is awesome!

Edit: Tried encrypting, unfortunately it failed. Rebooted to recovery while encrypting, and then had to reformat and reflash.
 
Last edited:
  • Like
Reactions: Sigil_Thane

Messaibi

Member
Dec 27, 2017
28
10
Wonderful! can't believe you got LineageOS 16 on beta this soon, great job.
Will flashing this ROM after being on stock Oreo breaks fingerprint scanner just how LineageOS 15.1 does it? or is it fine? if it does the same I should flash Stock nougat first before flashing this one.
 

me2151

Senior Member
Apr 12, 2012
2,190
4,494
Jacksonville, FL
I checked logs, nothing out of the ordinary (for this beta build), most failures are ok. Obviously, something caused the shutdown. I had the same issue initially on my us996, but did get past it. I'm guessing something with the H990 is causing it, which might be the dual sim.

If you want to enable the loggy.sh, you need to remount system rw, then edit /vendor/bin/loggy.sh an uncomment the two logcat and dmesg lines. It'll then catch a dmesg and full logcat from boot. Those might help more so.

In twrp even...
mount /system
vi /system/vendor/bin/loggy.sh (You'll need to understand vi at this point).

It should look like this: (right now the logcat and dmesg are commented out).

Code:
#!/system/bin/sh
# loggy.sh.

#_date=`date +%F_%H-%M-%S`
logcat -b all -f  /cache/logcat_${_date}.txt &
dmesg -w > /cache/kmsg_${_date}.txt &

Save..
umount /system

Then after boot check for the files in /cache in TWRP.

Sounds exactly like Rescue Party.
 

Grin59

Senior Member
Sep 5, 2018
623
214
OnePlus 8T
OnePlus 10 Pro
Everything is working well. Had to use kernel adiutor for the screen retention. Phone was pretty hot so that didn't help. Anyways

It's working amazing so thank you :) I'll update with any bugs if I find any.

Update: SELinux is not enforcing, and I don't think I can use privacy guard without it. We don't have exposed so I can't use xprivacyula so anyone got any help on how to fix it?

Update 2: fingerprint issue is there but deletes itself completely after a reboot but isn't an issue that much, don't mind it.
Also, ambient display isn't working. On the up side it's basically stable enough to use as a daily driver and I plan to. So happy with this, just need a new screen now :D

Also the brightness slider could use some work. Doesn't turn up the brightness till about half way up

---------- Post added at 01:57 AM ---------- Previous post was at 01:54 AM ----------

Are IR blaster/fm radio tested? and are there areas where lineage os 16 adds to 15.1 in terms of non-stock features?
The ir scanner works in gamma. I doubt the fm radio will ever work unless some dev can work it
 
Last edited:
  • Like
Reactions: Sigil_Thane

Top Liked Posts

  • There are no posts matching your filters.
  • 78
    yUIn6TF.png

    WARNING: BETA BUILD. There are numerous issues still.

    Disclaimer

    Your warranty is now void.
    I am not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed. Please do some research if you have any concerns about features included in this ROM before flashing it! YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you.

    Nougat firmware needed for fingerprints to work correctly : https://forum.xda-developers.com/showpost.php?p=79342931&postcount=939

    Introduction

    LineageOS is a free, community built, aftermarket firmware distribution of android, which is designed to increase performance and reliability over stock android for your device. More info.


    These are my UNOFFICIAL builds of LineageOS-16.0 for LG V20 variants. I did NOT create this ROM. I am helping to contribute to this ROM. Thanks to all other coders who contributed to LineageOS.

    IMPORTANT

    • BACKUP! These are UNTESTED builds. Please be ready to recover your previous ROM. If it kernel panic, boots into bootloader, etc... grab as much info as you can.
    • Builds are done periodically (see download below)
    • Do NOT be rude.
    • Respect all users.
    • Any and all users, please help each other. I have a us996 variant, so other variants might have some issues.



    For broken issues see 2nd post

    Issues:

    • us996 static on boot: Unlock bootload from LG, using dirty Santa causes static on boot, will not fix. (Flash the us996-DS version)
    • WiFi or Bluetooth MAC is "00:00:00:00:00:00" - You wiped the misc partition, you'll need to fix: https://forum.xda-developers.com/showpost.php?p=70474540&postcount=12 (Should be fixed by static hax thanks for @Blaises)
    • 5Ghz tether not working due to "error"
    • H918 - ARB1 .. flash the 10p version, ARB0..flash the PRE10p. (10p is where the ARB got tripped to 1)

    Install
    • You can upgrade from 15.1 (UNOFFICIAL) to 16.0. If you are not on my UNOFFICIAL yet, flash the to-x86cpu.zip first (and reboot recover before upgrade, not reboot into system).
    • I would suggest the TWRP from Phoenix591 (See Thanks section below)
    • Flash to-x86cpu.zip if needed. (See Downloads below)
    • Flash UNOFFICIAL ROM
    • Wipe cache, and dalvik cache
    • Magisk if you choose
    • Flash GAPPS (I use nano)
    • Reboot and wait....

    (Copied from OFFICIAL thread)
    To enable Developer Options go to Settings, About Phone and repeatedly press Build Number.


    Bugs
    If you encounter issues/bugs that are not known, please report. This is not the OFFICIAL ROM, but I can help to get any issues fixed. I use the us996 variant. If I can replicate your issue then I can track it down. If I cannot, please provide as much detail as possible. Logcats are great.
    Please indicate what v20 variant you have (h910, h918/p, ls997 us996, vs995, h990/ds) athe dated version. Any mods (no judgment) as well.
    I am aware people run mods or change things. I am not against it (as I do myself). However, if needed I may ask you to data wipe (you can say no), or remove a mod that might be interfering. I will do the best I can.


    Thanks


    Downloads
    ROM: UNOFFICIAL downloads (Note date)
    Gapps: arm64 nano 9.0


    Sourcesrs/0B51rjK5Hd_P5NmpwY1o4VmlyaUk


    UNOFFICIAL downloads
    46
    Issues

    WARNING: This build is running in permissive mode.

    What is working:

    What is NOT working:
    • VoLTE and WiFi calling do not (and most likely never will).
    • 5.0 Ghz Hotspot (still)
    • Bluetooth will fail if you wipe (clean flash).
    • NFC
    • IR
    • Encrpytion is untested, so it may fail.
    • Fingerprints will only work until a reboot. You can then enroll again. If you get an error in enrolling, the fpdata is "full", and you will need to do the following as root and reboot. You can then enroll again:
      Code:
      rm /data/system/users/0/fpdata/user.db
      rm /data/system/users/0/settings_fingerprint.xml
    • Most likely safteynet will fail. This build is in permissive mode, unsure if anything can help to fake it (nor will I try).
    • Gamma Kernel will not work without updates to it. Camera will definitely break.


    Anything else NOT listed above might or might not work. I will adjust as necessary and reports. If anyone has any knowledge and can troubleshoot and fix the NOT working items, let me know.
    27
    Here you go guys, the first Lineage 16.0 test builds for Gamma Kernel:

    https://www.androidfilehost.com/?w=files&flid=286757

    Let me know what you guys find out ;)... I will create a separate thread after we know there are no weird things going on and the weird ones get fixed. Hopefully we can help out with a few things as we all begin testing LineageOS 16.0 for our beloved V20!

    UPDATE: Fixed link... oops!
    24
    lineage-16.0-20190514-X86CPU

    lineage-16.0-20190514-X86CPU

    • May security update.
    • Fixed issue with deep sleep.
    • Added 3 finger swipe screenshot (settings/system/advanced/gestures to enable)
    24
    lineage-16.0-20190327-X86CPU

    lineage-16.0-20190327-X86CPU

    NOTE: The h990 is the last in the build, it crossed the GMT date, so it labeled lineage-16.0-20190328-X86CPU

    • Brightness adjustment try.
    • I hope (and needs testing), that Bluetooth/WiFi work now on a clean (data wipe) flash. This means no more having to come from 15.1.
    It took way to much time to track down the issue with getting Bluetooth address on a reset.