[ROM][H910|H918|LS997|US996|VS995|H990*] UNOFFICIAL LineageOS 18.1 for LG V20

geofferyjoseph1

New member
Feb 18, 2015
3
0
21
I'm having the same issue with both the call reception and gps, i haven't been able to fix it. In anything other than 18.1 my reception and gps work like a charm, but in 18.1 they both have issues Actually, what variant do you use?
I use us996 although on the board it says vs995 and when I tried to unlock the bootloader on LG's site it says vs995

Had to use dirty Santa method.

Was thinking of flashing a stock modem don't know if it'll help, I'll update when it's done.
 

xxseva44

Senior Member
May 16, 2019
123
24
28
Canada
I use us996 although on the board it says vs995 and when I tried to unlock the bootloader on LG's site it says vs995

Had to use dirty Santa method.

Was thinking of flashing a stock modem don't know if it'll help, I'll update when it's done.
It was most likely converted to a us996, i'd probably keep it the way it is since they're basically the same thing. So this issue seems to be present on the vs995, us996 and H990DS
 
  • Like
Reactions: ottafish

justcosmic

Senior Member
Dec 27, 2007
50
10
28
OK, I'm posting this for all of you who may either install Lineage without doing all the incremental updates (as per directions in the OP), as well as for those of you who may want to opt out of a working Lineage ROM in the future. I'm doing this because I just went through 3 days of Hell just trying to get back to where I was before coming over to Lineage:

If things don't go your way after installation, or if you just want to try a different ROM (or if you just want to rid yourself of Lineage Recovery), do the following:

1) Get the 13A kdz from lg-firmwares.com for your device
2) Get LGUP_DualMode and run SetDev.bat before running LGUPD.exe. This will allow you to reflash your stock kdz in REFURBISH mode, which is the only method that will get you back to stock. From Download Mode on your V20, flash the 13A kdz with REFURBISH checked.
3) You're still not out of the woods yet because although you are back to the stock ROM, you still cannot flash the boot partition without using the RAW command. Use the DirtySanta exploit as directed UNTIL YOU COMPLETE STEP 2.
4) EDIT the file called step3.bat. THIS IS CRITICAL or you will be back at reflashing the stock kdz and doing this over. Where you see the 4 lines that say:
fastboot flash boot boot1.img
Change this to add the RAW parameter (all 4 times):
fastboot flash:raw boot boot1.img
If you fail to do this step, you will get the error: Couldn't parse partition size '0x'
5) Run Step3.bat. Once completed, your device will reboot. Reboot to recovery and you should have TWRP. If you have a VS995 (Verizon model) you will probably be stuck at the boot screen indefinitely. Pull your battery and boot into recovery.
6) You will have to mount System and go to the Repair File System option (this may only affect VS995 users but YMMV). Change to ext2, then change back to ext4. For good measure, I also upgraded to the latest TWRP as well.
7) At the Install option, you should see that 0MB error disappear for your Internal Storage and it should now reflect your actual hard drive space.
8) Flash the ROM of your choice. If you're using Lineage 18.1, be sure to start with 15.1 and increment installations as per xxseva44's direction until you get to 18.x.
I asked if/why Ihad to install incremental updates rather than clean flashing this ROM (after flashing Stock 7 and then doing Dirty Santa): Aleastro the dev of this ROM replied that I didn't have to; I could just (clean) flash the ROM directly. If you can explain some reason to the contrary I would be interested to know.
 

geofferyjoseph1

New member
Feb 18, 2015
3
0
21
I use us996 although on the board it says vs995 and when I tried to unlock the bootloader on LG's site it says vs995

Had to use dirty Santa method.

Was thinking of flashing a stock modem don't know if it'll help, I'll update when it's done.
So I tried flashing the stock modem and ended up making things worse, I started having the dreaded kernel panic with modem crash as the cause.

I searched the web for a possible solution and come across this, it didn't just fix the kernel panic issue but improved my cell signal as well
 

iTzFeRReTTi

Senior Member
Jun 14, 2012
1,419
374
103
Boston
I'm having the same issue with both the call reception and gps, i haven't been able to fix it. In anything other than 18.1 my reception and gps work like a charm, but in 18.1 they both have issues Actually, what variant do you use?
I haven't had issues with either my GPS nor cell reception.
 

justcosmic

Senior Member
Dec 27, 2007
50
10
28
Curent issues I'm experiencing Current Jan 4 2021 installed):
Windows not seeing the phone/storage over USB sometimes when I have my 128gb card in the phone (which the phone sees no problem); works fine over WiFi with MyponeExplorer. Sometimes it sees it sometimes not.
Waze navigation app just hangs on openning screen. Google Maps seems to be OK though.
Camera Apps all seem to crash quite often on changing cameras etcetera.
 

ottafish

Senior Member
Sep 17, 2015
50
10
28
Sadly, the time has come. After 6 and a bit years of V20 togetherness, and ending up at 18.1, I have retired my V20's from daily life. Whist I love the phone and also 18.1, I was running into many small issues, which mounted up I to daily frustrations.
Without doubt, the best and most stable was Los 16.
What I have rediscovered is the amount of extra bloat on oem firmware that I now loath. But I'm willing to accept that for now for stability and "just works"
My gratitude and thanks for all the work the many Devs have put in to keep the V20 alive so long after LG bailed on it.
 
Last edited:
  • Like
Reactions: justcosmic
Oct 31, 2018
46
2
8
Anyone have a suggestion for a working Gcam? I'm running a US996 and every Gcam I use, I can take a photo or two before it crashes and gives me a "camera has an error".

Is there something specific with the US996 that I am not aware of?
 

xxseva44

Senior Member
May 16, 2019
123
24
28
Canada
Anyone have a suggestion for a working Gcam? I'm running a US996 and every Gcam I use, I can take a photo or two before it crashes and gives me a "camera has an error".

Is there something specific with the US996 that I am not aware of?
I use this version of gcam on my vs995.
Gcam
It works well and rarely crashes.
Night sight does NOT work, if i can find the tread i'll link it
 

TripOG

Senior Member
Mar 30, 2010
244
70
48
I use this version of gcam on my vs995.
Gcam
It works well and rarely crashes.
Night sight does NOT work, if i can find the tread i'll link it
I haven't had a lot of camera issues but today I tried to take a simple picture and man did the camera just not work. i tried rebooting, force closing, clearing the cache all the normal stuff and it just wouldn't cooperate. I imagine the people who report no camera issues just don't ever use the camera. Hopefully, this one works better
 

xxseva44

Senior Member
May 16, 2019
123
24
28
Canada
I haven't had a lot of camera issues but today I tried to take a simple picture and man did the camera just not work. i tried rebooting, force closing, clearing the cache all the normal stuff and it just wouldn't cooperate. I imagine the people who report no camera issues just don't ever use the camera. Hopefully, this one works better
Yea, i've had camera issues on all the roms for the v20 except the roms based on the stock firmware. Wish the camera worked as well as it did on the stock firmware but for now i can tolerate the crashes every once in a while
 

TripOG

Senior Member
Mar 30, 2010
244
70
48
Yea, i've had camera issues on all the roms for the v20 except the roms based on the stock firmware. Wish the camera worked as well as it did on the stock firmware but for now i can tolerate the crashes every once in a while
unfortunately, cameras are a big part of people's everyday routine. hopefully, someday lineage has the whole camera thing sorted out but until it is I imagine, it's going to be a deal-breaker for most people.
 

coliny59

Senior Member
Feb 20, 2009
77
3
28
I just installed v18.1 on H918. Is there any way to get NetFlix working? I tried Magisk and hid Netflix and Google Play, which did not work. As soon as I open the NetFlix app i get the following error, "Device failure occurred. Please try again (500.-1006). Same problem after wiping data for NetFlix app.

To install the ROM, I wiped data and cache and flashed directly to v18.1. Just wondering if there is some trick.
 

xxseva44

Senior Member
May 16, 2019
123
24
28
Canada
I just installed v18.1 on H918. Is there any way to get NetFlix working? I tried Magisk and hid Netflix and Google Play, which did not work. As soon as I open the NetFlix app i get the following error, "Device failure occurred. Please try again (500.-1006). Same problem after wiping data for NetFlix app.

To install the ROM, I wiped data and cache and flashed directly to v18.1. Just wondering if there is some trick.
I haven't gotten netflix to work either