[ROM] Havoc-OS 4.6 [OFFICIAL] [R]

Search This thread

GT500s

Senior Member
Sep 25, 2018
60
10
Yes, no natively installed camera app. I use Open Camera which was recommended to me on Telegram. Work perfectly. There is just a bug on the rom concerning the playback of HD videos (in 60fps if I say no nonsense)
I'm also using Open Camera but installed xperiance camera Magisk module that gives original Xperia camera. Think video quality is very good but photos are worse than Open Camera.
 
  • Like
Reactions: maarek7

maarek7

Member
Mar 12, 2021
22
2
Apps & Games
I'm also using Open Camera but installed xperiance camera Magisk module that gives original Xperia camera. Think video quality is very good but photos are worse than Open Camera.
Tried the "xperiance" but it's crashing in my case as soon as I switch to front camera or try to record anything.
 

GT500s

Senior Member
Sep 25, 2018
60
10
Now when trying to record video app crashes but taking pictures or switching to front camera works fine. When i was using Lineage 19.1 camera xperiance was working without any issues.
 
  • Like
Reactions: 4qx and maarek7

mstrnemo

Senior Member
Feb 1, 2021
158
20
I installed 4,19 yesterday had the following problems

- on startup i get a message that says the following
(there is a internal problem with the device,contact the manufacturer for more information?
- connectivity problems specifically sim card
- batterie drain

anyone here have similar problems?
 
  • Like
Reactions: NeoSeven

NeoSeven

Member
Jun 28, 2016
24
6
Sony Xperia XZ1 Compact
Hi Team!

Downloaded this rom and it works great. However I encounter one peculiar issue every time when booting the device. Before I can actually use it I always have to confirm this dialog, translated from German it reads:
Android system
There is an internal problem with your device. Please contact the manufacturer about this.
When I hit OK, everything works fine. What do I do about it? What is this message even related to? How can I get rid of it?

Greetings!
 

NeoSeven

Member
Jun 28, 2016
24
6
Sony Xperia XZ1 Compact
I installed 4,19 yesterday had the following problems

- on startup i get a message that says the following
(there is a internal problem with the device,contact the manufacturer for more information?
- connectivity problems specifically sim card
- batterie drain

anyone here have similar problems?
I get the same error message, although I neither experience connectivity problems nor battery drain. On the latter I learned that I mistakenly thought that my battery was drainig, because in the morning, the battery was down to 64% despite charging up all night, but this was due to the battery settings. Once up to 100% it stopped charging and by the time I woke up I seem to have lost 46%, which is quite a lot. On the other hand today it runs for 4 hours straight and I've still got 94%, but mostly on ldle and not using the phone much. So everything normal it seems - except for this ominous message on startup. I wonder if anyone else gets this.
 
  • Like
Reactions: mstrnemo

mstrnemo

Senior Member
Feb 1, 2021
158
20
I installed 4,19 yesterday had the following problems

- on startup i get a message that says the following
(there is a internal problem with the device,contact the manufacturer for more information?
- connectivity problems specifically sim card
- batterie drain

anyone here have similar problems?

Oke so after reflashing it will work my cellular connection (the interal problem message stil shows up) however evrytime i restart i dont have cellular connection because it wont give me the screen to insert my simcard pincode ? neither can i do it in the settings or interly remove it?

it doesnt stop there though because i thought F this i go back to 4.16 and nothing ... it keeps going into a loop back into twrp ???

so i try another rom linageos this one will start up and everything works fine until i restart the device and it does not give me the abilty to insert my simcard pincode???

A completely diffrent rom does the same now wtf ?

why cant i go back to 4.16 which i was running before updating ? why does it go in a loop?

removing and putting back the simcard does nothing ?

This is what my device had before installing


havoc 4.16
magisk plus microg module

before updating i uninstalled magisk.

so i dont see how a simple update can cause this ? is it possible for a update to break your device like this ? how is it possible i get the same problem on a difrent rom ???


I haven't had the time yet but wanted to flash back stock and then from there flash a custom rom again see if that helps.
 

NeoSeven

Member
Jun 28, 2016
24
6
Sony Xperia XZ1 Compact
This may sound crazy now, but I would try to put the sim card into an old phone - preferably an old style phone, like an old Nokia - and check if you can enter the sim code there normally. If so, boot the smartphone with your preferred ROM (I'm assuming Havoc), wait until it's completely booted up, swap the sim into your smartphone while the ancient phone is still on, and see if it's unlocked. If it is, you should have normal network reception, if not, you will be asked for the code again.
I only get this crazy idea because you say that two different freshly installed ROMs have the same behavior. Maybe it works. Let's see.
 
  • Like
Reactions: mstrnemo

norabitox

Senior Member
Dec 13, 2020
149
33
61
it keeps going into a loop back into twrp
Hello everyone
I also updated to 4.19 and have the same issue.

* 4.19 Update > Call X battery consumption?

* Restore 4.16 with TWRP > TWRP loop

* Format data with TWRP > Restart TWWRP

* Wipe system, cache and internal storage in TWRP
> Install 4.16,gapps > Start the system > Make a call 〇

* Restore the previous 4.16 backup with TWRP > Make a phone call 〇

* Restore only 4.19 data with TWRP > Make a call X

I'm using 4.16 now.

Sorry for my bad English.
 
  • Like
Reactions: mstrnemo

doeternietoe

Senior Member
Dec 31, 2010
74
29
So I updated to 4.19, also got a message about some (unspecified) internal problem, and what's worse a bootloop. That is to say: some 5-7 seconds after the phone has booted up, it starts all over again (but from the havoc logo, not from the sony logo).

I use this as my secondary device, so it currently has no simcard in it. Also, I have magisk installed (via a patched boot.img). Flashing the original boot.img (without magisk) does not solve the problem however.
 

WilcoSnel

Senior Member
Nov 20, 2011
102
12
Is there any word on fixing android auto for our device on a custom rom? Both lineage and havoc builds haven't had a working android auto for about a year in multiple builds now. I know dev time is limited and I would love to help troubleshoot, but it seems this isn't really on the agenda at all??? If I can help in any way with this, please pm.
 

sardighi

Member
Sep 22, 2020
43
12
Is there any word on fixing android auto for our device on a custom rom? Both lineage and havoc builds haven't had a working android auto for about a year in multiple builds now. I know dev time is limited and I would love to help troubleshoot, but it seems this isn't really on the agenda at all??? If I can help in any way with this, please pm.
A donation helps always.
Is it in your agenda?
 

WilcoSnel

Senior Member
Nov 20, 2011
102
12
A donation helps always.
Is it in your agenda?
I actually have donated. As I always do when I start using a rom as a daily driver (and it works properly) on any of my devices. I have asked about android auto on both roms several times in the last year, but never get a response.

Anyway, it was just a question. Not a demand. Please note the question marks and the offer to help out. If it came across as a demand, that was not my intent.
 

mstrnemo

Senior Member
Feb 1, 2021
158
20
This may sound crazy now, but I would try to put the sim card into an old phone - preferably an old style phone, like an old Nokia - and check if you can enter the sim code there normally. If so, boot the smartphone with your preferred ROM (I'm assuming Havoc), wait until it's completely booted up, swap the sim into your smartphone while the ancient phone is still on, and see if it's unlocked. If it is, you should have normal network reception, if not, you will be asked for the code again.
I only get this crazy idea because you say that two different freshly installed ROMs have the same behavior. Maybe it works. Let's see.
did not work,
 

mstrnemo

Senior Member
Feb 1, 2021
158
20
Hello everyone
I also updated to 4.19 and have the same issue.

* 4.19 Update > Call X battery consumption?

* Restore 4.16 with TWRP > TWRP loop

* Format data with TWRP > Restart TWWRP

* Wipe system, cache and internal storage in TWRP
> Install 4.16,gapps > Start the system > Make a call 〇

* Restore the previous 4.16 backup with TWRP > Make a phone call 〇

* Restore only 4.19 data with TWRP > Make a call X

I'm using 4.16 now.

Sorry for my bad English.
I finally got araund to installing the stock software and it works as normal now?

just installed twrp again and am downloading 4.16 as we speak.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 23
    Havoc_Logo.png


    About.png

    Havoc-OS 4.x is based on AOSP, inspired by Google Pixel.
    Has a refined Material Design 2 UI crafted by @SKULSHADY.
    Many useful features that will blow your mind.
    All you can dream of and all you'll ever need.
    Just flash and enjoy...

    Features.png

    Code:
    [SIZE="3"][SIZE="3"][B][U]General:[/B][/U][/SIZE]
    
    Material Design 2 UI
    Android R Style Screenrecord Dialog
    Rounded UI
    Inbuilt GApps (optional)
    Face Unlock
    Enhanced QS Battery Estimation
    Lockscreen Clocks
    Font Customisation
    Dark Theme Support for AOSP apps
    Notification LED Settings
    Pixel Lockscreen weather
    Signature Spoofing
    Micro-G support
    Lockscreen charging animation
    
    [SIZE="3"][B][U]Status Bar:[/B][/U][/SIZE]
    
    Clock & Date Settings
    Custom Logo
    Brightness Control Gesture
    Double Tap to Sleep
    Network Traffic Indicator Settings
    Carrier Label Settings
    Battery Icon Style/Percentage Settings
    Status Bar Icons Toggle
    HD/VoLTE Icon Toggle
    4G/LTE Icon Toggle
    Data Disable Icon Toggle
    Roaming Indicator Toggle
    Small Mobile Type Icon Toggle
    Bluetooth Battery Status Toggle
    
    [SIZE="3"][B][U]Quick Settings:[/B][/U][/SIZE]
    
    Quick Pulldown
    Smart Pulldown
    Battery Estimates Toggle
    Background Opacity
    Background Blur Configuration
    Header Image Configuration
    QS Customisations
      Rows/Column
      Tile Title
      Vibrate on Touch
    Brightness Slider Customization
      Brightness Slider On Bottom/Top/Hidden
      Auto Brightness Icon
      Brightness Control Buttons
    QS Footer Customization
      Settings Icon
      Running Services Icon
      Edit Icon
      User Switcher Icon
    
    [SIZE="3"][B][U]Ambient Display:[/B][/U][/SIZE]
    
    Show/Hide Battery Level
    Ambient Options
      Always On
      Always On When Charging
      Wakeup On New Notifications
      Wakeup on New Music (Music Ticker)
      Sensor Based Screen Wakeup (Tilt/Hand Wave/Pocket)
      Double Tap for Ambient Display
    Ambient/Always On Display Brightness Configuration
    
    [SIZE="3"][B][U]Screen:[/B][/U][/SIZE]
    
    Corners Customisation
      Rounded Corner Radius
      Corner Content Padding
    Legacy App Scaling
      Force Higher Aspect Ratio for Selected Apps
    
    [SIZE="3"][B][U]Buttons:[/B][/U][/SIZE]
    
    Navigation
      Nav Bar Toggle
      System Navigation Type
      Arrows Keys
    Volume Buttons
      Swap Keys
      Volume Steps
      Long Press to Seek Tracks
      Keyboard Cursor Control
      Volume Rocker Wakeup
      Volume keys Answer Call
    Power Button
      Power Menu Customization
      Lockscreen Options
        Visibility on the Lockscreen
        Reboot
        Advanced Reboot
        Screenshot Option
        Screenrecord
      Screen-Off Torch
        Double Tap Power Button
        Long Press Power Button
    Back Gesture
      Arrow Animation toggle
      Long Swipe Type (Swipe and Hold/Swipe Edge to Edge)
      Long Swipe Timeout
      Long Left/Right Swipe Action
      Haptic Feedback toggle
    
    [SIZE="3"][B][U]Gestures:[/B][/U][/SIZE]
    
    Jump To Camera
    System Navigation Settings
    Prevent Ringing Gesture
    Swipe To Screenshot
    Touchscreen Gestures
    
    [SIZE="3"][B][U]Lockscreen:[/B][/U][/SIZE]
    
    Double Tap to Sleep
    Media Cover Art
    Media Cover Art Blur Level
    Music Visualiser
    Unlocking
      Pocket Detection
    Fingerprint
      Screen Off FOD
      Show Icon
      Recognizing Animation
      FP Authentication Vibration
      FP error Vibration
    Elements Customisation
      Status Bar
      Quick Settings
      Lock Icon
      Charging Info
    
    [SIZE="3"][B][U]Notifications:[/B][/U][/SIZE]
    
    Flashlight
      Blink for incoming call
      Blink for Call Waiting
    Screen
      Edge Lighting Customisation
    Status Bar
      Heads Up
    System
      FC Notifications
    Misc
      Kill App Button
      Noisy Notifications
    
    [SIZE="3"][B][U]Animations:[/B][/U][/SIZE]
    
    Animation Duration
    System Animation customization
    QS Tile Animation Customisation
    
    [SIZE="3"][B][U]Battery Saving:[/B][/U][/SIZE]
    
    Smart Pixels
    Suspend Actions
    
    [SIZE="3"][B][U]Miscellaneous:[/B][/U][/SIZE]
    
    Gaming Mode
    Wake Up on Charge
    Charging Animation
    Screenshot Type (Full/Partial)
    Adaptive Playback
    Playback Timeout (30sec/1min/2min/5min/10min)
    
    [SIZE="3"][B][U]Other Features:[/B][/U][/SIZE]
    
    Vibration & Haptics Customization
    LiveDisplay
    Notch Hide Settings
    Seperate ringtone for SIM1&2
    Screen Refresh Rate (For Supported Devices)
    ALways On Display
    Smart Charging
    Theming
      Styles and Wallpapers
      Dark Theme
      Accent Colour
      Icon Shape
    
    [SIZE="3"][B][U]QS Tile Shortcuts:[/B][/U][/SIZE]
    
      Heads Up tile
      Caffeine tile
      CPU info tile
      Smart pixel tile
      Live Caption
      Screenrecord tile
      Gaming Mode tile
      Screenshot tile
      LTE tile
      Music Tile
      LiveDisplay
      Switch Data Card Tile
      Reboot Tile
      Reading Mode
      Gaming Mode
      Compass
      Sound Search
      Compass Tile
    
    [/SIZE]

    camera-err2.jpg
    photo_2021-01-19_20-48-21.jpg
    photo_2021-01-19_20-48-25_LI.jpg
    photo_2021-01-19_20-48-29.jpg

    Screenshot_20210130-103311_Settings.png
    Screenshot_20210130-103344_XperiaParts.png
    photo_2021-01-19_20-48-53.jpg
    Screenshot_20210130-103323_Settings.png


    Team.png

    Founder & Lead Developer:
    Support Team:

    Donate.png

    If you like our work then please consider donating.
    Maintainer PayPal: https://www.paypal.me/Shank03

    Links.png

    Telegram Support Group: https://t.me/havoc_lilac
    Telegram Announcements Channel: https://t.me/Havoc_OS
    Installation.png

    For GApps build:

    Clean Flash:
    • Make sure you remove your passwords and fingerprint
    • Download ROM and twrp 11 from above links
    • Flash the new downloaded twrp
    • Boot to recovery
    • Wipe system, cache and data ONLY
    • Reboot to recovery (Ignore "No OS installed" warning)
    • Flash the ROM and reboot

    Dirty Flash:
    • Backup your data (just in case)
    • Download ROM and twrp 11
    • Flash the new downloaded twrp
    • Boot to recovery
    • Flash ROM and reboot


    For Non-GApps build:

    Clean Flash:
    • Make sure you remove your passwords and fingerprint
    • Download ROM, twrp 11 and gapps (if you want) from above links
    • Flash the new downloaded twrp
    • Boot to recovery
    • Wipe system, cache and data ONLY
    • Reboot to recovery (Ignore "No OS installed" warning)
    • Flash the ROM (and gapps if downloaded) and reboot

    Dirty Flash:
    • Backup your data (just in case)
    • Download ROM, twrp 11 and gapps for android 11
    • Flash the new downloaded twrp
    • Boot to recovery
    • Flash ROM
    • Flash android 11 gapps the same version you flashed in android 10. If you flashed pico on android 10, then download android 11 pico gapps and flash it.
    • Reboot

    NOTE: It is recommended to clean flash. But those who wish to take risk, can follow dirty flash step.
    Credits.png
    @derf elot for device tree bring-up
    And all the other Developers, Testers, Donators and Users.
    Source.png
    Device:

    13
    Changelog.png


    August (4.8): Download link
    UPDATE WAS PASSED THROUGH OTA
    During OTA update, make sure you enter the password if twrp asks, don't skip it.


    June (4.6):
    Download link
    • Attempt to reduce power consumption
    • Merged June patch
    • Attempt to fix SBC codec issues
    • Removed sony music app. (installable from playstore, if any issues in that, then I'll create a magisk module for it)
    • ROM changes
    UPDATE WAS PASSED THROUGH OTA
    During OTA update, make sure you enter the password if twrp asks, don't skip it.



    May (4.5):
    Download link
    • Fixed battery drain issue
    • Few fixes in audio / video issues
    • Updated sony music app to 9.4.8.A.0.13
    • Kernel up-streamed to 4.4.269 (thanks to derf)
    • ROM changes
    NO SPECIFIC NOTES THIS TIME.
    Next update will be given through OTA :D



    April (4.4): Download link
    • Fixed SMS bug in VoLTE
    • April patch merged (obviously)
    • Camera button handler is now in Configuration Center > Buttons, and is much quicker now
    • Increased zram to 2GB
    • Few power optimization in kernel
    • Kernel up-streamed to 4.4.267 (thanks to derf)
    • ROM changes
    NO SPECIFIC NOTES THIS TIME.


    March (4.3): Download link
    • Switched to EAS kernel (thanks to linckandrea)
    • Internal stability improvements
    • Few camera glitch fixes
    • ROM changes
    UPDATE NOTE: Default home launcher has been changed. Please remove all the magisk modules for different home launcher and switch to pixel default launcher before upgrading.

    January (4.1):

    Initial Release​



    KNOWN ISSUES
    • WFD is not working yet (waiting for new non-BSP blobs)
    • Stock camera is not working anymore due to incompatibility of stock library (libimageprocessorjni.so) with new libgui
    • You tell me...

    For quick responses, join this telegram group: https://t.me/havoc_lilac
    To buy me a juice: https://www.paypal.me/Shank03


    Safety net checker is broken in magisk. Please use this app


    no other app.
    9
    IMS

    All the carrier specifc are disabled by default. Only basic mobile data will work.

    To enable carrier specific features, such as IMS, VoLTE, VoWiFi or WiFi calling,

    - Go to Settings > XperiaParts
    - Enable "IMS features". This will pick and update the modem based on your carrier
    - A reboot dialog should pop up, and reboot.

    NOTE: Above will only work if it worked on stock too.

    Here as some FAQs if you run into some issue.

    What is modem crashing ?
    Sometimes, the modem flashed may not be right (mainly due to lack of carrier updates). Due to this, the modem keeps crashing and so it can't connect sim in service.

    How to know if modem is crashing ?
    Your SIM won't get in service at all, and your wifi will disconnect and reconnect frequently.

    What to do then ?
    You can do 2 things:

    - Switch to 3G and wait if it works
    OR
    - Go to Settings > XperiaParts
    - Turn off "IMS features". This will flash default modem which will provide basic mobile data and calling feature.

    I have enabled IMS features, I have SIM connected, no modem crashing and yet IMS can't register. What to do ?
    If the WiFi and SIM connectivity are stable but IMS can't be registered, it must be the APN issue. See if updating APN fixes it else contact me.

    I didn't turn on "IMS features", but still I can't get my sim connected. What to do ?
    Make sure to check if default modem is flashed.

    - Switch to 3G and wait.
    If it doesn't work then:
    - Go to Settings > XperiaParts > Status
    - If it says this "amss_fsg_lilac_tar.mbn" modem, then contact me
    - Else either reboot or turn on and turn off "IMS Features" or check your APN.

    9
    Hello there guys,

    I won't be able to release this month's build due to ongoing exams.

    Extremely sorry for any inconvenience caused :(
    7
    Hey guys

    FInally new update is here !


    March (4.3): Download link
    • Switched to EAS kernel (thanks to linckandrea)
    • Internal stability improvements
    • Few camera glitch fixes
    • ROM changes
    UPDATE NOTE: Default home launcher has been changed. Please remove all the magisk modules for different home launcher and switch to pixel default launcher before upgrading.

    If you like my work .. don't forget to buy me juice ! :)
    https://paypal.me/Shank03