• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][I9100][UNOFFICIAL][7.1.1] Lineage OS 14.1

Search This thread

kiwigi

Senior Member
Oct 4, 2012
163
20
To Access root you need to flash su addon, you can download it from "extras" in lineagoOS website, but i attached it anyway.
About that issue you have, i believe you didn't clean flash when you moved from cm to lineage, also why are you posting here?, we've gone official already, and there is an official thread now.
OFFICIAL THREAD:
https://forum.xda-developers.com/galaxy-s2/general/rom-t3555834/page125
Thanks.
I have forgotten(grey hair(if you know what I mean)) if I did a clean install or not. Will do that and use the addon next. Must also admit that I did not see the official thread.
 
  • Like
Reactions: MigoMujahid

scroom

New member
May 7, 2017
1
0
Stuck at boot animation

Flashed the last Lineage build (lineage-14.1-20170503-nightly-i9100-signed.zip) and GApps with the latest TWRP version (3.1.0.0). But the phone doesn't boot. It has been stuck at the boot animation. Before flashing I wiped everything.

Seems that I'm not the only one experiencing this issue: (Can't post the link to the reddit page with the title "Stuck at boot animation (i9100)" because I've just registered to the xda forums)

What can I do? Should I file a bug report at the Lineage JIRA?
 

toy_story

Senior Member
Feb 5, 2017
355
572
39
Tambov
Flashed the last Lineage build (lineage-14.1-20170503-nightly-i9100-signed.zip) and GApps with the latest TWRP version (3.1.0.0). But the phone doesn't boot. It has been stuck at the boot animation. Before flashing I wiped everything.

Seems that I'm not the only one experiencing this issue: (Can't post the link to the reddit page with the title "Stuck at boot animation (i9100)" because I've just registered to the xda forums)

What can I do? Should I file a bug report at the Lineage JIRA?
Hi, first write this post in the official LOS topic here .
 
Last edited:

laberuschi

Member
May 8, 2017
5
0
anyone else got problems with wifi?
my S2 randomly and very often disconnects wifi when it is active (not in sleep mode).
somtimes it helps when i deactivate and activate the wifi. but most of the time i have to restart the phone.
didn't find somehting similar here in the forum. i tried to factory reset and flash the rom again but have always the same problem. even tried other roms..
is it a hardware-problem?
 

toy_story

Senior Member
Feb 5, 2017
355
572
39
Tambov
anyone else got problems with wifi?
my S2 randomly and very often disconnects wifi when it is active (not in sleep mode).
somtimes it helps when i deactivate and activate the wifi. but most of the time i have to restart the phone.
didn't find somehting similar here in the forum. i tried to factory reset and flash the rom again but have always the same problem. even tried other roms..
is it a hardware-problem?
Hello, this is not a mass problem, try with another connection to WIFI, to another WIFI point.
 

Nobby1960

Senior Member
Jun 3, 2016
843
404
Freiburg
hi, i tried to flash your rom, but remains in bootloop, i don't know why.
i used repit http://forum.xda-developers.com/gal...ivatives/mod-increase-partition-size-t3011162 (1.5 gb /system, 6 gb data etc.)
and i've installed TWRP 3.1.0.

idk what i'm doing something wrong, help me if you can. :/
(note: i tried to install RR, same error, but i saved a logcat)
Flash seems okay, first try in recovery: wipe cache, dalvik cache and then reboot. If it fails, make a new repit. I attach you the file, but you must rename it. The forum software makes from "=" an underscore after the download. The right syntax:

lanchon-repit-20170115-system=1.5G-data=6G+wipe-sdcard=max-preload=0.5G+wipe-i9100.zip

After you flash it in the recovery, you get an error message. Now jump to the folder "temp" and flash it again from there. Repit must work now. Now flash ROM, GApps and addon-arm-signed.zip (ignore error message) to have root access later.
 
Last edited:

matti4962

Member
Aug 30, 2016
10
0
Cosenza
Flash seems okay, first try in recovery: wipe cache, dalvik cache and then reboot. If it fails, make a new repit. I attach you the file, but you must rename it. The forum software makes from "=" an underscore after the download. The right syntax:

lanchon-repit-20170115-system=1.5G-data=6G+wipe-sdcard=max-preload=0.5G+wipe-i9100.zip

After you flash it in the recovery, you get an error message. Now jump to the folder "temp" and flash it again from there. Repit must work now. Now flash ROM, GApps and addon-arm-signed.zip (ignore error message) to have root access later.

doesn't work, TWRP gets me an error

FATAL: file system errors in partition #11 'sdcard' (UMS) could not be fixed

[ERROR 1]

Updater process ended with ERROR: 1
I:Legacy property environment disabled.
I:Install took 13 second(s).
Error installing zip file '/tmp/lanchon-repit-20170115-system=1.5G-data=6G+wipe-sdcard=max-preload=0.5G+wipe-i9100.zip'
 

the.gangster

Senior Member
Apr 3, 2015
955
1,372
Samsung Galaxy S7
doesn't work, TWRP gets me an error
FATAL: file system errors in partition #11 'sdcard' (UMS) could not be fixed
[ERROR 1]
Updater process ended with ERROR: 1
I:Legacy property environment disabled.
I:Install took 13 second(s).
Error installing zip file '/tmp/lanchon-repit-20170115-system=1.5G-data=6G+wipe-sdcard=max-preload=0.5G+wipe-i9100.zip'
@matti4962
Sounds not good. In your case I would try to make a factory reset (flash a stock ROM with Pit file) via Odin, see here.
Why that???
Simply either rerun it (as repit only retries once for fixing filesystem errors at a time), or fix them manually or simply tell repit to also wipe sdcard!
 

Nobby1960

Senior Member
Jun 3, 2016
843
404
Freiburg
Why that???
Simply either rerun it (as repit only retries once for fixing filesystem errors at a time), or fix them manually or simply tell repit to also wipe sdcard!
I already see, with the error codes and repit I have to occupy myself closer, there is still so much, which I do not know :silly: ;)

In this case, is this the right syntax? It should wipe the SD card too.

lanchon-repit-20170115-system=1.5G-data=6G+wipe-sdcard=max+wipe-preload=0.5G+wipe-i9100.zip
 
Last edited:
  • Like
Reactions: matti4962

the.gangster

Senior Member
Apr 3, 2015
955
1,372
Samsung Galaxy S7
I already see, with the error codes and repit I have to occupy myself closer, there is still so much, which I do not know :silly: ;)
In this case, is this the right syntax? It should wipe the SD card too.
lanchon-repit-20170115-system=1.5G-data=6G+wipe-sdcard=max+wipe-preload=0.5G+wipe-i9100.zip
Yes for wiping sd. Still wonder who should ever want to waiste the 0.5G for preload. (I'd choose 'preload=min+wipe').
@matti4962
If you still have problems with Repit it's better to post there. Safe the log and post it there. Documentation of Repit can be found here.
 

MigoMujahid

Senior Member
Aug 31, 2015
1,920
680
New York
When I try to flash with TWRP, it gets stuck at "patching system image unconditionally". Any solution?
Did you repartition first?
You need to increase the system partition size first to be able to flash nougat ROMs here.
Search for Lanchon tool thread in the i9100 Q&A thread, or also Saber guide to repartition using Odin.
Also note that this is the unofficial thread, there is official thread already in the s2 general thread.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 103
    THREAD MOVED (OFFICIAL THREAD)
    https://forum.xda-developers.com/showthread.php?t=3555834




    Code:
    /*
    ** Your warranty is now void.
    **
    ** We are not responsible for bricked devices, dead SD cards,
    ** thermonuclear war, or you getting fired because the alarm app failed. Please
    ** do some research if you have any concerns about features included in this ROM
    ** before flashing it! YOU are choosing to make these modifications, and if
    ** you point the finger at us for messing up your device, we will laugh at you.
    **
    **/

    Work :
    Almost Everything

    Not Work :
    What you tell me

    Changelog :
    LineageOS 14.1 Changelog

    Download :
    https://download.lineageos.org/i9100

    You must use 1GB System PIt. Rom files bigger than 512MB(Stock system partition size).

    Sources :
    https://github.com/lineageos

    Thanks to @rINanDO for his effort.
    52
    FIRST LINEAGEOS-BUILD 14.1 IS UP!

    Changes:
    - Updated sources (Sayonara CyanogenMod, Hello LineageOS)
    - Samsung STK support
    - Battery optimization is back with working profiles (It is working but still in review in CM)
    - Working CM-recovery (applied unofficial fix, for official fix we needs FUSE 7.23 in kernel and we have 7.16.. :( )

    Download: lineage-14.1-20161231-UNOFFICIAL-i9100.zip

    Happy new year everybody!! :):):):)
    41
    New build is up!

    Changelog
    * Reverted a fix (from AICP) which possibly causes random boots. I hope this works.
    * Fixed CMFilemanager
    * Updated sources cm-14.1

    Download here:
    cm-14.1-20161205-UNOFFICIAL-i9100.zip
    41
    New build is up!!
    Changes:
    * Update sources (security update 05-01-2017)
    * Fixed WiFi Hotspot
    * Powersave-mode is using conservative-governor now
    * Memory tweaks. Please test and share if you experience any difference.
    KSM, LZ4 ZRAM (400mb), LMK

    Download here: lineage-14.1-20170108-UNOFFICIAL-i9100.zip
    41
    New build is up!

    Fixes:
    * SIM contacts import/export
    * MMS with mobile data off
    * Flashlight torch wakelock issue (sorry, I forgot the (not yet merged) patch in build 20161205)

    Download here: cm-14.1-20161208-UNOFFICIAL-i9100.zip
    @SerenityS: Can we change the subject of this forum to [ROM][7.1.1][i9100][UNOFFICIAL] CyanogenMod 14.1?
    Work :
    Everything

    Not Work :
    FC in MptDocumentsProvider when opening Downloads-app due missing kernel patches for vold -> /proc/[pid]/mnt