• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][ICS][IML74K] teamhacksung's CM9 ALPHA for Galaxy S (BUILD 17) BUG REPORTS ONLY

Status
Not open for further replies.
Search This thread

beekay201

Senior Member
Nov 8, 2010
5,226
1,221
Yes but I want to disable it for emails :)

My guess is that this will be available when device stuff is ready to be merged to CM ics branch, with CMParts. Patience.

Hmm, I dunno man.. this is an early build and I don't think the devs would recommend using different kernel regardless, because it makes it harder to track bugs.
If your after a smoother experience cm7 is still probably better at the moment.
While this port may be stable enough for some users to use everyday (it is for me anyway) it is by no means a finished product and changes might require you to wipe everything or bugs might crash things etc..

true, custom kernels for cm9 will start showing up after it gets released, not sure why people are already thinking about that. even so, i believe we should keep using same method, no custom kernel/kangs talk in main thread.
i got back to cm7, for example. speed demon.

hmm, still no html5 gpu acceleration.... speedreading results are very poor. It has only one fps with this build. onecosmics is at 5 fps, wp7 is at about 30 fps and modern iphones can do even more...

Is this because android 4 won't support it better or isn't html5 accelaration activated yet? Couldn't find more info witj google, sorry for asking again.

because this is also a port and a WIP? or because apple started this whole thing, html5 vs flash?
a bit off topic, but part of the reason HTML5 apps perform much better on Apple devices is because Apple long ago invested in hardware acceleration, and Google only got around to it in version 3.0 of Android.

It's an ICS feature, you can view notifications on lockscreen..

a pretty good one, i think.
 

hackeron

Senior Member
Jan 23, 2011
826
69
When the ICS sources for nexus s is released, how much easier will it be for you devs to fix bugs and continue with this work?
Im just curious since the hardware is almost identical?
 

mikebeecham

Senior Member
May 5, 2010
56
57
just thought that I would mention that after flashing build 4, I then flashed gapps5.1. On reboot it turns out that my network icons are showing blue again. Coincidence?
 

ramas123

Senior Member
Sep 23, 2010
307
52
Can someone share his expirience on build 4 ui overall smoothness. Is it smoother than in build 3?

Sent from my GT-P1000 using XDA Premium App
 

BLADESMAN1889

Senior Member
Jun 18, 2010
1,355
505
Hasting / Sheffield
HSDPA icon works fine. If you have 3G icon then you're actually connected to 3G and not HSDPA. Maybe some problem with your carrier in your current area?

Agreed.

I am on the 3 [UK] Network which only uses the 3g/HSDPA so I know that it often switches between the 2, I also have a dongle on this Network for my Laptop and this is the same.

I'm not sure exactly why it flicks between the two maybe it has something to do with traffic congestion, as after midnight it seems to be on HSDPA for most of the time - which is why I get much faster speeds than on 3g.
 

~coolphoenix~

Member
Aug 11, 2010
44
8
build 4 + gapps 5.1: device encryption does not work. (first try on cm9, so don't know whether it worked before - at least it is stated as solved since build 3).

encryption starts, boot screen appears and after about 10-15 seconds it says encryption went wrong an i have to factory reset the phone. but i can simply reboot it, and everything is like before the encryption try (spottet no fc nor lost data yet)

besides of this i spotted no other bug which isn't statet in the op. good work.
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 817
    Moved
    The project is now continued under CM9 Nightlies. This thread will be kept here for history/reference.

    Introduction

    Teamhacksung has been porting ICS (to be CM9) for the Galaxy S and we feel that it has reached a state where it would benefit from public testing. However this is still a very early versions and there will be bugs. Bug reports are allowed in this thread only. Please check the known issues section before reporting a bug. The most minor bugs are welcomed (we'd love to know them, but we may not fix them instantly).

    Go to the thread (unaffiliated with teamhacksung) in the General Section for Q&A, General Discussion, Custom Kernels, etc. DO NOT POST THEM IN THIS THREAD.
    MODERATOR TEAM REQUEST: PLEASE NO ETA, NO COMMENTS, NO QUESTIONS....JUST BUG REPORTS !!!!

    To report random bugs
    Current build
    Last build without the problem
    Stock kernel?
    Current modem
    Any other modification you've made to the ROM.
    What were you doing
    How often does the problem occur?
    Attach a logcat
    Attach last_kmsg if it's a random reboot (If it rebooted into recovery, get it while booted into recovery. Also get /proc/cmdline.)

    Download
    ROM: Download from get.cm. (The nightlies are a continuation of the builds.)
    Google Apps: Download from ROM Manager. (Or http://goo-inside.me/gapps/)
    Face Unlock: Bundled with Google Apps from ROM Manager.
    Google Apps Fixer: MultiUpload / tux-head.net / faramir.eriador.org (md5: af8bcaf5f8158e8e1be7097fc86b6b28)

    Google Apps Fixer will fix your problem with not being able to add Google Account or Calendar Sync, but will also reset your Google Apps data. Only flash if you're having problems. If Google Apps Fixer does not work for you, do a factory reset from CWM (or Android Settings) and do not restore system data via TitaniumBackup.

    Older Downloads

    ROM
    BUILD 17: tux-head.net / faramir.eriador.org / ics.haxer.org (md5: 524580b5b0115b1a6b31ac9ea3522c96)
    BUILD 16: faramir.eriador.org / ics.haxer.org / Mirror By Quacktop (md5: daae5ea6ee7f73b67f679417b0fe668a)
    BUILD 15: faramir.eriador.org / Mirror by beN.. / ics.haxer.org (md5: e56f541184f0f93f943f9cdda077c8b6)
    BUILD 14: MultiUpload / tux-head.net / faramir.eriador.org (md5: 037c3c23c271cfe91e4fddea21fadf8d)
    BUILD 13: tux-head.net / faramir.eriador.org (md5: a816e405bd6b292d6088dbd6a6079b10)
    BUILD 12: MultiUpload / tux-head.net / faramir.eriador.org (md5: c7ff813b861b24f6d833602094c8a230)
    BUILD 11: MultiUpload / tux-head.net / faramir.eriador.org (md5: 8adf67bbbd3ea99c78b2c0a710967e66)
    BUILD 10: MultiUpload / tux-head.net / faramir.eriador.org (md5: bf45b9fecfeb4a8834b96bc4c8e2d8c4)
    BUILD 9: MultiUpload / tux-head.net / faramir.eriador.org (md5: cb6a55d1d43d9c4dc2a78c4469589d1b)
    BUILD 8: MultiUpload / tux-head.net / faramir.eriador.org (md5: 8573a4c37fd6578e8e0a79d2213bf63c)
    BUILD 7: MultiUpload / faramir.eriador.org (md5: 33d31ad427672db24b6be49d658ac9d9)
    BUILD 6: MultiUpload / faramir.eriador.org (md5: 5afcb3c424e87bc610131c62a2a37976)
    BUILD 5: MultiUpload (md5: 62118275cbf02d56ce4a49a4417e0c51)
    BUILD 4: MultiUpload (md5: 12d1316e36fab6da46af5841558cc492)
    BUILD 3: MultiUpload (md5: 449eefbc5d37f58db1f61335840553cd)
    BUILD 2: MultiUpload
    BUILD 1: MultiUpload

    Google Apps
    v7.1: MultiUpload / tux-head.net / faramir.eriador.org (md5: 8bf66137f18de45657f29c129a8f4d52)
    v7: MultiUpload / tux-head.net / faramir.eriador.org (md5: 1888fbb15f36a076cb3908acaf1bd15a)
    v6: MultiUpload / tux-head.net / faramir.eriador.org (md5: 6f51ded731d173c31b8c47395ca580b7)
    v5.3: MultiUpload / tux-head.net / faramir.eriador.org (md5: e7d69d98a633b646e4f14e6a43208e66)
    v5.1: MultiUpload / tux-head.net (thanks! Kaik541) (md5: 87415730a1db2e90d3588bc895f239e5)
    v5: MultiUpload (thanks! Kaik541) (md5: 8667c9ddca581a98867fc02db29a2326)
    v4: MultiUpload (thanks! Kaik541) (No longer include apps downloadable from Market.) (md5: 8b2dad009bc2f8724d27f78bca162495)
    v3: internal
    v2: MultiUpload (thanks! koush)
    v1: MultiUpload (thanks! koush)

    Face Unlock
    v5: MultiUpload / tux-head.net (md5: eb713a8061e920da87c6c3fbea63ce3e) (Does not work with BUILD10+)
    v1: MultiUpload (md5: 5f6ed343f4de038f78f54be4e4395c7d)

    Installation

    - First time flashing ICS to your Galaxy S (or coming from another ROM)?
    1. Root your device and install ClockworkMod Recovery.
    2. Reboot into Recovery using 3-button-combo
    3. Do a Nandroid backup!
    4. WIPE (wipe data/factory reset + wipe cache partition)
    5. Install the ROM from internal sdcard using ClockworkMod Recovery
    6. Optionally install the Google Addon
    7. WIPE again or Calendar Sync will not work.
    - Upgrading from CM7?
    1. Do a Nandroid Backup!
    2. WIPE (wipe data/factory reset + wipe cache partition)
    3. Install the ROM from internal sdcard using ClockworkMod Recovery
    4. Optionally install the Google Addon
    - Coming from onecosmic's ICS build?
    1. Do a Nandroid Backup!
    2. Install the ROM from internal sdcard using ClockworkMod Recovery
    3. Optionally install the Google Addon
    4. Reboot into recovery and WIPE (wipe data/factory reset + wipe cache partition)
    5. If radio doesn't work, go back to Samsung ROM and flash from there.
    - Upgrading from another build of ICS by teamhacksung?
    1. Do a Nandroid Backup!
    2. Install the ROM from internal sdcard using ClockworkMod Recovery
    3. Optionally install the Google Addon
    Note: The upgrade process from CM7 to ICS is automatic, but downgrading from ICS to CM7 (or restoring Nandroid) requires flashing twice. Once from ICS and again from CM7's recovery.

    Source

    Kernel Source: https://github.com/teamhacksung/samsung-kernel-aries
    Userspace Source: Patches are being integrated into CM's mainline tree. Device tree are available on teamhacksung's github, but may not be buildable. No support for the source code, do not post that you are not able to build it.

    Known Issues
    • Camera does not support scene modes
    • FM Radio does not work.
    • Phone unnecessarily gets data connection on device encryption password enter screen.
    • Cannot format external SD *
    • Android OS battery usage display higher than normal.
    • Sometime wrong SMS selected for forwarding
    • Format internal instead of external SD when requested to format ext. SD
    • Transfer speed slows down when screen off
    • Screenshot shutter sound
    • TV Out using HW-decoding (probably won't be fixed)
    • Sim Toolkit (probably won't be fixed)
    • No camera focus mode setting
    • Compass doesn't work in Google Maps v6
    • Unable to dial "0001" in some regions
    • Slow USB transfer speed for some people
    • Camera still photos problem after recording video
    • Note: there are a lot of new options in Settings, but many of them are not implemented yet. DO NOT REPORT THEM AS BUGS. Additionally, some users has reported boot failure after disabling boot animation.
    • Empty wifi icon when using juice defender / sometimes on boot
    • Unused bottom bar in landscape dialer
    Fixed Issues

    BUILD 17
    • Top of widget selection selector says "Select screen lock" (Upstream fix)
    • Chrome not working
    • Various other upstream fixes
    BUILD 16
    • Regression in BUILD 15: Superuser application crashes
    • Regression in BUILD 15: Data Roaming enabled by default
    • Back camera does not record geotagging
    • Camera crashes when changing resolution
    • New: WM8994 Extensions (aka "Voodoo Sound") is now configurable from DSP Manager
    BUILD 15
    • Duplicate entries in MediaScanner (will only prevent new duplicates, need to clear data to get rid of old duplicates)
    • Regression in BUILD 14: Screen flicker while turning off
    • Regression in BUILD 14: adb turns off every reboot
    • Mute-unmute needed on some calls (hopefully)
    • Notification power widget uncustomizable (now integrated into Settings)
    • Reboot into recovery on crash (it will still reboot, just not into recovery)
    • Unreliable Wi-Fi on screen off (hopefully)
    • Gallery face glow FCs
    BUILD 14
    • Laggy video recording in low light
    • "sin" does not work in calculator in Spanish
    • Laggy playback of some video in .mkv container (same video works in the .mp4 container) (Recommendation: Dice Player from market. Does its own mkv extraction and has hw decoding support)
    • New Feature: Gamma tuning (equivalent to Voodoo Color's "v1 gamma hack")
    BUILD 13
    • 720p Video Recording laggy
    • No camera zoom
    • Timelapse video recording crashes
    • TV Out broken on sleep
    • TV Out black video
    • Broken encryption (regression in BUILD 11) (WARNING: users with already encrypted phone will have their data cleared (for real this time))
    BUILD 12
    • Compass, accelerometer broken in certain apps
    • Random force closes (hopefully)
    • Missing camera touch to focus (thanks to havlenapetr)
    • GPS does not work (regression in BUILD 11)
    • Off-charging does not show progress
    • /datadata cache not cleared when space is low
    • Slow mass storage transfer speed
    • Automatic brightness not working
    GApps v7.1
    • Network location broken
    GApps v7
    • Market purchase broken
    BUILD 11
    • Encryption not working without a data wipe (WARNING: users with already encrypted phone will have their data cleared)
    • Cannot authenticate new apps for root
    • Data sometimes get disabled on boot
    GApps v6 / Face Unlock v6
    • Updated: based on IML74K
    • Face Unlock not working on BUILD 10+
    BUILD 10
    • No hardware composition (but hardware acceleration works)
    • Video recording does not work.
    • Video playback is not hardware-accelerated.
    • The front camera produces distorted preview.
    • Photo taking does not work with the front camera.
    • Some camera options FC. (The camera is a temporary hack, when the Nexus S ICS source is released, there will be a proper fix.)
    • Movie Studio does not work.
    • WiFi automatically turns on after quitting airplane mode if WiFi was used during airplane mode.
    • Data Roaming is enabled by default
    • Can select widget on launcher without being on the widget screen *
    GApps v5.3
    • Updated: Market apk
    • Removed: unneeded GoogleLatinIME
    BUILD 9
    • WPA Wifi Tethering broken (regression in BUILD 8)
    • Audio recording by android app crashes (phone calls still work) (regression in BUILD 8)
    • Phone crashes in landscape with T9 enabled
    • Reboot to recovery by default even though recovery not selected.
    • Slow T9 speed
    • CPU rarely scaling up to 1000 MHz
    • GMail sometimes fills up /datadata with attachments
    BUILD 8
    • USB Tethering on Windows requires the user go to to driver update and manually select the RNDIS driver.
    • Sketchy wifi tether (breaks if data connection comes up while tether is active) (it will still error, but you can now re-enable it)
    • Mounting external SD via USB broke in BUILD 7
    • Cannot accept many file types via bluetooth
    • Data activity icon sometimes gets stuck even data is off.
    • New feature: T9 Dialing by devatwork (Enable in Dialer Setting)
    BUILD 7
    • Cannot encrypt phone after restoring data.
    • Wi-Fi problems for Iran users
    • Market download temporarily goes to /datadata
    • Support for TV Out (in Galaxy S Setting application)
    • Screen appearing for a split second after screen off animation
    BUILD 6
    • Persistent "Removed SD card" message on external sd card removal.
    • Missing library for Android Open Accessory
    • Support for USB Mass Storage (see FAQ)
    BUILD 5
    • VPN does not work
    • Regression in device encryption
    BUILD 4
    • Large photos cannot be edited.
    • Missing Live Wallpapers
    • Bluetooth Reverse Tether does not work
    • Wi-Fi Direct not supported (it's supported in settings now, but apps are needed to use it as ICS does not come with any use-case for Wi-Fi direct)
    • Sometimes wifi strength won't show after boot if wifi is enabled. Toggle once to fix. (fixed, hopefully)
    GApps v5.1
    • GApps: Missing TTS libs
    GApps v5
    • GApps: Missing Picasa Sync
    • GApps: Unable to purchase apps
    Build 3
    • Device encryption does not work. (Note: temporarily broken again in BUILD 4, works on BUILD 5)
    • User does not have write permission for external sd
    • A2DP bluetooth headsets do not work.
    GApps v4
    • GApps: More missing libs for GoogleTTS
    Build 2
    • Superuser.apk does not open.
    • Installer does not work on Samsung ROMs.
    • Factory reset (from settings menu) does not clear /datadata.
    GApps v2
    • GApps: Missing voice chat, maps, text-to-speech libraries
    • GApps: Android Keyboard appears twice in Settings.
    Frequently Asked Questions

    My calendar sync isn't working!
    Install the latest build and gapps and gapps fixer. If it still doesn't work, wipe your data.

    App X isn't working!
    Check the list at http://forum.xda-developers.com/showthread.php?t=1402210 (unaffiliated with teamhacksung) first and check if it works on other ICS phones. Most likely, it's the application's problem, not ours.

    Can I mount the phone as mass storage via USB?
    Starting from BUILD12, mass storage is the default configuration (might not apply to existing installations). The below command can be used to change into USB Mass Storage mode. USB Mass Storage mode is always used in recovery.
    Code:
    setprop persist.sys.usb.config mass_storage,adb
    If you want to switch to MTP mode use
    Code:
    setprop persist.sys.usb.config mtp,adb
    Please reboot after executing the command.

    I can't adb into the phone!
    Please install Nexus S drivers from Google. (Or Galaxy Nexus's driver in MTP mode)

    Can I flash other modems?
    You may flash modem packages designed for CM7.

    How do I take a screenshot?
    The screenshot taking function is built into ICS. Hold volume down + power.

    Can I use CM7 kernels?
    No, the kernel has modifications to make graphics, camera, data counter and data limit work.

    Can I disable LED Notification?
    Yes. Untick Settings -> Display -> Pulse notification light.

    Maps keeps asking me to sign in even though I'm signed in!
    Ignore the sign in dialog and pull down the notification menu. Answer the request for permission. Do this a few times and Maps will work.

    How do I enter Galaxy S Settings (Device Settings)?
    Type "am start com.cyanogenmod.AriesParts/.AriesParts" from adb. Or starting from BUILD 7, it is available as an icon in your launcher.

    How do I enter service mode?
    Type "*#*#197328640#*#*" into the dialer.

    Is there a Captivate/Vibrant version?
    A captivate build from the same source (but with captivate config) is available here. We currently lack a developer/maintainer for Vibrant.

    Does this work for I9000B?
    No, the I9000B requires a different kernel configuration. A build for I9000B may be added later in the process.

    What's working? Why is there only a list of issues?
    Everything else not listed are supposed to be working (aside from the usual CM7 bugs). If they're not listed, please post so that they can be added to the list of issues. A list of issues is far more useful from a development standpoint.

    Why am I getting notified that my data partition is getting full when I have 1+ GB free?
    Your /datadata partition, a smaller partition, is getting full. System automatically clears the cache when the space is low. The problem with "low space" is that you have too many applications installing libraries in /datadata (which can be solved by moving the said app to SD). It's a Galaxy S-specific problem (with our sucky NAND) and thus a general solution cannot be implemented.

    I want to install gazillion apps on my phone and /datadata is too small
    Run the following and datadata will no longer be used on next reboot. Your phone might become slower though.
    Code:
    touch /datadata/.nodatadata

    IRC?
    #teamhacksung-support on freenode for support
    #teamhacksung on freenode for development

    My adb shell isn't root!
    Run "adb root" to restart adb in root mode.

    Why is "Android OS" battery usage so high?
    It's just a reporting change in ICS. Android OS now includes battery usage from more components than in Gingerbread, the actual battery drain is the same.

    What is "Random Offset" during installation?
    It's just a harmless message given as a verbose logging due to the new ASLR security feature in ICS. It is not an error.
    (NOTE: Newer BUILDs might have it removed.)

    What do you mean by "wipe"?
    A wipe, unless specified otherwise, means running a "factory reset" from CWM Recvoery. This will clear all your installed apps/settings but will keep your /sdcard in tact.

    A cache wipe is the wipe of /cache (which is mostly unused) and will not cause you to loose any data.

    How do I get the latest version of Rom Manager without market?
    If the bundled version doesn't work, update from http://download.clockworkmod.com/recoveries/RomManager.apk.

    How do I setup Rom Manager?
    Menu -> Manual Flash Override -> OK -> Samsung GalaxyS i9000 (MTD) -> ClockworkMod 3.x+

    I would like feature X
    This thread is not the place for it. Submit it to the CM bug tracker once an official RC is released.

    Thanks

    syndtr: Updated touch and graphics driver
    onecosmic: Being the first to successfully build the AOSP tree
    Kaik541: GApps from v3 onward
    ancdix: For hosting on tux-head.net
    nikademus (_renaud_): For hosting on faramir.eriador.org
    SysTem-X: For hosting on ics.haxer.org
    CyanogenMod team: Setting up the infrastructure and being a great help in the porting process.
    and everyone else involved in this port or CM7 for SGS.
    73
    Uploaded BUILD 17.

    Please do not bother mods with reporting post (unless they REALLY deserve to be reported, such as advertisements). I ignore them and you can too.
    70
    And I couldn't resist. Looks okay (Using the dialer from 4.0.3 for now because the new one broke and I don't have time to fix it.)

    MD5 = 549831c846d74e3cf37949f490b01953
    http://faramir.eriador.org/pawitp/update-cm-9.0.0-RC0-galaxysmtd-20120329-KANG-signed.zip
    http://ics.haxer.org/pawitp/update-cm-9.0.0-RC0-galaxysmtd-20120329-KANG-signed.zip
    49
    BUILD 13 posted.
    46
    Welcome to CM9 Nightlies. Please continue your conversations there.