• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] LineageOS 14.1 for Samsung Galaxy J3 (2016) [SM-J320FN/F/G/M] [UNOFFICIAL]

Implementing OTA Updates ?

  • Yes

    Votes: 27 93.1%
  • No

    Votes: 2 6.9%

  • Total voters
    29
  • Poll closed .
Search This thread

Sugarpop

Member
Apr 11, 2013
7
0
How can I fix the hotspot losing its security?

I set up the hotspot with WPA2 PSK, I connect successfully on one device, then check on a second device and it's secured, but if I disconnect / disable wifi on device one, the previously secured hotspot now becomes open and any device can connect.

On the J3, there's no devices showing connected, but the devices are connected and can use the phones data - now if I turn off the hotspot, and then put back on again the security is reapplied.
 

eurosportHD

New member
Jul 6, 2013
2
0
After flashing the rom and booting the first time i got the message "com.android.phone has stopped" and the sim cards do not work, they are not recognized, rebooting doesn't help.
Of course i wiped /data, /system and /cache before flashing.
Any idea?
 

Rotundjere

Senior Member
Dec 13, 2010
370
30
JKT48
Aosp rom dont support volte and never will work on this rom Sorry Read the posts

I know it doesn't work. I mean is there's workaround to enable VoLTE in this ROM?

I've disassembled & analyzed an app from my carrier that enable VoLTE on any devices.
This carrier only support 4G LTE network (2G & 3G isn't supported on their network), so that means any phone without VoLTE capability can't make phone calls.
But Their app seems to works on any phone with stock ROM (unrooted, without VoLTE support).

I can use their app to make VoLTE calls using this LineageOS ROM. The problem is the internet connection must be turned on at all time (to receive calls), thus making the battery drains so fast.
It's different than my other phone (Redmi Note 9 Pro), that support VoLTE out of the box. I can use VoLTE calls even with internet connection data turned off, thus making the battery standby last very long.
 
Last edited:

GRiM200

Member
Jul 16, 2020
10
1
Hello,
just finished installing this rom but for some reason it thinks that my phone is "rooted/jailbroken" when I want to install my banking app. I switched on developer mode and there it says that my root access is not active. What am I missing?
 

pleniceanu cristian

Senior Member
Aug 9, 2017
98
26
Hello,
just finished installing this rom but for some reason it thinks that my phone is "rooted/jailbroken" when I want to install my banking app. I switched on developer mode and there it says that my root access is not active. What am I missing?
some bank apps or most of them do not accept custom ROMs. I think there is a way to pass the security test but I don't know much about it. Search for more details
 

Top Liked Posts

  • There are no posts matching your filters.
  • 105
    https%3A%2F%2Fimg.xda-cdn.com%2FNEqGNs6rv5B0hFKzbB7Z_gXjqkY%3D%2Fhttp%253A%252F%252Ffiles.paulfasola.fr%252FCyanogenMod%252FLineageOS.png

    Lineage OS is a free, community built, aftermarket firmware distribution of Android 7 (Nougat), which is designed to increase performance and reliability over stock Android for your device.

    Code:
    /*  
    * Your warranty is... still valid?  
    *  
    * I am not responsible for bricked devices, dead SD cards,  
    * thermonuclear war, or you getting fired because the alarm app failed. Please  
    * do some research if you have any concerns about features included in this ROM  
    * before flashing it! YOU are choosing to make these modifications, and if  
    * you point the finger at me for messing up your device, I will laugh at you.  
    */

    Introduction
    Lineage OS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). Lineage OS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for Lineage OS is available in the Lineage OS Github repo. And if you would like to contribute to Lineage OS, please visit our Gerrit Code Review. Your changelog is whatever was merged into gerrit.

    Installation instructions

    1. Download ROM and Optional: GApps.
    2. Copy ROM and Optional: GApps to internal storage.
    3. Optional: Perform a NANDroid backup of your current ROM (Optional but highly recommended).
    4. Wipe /data, /system and /cache.
    5. Flash ROM and Optional: GApps.
    Note: First boot can take some time. They may even loop a few times...


    Screenshots


    SOON



    Known issues

    • RDS on FM Radio
    • VoLTE not implanted


    Download


    Sources


    Thanks To/Credits

    @djeman (main dev)
    @faltisal (dev, thread manager)
    micro_maniaque (OTA Server)


    FOR Q&A PLEASE USE THIS THREAD


    XDA:DevDB Information
    [ROM] LineageOS 14.1 for Samsung Galaxy J3 (2016) [SM-J320FN/F/G/M] [UNOFFICIAL], ROM for the Samsung Galaxy J3 (2016)

    Contributors
    faltisal, djeman
    Source Code: https://github.com/djeman

    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.10.x
    Based On: LineageOS

    Version Information
    Status: Stable
    Stable Release Date: 2020-08-22

    Created 2017-09-02
    Last Updated 2020-08-22
    11
    And I began the cm13 there is 4 months and the cm14.1 since 1 month ^^

    All help to develop the rom is always really appreciated ;)
    10
    I had 10 hours of time to make new build :)
    Code:
    [100% 36463/36463] build bacon
    Package Complete: /home/danijel/lineage/out/target/product/j3xnlte/lineage-14.1-20190525-UNOFFICIAL-j3xnlte.zip
    make: Leaving directory '/home/danijel/lineage'
    
    #### make completed successfully (05:15:17 (hh:mm:ss)) ####

    New build is out:

    lineage-14.1-20190525-UNOFFICIAL-j3xnlte

    -> May Security Patch

    P.S: J3 hasn't dead (for now) :D
    10
    It's only lineage updates as declain12345 said.

    I only launched a build without modifications except the lineage repo updated.
    I agree it's not fantastic but it's better than nothing :x
    9
    It's the worst bug ... I tried a lot of things to fix it ... I tried differents mali kernel modules, differents vendor drivers, differents hwcomposer, differents gralloc, a lot of build options, a lot of patches on the framebuffer driver, ...
    And the result is always the same :x
    Flickering on cm14.1 and no display on los15.1 ...

    The latest update is for the october security patch, a patch on the kernel to add a missing function to destroy a socket and some changes on ril to enable more functions.
    Maybe sim contacts works and the eap-sim protocol have more chances to work now the sim can communicate with an icc logical channel.
    FM flood log removed, missing selinux rules added.