[ROM][LineageOS-14.1] Samsung Galaxy Tab A 7.0 - SM-T280 (gtexswifi)

Search This thread

Avenger772

New member
Jan 16, 2022
1
0
So I managed to find a version of gapps that would install. But now the problem I see is that Google play store and Google services seem to appear in my apps list but not on my home screen.

Is that normal?
 
Last edited:

Gizma

New member
Jan 17, 2022
2
0
Hi! Please help me! how do I get ROOT rights? installed different versions of SuperSU. Installed using ODIN and SWRP. goes into a cyclic reboot(


sorry for my english
 

Alixbot

Senior Member
Dec 1, 2014
91
8
I'm having the weirdest issue. I installed this on my t280 and I don't know if this has been there the whole time or not but

whenever I press the power button to lock the screen the whole screen flips 180° before locking. Is this a setting I need to change?
 

totofe69

Senior Member
Feb 19, 2013
818
162
47
Gleizé
Samsung Galaxy S8
Redmi Note 8 Pro
Hi everybody
I have more and more issues.
WiFi doesn't work well, BT works when i restart the device.
And when i want to download From the net, the device restart or stops and halt.
I think the device is fed up.
I don't know what happen and i would like to know if there is another custom ROM for sm-280
 

Rainshine

New member
Jan 14, 2013
4
1
Appreciate any troubleshooting tips; From TWRP I did the standard wipe/install/mount/install, and everything seems to be fine. No bloatware, running faster, no 3.5 GB of space inexplicably gone.
Except. I basically only use the tablet for three things: VLC OTG, reading ebooks, and Pandora.
I've got no sound. I thought I heard some sound at some point during the first power on, but I definitely don't have any now. No speaker, no wired headphone, no bluetooth sound. Multiple reboots, went in and played with the sound levels, I can't get it to make a peep, and could use some tips to figure out what's wrong.
 

tmuhlhausen

New member
Dec 8, 2021
4
0
i have successfully installed it, and preformed a reinstalling using ARM Nano 7.1 Gapps. i am unsure why the first time i got an FRP lock. i managed to install it with odin to flash the recovery then quickly booting into the recovery and installing the lineage14 ZIP package with ADB, whilst also wiping dalvik cache & cache. Once finished then i mounted the system still inside twrp 3.4.0-3, and de-selected wiping dalvik and the cache going into ADB sideload. on the computer i initiated the command in adb to sideload the gapps and upon reboot everything looked proper. i will edit though if i encounter issues. mind you..... i am not connected to the internet yet.

EDIT: Absolutely Impressed... no crashes or FRP locks and the rom is extremely stable minus the fact the camera does not work obviously. Which is not a big deal... you just have to download any standard camera apk for android 7.1.2 and sideload it before you boot your rom inside the recovery.
 
Last edited:

G_Bot

Member
Jul 4, 2020
29
12
im currently looking at making a rom for this device.... updated to android 10 as long as the device will support it... from what i have read as long as the device in question, has 8GB of ram it should be able to compile and install fine up to android 10 Q. If i have success with this device i will post the custom firmware i am creating.
Thanks look forward to the new Rom you're creating. But this device only has 1.5gb of Ram. And It has 8gb of storage.
 

tmuhlhausen

New member
Dec 8, 2021
4
0
There is not much need for a new rom for this model considering its hardware capability is almost maxed out as is, i was going with the impression this version of lineage 14.1 was not stable based on my own and others reactions. but it is however a stable rom and seems to be suffient for this tablet
 
Last edited:

Ramflop

New member
May 5, 2022
3
1
Hello, I need help! How can I root this ROM? System does not boot after Supersu install.
Thank you
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I'm running a custom ROM "Lifetime" installed with twrp. Would that still work?
    I don´t know, sorry
  • 10
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 7, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and (optional) GApps
    • Boot to recovery
    • Flash the latest build
    • If you want GApps you have to mount system first:
      Mount -> System -> Go back to the first page and install GApps as normal
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Known Bugs :
    • Camera doesn't work (use opencamera instead)
    • RadioFM doesn't work

    Credits :

    Source :

    XDA:DevDB Information
    LineageOS for gtexswifi, ROM for the Samsung Galaxy Tab A series

    Contributors
    _mone
    Source Code: https://github.com/lineageos

    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: T280XXS0ARJ2

    Version Information
    Status:
    Testing

    Created 2020-09-03
    Last Updated 2020-09-08
    6
    New build: lineage-14.1-20210209-UNOFFICIAL-gtexswifi.zip

    You can now format the external sdcard as internal storage
    5
    For anyone trying to figure out how to get this or other ROMs working on the T280 with a valid google account (without FRP ruining all of your fun), here is what you need to know:

    * Follow instructions to install custom bootloader, ROM and GApps Pico (see OP)
    * Download ADB here: https://dl.google.com/android/repository/platform-tools-latest-windows.zip
    * Unzip to a folder, open a cmd prompt and navigate to that folder
    * On the tablet, perform initial setup and go into settings, Developer Options and enable root access (ADB only)
    * Connect your tablet to your PC.
    * Run the following commands:
    * adb devices (confirm that adb "sees" your device as connected)
    * adb root
    * adb remount
    * adb pull /system/build.prop
    * Now you will have a copy of build.prop in your adb folder. Edit the file with notepad, or some other simple text editor that will not insert hidden characters.
    * Find the following entry: ro.frp.pst=
    * Comment it out (disable it) by adding a # at the beginning of the line. Ex: # ro.frp.pst=
    * save the file
    * Go back to adb and run the following commands
    * adb remount -o rw /system
    * adb push build.prop /system/build.prop
    * adb shell chmod 644 /system/build.prop
    * adb remount -o ro /system
    * adb reboot
    * Add your google account. You could add your account before modifying build.prop, but if you forget and reboot you'll be out of luck and will have to start from scratch flashing the factory ROM, etc.
    * That should do it! You should now be able to reboot as much as you like.
    * If you want extra assurance in the event that build.prop ever gets overwritten, you can blank out the FRP partition with FRP destroyer (I recommend): https://forum.xda-developers.com/t/frp-destroyer-flashable-zip.3920067/

    When I tried FRP destroyer without modifying build.prop, I never got to install it with TWRP as FRP would already be blocking me from booting. It is possible that I was doing things in the wrong order, but I thought I would share just in case someone finds themselves stuck like I was. I am not a pro at this, I have used CM on a few devices in the past but have never dealt with FRP before. I prefer to share my learnings to hopefully help others in the future.

    Cheers!

    SCH00N3R
    3
    New build: lineage-14.1-20210207-UNOFFICIAL-gtexswifi.zip

    GPS should work now.
    Let me know.

    I'm having difficulties uploading new builds.. if anyone is building for themselves and want to share builds with the community, feel free to do it here.
    2
    I'm a newbie in this topic. Can you guide me how to do it on my device? At this point I made everything like expalained in the link below and I'm stuck on error 7 in TWRP. View attachment 5177541
    Hi,
    for error 7 : see here
    And for the way of how to proceed, I suggest you watch the youtube video from Mone:
    I used : odin 3.10.7;twrp_3.2.1-1_sm-t280_080118;lineage-14.1-20200929-UNOFFICIAL-gtexswifi;
    and after installation of the custom rom : Magisk 20.4