[ROM][LineageOS-14.1] Samsung Galaxy Tab A 7.0 - SM-T280 (gtexswifi)

Search This thread

existensialdread

New member
Sep 12, 2020
4
0
please help, i flashed it with odin and it said rqt close, after 10 minutes i restarted it and it freezes when i try to go to recovery. should i be using a specific odin version

---------- Post added at 02:28 AM ---------- Previous post was at 01:44 AM ----------

edit, i think i bricked it, it is stuck on the galaxy tab a logo and only boots into download mode
 

ronsan

Senior Member
Aug 3, 2012
117
19
Aracaju
please help, i flashed it with odin and it said rqt close, after 10 minutes i restarted it and it freezes when i try to go to recovery. should i be using a specific odin version

---------- Post added at 02:28 AM ---------- Previous post was at 01:44 AM ----------

edit, i think i bricked it, it is stuck on the galaxy tab a logo and only boots into download mode

Try to be more clear. Report step by step what you did ...
 

existensialdread

New member
Sep 12, 2020
4
0
Ok, so what I did was try to flash _mone’s twrp with odin onto my t280. Odin then says rqt close. After waiting 10 minutes, I hard reset my tablet, and now it is stuck on the Galaxy tab a logo and only boots into download mode. Recovery does not work.

---------- Post added at 03:46 PM ---------- Previous post was at 03:45 PM ----------

2faraway2 do you know where to get the stock os? I cannot find the us version of the os.
 

ronsan

Senior Member
Aug 3, 2012
117
19
Aracaju
Ok, so what I did was try to flash _mone’s twrp with odin onto my t280. Odin then says rqt close. After waiting 10 minutes, I hard reset my tablet, and now it is stuck on the Galaxy tab a logo and only boots into download mode. Recovery does not work.

---------- Post added at 03:46 PM ---------- Previous post was at 03:45 PM ----------

2faraway2 do you know where to get the stock os? I cannot find the us version of the os.

Redo the twrp flash correctly and see if you tried to access it properly.
 

2faraway2

Senior Member
Apr 24, 2016
185
29
Ok, so what I did was try to flash _mone’s twrp with odin onto my t280. Odin then says rqt close. After waiting 10 minutes, I hard reset my tablet, and now it is stuck on the Galaxy tab a logo and only boots into download mode. Recovery does not work.

---------- Post added at 03:46 PM ---------- Previous post was at 03:45 PM ----------

2faraway2 do you know where to get the stock os? I cannot find the us version of the os.

I've had the same issue after the flash of the newest TWRP ...
So my tested fully working steps are:

- Flash stock rom
- Enable developer options in stock
- Enable USB debugging and unlock bootloader (don't know the right english term)

- Flash TRWP 3.4.0-1_mone...tar in ODIN

- As soon as the tablet boots reboot in recovery (HOME + VOL UP + POWER)
(because the 3.4.0-2_mone...tar doesn't boot after the flash)

- In TWRP install 3.4.0-2_mone...img , then reboot recovery

- In TWRP wipe cache/dalvik/data, then format data

- In TWRP install the rom
(+ install widivine blobs if needed)
(+ install Magisk 20.4 if needed)

- Reboot system (first boot will take around 5 minutes, so be patient ..;) )

The stock rom can be downloaded via SamFirm (windows programm), should be easy to find :)

---------- Post added at 08:51 PM ---------- Previous post was at 08:31 PM ----------

@_mone:

Found two issues (except these the rom is fantastic, thanks for your hard work :) )

Like already mentioned the camera is crap ..
But that doesn't matter that much because open camera work perfect. Can be found in FDroid store or even Google play store
However most tested other camera apps aren't working too, so imho something with the camera api is broken/incorrect ..

Maybe you can cheek the LOS14 devices trees of the SM-T580 (gtaxlwifi) or even SM-G800F (kminilte) of the for an optimized code ?
The developer of the kminilte (spookcity) had the same issues in his first LOS14 builds, but found a perfect fix ..


Second issue is the GPS
This doesn't work for me, no satellites found (neither gps nor glonass), all satellite-testing apps will fail or at least report that they couldn't find any ..

I don't have any workround yet for the gps location issue, tips/hints warmly welcome :)
 
Last edited:

existensialdread

New member
Sep 12, 2020
4
0
Redo the twrp flash correctly and see if you tried to access it properly.
This is the problem. I could never flash it properly because odin says rqt close in the middle of flashing.

---------- Post added at 10:12 PM ---------- Previous post was at 10:02 PM ----------

Try to be more clear. Report step by step what you did ...

No worries ;)
Flash the stock rom in odin (you have to be in the download mode) and start from the beginning.

I've had the same issue after the flash of the newest TWRP ...
So my tested fully working steps are:

- Flash stock rom
- Enable developer options in stock
- Enable USB debugging and unlock bootloader (don't know the right english term)

- Flash TRWP 3.4.0-1_mone...tar in ODIN

- As soon as the tablet boots reboot in recovery (HOME + VOL UP + POWER)
(because the 3.4.0-2_mone...tar doesn't boot after the flash)

- In TWRP install 3.4.0-2_mone...img , then reboot recovery

- In TWRP wipe cache/dalvik/data, then format data

- In TWRP install the rom
(+ install widivine blobs if needed)
(+ install Magisk 20.4 if needed)

- Reboot system (first boot will take around 5 minutes, so be patient ..;) )

The stock rom can be downloaded via SamFirm (windows programm), should be easy to find :)

---------- Post added at 08:51 PM ---------- Previous post was at 08:31 PM ----------

@_mone:

Found two issues (except these the rom is fantastic, thanks for your hard work :) )

Like already mentioned the camera is crap ..
But that doesn't matter that much because open camera work perfect. Can be found in FDroid store or even Google play store
However most tested other camera apps aren't working too, so imho something with the camera api is broken/incorrect ..

Maybe you can cheek the LOS14 devices trees of the SM-T580 (gtaxlwifi) or even SM-G800F (kminilte) of the for an optimized code ?
The developer of the kminilte (spookcity) had the same issues in his first LOS14 builds, but found a perfect fix ..


Second issue is the GPS
This doesn't work for me, no satellites found (neither gps nor glonass), all satellite-testing apps will fail or at least report that they couldn't find any ..

I don't have any workround yet for the gps location issue, tips/hints warmly welcome :)

Samfirm does not have a download for the american os for the t280, where do I get that?
 

existensialdread

New member
Sep 12, 2020
4
0
Ok, here is my progress so far. I have gone back to stock and tried to install mones version of twrp but it is always stuck at rqt close.

---------- Post added 14-09-2020 at 12:19 AM ---------- Previous post was 13-09-2020 at 11:54 PM ----------

I got it to work! :)
 

_mone

Inactive Recognized Developer
Jul 25, 2015
950
2,898
London
Apologies for this recovery mess with ODIN, but this device has "secure boot" enabled and we need special tools to sign the .img. We now have them!
I've uploaded a new recovery build (TWRP-3.4.0-3).
The 3rd is always the good-one, right!? It should be!
From now on our recovery.img and boot.img will be properly signed as the stock-ones, so there shouldn't be anymore issues with ODIN.
See this and this commit for the tools.

As always: Flash at your own risk. If anyone flash it with ODIN let me know how it goes.

P.S.: I'm reading every post in this thread and I'm aware of bugs and suggestions reported.
 

2faraway2

Senior Member
Apr 24, 2016
185
29
@_mone :

Can you confirm the gps issue ?
I'm not sure whether it is my single problem because I've patched your rom with the nanodroid-patcher to be able to install MicroG. Maybe it's an MicroG issue ?

Another question:
Adaptive brightness isn't implemented but I think that wasn't in stock also, right ?
 

barrie.kenyon

Member
Jun 9, 2015
33
4
Hi, and thank you to _mone!
I have now got my T280 running the latest rom. A steep learning curve, but I am finally there.
My first install was blocked by 'FRP Lock' when I rebooted. As suggested by _mone, I reloaded the stock rom and started again.
This time I loaded up the lineage rom and gapps, and found an FRP removal site at samsungsfour.com. It did not work for me. Back to loading the stock rom, and start again.
This time I used the 'FRP Destroyer - flashable zip' suggested by Fraser06 and it has worked. I came across the wipe problem, rebooted into recovery again and it loaded up with no further trouble. I loaded the Open Camera app, also fine.
My T280 now runs the new rom and everything works. Emails, web browsing, BBC News, Cool Reader ebook app, sudoku, Facebook, fantastic!
Thank you to _mone and all the other people who have provided advice and guidance.
Keep up the good work. (I am looking forward to Lineage 17.1 now!)
 

_mone

Inactive Recognized Developer
Jul 25, 2015
950
2,898
London
@_mone :

Can you confirm the gps issue ?
I'm not sure whether it is my single problem because I've patched your rom with the nanodroid-patcher to be able to install MicroG. Maybe it's an MicroG issue ?

Another question:
Adaptive brightness isn't implemented but I think that wasn't in stock also, right ?

Yes. No gps at all. I was working on it this morning.. no success yet.
About adaptive brightness.. not sure about stock but we don't have a light sensor so i guess it wasn't implemented in stock neither.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    The latest build works fine, but it having troubles with the WiFi, it doesn't see any wifi sometimes, and some times see it but doesn't connect, if can solve that, I will appreciate, thanks @mone
    1
    O WiFi esta desconectando e não esta localizando a rede WiFi! Depois de varias tentativas ele conecta!

    Translation: WiFi is disconnecting and not locating the WiFi network! After several attempts it connects!

    Greetings, and welcome to XDA. Please be respectful and observant of XDA Rule #4 for all of your future posts. Thank you.

    4. Use the English language.

    We understand that with all the different nationalities, not everyone speaks English well, but please try. If you're really unable to post in English, use an online translator. You're free to include your original message in your own language, below the English translation. (This rule covers your posts, profile entries and signature). You could try :- https://translate.google.com/ or https://www.babelfish.com/ or use one of your choice.
  • 7
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 7, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and (optional) GApps
    • Boot to recovery
    • Flash the latest build
    • If you want GApps you have to mount system first:
      Mount -> System -> Go back to the first page and install GApps as normal
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Known Bugs :
    • Camera doesn't work (use opencamera instead)
    • RadioFM doesn't work

    Credits :

    Source :

    XDA:DevDB Information
    LineageOS for gtexswifi, ROM for the Samsung Galaxy Tab A series

    Contributors
    _mone
    Source Code: https://github.com/lineageos

    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: T280XXS0ARJ2

    Version Information
    Status:
    Testing

    Created 2020-09-03
    Last Updated 2020-09-08
    6
    New build: lineage-14.1-20210209-UNOFFICIAL-gtexswifi.zip

    You can now format the external sdcard as internal storage
    4
    For anyone trying to figure out how to get this or other ROMs working on the T280 with a valid google account (without FRP ruining all of your fun), here is what you need to know:

    * Follow instructions to install custom bootloader, ROM and GApps Pico (see OP)
    * Download ADB here: https://dl.google.com/android/repository/platform-tools-latest-windows.zip
    * Unzip to a folder, open a cmd prompt and navigate to that folder
    * On the tablet, perform initial setup and go into settings, Developer Options and enable root access (ADB only)
    * Connect your tablet to your PC.
    * Run the following commands:
    * adb devices (confirm that adb "sees" your device as connected)
    * adb root
    * adb remount
    * adb pull /system/build.prop
    * Now you will have a copy of build.prop in your adb folder. Edit the file with notepad, or some other simple text editor that will not insert hidden characters.
    * Find the following entry: ro.frp.pst=
    * Comment it out (disable it) by adding a # at the beginning of the line. Ex: # ro.frp.pst=
    * save the file
    * Go back to adb and run the following commands
    * adb remount -o rw /system
    * adb push build.prop /system/build.prop
    * adb shell chmod 644 /system/build.prop
    * adb remount -o ro /system
    * adb reboot
    * Add your google account. You could add your account before modifying build.prop, but if you forget and reboot you'll be out of luck and will have to start from scratch flashing the factory ROM, etc.
    * That should do it! You should now be able to reboot as much as you like.
    * If you want extra assurance in the event that build.prop ever gets overwritten, you can blank out the FRP partition with FRP destroyer (I recommend): https://forum.xda-developers.com/t/frp-destroyer-flashable-zip.3920067/

    When I tried FRP destroyer without modifying build.prop, I never got to install it with TWRP as FRP would already be blocking me from booting. It is possible that I was doing things in the wrong order, but I thought I would share just in case someone finds themselves stuck like I was. I am not a pro at this, I have used CM on a few devices in the past but have never dealt with FRP before. I prefer to share my learnings to hopefully help others in the future.

    Cheers!

    SCH00N3R
    3
    New build: lineage-14.1-20210207-UNOFFICIAL-gtexswifi.zip

    GPS should work now.
    Let me know.

    I'm having difficulties uploading new builds.. if anyone is building for themselves and want to share builds with the community, feel free to do it here.
    2
    I'm a newbie in this topic. Can you guide me how to do it on my device? At this point I made everything like expalained in the link below and I'm stuck on error 7 in TWRP. View attachment 5177541
    Hi,
    for error 7 : see here
    And for the way of how to proceed, I suggest you watch the youtube video from Mone:
    I used : odin 3.10.7;twrp_3.2.1-1_sm-t280_080118;lineage-14.1-20200929-UNOFFICIAL-gtexswifi;
    and after installation of the custom rom : Magisk 20.4