[ROM][LineageOS-14.1] Samsung Galaxy Tab A 7.0 - SM-T280 (gtexswifi)

Search This thread

Mariadif

Member
Dec 29, 2020
9
3
I Have a question, nothing linked to GPS. What can be linked/transfered to the internal sd card? Is there any limitation, ie. Can I linked all system file?
 

ven316

New member
Jan 24, 2019
3
0
Can someone compile or teach me how to compile an overclockable kernel?
The device is still laggy with a 1.3GHz max clock
It would be way better to be clocked 1.5+GHz and have a schedutil governor if possible
 

GLRioux

Member
Apr 29, 2019
6
0
I want to update Android on my wife's Tab A 7" so than an SD card can be formatted as internal memory. We'd replace the tablet, except that no current 7" tablet can match its screen resolution. I'm a newbie as far as rooting Android and updating the OS on a tablet, but I'm reading up on it. I have some of questions first.

Does Lineage 14.1 provide the most up to date version of Android that is available for her Tab A? If newer versions are available, how polished and/or reliable are they?

In _mone's Sept 3, 2020 post, it lists "External SDCard can't be formatted as internal storage" as a known bug. Has this been corrected yet? If not, is someone specifically working to resolve this problem?

Thanks!

Jerry
 

Rutilicus

Member
Aug 15, 2006
13
1
Unfortuntely, you cannot format your external card as internal card yet. A lot of people are waiting for this option and I hope we will get this feature soon.
 
  • Like
Reactions: GLRioux

Justin Thought

Senior Member
May 5, 2013
429
309
Monterrey
Hello, _mone and all. You don't know how excited I am to find this thread, and this ROM. When I first bought the TAB (October 2019), all the developers and users were bemoaning that there were no custom ROMs for this equipment, despite attempts by several to develop one. Now I see this one has been through the trials (and unfortunate errors--but hey! that happens!) and everyone seems satisfied. Couple'a quick questions--

is lineage-14.1-20200929-UNOFFICIAL- the most recent build?

Can anyone direct me to a listing of the Lineage features? I have specific things that I desire (not necessarily need, obviously, since I've been using the stock ROM these couple'a years) such as page animation, the ability to use an alternative on-screen method of turning off the screen--things that you often or sometimes find in custom ROMs.

And, probably a very general question--are people overall satisfied with using this ROM?

I've downloaded the pertenent files, the new Twerp, the ROM (duhhh), and I'll snag the most recent version of GAAPS once I hear back on these questions, but I'm going to hold off on flashing anything. Though a part of my mind is going to be like that child in the back seat--"Are we there yet? Huh? Are we there?"

And, anytime a person benefits from the work of a developer who has devoted his time, effort, and skull-sweat to something he provides gratis, I have to say in advance (and I'll say afterwards too, 'cause you can't say it enough) Thank you thank you thank you! I look forward to making my TAB, which was partly under the perview of Android before, my own at last.
 
  • Like
Reactions: Zocker1012

mc0133

Member
Aug 9, 2020
6
0
Wondering if @_mone is still actively developing this rom? lineage-14.1-20200929-UNOFFICIAL appears to be the most recent build he has released, yet it seems to work ok. Have to thank him for even bringing a newer android to the tab

Wondering if the battery image when charging the battery powered off can be fixed? Currently, it displays upside down and looks funny.

Also scrolling through the homescreen pages seems to not be particularly smooth (default homescreen launcher that comes with the rom, haven't tried any third party homescreen replacement launcher app you have to get thru the google playstore)
 

treapan

New member
Feb 4, 2021
1
0
I've seen several people on this thread say the audio for this ROM doesn't work.
Is this still a problem or has it been fixed?

My use case is mainly using the tablet's built-in speakers or wired headphones.
 

_mone

Inactive Recognized Developer
Jul 25, 2015
950
2,898
London
New build: lineage-14.1-20210207-UNOFFICIAL-gtexswifi.zip

GPS should work now.
Let me know.

I'm having difficulties uploading new builds.. if anyone is building for themselves and want to share builds with the community, feel free to do it here.
 

Attachments

  • Screenshot_20210208-104947.png
    Screenshot_20210208-104947.png
    76.5 KB · Views: 50

FBK2904

Member
Nov 28, 2011
12
3
Near Stuttgart (Germany)

Hi _mone, great job and it works very well -> THANK YOU :love:!
Is there still hope that the system camera app will no longer crash?
I am using "Motion Detector" and I see an image in the app settings for the front and rear camera. But the app doesn't want to trigger on movement (I've already tested "Open Camera" and "Footej Camera").

Greetz,
Frank
 

_mone

Inactive Recognized Developer
Jul 25, 2015
950
2,898
London
Is there still hope that the system camera app will no longer crash?
Not sure. Camera is always a mess to port properly.. I'll give it a shot when I can.. no promises.

Is this new version solving the issue of wifi disconnection?
I don't have any wifi disconnections, you probably want to clean install the latest build. If the problem persist grab and share a logcat and I'll see if I can help.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    The latest build works fine, but it having troubles with the WiFi, it doesn't see any wifi sometimes, and some times see it but doesn't connect, if can solve that, I will appreciate, thanks @mone
    1
    O WiFi esta desconectando e não esta localizando a rede WiFi! Depois de varias tentativas ele conecta!

    Translation: WiFi is disconnecting and not locating the WiFi network! After several attempts it connects!

    Greetings, and welcome to XDA. Please be respectful and observant of XDA Rule #4 for all of your future posts. Thank you.

    4. Use the English language.

    We understand that with all the different nationalities, not everyone speaks English well, but please try. If you're really unable to post in English, use an online translator. You're free to include your original message in your own language, below the English translation. (This rule covers your posts, profile entries and signature). You could try :- https://translate.google.com/ or https://www.babelfish.com/ or use one of your choice.
  • 7
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 7, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and (optional) GApps
    • Boot to recovery
    • Flash the latest build
    • If you want GApps you have to mount system first:
      Mount -> System -> Go back to the first page and install GApps as normal
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Known Bugs :
    • Camera doesn't work (use opencamera instead)
    • RadioFM doesn't work

    Credits :

    Source :

    XDA:DevDB Information
    LineageOS for gtexswifi, ROM for the Samsung Galaxy Tab A series

    Contributors
    _mone
    Source Code: https://github.com/lineageos

    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: T280XXS0ARJ2

    Version Information
    Status:
    Testing

    Created 2020-09-03
    Last Updated 2020-09-08
    6
    New build: lineage-14.1-20210209-UNOFFICIAL-gtexswifi.zip

    You can now format the external sdcard as internal storage
    4
    For anyone trying to figure out how to get this or other ROMs working on the T280 with a valid google account (without FRP ruining all of your fun), here is what you need to know:

    * Follow instructions to install custom bootloader, ROM and GApps Pico (see OP)
    * Download ADB here: https://dl.google.com/android/repository/platform-tools-latest-windows.zip
    * Unzip to a folder, open a cmd prompt and navigate to that folder
    * On the tablet, perform initial setup and go into settings, Developer Options and enable root access (ADB only)
    * Connect your tablet to your PC.
    * Run the following commands:
    * adb devices (confirm that adb "sees" your device as connected)
    * adb root
    * adb remount
    * adb pull /system/build.prop
    * Now you will have a copy of build.prop in your adb folder. Edit the file with notepad, or some other simple text editor that will not insert hidden characters.
    * Find the following entry: ro.frp.pst=
    * Comment it out (disable it) by adding a # at the beginning of the line. Ex: # ro.frp.pst=
    * save the file
    * Go back to adb and run the following commands
    * adb remount -o rw /system
    * adb push build.prop /system/build.prop
    * adb shell chmod 644 /system/build.prop
    * adb remount -o ro /system
    * adb reboot
    * Add your google account. You could add your account before modifying build.prop, but if you forget and reboot you'll be out of luck and will have to start from scratch flashing the factory ROM, etc.
    * That should do it! You should now be able to reboot as much as you like.
    * If you want extra assurance in the event that build.prop ever gets overwritten, you can blank out the FRP partition with FRP destroyer (I recommend): https://forum.xda-developers.com/t/frp-destroyer-flashable-zip.3920067/

    When I tried FRP destroyer without modifying build.prop, I never got to install it with TWRP as FRP would already be blocking me from booting. It is possible that I was doing things in the wrong order, but I thought I would share just in case someone finds themselves stuck like I was. I am not a pro at this, I have used CM on a few devices in the past but have never dealt with FRP before. I prefer to share my learnings to hopefully help others in the future.

    Cheers!

    SCH00N3R
    3
    New build: lineage-14.1-20210207-UNOFFICIAL-gtexswifi.zip

    GPS should work now.
    Let me know.

    I'm having difficulties uploading new builds.. if anyone is building for themselves and want to share builds with the community, feel free to do it here.
    2
    I'm a newbie in this topic. Can you guide me how to do it on my device? At this point I made everything like expalained in the link below and I'm stuck on error 7 in TWRP. View attachment 5177541
    Hi,
    for error 7 : see here
    And for the way of how to proceed, I suggest you watch the youtube video from Mone:
    I used : odin 3.10.7;twrp_3.2.1-1_sm-t280_080118;lineage-14.1-20200929-UNOFFICIAL-gtexswifi;
    and after installation of the custom rom : Magisk 20.4