[ROM][LineageOS][17.1][UNOFFICIAL][Nexus10] -> 2021-04-10

Search This thread

pollopopo

Senior Member
May 19, 2013
55
7
28
guys good morning, I ask you a question, I tried the latest version of lineage 17.1 and it works well but it is very slow, it is unusable, I am the one who configures something wrong or is it better to take 5 steps back and go back to version 5.1.1 that I remember being quite fast :)
 

geronimoge

Senior Member
Aug 4, 2016
492
116
43
On my device it's slow too. Propably the hardware is getting (too) old.
Also one of my apps has an FC when I'm opening it - unfortunately the one I'd use the most.
Since followmsi is only releasing security updates after all his great effort (thanks again!) and nobody seems to continue his work I'm finally thinking about saying goodbye to my Nexus 10.
 

pollopopo

Senior Member
May 19, 2013
55
7
28
On my device it's slow too. Propably the hardware is getting (too) old.
Also one of my apps has an FC when I'm opening it - unfortunately the one I'd use the most.
Since followmsi is only releasing security updates after all his great effort (thanks again!) and nobody seems to continue his work I'm finally thinking about saying goodbye to my Nexus 10.

I appreciate the great work done but android version 10 requires too many resources, already 7 is heavy, 10 makes it unusable
 

onoakino

Senior Member
Sep 25, 2015
224
51
48
Manila
Installed LOS17 coming from LOS14 and I never looked back. I don't do any heavy stuff on it. I use the tablet primarily to teach myself piano (Simply Piano). Sometimes I connect the manta to my amplifier (aux in) when I want to listen to Spotify. Bluetooth also works. V4A is also installed. Battery needs replacing as it is now only able to endure about an hour screen-on time, but that's basically its weakness - an almost 8 year old battery. LOS 17 is running like butter, at least in my case (no heavy, graphics intensive apps), but then again, we have different use-cases, so your mileage may vary.
 

pollopopo

Senior Member
May 19, 2013
55
7
28
Installed LOS17 coming from LOS14 and I never looked back. I don't do any heavy stuff on it. I use the tablet primarily to teach myself piano (Simply Piano). Sometimes I connect the manta to my amplifier (aux in) when I want to listen to Spotify. Bluetooth also works. V4A is also installed. Battery needs replacing as it is now only able to endure about an hour screen-on time, but that's basically its weakness - an almost 8 year old battery. LOS 17 is running like butter, at least in my case (no heavy, graphics intensive apps), but then again, we have different use-cases, so your mileage may vary.
to me it jerks well on the main screen, and without installing anything

mystery of faith
 

pollopopo

Senior Member
May 19, 2013
55
7
28
to me it also freezes in the main menu without having installed anything

i tried the 6.0 aosp it goes perfectly, almost unbelievable, too bad for the security patch
 

onoakino

Senior Member
Sep 25, 2015
224
51
48
Manila
to me it also freezes in the main menu without having installed anything

i tried the 6.0 aosp it goes perfectly, almost unbelievable, too bad for the security patch

Is the "freezing" only happening when you power on the tablet? I have mine set up with a pin. Everytime I turn on (from power off state to power on state, aka cold boot), there is a short moment, probably about 3 minutes before I could get the manta to accept my pin. I've learned to live with this behavior and just wait for the manta to "get everything ready" -- reminds me of Windows XP and Windows 7 of old where you have to wait for all the background process to finish loading before Windows could let you use the mouse for anything, -- and only after waiting for some time will my PIN input be successful.

I would know when the tablet is ready to accept my pin when I can see a Google Play Protection notification warning me about potentially unsafe application (Viper4Android). Once I see that notif on the lockscreen, I would know the system is 100% ready to accept my PIN. From then on, no more waiting needed for subsequent pin unlocks.
 

followmsi

Senior Member
Oct 10, 2013
4,068
12,108
263
Lineage-17.1 - January 2021

lineage-17.1-20210111-UNOFFICIAL-manta.zip

Changes:
- Google security updates -> January 2021
- Patched framework/base to support microG
- Patched framework/av to bring back "wifi-display" in android 10. (Still not working correctly !)
- Latest LineageOS changes for Android 10

Pls check first page for known issues.

If Safety.net check does not work just disable and re-enable "Magisk Hide" in Magisk settings menu.

For the "System and Cache repartitioning / Opengapps: Error 70" topic pls have a look on the first page.

Enjoy :p
 

Azukegi

Member
Mar 23, 2016
5
1
23
Lineage-17.1 - January 2021

lineage-17.1-20210111-UNOFFICIAL-manta.zip

Changes:
- Google security updates -> January 2021
- Patched framework/base to support microG
- Patched framework/av to bring back "wifi-display" in android 10. (Still not working correctly !)
- Latest LineageOS changes for Android 10

Pls check first page for known issues.

If Safety.net check does not work just disable and re-enable "Magisk Hide" in Magisk settings menu.

For the "System and Cache repartitioning / Opengapps: Error 70" topic pls have a look on the first page.

Enjoy :p
Is there a way to use the flashlight? I know the camera does not work atm
 

followmsi

Senior Member
Oct 10, 2013
4,068
12,108
263
Lineage-17.1 - February 2021

lineage-17.1-20210208-UNOFFICIAL-manta.zip

Changes:
- Google security updates -> February 2021
- Patched framework/base to support microG
- Patched framework/av to bring back "wifi-display" in android 10. (Still not working correctly !)
- Latest LineageOS changes for Android 10

Pls check first page for known issues.

If Safety.net check does not work just disable and re-enable "Magisk Hide" in Magisk settings menu.

For the "System and Cache repartitioning / Opengapps: Error 70" topic pls have a look on the first page.

Enjoy :p
 

dahawthorne

Senior Member
Nov 15, 2014
1,960
1,809
143
Brighton
@followmsi, thank you once again for keeping us updated.
One minor point that I think I may have read somewhere in this thread, though equally it may just be my own N10. On reboot the device quickly shows the PIN input screen and accepts the PIN, but then stalls and times out to black. This happens repeatedly for maybe about 90 seconds, after which it finally works.
Not a big thing if you're expecting it, but perhaps confusing for new users. If this is a known behaviour, would it be worth noting in on the first post?
 

AciDCooL85

New member
Feb 17, 2021
1
0
11
I'm getting error 7, complete wipe nothing worked even tried editting the updater script. Can someone point me in the right direction? Last known working rom was Omni7.1.2. Maybe radio? SOS

Did the partitioning lanchon-repit-09180102-cache=max+wipe-system=1228M-manta.zip. I'm not sure if I had a 32GB version but I only see 16GB, am I assuming correctly that only the system partiton is resized and "the rest" goes to the sdcard mountpoint?

And still had error 70 when trying to use gapps stock. Went with pico which worked. So the partitioning still not enough for stock?!
 
Last edited:

GhostMachine7

Member
Sep 26, 2020
8
1
3
@followmsi, thank you once again for keeping us updated.
One minor point that I think I may have read somewhere in this thread, though equally it may just be my own N10. On reboot the device quickly shows the PIN input screen and accepts the PIN, but then stalls and times out to black. This happens repeatedly for maybe about 90 seconds, after which it finally works.
Not a big thing if you're expecting it, but perhaps confusing for new users. If this is a known behaviour, would it be worth noting in on the first post?

This also happens with mine with the most recent build installed. I did a system refresh prior to installing so I don't know why it does that. I'm assuming that it's just busy in the background getting things set up because afterwards it works normally, but if there's a fix let me know.
 

GhostMachine7

Member
Sep 26, 2020
8
1
3
Lineage-17.1 - February 2021

lineage-17.1-20210208-UNOFFICIAL-manta.zip

Changes:
- Google security updates -> February 2021
- Patched framework/base to support microG
- Patched framework/av to bring back "wifi-display" in android 10. (Still not working correctly !)
- Latest LineageOS changes for Android 10

Pls check first page for known issues.

If Safety.net check does not work just disable and re-enable "Magisk Hide" in Magisk settings menu.

For the "System and Cache repartitioning / Opengapps: Error 70" topic pls have a look on the first page.

Enjoy :p

I installed this update, following the directions on the original post on the first page of this thread. It works quite well with one major exception. When I try to watch a video using the tubi app the video begins to load, the transport controls and timescale are displayed, then the tablet reboots without warning. It happens every time using the tubi app, but it plays videos just fine using VLC. I tried to watch tubi using their website, but that just kicks you to the app, or the Play Store if the app isn't installed, so I was unable to test browser video.

Any suggestions? Any logs that I should post and if so, how do I do that? It's a bit of a problem because with its screen it's a great device for watching movies.

On the bright side of things, it works great for the Rosetta Stone app. The Public Library where I live lets members use the app for free so you can take your pick of languages to learn. I use it with a pair of good quality on-ear headphones that have a mic in the cord and it's an excellent setup. Just a suggestion for anyone that might be interested in that sort of thing.
 

DragonFire1024

Senior Member
Mar 27, 2017
4,688
1,873
233
40
Fort Lauderdale
www.twitter.com
Lineage-17.1 - February 2021

lineage-17.1-20210208-UNOFFICIAL-manta.zip

Changes:
- Google security updates -> February 2021
- Patched framework/base to support microG
- Patched framework/av to bring back "wifi-display" in android 10. (Still not working correctly !)
- Latest LineageOS changes for Android 10

Pls check first page for known issues.

If Safety.net check does not work just disable and re-enable "Magisk Hide" in Magisk settings menu.

For the "System and Cache repartitioning / Opengapps: Error 70" topic pls have a look on the first page.

Enjoy :p

In regards to the wi-fi display I'm pretty sure the problem has to do with the fact that the system is not recognizing the p2p interface. Without Wi-Fi Direct working properly, I'm almost pretty sure the Wi-Fi display or screen mirroring also will not work properly. I do believe you built the Android 7 AOSP ROM for this device as well? I was able to get my LG K51 to act as a source and the Nexus tablet to act as the sink and was able to receive a screen mirror on my Nexus 10 from the LG. Just download this APK and install it on the device that is the sink. You have got to get the timing just right and it will work. I still haven't mastered it and can only get it to work every so often. https://m.apkpure.com/wi-fi-display-miracast-receiver/soho.studio.sara.wifidisplaysink
 

gadb

New member
Feb 27, 2021
1
0
1
guys good morning, I ask you a question, I tried the latest version of lineage 17.1 and it works well but it is very slow, it is unusable, I am the one who configures something wrong or is it better to take 5 steps back and go back to version 5.1.1 that I remember being quite fast :)
Hey, I'm pretty stoked at being able to still use my Nexus 10, but I'm experiencing the sluggishness too. Bringing up the app list and scrolling is fairly jerky, but I can live with that. The main issue is video and audio playback in VLC and YouTube. Is there an optimal prior version I might try if I'm looking to speed things up a little?
Thanks, G.
 

Galaxyninja66

Senior Member
Jan 25, 2015
441
112
73
Milton
Hello followmsi, I'm so happy to see you are still working on our shared chonker of a tablet. I recently bought another one (just can't get away from it) and wanted to retry porting sailfiish OS to it but first needed a good android base. I'm now pursuing computer engineering, so this might play well into my major. I was wondering about the HAL camera frameworks, and if it would be feasible to rewrite the camera binaries in ARM machine code from scratch and add a framework so that they can kind of "snap in place" with the linux kernel. Assuming my understanding of how this hardware works is correct. I wanted a new tablet but they all look likt sh*t and the Nexus 10 is just such a big and beefy son of a b*tch you can't help but love it. Hoping to hear back, I'm syncing the sources and will be invstigating the camera issues right now.

tl;dr, rather than reconcile our archaic camera drivers with 10, how hard would it be to rewrite a new camera driver in ARM machinecode/assembly? Since I assume that's what it all comes down to (and as a CE is my bread and butter baby)
 

Azukegi

Member
Mar 23, 2016
5
1
23
Hey, I'm pretty stoked at being able to still use my Nexus 10, but I'm experiencing the sluggishness too. Bringing up the app list and scrolling is fairly jerky, but I can live with that. The main issue is video and audio playback in VLC and YouTube. Is there an optimal prior version I might try if I'm looking to speed things up a little?
Thanks, G.
Youtube is the only thing that is not buggy for me, vlc will not play videos
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone