[ROM] LineageOS 17/18/19 UNOFFICIAL - (Update: 2023-02-25)

Shall F-Droid be included in the ROM(s)?


  • Total voters
    199
Search This thread

teguwecali

Member
Aug 19, 2018
9
1
Hi, can anyone help me?
I dirty-upgraded from version 17 to 18, and after that I dirty-upgraded to 19. I made a backup of version 17 beforehand.
After upgrading I wanted to roll back to version 17. I wiped all the data and did a clean install, but the system doesn't want to boot. After restarting, my phone boots to a black screen (with the green LED for microsecond) and then boots back to TWRP on its own.

Now all I can do is install a clean version 19 and use it. The backup doesn't want to boot, giving an error `extractTarFork() process ended with ERROR: 255`. Both clean installed 17 and 18 versions are won’t boot.
I even updated TWRP, but it had no effect.

What can I do?
Thanks.
 

petefoth

Senior Member
Dec 12, 2015
219
175
Whaley Bridge
Sony Xperia Z3 Compact
I wiped all the data and did a clean install, but the system doesn't want to boot.
You need to format the data partition, not just wipe it. It is usually possible to upgrade to a higher Android version by dirty flashing. but downgrading to a lower version usually requites you to format. The steps I usually follow are
1. Format data partition
2. Install the ROM
3. Boot the system, go through first time setup, setting whatever screen lock (pattern, PIN) you had when you made the backup
4. Boot to recovery
5. Restore the backup

Good luck!
 

teguwecali

Member
Aug 19, 2018
9
1
You need to format the data partition, not just wipe it. It is usually possible to upgrade to a higher Android version by dirty flashing. but downgrading to a lower version usually requites you to format. The steps I usually follow are
1. Format data partition
2. Install the ROM
3. Boot the system, go through first time setup, setting whatever screen lock (pattern, PIN) you had when you made the backup
4. Boot to recovery
5. Restore the backup

Good luck!

Thank you very much! Everything is now fine.
 

android666

Senior Member
Jun 19, 2010
90
18
this v19 react the same way as "LineageOS 19.1 UNOFFICIAL - 1.6" - no DATA for Telekom (flapping) on my device
 

Flamefire

Senior Member
Jul 26, 2013
240
618
Sony Xperia XZ1 Compact
this v19 react the same way as "LineageOS 19.1 UNOFFICIAL - 1.6" - no DATA for Telekom (flapping) on my device
You mean you get reception and can do calls&SMS but no mobile internet? Have you checked the APN settings? If you find the correct APN settings (MCC, MNC, APN, ...), best on the website of your provider, let me know and I can include them. But I need that information as "Telekom (flapping)" isn't enough, although "flapping" turns up funny pages on Google, just nothing related to phones ;-)
 
  • Like
Reactions: sieghartRM

android666

Senior Member
Jun 19, 2010
90
18
when i turn data on (with any LTE or another combination) connectivity to GSM provider flapping, situation is mentioned in 1.6 release of v19, or v20 (like here)


it looks to be problematic with Tmobile


flapping everything: gsm,sms,data...whole connectivity
 
Last edited:

3ncryptet

Member
Apr 25, 2021
11
5
Amazing, thank you for keeping us up to date with this firmware @Flamefire.

Two thing I noticed:
- 2G is not selectable anymore as preferred network type in Settings (I sometimes need that when I'm in the mountains)
- Direct unlocking with fingerprint does not work. It first unlocks to lock screen, then I have to touch a second time. Worked directly before updating.

I upgraded from derf elot's lineage-19.1-20220918-UNOFFICIAL-1.6-lilac.zip

All the best
 

Arcline

Senior Member
Sep 11, 2016
167
58
Amazing, thank you for keeping us up to date with this firmware @Flamefire.

Two thing I noticed:
- 2G is not selectable anymore as preferred network type in Settings (I sometimes need that when I'm in the mountains)
- Direct unlocking with fingerprint does not work. It first unlocks to lock screen, then I have to touch a second time. Worked directly before updating.

I upgraded from derf elot's lineage-19.1-20220918-UNOFFICIAL-1.6-lilac.zip

All the best
The 2G setting is gone since 19.1 i believe on derfelot's build as well.
As for the fingerprint it's been like this on flamefires builds for a while, dunno why, some of his changes broke that functionality because on derf's builds it's working fine.
Im curious does going into Settings > Security > Gear icon on "Screen lock > Touch fingerprint to unlock change anything?
 
  • Like
Reactions: 3ncryptet

Flamefire

Senior Member
Jul 26, 2013
240
618
Sony Xperia XZ1 Compact
The 2G setting is gone since 19.1 i believe on derfelot's build as well.
As for the fingerprint it's been like this on flamefires builds for a while, dunno why, some of his changes broke that functionality because on derf's builds it's working fine.
I can double-check why the 2G setting is gone but it looks like it was removed upstream. I see if I can patch it back.
As for the fingerprint: This is not "broken" but working as intended: A lot of people here complained that touching the on/off button immediately unlocks the phone. Hence I decided to follow suit with upstream LOS to disable this if the fingerprint is integrated into the powerbutton and cherry-picked a change used in similar LOS devices: https://github.com/Flamefire/androi...mmit/924352c24a95959941fe5a471741528dc2d87026
Unfortunately there isn't a user-setting to change this although I was thinking about adding one. I think that the current setting being the default makes sense also from a security perspective as unlocking the phone also enables NFC payments so doing that by accident can be a real problem.

Anyway: I'm currently very packed with work as I'm backporting security patches to the kernel, incorporating new changes from 19.1 to 17/18.1, updating blobs to hopefully resolve the connection loss issue (has anyone observed those on 19.1?) and just got the MicroG build working on 18.1 so at least that will be there once I'm done
 

gagou7

New member
Jan 22, 2023
1
0
Tested latest lineage 19, even connected to a WIFI, no internet. Tested all TWRP version, the data partition was still encrypted. Version 3.7 is unusable, the screen is cropped.

Tested latest lineage 18, wifi working, fingerprint as well, TWRP 3.6 is able to decrypt the data partition ! MindTheGAPPS work perfectly as well.

So, no Android 12 for now but an up-to-date Android 11 with latest security patch ! Thank you for your awesome work !
 

Arcline

Senior Member
Sep 11, 2016
167
58
Tested latest lineage 19, even connected to a WIFI, no internet. Tested all TWRP version, the data partition was still encrypted. Version 3.7 is unusable, the screen is cropped.

Tested latest lineage 18, wifi working, fingerprint as well, TWRP 3.6 is able to decrypt the data partition ! MindTheGAPPS work perfectly as well.

So, no Android 12 for now but an up-to-date Android 11 with latest security patch ! Thank you for your awesome work !
Use the TWRP in Los20 thread for A12/13
 

hadr1an

Member
Jan 9, 2017
7
0
Updated today to 18.1 20230120 (dirty flashed from older 18.1) and mobile data is not working. Any fixes / anyone with the same issue?
 

7alvoo

Senior Member
Jul 18, 2019
163
52
Updated today to 18.1 20230120 (dirty flashed from older 18.1) and mobile data is not working. Any fixes / anyone with the same issue?
My setup:
- twrp 3.7.0
- 18.1 20230120
- NikGapps-core-arm64-11-20220908-signed
- always backup the data and reformat the system part. before update
- the end: like a swiss clock
 
  • Like
Reactions: Rataplan626
Thank you, everything works ❤️

I love my XZ1 compact so much...and I keep coming back to it.
You gave me a few more years out of the phone.
 

Attachments

  • Screenshot_20230125-122206_XDA Developers.png
    Screenshot_20230125-122206_XDA Developers.png
    74.8 KB · Views: 81
Been using this ROM for over a month and I'm really happy with it. Thanks for your work.
However, today SafetyNet failed for no reason. Play Integrity also fails. Last time I checked both passed.
Aby advice or thoughts what happened?

EDIT: wiped system, reflashed zip and OpenGapps, wiped Dalvik (or rather ART) and cache... and it fixed itself. That's bit odd.
 

Attachments

  • Screenshot_20230130-104311_Sklep_Google_Play.png
    Screenshot_20230130-104311_Sklep_Google_Play.png
    111.1 KB · Views: 30
  • photo_2023-01-30_11-25-42.jpg
    photo_2023-01-30_11-25-42.jpg
    73 KB · Views: 25
Last edited:

Flamefire

Senior Member
Jul 26, 2013
240
618
Sony Xperia XZ1 Compact
- 2G is not selectable anymore as preferred network type in Settings (I sometimes need that when I'm in the mountains)
I found this: "Android 12 users need to go to Settings > Network & Internet > SIMs > Allow 2G"

However I just quickly checked on the spare phone and I do still have that setting on latest 19.1, although it is more hidden than on 17.1 (which I'm using personally)

Also switching to 2G is what I do when I have network issues (and done by the switcher service on startup). But I've seen a changeset that might help better here. Will be included in the February builds if that works.

EDIT: wiped system, reflashed zip and OpenGapps, wiped Dalvik (or rather ART) and cache... and it fixed itself. That's bit odd.

Wiping dalvik and cache is what I always do. Here I guess there was something on /system which shouldn't be there. Glad you could fix that! The SafetyNet fix is one of the things I do test for every update so I'd be surprised if it doesn't work.
 
Last edited:

Flamefire

Senior Member
Jul 26, 2013
240
618
Sony Xperia XZ1 Compact
I uploaded MicroG builds for all 3 versions, they are named e.g. lineage-19.1-20230131-MICROG instead of lineage-19.1-20230131-UNOFFICIAL but are contained in the same folder.

As they are not compatible with each other (not sure if you can dirty-flash one over the other, at least you need to wipe system) you have to be careful to choose the correct one!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    I uploaded the new updates yesterday. Took a bit longer than usual especially due to some tricky updates to the kernel and XperiaParts
    3
    can confirm android auto is working with the latest update
    2
    But I am on 19-20220918 - which version does fix this (or is it something completely different I'm experiencing?)...
    There isn't a real fix yet, this happens after reboot or some time without network (e.g. Tunnel or basement)
    You can try updating to latest version and enable the reflash-modem option in XperiaParts and see if that helps.
    Didn't help for me on 17.1 but 19.1 has stuff that is not possible on 17.1 which may help.
    2
    Hello, now in latest update of LOS 17.1 for lilac 02/25 (clean install) I am experiencing random UI reboots and one bug:
    If i turn off device and turn on (no reboot), system sounds arent working, freeze and FC when i want to set an alarm in clock app or play music, no flashlight, camera cannot start and maybe something else which i havent noticed.
    [...]
    I dont know if someone has similar problems, but this is strange.
    I'm using that ROM (17.1) myself on my daily device and haven't encountered any issues at all. So looks like something with your device, not the ROM itself.
    Now battery lasted 3 days +20% with 5hrs SOT, very nice ! No gapps.
    2 more bugs:
    Camera taking blank photos if default storage is set to sd card.
    Front camera gives white screen, freezes, FC and then i cant open camera when is flashlight turned on.

    Maybe it is related only to Sony camera app, i havent tested other camera apps.
    I assume you are (still) using 17.1 as you mention the Sony camera app. I'm a bit confused: Above you said that the camera cannot start.

    I just tried to reproduce the other issues: Camera works fine for me, I've always had the default set to SD and front camera does also work. I can imagine issues with camera and the flashlight feature as the former may want to access the light which may be already in use in that situation but it also does work fine for me.
    In fact the camera is one of the things I test on a spare device for a new ROM before even installing that on my own phone as a working camera is a good hint that a big part of the system works.

    So I can only imagine that there is still something left on your device interfering with the current ROM. If you don't mind loosing your data reflash the Stock firmware with newflasher, TWRP and then this ROM making sure to wipe /data, /cache and dalvik in the process. Or if you don't want to flash stock wipe /system, /cache & dalvik and format /data, then reinstall the ROM (without rebooting TWRP) which might help.
    At the very least try wiping /cache & dalvik (keep your data)

    This update seems to have broken extract-files.sh, preventing a clean build from source. Reported on github as issue 13.
    Answered there (a link to the issue in your post would be helpful as I don't get a notification on GH, but found it anyway): In short: It does work (I always do clean builds, by now 6 times), check your extracted system image :)
    2
    First, my TWRP backups were all done from within TWRP with the phone running in Recovery, not using `adb backup --twrp` so I don't know if they two methods are functionally equivalent.
    Thanks for the reply! I actually think they use slightly different storage formats, so next time backing up to the SD card may be worth a try.

    Are you able to get back to your original setup (i.e. your custom ROM, with your backup restored?
    Maybe I'm misunderstanding the question, but my problem is exactly that I can't boot the restored backup unless I format the restored data partition... at which point it wouldn't be my original setup anymore. (The backup I created covers all partitions, and adb does not support partial restores)

    My '"if all else fails" backup' is to backup using Android Backup and Restore Tools project. You need rooted debugging enabled, and access to a Linux machine (real or virtual). I have used these scripts to backup my apps and data and then to
    1. Restore to the same device, running the same or different custom ROM
    2. Restore / migrate to a completely new / different device
    Not everything gets retored - any apps whose account data is handled by Accuont Manager (e.g DAVx5, NextCloud) will lose the account settings, as will K-9 Mail (though you can export your settings before the backup, and re-import them after the restore). See this post in the /e/OS community forums for more information on my experiences with this.
    Yeah I've read about this project after the failed backup as well. Looks like another good line of redundancy in addition to SeedVault and partition backups.

    For now I've come to accept that the original data partition is just lost forever despite my best attempt at creating a proper backup. I was kinda hoping there'd be some takeaway lesson here like "If you format Data once, restoring old backups won't work anymore [for some reason]" to explain what went wrong. But it looks like my best bet is trying to back up to SD card rather than through adb in the future and cross fingers that'll work better 😬
  • 54
    LineageOS 17/18/19 for Sony Xperia XZ1 Compact

    logo.png


    RELEASE

    This is an alternative ROM for the Sony Xperia XZ1 Compact.

    Creating this to honor the great work of modpunk and derf elot from https://forum.xda-developers.com/t/rom-lineageos-18-1-unofficial-2-0-update-2021-01-20.4047763/ which seems to be discontinued. Posting an own thread to keep the latest versions visible, I'm NOT claiming authorship over the ROM.
    I basically just build the ROM using the latest changes from upstream LineageOS/Google and kernel updates (usually incorporated by derf elot ) See my post.

    FEATURES
    • Signed with dev keys
    • EAS kernel
    • Passes SafetyNet out of the box (thanks Rooted_Ansh, Havoc-OS Team and kdrag0n)
    • Seedvault (Video)
    • IMS support (thanks to Rooted_Ansh and also Shujath)
    • 17.1 has stock Sony camera (not possible on 18+)

    DOWNLOAD

    You can download the latest release here.
    HINT: Download both the ZIP and md5sum file so TWRP can check the consistency of the upload/download.
    Make sure you download the right version, vanilla LineageOS is named lineage-*UNOFFICIAL-lilac.zip while the MicroG version is named lineage-*-MICROG--lilac.zip

    REQUIRED FIRMWARE: 47.2.A.11.228

    IMPORTANT:
    I only test the 17.1 releases myself. The 18.1/19.1 are build from mostly the same sources and hopefully work. I only test them roughly.
    Backup download

    INSTALLATION

    IMPORTANT:
    Magisk seems to cause issues (bootloops) on update, so remove it first and reinstall if required. Note that Magisk is usually not required unless you want root.
    1. Put the zip file of the ROM on your SD card or internal store and boot into recovery.
    2. When coming from stock ROM, do a full wipe (i.e. factory reset) via "Wipe". Do not wipe system! When flashing the stock ROM you can select to not keep user data which is equivalent to this step.
    3. Go to "Install", select the zip file and add optionally the gapps zip. Then flash it.
    4. After updates you may now wipe cache&dalvik (option after install)
    I suggest to use modpunks TWRP recovery. Again: Don't forget the md5sum file!
    TWRP 3.3.1-0 by modpunk / derf elot
    Or use the latest TWRP for 17.1/18.1 or TWRP for 19.1.
    3.7.0 Seems to work well with latest updates (decryption working) but LineageOS 19.1 (Android 12) requires the ones with "_12" suffix, e.g. 3.6.2_12.

    For ease of use I suggest to flash this recovery (only required once):
    1. Boot in Fastboot mode: Hold "Volume Up" while connecting the USB cable to phone and PC
    2. Flash TWRP by running this on the PC: fastboot flash recovery twrp-3.3.1-0-lilac-android10-1.img
      (adjust the filename if necessary)
    3. From now you can boot TWRP by turning on the phone with "Volume Down" + Power
    I heavily recommend to make a full backup before any installation so you can go back in case of issues. Flashing an older ROM usually helps to recover bootloops etc.

    Upgrades between versions​

    Dirty-flashing (e.g. from 17.1 to 18.1) works well but you have to also flash a GApps version matching the Android version or the device will bootloop.
    For the upgrade to 19.1 you may need to fully remove OpenGapps by wiping /system and install e.g. MindTheGapps.

    SUPPORT

    There is NONE. If you have any issues or question ask in the thread so maybe someone else knows the answer.
    I'm just providing the ROM (Lineage 17.1 variant) I use myself for others to try to and just build the Lineage 18.1 ROM without much testing.
    If you prefer to use a more well-tested Android 11 ROM, I suggest to look at Havoc-OS.
    Contributions to the sources are welcome and likely get integrated into the next release.

    Contributors
    modpunk, derf elot, Rooted_Ansh, Flamefire, linckandrea
    Source Code: https://github.com/Flamefire/android_device_sony_lilac, Original: https://github.com/whatawurst/

    If you want to buy me a coffee/beer, I'll appreciate it but it is not necessary.
    Also please consider donating to the original authors too or to local charities as requested by @modpunk

    Special thanks to landsome for donating a test phone for bug hunting and development.

    ROM OS Version: Android 10/11/12
    ROM Kernel: Linux 4.4.x
    Based On: LineageOS
    GApps: None included, except for the MICROG builds. Recommended is OpenGApps for 17/18 and MindTheGapps for 19.
    22
    CHANGELOG


    2023-02-25

    • February security patches
    • Kernel updates (e.g. CIP tag -st37, also add some missing patches to 19.1 kernel)
    • Use newer compiler (Clang 12.0.7) for kernel, possibly improving performance/battery life
    • Add "Re-apply Modem" setting to XperiaParts to help with connection/modem-crash issues
    • Clear some space on /system & /vendor partitions by removing files no longer needed
    • Attempt to fix Android Auto connection (untested)
    2023-01-20
    • January security patches
    • Kernel updates
    • MicroG builds added (build date 31st Jan, but same sources)
    2022-12-27
    • December security patches
    • AGPS fix (using Google servers)
    • Kernel updates (e.g. Wireguard v1.0.20220627, improved security against stack attacks)
    2022-11-15
    • November security patches
    • WLAN driver update
    • Huge APN update
    2022-10-13
    • October security patches
    • Kernel update
    • APN for DIGI HU
    • Option to switch temporarily to 2G on boot
    2022-09-29
    • September security patches
    • Kernel update
    • APN update
    2022-08-12
    • August security patches
    • Kernel update (CIP st20)
    2022-07-25/28
    • July security patches
    • Kernel update
    2022-06-30
    • June security patches
    • Kernel update
    • Backport fix for CVE-2021-39686
    • Workaround fixing bootloop with recent OpenGapps (20220503 tested)
    2022-05-16
    • May security patches
    • Fix mic volume issue with wired headsets
    • Known issue: OpenGapps after 15/2 result in bootloop
    2022-05-03
    • April security patches
    • Kernel update (CIP st5-tag)
    • Removed LineageOS updater (unused application here)
    • Added Sony identification packages (Compatibility for some Sony apps from other sources)
    2022-03-20
    • March security patches
    • Updated some carrier configs (mostly Indian&Chinese) for IMS (VoLTE...)
    • Better support for flip covers
    • Allow disabling battery optimizations for the SMS app
    2022-02-20
    • February security patches
    • Kernel 4.4.302 (final LTS kernel)
    • Re-enable VoLTE toggle switch (there were reports of modem crashes when VoLTE is disabled, can't reproduce this, hence added the setting back)
    2022-01-23
    • January security patches
    • Kernel 4.4.299
    • Wireguard v1.0.20211208
    • Enhanced display brightness range
    • Experimental Ultra-Dim mode
    2021-12-19
    • December security patches
    • Kernel 4.4.295
    • QCom driver updates
    • Fix some permission issues
    • Reset phone ID to XZ1C
    2021-11-29
    • November security patches
    • Kernel 4.4.291
    • Fix IMS on 17.1
    • Fix/enhance Wifi-Display
    • Fix some power hints
    • Update APNs
    2021-10-19
    • October security patches
    • Kernel 4.4.288
    2021-09-18
    • September security patches
    • Include some more security patches from AOSP
    • Clang 11 for LOS 17.1 version (same as 18.1, improved optimizations)
    • Misc bugfixes backported from Android 11 to Android 10
    • Kernel 4.4.283
    2021-08-11
    • August security patches
    • Fix bug with switch 3G->4G in XperiaParts not working on slow boot
    • Include some more security patches from AOSP
    • Kernel 4.4.279
    2021-07-20
    • July security patches
    • Kernel 4.4.275
    2021-07-03
    • June security patches
    • Update to Linux Kernel 4.4.272
    • Updated APNs
    20
    I'm happy to announce the June update. Took a lot more work as I backported quite a bit to our kernel to fix CVE-2021-39686 although I'm not sure we were ever really affected by that. Anyway the backport fixes that hole and a few potential others making the device a bit safer!
    15
    @MarkMRL Update 20220516 is out which should also fix the headset issue. Reproduced, found and fixed it as far as I can tell.
    14
    I updated the ROM with the January security patches. I also included the "Ultra Dim" QuickSettings tile to reduce the screen brightness (overall). But that is experimental. I'm thinking about including that in the range of the brightness, i.e. make the lowest brightness levels less. Problem is that there are only 255 values possible so I have to define a switch-over point somehow and distribute those 255 values over effectively 2 distinct ranges. Let's see...

    I also added Google Drive downloads temporarily as a backup if AFH fails again...