[ROM] LineageOS 17/18/19 UNOFFICIAL - (Update: 2023-02-25)

Shall F-Droid be included in the ROM(s)?

  • Total voters
Search This thread


Feb 21, 2022
First of all thanks and congratulations to every contributor on the Lineage OS mod for XZ1C; I really like this device so having the chance to keep it updated is great.

I'm wondering if anyone in this thread can give me some advice: yesterday I flashed Lineage OS 19.1 (in particular the build lineage-19.1-20230120-UNOFFICIAL-lilac) together with GApps (MindTheGapps-12.1.0-arm64-20220605_112439), which seems to be working fine. But I have just installed a few things and was thinking on moving to the MICROG build, so: any suggestion on how to proceed?

Based on what's said on the first post I guess the way to go is wiping everything from TWRP and flashing the mod, does it make sense? I'm unclear if I need to use a specific TWRP version and if so, which one.

On top of that not sure what could be the procedure for going back, I guess again wiping everything and flashing LineageOS and MindTheGapps...

Sorry for the questions but as I've mentioned last year, I'm totally newbie on these matters. Thanks in advance


Jan 29, 2017
I have a problem with NikGapps.

Been using HavocOS until recently (latest v4.19) and now switching over to LOS 18.1. Mostly because I read Android Auto for some people works on LOS and also wanted to try it out and HOS hasn't been updated in a while.

I flashed the latest 18.1 build and the lates NikGapps, however, during he initial setup when trying to restore my Google backup, the restore crashes and goes back to WiFi selection screen. I tried with all NikGapps that have Google Backup, and I get the same issue.

When trying with OpenGapps and MindTheGapps, I don't get this issue, but Android Auto also doesn't work for me with them.

Has anyone encountered this issue?

Last edited:


Jan 29, 2017
Forgot to mention, I tried with LOS 17.1 as well. At the initial copy apps & data screen I get the same issue. However, if I skip that and skip adding an account, add the account in Backup settings afterwards and then go to "Finish Setup", it works and I am able to restore my backed-up data. Unfortunately this workaround isn't successful on 18.1...


Senior Member
Dec 12, 2015
Whaley Bridge
Sony Xperia Z3 Compact
Based on what's said on the first post I guess the way to go is wiping everything from TWRP and flashing the mod, does it make sense?

That may not be necessary. I would try backing up your apps and data (using TWRP and Android Backup and Restore Tools project. Then try dirty flashing the microG version

If the dirty flash desn't work, then format data, clean flash, boot, then restore your apps and data. Detailed instructions in the last part of this /e/OS forums post


Senior Member
Mar 14, 2013
Caltagirone (Catania)
Hi all,
I'm using LOS 17,1 latest version just flashed, and my need is to have Android Auto working (Peugeot e-208)

At the First i used opengapps with no luck, then wiped everything and tried NikGApps core for android 10 + NikGApps Android Auto Add-on.
Also no luck.

Tried different cables which I used successfully before (also LOS 17 but coming from older releases)
car keep saying Android Auto Error `check equipment which may be not compatible'.

Do you have any suggestion? Anyone with similar issue and who have managed to solve?


Senior Member
Jul 26, 2013
Sony Xperia XZ1 Compact
But I have just installed a few things and was thinking on moving to the MICROG build, so: any suggestion on how to proceed?

Based on what's said on the first post I guess the way to go is wiping everything from TWRP and flashing the mod, does it make sense? I'm unclear if I need to use a specific TWRP version and if so, which one.
You can try to only wipe system and install the MICROG build. But I guess the data stuff from the other GApps won't be compatible so you may need to wipe data too (factory reset).
In any case wiping cache&dalvik is a good idea.
If all fails just flash the stock ROM and then the MICROG build. Of course you (also) loose your data but that should always work.
I'm using LOS 17,1 latest version just flashed, and my need is to have Android Auto working (Peugeot e-208)
Do you have any suggestion? Anyone with similar issue and who have managed to solve?
derfelot has found something which may fix this. I'll likely add this to the February builds if I get to that. I can't test that though as I don't have an Android Auto device/car.
Anyway when I include that stuff I'll mention it in the changelog, so keep an eye there


Feb 21, 2022
Thanks @petefoth and @Flamefire for your replies and advices.
I ended up wiping everything (I've already lost most of the stuff few weeks ago) so was no big deal.

The only thing to remark is that on first boot I got a message that factory reset was needed and inmediately reboot into recovery. I wiped it again and from then on, everything went fine.


Senior Member
Jul 18, 2019
Completely smooth update, thank you very much!
my setup:
lineage-18.1-20230120-UNOFFICIAL-lilac --> lineage-18.1-20230225-UNOFFICIAL-lilac
NikGapps-core-arm64-11-20220908-signed --> NikGapps-core-arm64-11-20230218-signed


Senior Member
Sep 11, 2016
Hey, could someone use the Momo detection app and show the results? I'm curious if it detects custom rom using this rom.


Senior Member
Sep 30, 2017
Hey thanks! Hide the magisk app and it should be fixed.
But do you get "The device is running a custom rom" and "Init.rc is modified" in Momo
it is hidden already
using LSPosed with magisk zygisk deny list


  • Screenshot_20230226-173126_Momo.png
    62 KB · Views: 10
  • Screenshot_20230226-173137_Momo.png
    87.8 KB · Views: 10
Last edited:


Senior Member
Sep 11, 2016
it is hidden already
using LSPosed with magisk zygisk deny list
Ah I see. I get the same results with Los20, that's why I'm asking. If you want to hide Magisk and su/zygisk use ether Shamiko or MagiskHide/Magisk Delta by HuskyG. Problem is, my bank account detects I'm running a custom rom and I think it has something to do with what Momo is showing.


New member
Feb 27, 2023
Hi! First of all, thanks Flamefire and everyone else for putting in the effort to keep the XZ1 alive :)

I've finally found a reason to sign up to these forums, but sadly not a pleasant one: After installing this build, I need to restore my TWRP backup, but even though it includes all partitions, I can only boot the phone if I format `Data`. I have redundancy for my photos, but formatting Data loses all my apps, messages, etc, so I'm looking for a way to recover. Shouldn't Data be restorable even after a format?

Here's what I did:
  • Starting situation: Custom LOS with MicroG 18.1 (built myself from the whatawurst repositories)
    • I created a full backup from TWRP 3.5 from this using `adb backup --twrp`
  • Dirty-flashed Flamefire's 18.1+MicroG builds from January
  • Dirty-flashed Flamefire's 19.1+MicroG builds from January
  • Dirty-flashed Flamefire's 19.1+MicroG builds from February
    • I created *another* full backup from TWRP *3.6* from this using `adb backup --twrp`
Up until this point, almost everything worked fine. 4G wasn't working in the 19.1 builds though (happy to debug another day), so I decided to restore my backup. Here's where things went south:
  • Restoring my first backup was very unreliable and I had to manually patch up the `archive.ab` file to skip the oem.ext4 and cache.ext4 backups. After restore, the phone boots back to recovery until I format Data
  • Restoring my *second* backup worked more reliably, but again my phone boots back to recovery unless I format Data

I have *some* redundancy in case this Data partition is forever lost, but I really wonder what's going on here. Am I out of luck or is there something I'm missing?

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    I uploaded the new updates yesterday. Took a bit longer than usual especially due to some tricky updates to the kernel and XperiaParts
    can confirm android auto is working with the latest update
    But I am on 19-20220918 - which version does fix this (or is it something completely different I'm experiencing?)...
    There isn't a real fix yet, this happens after reboot or some time without network (e.g. Tunnel or basement)
    You can try updating to latest version and enable the reflash-modem option in XperiaParts and see if that helps.
    Didn't help for me on 17.1 but 19.1 has stuff that is not possible on 17.1 which may help.
    Hello, now in latest update of LOS 17.1 for lilac 02/25 (clean install) I am experiencing random UI reboots and one bug:
    If i turn off device and turn on (no reboot), system sounds arent working, freeze and FC when i want to set an alarm in clock app or play music, no flashlight, camera cannot start and maybe something else which i havent noticed.
    I dont know if someone has similar problems, but this is strange.
    I'm using that ROM (17.1) myself on my daily device and haven't encountered any issues at all. So looks like something with your device, not the ROM itself.
    Now battery lasted 3 days +20% with 5hrs SOT, very nice ! No gapps.
    2 more bugs:
    Camera taking blank photos if default storage is set to sd card.
    Front camera gives white screen, freezes, FC and then i cant open camera when is flashlight turned on.

    Maybe it is related only to Sony camera app, i havent tested other camera apps.
    I assume you are (still) using 17.1 as you mention the Sony camera app. I'm a bit confused: Above you said that the camera cannot start.

    I just tried to reproduce the other issues: Camera works fine for me, I've always had the default set to SD and front camera does also work. I can imagine issues with camera and the flashlight feature as the former may want to access the light which may be already in use in that situation but it also does work fine for me.
    In fact the camera is one of the things I test on a spare device for a new ROM before even installing that on my own phone as a working camera is a good hint that a big part of the system works.

    So I can only imagine that there is still something left on your device interfering with the current ROM. If you don't mind loosing your data reflash the Stock firmware with newflasher, TWRP and then this ROM making sure to wipe /data, /cache and dalvik in the process. Or if you don't want to flash stock wipe /system, /cache & dalvik and format /data, then reinstall the ROM (without rebooting TWRP) which might help.
    At the very least try wiping /cache & dalvik (keep your data)

    This update seems to have broken extract-files.sh, preventing a clean build from source. Reported on github as issue 13.
    Answered there (a link to the issue in your post would be helpful as I don't get a notification on GH, but found it anyway): In short: It does work (I always do clean builds, by now 6 times), check your extracted system image :)
    First, my TWRP backups were all done from within TWRP with the phone running in Recovery, not using `adb backup --twrp` so I don't know if they two methods are functionally equivalent.
    Thanks for the reply! I actually think they use slightly different storage formats, so next time backing up to the SD card may be worth a try.

    Are you able to get back to your original setup (i.e. your custom ROM, with your backup restored?
    Maybe I'm misunderstanding the question, but my problem is exactly that I can't boot the restored backup unless I format the restored data partition... at which point it wouldn't be my original setup anymore. (The backup I created covers all partitions, and adb does not support partial restores)

    My '"if all else fails" backup' is to backup using Android Backup and Restore Tools project. You need rooted debugging enabled, and access to a Linux machine (real or virtual). I have used these scripts to backup my apps and data and then to
    1. Restore to the same device, running the same or different custom ROM
    2. Restore / migrate to a completely new / different device
    Not everything gets retored - any apps whose account data is handled by Accuont Manager (e.g DAVx5, NextCloud) will lose the account settings, as will K-9 Mail (though you can export your settings before the backup, and re-import them after the restore). See this post in the /e/OS community forums for more information on my experiences with this.
    Yeah I've read about this project after the failed backup as well. Looks like another good line of redundancy in addition to SeedVault and partition backups.

    For now I've come to accept that the original data partition is just lost forever despite my best attempt at creating a proper backup. I was kinda hoping there'd be some takeaway lesson here like "If you format Data once, restoring old backups won't work anymore [for some reason]" to explain what went wrong. But it looks like my best bet is trying to back up to SD card rather than through adb in the future and cross fingers that'll work better 😬
  • 54
    LineageOS 17/18/19 for Sony Xperia XZ1 Compact



    This is an alternative ROM for the Sony Xperia XZ1 Compact.

    Creating this to honor the great work of modpunk and derf elot from https://forum.xda-developers.com/t/rom-lineageos-18-1-unofficial-2-0-update-2021-01-20.4047763/ which seems to be discontinued. Posting an own thread to keep the latest versions visible, I'm NOT claiming authorship over the ROM.
    I basically just build the ROM using the latest changes from upstream LineageOS/Google and kernel updates (usually incorporated by derf elot ) See my post.

    • Signed with dev keys
    • EAS kernel
    • Passes SafetyNet out of the box (thanks Rooted_Ansh, Havoc-OS Team and kdrag0n)
    • Seedvault (Video)
    • IMS support (thanks to Rooted_Ansh and also Shujath)
    • 17.1 has stock Sony camera (not possible on 18+)


    You can download the latest release here.
    HINT: Download both the ZIP and md5sum file so TWRP can check the consistency of the upload/download.
    Make sure you download the right version, vanilla LineageOS is named lineage-*UNOFFICIAL-lilac.zip while the MicroG version is named lineage-*-MICROG--lilac.zip

    REQUIRED FIRMWARE: 47.2.A.11.228

    I only test the 17.1 releases myself. The 18.1/19.1 are build from mostly the same sources and hopefully work. I only test them roughly.
    Backup download


    Magisk seems to cause issues (bootloops) on update, so remove it first and reinstall if required. Note that Magisk is usually not required unless you want root.
    1. Put the zip file of the ROM on your SD card or internal store and boot into recovery.
    2. When coming from stock ROM, do a full wipe (i.e. factory reset) via "Wipe". Do not wipe system! When flashing the stock ROM you can select to not keep user data which is equivalent to this step.
    3. Go to "Install", select the zip file and add optionally the gapps zip. Then flash it.
    4. After updates you may now wipe cache&dalvik (option after install)
    I suggest to use modpunks TWRP recovery. Again: Don't forget the md5sum file!
    TWRP 3.3.1-0 by modpunk / derf elot
    Or use the latest TWRP for 17.1/18.1 or TWRP for 19.1.
    3.7.0 Seems to work well with latest updates (decryption working) but LineageOS 19.1 (Android 12) requires the ones with "_12" suffix, e.g. 3.6.2_12.

    For ease of use I suggest to flash this recovery (only required once):
    1. Boot in Fastboot mode: Hold "Volume Up" while connecting the USB cable to phone and PC
    2. Flash TWRP by running this on the PC: fastboot flash recovery twrp-3.3.1-0-lilac-android10-1.img
      (adjust the filename if necessary)
    3. From now you can boot TWRP by turning on the phone with "Volume Down" + Power
    I heavily recommend to make a full backup before any installation so you can go back in case of issues. Flashing an older ROM usually helps to recover bootloops etc.

    Upgrades between versions​

    Dirty-flashing (e.g. from 17.1 to 18.1) works well but you have to also flash a GApps version matching the Android version or the device will bootloop.
    For the upgrade to 19.1 you may need to fully remove OpenGapps by wiping /system and install e.g. MindTheGapps.


    There is NONE. If you have any issues or question ask in the thread so maybe someone else knows the answer.
    I'm just providing the ROM (Lineage 17.1 variant) I use myself for others to try to and just build the Lineage 18.1 ROM without much testing.
    If you prefer to use a more well-tested Android 11 ROM, I suggest to look at Havoc-OS.
    Contributions to the sources are welcome and likely get integrated into the next release.

    modpunk, derf elot, Rooted_Ansh, Flamefire, linckandrea
    Source Code: https://github.com/Flamefire/android_device_sony_lilac, Original: https://github.com/whatawurst/

    If you want to buy me a coffee/beer, I'll appreciate it but it is not necessary.
    Also please consider donating to the original authors too or to local charities as requested by @modpunk

    Special thanks to landsome for donating a test phone for bug hunting and development.

    ROM OS Version: Android 10/11/12
    ROM Kernel: Linux 4.4.x
    Based On: LineageOS
    GApps: None included, except for the MICROG builds. Recommended is OpenGApps for 17/18 and MindTheGapps for 19.


    • February security patches
    • Kernel updates (e.g. CIP tag -st37, also add some missing patches to 19.1 kernel)
    • Use newer compiler (Clang 12.0.7) for kernel, possibly improving performance/battery life
    • Add "Re-apply Modem" setting to XperiaParts to help with connection/modem-crash issues
    • Clear some space on /system & /vendor partitions by removing files no longer needed
    • Attempt to fix Android Auto connection (untested)
    • January security patches
    • Kernel updates
    • MicroG builds added (build date 31st Jan, but same sources)
    • December security patches
    • AGPS fix (using Google servers)
    • Kernel updates (e.g. Wireguard v1.0.20220627, improved security against stack attacks)
    • November security patches
    • WLAN driver update
    • Huge APN update
    • October security patches
    • Kernel update
    • APN for DIGI HU
    • Option to switch temporarily to 2G on boot
    • September security patches
    • Kernel update
    • APN update
    • August security patches
    • Kernel update (CIP st20)
    • July security patches
    • Kernel update
    • June security patches
    • Kernel update
    • Backport fix for CVE-2021-39686
    • Workaround fixing bootloop with recent OpenGapps (20220503 tested)
    • May security patches
    • Fix mic volume issue with wired headsets
    • Known issue: OpenGapps after 15/2 result in bootloop
    • April security patches
    • Kernel update (CIP st5-tag)
    • Removed LineageOS updater (unused application here)
    • Added Sony identification packages (Compatibility for some Sony apps from other sources)
    • March security patches
    • Updated some carrier configs (mostly Indian&Chinese) for IMS (VoLTE...)
    • Better support for flip covers
    • Allow disabling battery optimizations for the SMS app
    • February security patches
    • Kernel 4.4.302 (final LTS kernel)
    • Re-enable VoLTE toggle switch (there were reports of modem crashes when VoLTE is disabled, can't reproduce this, hence added the setting back)
    • January security patches
    • Kernel 4.4.299
    • Wireguard v1.0.20211208
    • Enhanced display brightness range
    • Experimental Ultra-Dim mode
    • December security patches
    • Kernel 4.4.295
    • QCom driver updates
    • Fix some permission issues
    • Reset phone ID to XZ1C
    • November security patches
    • Kernel 4.4.291
    • Fix IMS on 17.1
    • Fix/enhance Wifi-Display
    • Fix some power hints
    • Update APNs
    • October security patches
    • Kernel 4.4.288
    • September security patches
    • Include some more security patches from AOSP
    • Clang 11 for LOS 17.1 version (same as 18.1, improved optimizations)
    • Misc bugfixes backported from Android 11 to Android 10
    • Kernel 4.4.283
    • August security patches
    • Fix bug with switch 3G->4G in XperiaParts not working on slow boot
    • Include some more security patches from AOSP
    • Kernel 4.4.279
    • July security patches
    • Kernel 4.4.275
    • June security patches
    • Update to Linux Kernel 4.4.272
    • Updated APNs
    I'm happy to announce the June update. Took a lot more work as I backported quite a bit to our kernel to fix CVE-2021-39686 although I'm not sure we were ever really affected by that. Anyway the backport fixes that hole and a few potential others making the device a bit safer!
    @MarkMRL Update 20220516 is out which should also fix the headset issue. Reproduced, found and fixed it as far as I can tell.
    I updated the ROM with the January security patches. I also included the "Ultra Dim" QuickSettings tile to reduce the screen brightness (overall). But that is experimental. I'm thinking about including that in the range of the brightness, i.e. make the lowest brightness levels less. Problem is that there are only 255 values possible so I have to define a switch-over point somehow and distribute those 255 values over effectively 2 distinct ranges. Let's see...

    I also added Google Drive downloads temporarily as a backup if AFH fails again...